18:00:18 <bh526r_> #startmeeting #gluon
18:00:19 <openstack> Meeting started Wed Mar 15 18:00:18 2017 UTC and is due to finish in 60 minutes.  The chair is bh526r_. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:23 <openstack> The meeting name has been set to '_gluon'
18:00:41 <bh526r_> #topic Roll Call
18:00:48 <bh526r_> #info Bin Hu
18:01:14 <bh526r_> Hi guys
18:02:06 <georgk> #info Georg Kunz
18:02:14 <bh526r_> Hi Georg
18:02:31 <bh526r_> Looks like only you and I
18:02:47 <bh526r_> Other people may be confused by daylight savings time
18:03:28 <bh526r_> #topic Admin Update
18:03:44 <bh526r_> #info We just finished OPNFV NetReady meeting
18:04:10 <bh526r_> #info Our lab was deployed with Fuel OpenStack Newton, ODL and Gluon Ocata
18:04:23 <bh526r_> #info Basic verification was done
18:04:45 <bh526r_> #info Next step is to deploy Shim Layer on SDN-C specific VMs
18:05:15 <bh526r_> #info And make Contrail work (Mechanism Driver) with Fuel OpenStack
18:05:44 <bh526r_> anything else to add, Georg?
18:06:06 <georgk> no, that´s all
18:06:12 <bh526r_> Thank you Gerog
18:06:38 <bh526r_> #info At an offline conversation, Huawei intended to set up a 2nd lab in Santa Clara
18:06:59 <bh526r_> #info They will start to work on the lab setup
18:07:26 <bh526r_> #topic PoC Planning for OpenStack Summit and OPNFV Summit
18:12:14 <jinli> #info JinLi
18:12:49 <bh526r_> Hi Jin
18:13:10 <bh526r_> #info Logistics wise, in OpenStack Summit, we may not have our dedicated booth
18:13:10 <jinli> Hi Bin, sorry late, just came back from dr appt
18:13:18 <bh526r_> no problem
18:13:47 <bh526r_> #info Bin is in talk with OPNFV regarding the possibility to share OPNFV booth there
18:14:44 <bh526r_> #info OPNFV is discussing it (marketing, admin, event team), and see what are the options, e.g. OpenSource Day booth etc.
18:15:11 <bh526r_> #info Bin will share more information once he knows more from OPNFV
18:15:27 <georgk> thanks
18:16:15 <bh526r_> #info For OPNFV Summit, Bin will submit PoC proposal to secure an AT&T Booth as we did for OPNFV Summit in Berlin
18:16:44 <bh526r_> #info In terms of PoC scope, there are several options
18:17:19 <bh526r_> #info E.g. SFC among controllers. But it appears to be too aggressive to implement within short time frame
18:17:47 <bh526r_> #info It is more confident to focus on the core value of Gluon and Proton
18:19:05 <bh526r_> #info So the demo scope could include:
18:20:00 <bh526r_> #info (1) 3 YAMLs and Protons/APIs: L3VPN, SFC and P2P. We will write 3 YAMLs for L3VPN, SFC and P2P service models respectively. Then use Particle Generator to generate 3 Protons / 3 sets of APIs respectively.
18:20:30 <bh526r_> #info No code is needed to implement those APIs on SDN-C, except those already supported.
18:21:32 <bh526r_> #info The value proposition is to enable quick development and deployment of new networking service APIs so as to accelerate time-to-market and improve business agility
18:22:01 <bh526r_> #info (2) Then demonstrate a fun use case for interoperability of multiple SDN controllers using Proton API L3VPN.
18:22:47 <bh526r_> #info Minimum code is needed to automate passing RT and RD parameters via Proton L3VPN API so as to enable BGP peering among those SDN controllers
18:23:24 <bh526r_> any other thoughts?
18:24:07 <georgk> yes
18:24:22 <georgk> regarding the last point, we need to extend the l3vpn api
18:24:40 <georgk> i guess we need to collect required parameters which need to be added
18:24:48 <georgk> right?
18:24:56 <bh526r_> That's right.
18:26:07 <bh526r_> What about using "protonclient --api net-l3vpn vpnafconfig-create" to pass parameters?
18:26:21 <georgk> good point
18:26:30 <georgk> it is not really used at the moment anyway
18:26:45 <georgk> i need to see which parameters are needed
18:26:58 <georgk> at least the remote SDN controller IP
18:27:25 <georgk> maybe AS-number
18:27:59 <georgk> so maybe it makes sense to create a bgppeering object
18:28:12 <georgk> instead of the afconfig thingy
18:28:16 <georgk> let´s see
18:28:18 <bh526r_> Great. Please figure out what are the parameters needed, and see if current vpnafconfig-create can be reused, or needs to add more arguments for this command, or need a new API endpoint
18:29:25 <bh526r_> Currently "protonclient --api net-l3vpn vpnafconfig-create" supports RT values
18:29:31 <bh526r_> e.g. "$ protonclient --api net-l3vpn vpnafconfig-create --vrf_rt_type both --vrf_rt_value 1000:1000"
18:29:56 <bh526r_> If we need more parameters, we need to extend the arguments at least
18:31:10 <georgk> ok
18:31:22 <bh526r_> And bgppeering-create makes more sense if we have more parameters other than AFconfig
18:32:30 <bh526r_> So first find the list of parameters needed for BGP peering first. Then let's see what is the best way
18:32:39 <bh526r_> Thank you Georg
18:33:36 <bh526r_> #Action: @georgk figure out a list of parameters needed for BGP peering
18:33:57 <bh526r_> Other thoughts?
18:35:27 <bh526r_> Good, let's move on
18:35:58 <bh526r_> #topic Planning for Pike
18:36:20 <bh526r_> I think we need Sukhdev and Ian's wisdom regarding RFE in Neutron
18:36:30 <bh526r_> I will follow up with them offline
18:37:02 <bh526r_> #info Bin will follow up with Sukhdev and Ian regarding RFE "optional network type" and its implementation in Neutron
18:38:36 <bh526r_> #info We need more volunteer for other Pike tasks
18:39:02 <bh526r_> #link https://wiki.openstack.org/wiki/Gluon/Tasks-Pike
18:39:14 <bh526r_> #info All are encouraged to sign up
18:39:38 <bh526r_> #topic Planning for Forum in Boston
18:40:10 <bh526r_> #info Telecom/NFV Etherpad is here:
18:40:13 <bh526r_> #link https://etherpad.openstack.org/p/BOS-UC-brainstorming-Telecom&NFV
18:41:19 <bh526r_> Do you feel we need to create an Etherpad for our own Gluon group session?
18:41:58 <georgk> well, we can try - etherpads are cheap
18:42:15 <bh526r_> :) OK, I will create one for planning purpose
18:43:16 <bh526r_> #info Bin will create an Etherpad for planning a Gluon session
18:43:49 <bh526r_> That's pretty much all from my side
18:43:57 <bh526r_> Anything else?
18:44:07 <jinli> bin, I can work on this one
18:44:08 <jinli> Look into what should be returned when the base URL is accessed, i.e. what is expected by a REST API when the base URL is accessed. Currently, the proton server returns a response body with default_version, version, name, etc. We need to mimic what other APIs do (e.g. Neutron, Nova, etc).
18:44:19 <jinli> can you put my name there?
18:44:32 <jinli> that's in the pike task
18:44:35 <bh526r_> Sure, thank you Jin
18:45:40 <bh526r_> Jin, I just put your name there. Please double check
18:46:02 <bh526r_> Georg, what is your colleague's name that is looking into SFC YAML?
18:46:26 <bh526r_> I will put his name under "New service binding model for SFC "
18:47:15 <georgk> his name is Juanma, but he might leave SFC due to a re-org
18:47:28 <georgk> so, not sure it if is good to put his name there
18:47:37 <jinli> yes, it is there now
18:47:49 <bh526r_> I see. Thank you Georg for more info.
18:48:42 <bh526r_> Anything else from everyone?
18:48:50 <georgk> no, i am good
18:49:39 <bh526r_> Good. Thank you everyone. And let's focus on PoC part, and I will work with Sukhdev and Ian to move RFE forward in Neutron.
18:49:49 <bh526r_> #info Meeting adjourned
18:49:57 <georgk> ok, bye
18:49:58 <bh526r_> #endmeeting