14:00:13 <mark-burnett> #startmeeting airship
14:00:14 <openstack> Meeting started Tue Jul 17 14:00:13 2018 UTC and is due to finish in 60 minutes.  The chair is mark-burnett. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:17 <openstack> The meeting name has been set to 'airship'
14:00:26 <mark-burnett> #topic role call
14:00:40 <mark-burnett> Hi all,  here is our agenda for today: https://etherpad.openstack.org/p/airship-meeting-2018-07-17
14:00:55 <sthussey> here
14:01:01 <blancos> o/
14:01:07 <roman_g> Good morning
14:01:15 <b-str> gm
14:01:29 <mattmceuen> o/
14:01:31 <roman_g> o/
14:01:37 <aaronsheffield> Good morning.
14:02:06 <portdirect> o/
14:02:41 <mark-burnett> #topic Duplicate repos/documentation sites
14:03:26 <mark-burnett> So it seems there is some confusion about the old git repos under att-comdev and the new openstack repos, as well as some confusion about rtd sites
14:03:44 <roman_g> Yes, that's mine
14:04:46 <mark-burnett> I wonder if we can archive the att-comdev repos to avoid confusion
14:05:32 <portdirect> this is what we did with osh
14:05:34 <portdirect> https://github.com/att-comdev/openstack-helm/commit/ef518cb0fb384031008a9deb372fadf1929dcf28
14:05:42 <portdirect> reduced a lot of confusion
14:05:59 <sthussey> just delete them, no one used them anyway
14:06:29 <mark-burnett> Ok, I'll look into either updating the readme/emptying them out or archiving them
14:07:00 <mark-burnett> #action mark-burnett to more clearly mark att-comdev repos or archive them
14:07:53 <roman_g> and documentation?
14:08:13 <roman_g> old sites need to be closed
14:08:24 <roman_g> and two mode docs sites need to be created
14:08:30 <mark-burnett> Yeah, so I think armada.readthedocs.org is not ours
14:08:31 <jayahn> o/
14:08:33 <mattmceuen> so one of the airship-related repos that hasn't migrated to openstack (yet) is treasuremap -- do we have a path forward yet on what we're going to migrate vs redo, and where it'll live?
14:08:58 <powerds0111> o/
14:09:25 <mattmceuen> o/ powerds0111 jayahn :)
14:09:27 <mark-burnett> mattmceuen I believe some folks have been working to clean that up before that gets moved over
14:09:42 <mattmceuen> ok awesome - thx
14:09:53 <roman_g> haven't heard of anything like that.
14:10:07 <mark-burnett> But the intention is that becomes a showcase of a realistic multi-node deployment
14:10:20 <mattmceuen> that's why we have a meeting now roman_g
14:10:22 <mark-burnett> With the hope that it helps the Akraino project, for example
14:10:35 <mattmceuen> look we're already communicating better
14:11:08 <roman_g> sample site documentation is outdated there, and Darren said that one of internal sites could be cloned to treasuremap as a sample of multinode installation (after cleanup)
14:11:36 <mark-burnett> Re: docs, I agree we should delete the old rtd repos and get them setup properly
14:11:49 <roman_g> +1
14:12:03 <roman_g> action is on whom? who manages those repos?
14:12:08 <b-str> We will need to track down the owners.
14:12:15 <b-str> I think it's various folks
14:12:19 <mark-burnett> agree
14:12:33 <roman_g> I will reach out to RTD team then
14:12:35 <mark-burnett> #action b-str to track down rtd owners to facilitate deletion
14:12:59 <roman_g> ok, ok )))
14:13:14 <mark-burnett> ah, thanks for volunteering roman, but i don't think we  need to goto that team yet
14:13:33 <mark-burnett> Anything else on these cleanup items?
14:13:50 <roman_g> sthussey: would you create 2 more RTD airship-* sites, please? bethr and divingbell
14:14:00 <roman_g> so that all of them are under your account
14:14:10 <sthussey> I can
14:14:34 <mark-burnett> #action sthussey to create remaining airship-* RTD sites
14:15:12 <mark-burnett> #topic Logo Feedback
14:15:26 <roman_g> INFO: Airship documentation on RTD patchsets are on hold until https://review.openstack.org/#/c/579434/ - "Use readthedocs webhook to trigger build" is merged. Felipe, that's for you, because you were reviewing
14:15:37 <mark-burnett> For those who haven't seen, here is the logo thread in the mailing list: http://lists.airshipit.org/pipermail/airship-discuss/2018-June/000025.html
14:15:51 <portdirect> there are also now stickers :D
14:16:02 <mark-burnett> Right
14:16:22 <mark-burnett> Anyway, I know I haven't given direct feedback yet, but if anyone has any, let's try to get feedback in this week :)
14:16:50 <mark-burnett> #topic Bandit incremental testing
14:17:32 <mark-burnett> So, I'm not quite clear on what this adds vs our existing bandit scans, is Jared here?
14:17:49 <roman_g> most probably not.
14:18:13 <mark-burnett> Does anyone have a sense of how this would be more thorough than what we already do?
14:18:55 <openstackgerrit> Marshall Margenau proposed openstack/airship-armada master: Run helm tests by default  https://review.openstack.org/582338
14:19:24 <b-str> We currently run a "full" scan, no?
14:19:27 <sthussey> Doesn't seem useful
14:19:42 <mark-burnett> Yeah, it's my understanding that all python components have full bandit scans on commit
14:19:55 <sthussey> And no arguments for adopting it were provided - I would table it or close it.
14:19:55 <mattmceuen> The incremental scans measure deltas from previous run, I believe (I'm not an expert on them though).  That seems helpful in a CI context to show that issues, haven't been added, right?
14:20:39 <sthussey> Do you not just care about the full attack surface?
14:20:47 <mattmceuen> Do we know who added this one to the agenda - so we can understand the ask better?
14:20:55 <mark-burnett> Jared Stein added it, but is not here
14:21:29 <mattmceuen> Ok, agree w/ sthussy on tabling it so we can talk w/ Jared
14:21:34 <mark-burnett> I think we should just shelve this, since we're already doing full scans and new issues will cause the gates to fail.
14:21:36 <mark-burnett> Ok
14:21:50 <mark-burnett> #topic New Drydock features/specs
14:22:05 <mattmceuen> your reasoning there ^ makes sense to me too mark-burnett
14:22:39 <mark-burnett> There are two thin stories up to prompt writing specs for supporting RAID and BIOS configuration in drydock
14:23:30 <mark-burnett> Is anyone interested in working on these specs?
14:23:47 <mark-burnett> I know there have been a couple of comments on the stories
14:24:03 <roman_g> 1 sec
14:24:26 <roman_g> there is
14:24:28 <roman_g> https://github.com/hemanthnakkina/opensource_blueprints/tree/master/specs/airship
14:24:51 <goutham> I can do that.. Please share the desc somewhere
14:24:58 <goutham> description *
14:25:00 <goutham> i will do
14:25:40 <mark-burnett> It sounds like hemanth has already gotten a nice start on this
14:26:16 <mark-burnett> Maybe you can help work through some additional details goutham?
14:26:38 <goutham> ok sure i will try doing that
14:26:46 <goutham> will talk to hemanth once
14:27:16 <singhannie> Can I contribute in one of them too?
14:27:45 <mark-burnett> So we should actually have an airship-specs repo up soon, so that everyone can contribute
14:27:55 <mattmceuen> That would be awesome singhannie & goutham
14:28:29 <mark-burnett> #action b-str to get the specs infrastructure in place once the repo is created
14:28:45 <mattmceuen> I know drydock is pluggable, but we've only been using one plugin for a while - would it make sense to make a no-op plugin to begin with just to exercise the pluggability part of it a little more before plugging in new backends?
14:28:50 <goutham> thanks mattmceuen and mark-burnett will be happy to do that.
14:29:11 <mattmceuen> (disclosure that was rodolfo's idea not mine)
14:29:21 <sthussey> there are already multiple plugins
14:29:35 <mattmceuen> oh ok
14:29:36 <mark-burnett> i suspect the plugin interface will be refined as we add more
14:29:54 <mattmceuen> what are the other ones sthussey?
14:30:03 <sthussey> virsh
14:30:07 <sthussey> and manual
14:30:15 <mattmceuen> awesome
14:30:18 <mark-burnett> Ok, this leads into our last topic
14:30:28 <mark-burnett> #topic MAAS alternatives
14:30:51 <mark-burnett> So I think the fundamental answer here is "yes, we want more plugins"
14:30:57 <mark-burnett> It's not a mutually exclusive situation
14:31:32 <roman_g> That's mine. I've heard that some people were concerned by performance, and proposed alternative I used previously
14:31:32 <sthussey> net add, folks can add support for any provisioner they want
14:31:58 <mark-burnett> If anyone is interested in adding another plugin, say for ironic or xcat, I would suggest starting with a spec -- ideally that spec will include how we can test the plugin
14:32:36 <roman_g> plugin must be able to run in container, right?
14:32:39 <mark-burnett> re: performance  -   I can't speak to what kinds of MAAS performance issues we've seen
14:33:03 <mark-burnett> roman_g: I think currently it would be an additional driver in drydock code
14:33:27 <mark-burnett> Does anyone have more thoughts on this?
14:34:11 <mark-burnett> OK
14:34:16 <mark-burnett> #topic round table
14:34:43 <mark-burnett> Does anyone have any other discussion points?  Perhaps we could propose longer items as agenda points for next week?
14:34:54 <roman_g> We have record in number of people on the channel.
14:35:01 <mark-burnett> Nice
14:35:37 <mattmceuen> :D
14:36:25 <mattmceuen> Just to +1 the idea of an ironic plugin up above - a spec for that (esp with help from someone with ironic experience) would be really valuable
14:36:45 <mark-burnett> Awesome, thanks everyone for coming!
14:36:49 <mark-burnett> #endmeeting