14:00:21 <mark-burnett> #startmeeting airship
14:00:22 <openstack> Meeting started Tue Sep 18 14:00:21 2018 UTC and is due to finish in 60 minutes.  The chair is mark-burnett. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:24 <portdirect> o/
14:00:25 <openstack> The meeting name has been set to 'airship'
14:00:31 <mark-burnett> Hi all, thanks for coming
14:00:31 <aaronsheffield> o/
14:00:32 <roman_g> o/
14:00:39 <mark-burnett> Here's our agenda for the meeting: https://etherpad.openstack.org/p/airship-meeting-2018-09-18
14:00:41 <mattmceuen> o/
14:01:00 <mark-burnett> Please feel free to add items
14:02:43 <mark-burnett> #topic Meeting reschedule
14:02:56 <mark-burnett> We've talked about this for quite a long time, and it seems that there's no traction for moving it
14:03:12 <mark-burnett> Everyone who voted in the doodle selected the current time
14:03:33 <mark-burnett> We didn't really get much participation from people who don't already attend
14:03:52 <mark-burnett> I think we should simply table this until it comes up again organically.  Any other thoughts?
14:03:53 <seaneagan> o/
14:03:54 <roman_g> I'm OK with this time and frequency.
14:04:01 <mattmceuen> Sounds reasonable to me
14:04:20 <roman_g> Yes, table it.
14:04:23 <sthussey> I believe the genesis for the request was the edge cloud
14:04:46 <sthussey> So maybe in the meantime, if there is a contact there the doodle could be provided such that those interested in attending both could vote
14:05:08 <mark-burnett> Yeah, that was a big motivator
14:05:49 <mattmceuen> Maybe let's connect with Chris H on this
14:05:58 <mark-burnett> @hogepodge ^
14:06:00 <mattmceuen> Let him make sure it gets in front of "the right people"
14:06:08 <mattmceuen> Oh look there he is ;-)
14:06:40 <openstackgerrit> Andrey Volkov proposed openstack/airship-shipyard master: Ensure Drydock pod logs are fetched in case of any exceptions  https://review.openstack.org/603398
14:06:46 <mark-burnett> Let's leave it at that for now then
14:07:15 <mark-burnett> #action mark-burnett work with hogepodge reach out to others who didn't participate in discussion about rescheduling
14:07:24 <mark-burnett> #topic PTG
14:07:35 <mark-burnett> We had pretty great attendance in our room at the PTG!
14:07:46 <mark-burnett> Thanks everyone for contributing
14:08:17 <mark-burnett> I listed some of the interested attendees in the etherpad, but there were also some really great questions and thoughts from other folks too
14:08:18 <roman_g> How many people?
14:08:43 <mark-burnett> Well, Monday morning, there was not enough room at the tables really.  I guess that was roughly 20 people?
14:08:58 <mark-burnett> I should have counted -- 2 or 3 people were literally sitting on the floor until we got more chairs
14:09:03 <mattmceuen> Here's the etherpad, where some notes were captured if anyone wants to catch up:  https://etherpad.openstack.org/p/AirshipPTG4
14:09:10 <mark-burnett> Thanks mattmceuen
14:09:17 <mark-burnett> I'll write up a digest email and send it to the list this week
14:09:30 <mark-burnett> #action mark-burnett write digest of PTG notes for the mailing list
14:09:52 <hogepodge> hi
14:10:20 <mark-burnett> Hey Chris
14:11:11 <mark-burnett> Does anyone have any other thoughts about how the PTG went?
14:11:32 <portdirect> I thoughr it was pretty good
14:11:42 * roman_g wants to participate.
14:11:48 <portdirect> there was a lot of interest, esp in a 'stepped' airship
14:12:08 <hogepodge> I don't know of anyone who wanted a different time. I'll check with ildiko but aside from waking up early here ;-) it should be fine
14:12:12 <portdirect> as many orgs found the full stack a bit much, eg they have a bm/k8s provisioner
14:12:31 <portdirect> or are simply looking to get there toes wet
14:12:58 <roman_g> portdirect, you mean that many of them want to use only specific parts of airship-*?
14:12:58 <sthussey> seems like Armada would be a good fit for them then
14:13:17 <portdirect> time will tell how much interest turns into contributions, but theres def great potential
14:13:19 <mattmceuen> Agree, that was the biggest "surprise" use case for me - there were other use cases / enhancements we knew would be useful that other folks were in large agreement in too, and it was really good fleshing those out a bit with potential users/contributors
14:13:32 <portdirect> sthussey: armada, into dechand, and also shipyard
14:13:43 <portdirect> and at that stage...
14:13:50 <portdirect> why not eat the whole cake ;)
14:14:51 <mark-burnett> Indeed, there are teams that dont' control hardware provisioning who want to leverage as much of the declarative approach as they can
14:14:55 <mark-burnett> for example
14:14:55 <portdirect> there was also a strong desire to make things pluggable, eg kubeadm instead of (or driven by) promenade
14:15:09 <portdirect> and ironic as a back end for maas
14:15:17 <sthussey> Drydock is pluggable
14:15:26 <sthussey> If someone wants Ironic, the design supports them adding it
14:15:36 <portdirect> yeah 0 though someone needs to step up and write the plug ;)
14:15:38 <mattmceuen> Yup, we discussed that and there was a lot of support for it
14:15:43 <sthussey> It seems kubeadm would mostly be a alternative to promenade
14:16:19 <portdirect> there was also some discussion later in the week on the use of yaml for deckhand
14:16:38 <portdirect> where a few people expressed an interest in json responses
14:16:59 <portdirect> though fmonetro has a better understanding of the discussion there.
14:17:00 <sthussey> Sounds like there is a lot of room for some speculative designs
14:17:19 <sthussey> Will be great to see specs written up by those interested in these enhancements
14:17:31 <portdirect> ++
14:17:33 <jayahn> o/
14:17:38 <mark-burnett> Hi jay :)
14:18:31 <jayahn> hi
14:18:32 <portdirect> on the subject of `stepped` airship - I think mattmceuen 's work on airskiff has great potential there.
14:18:47 <jamesgu__> ++
14:18:56 <portdirect> as it's already 90% of what people were expressing an interest in.
14:19:04 <portdirect> in addtion to the full stack.
14:19:06 <sthussey> There you go
14:20:00 <jamesgu__> airskiff is a step up itself to just using the Armada
14:20:04 <mattmceuen> Thanks portdirect - I think that's a good POC of the concept, and I think some additional things would need to be done to make the concept work well in a real life deployment
14:20:56 <mattmceuen> E.g. there was discussion around leveraging drydock to potentially manage machines that were brought in a "bring your own OS" type scenario
14:21:16 <mattmceuen> But we can evolve to those
14:21:46 <jamesgu__> or possible to bring in promenade in the bring your own hardware?
14:22:43 <mark-burnett> I think airskiff is basically just running helm install on the airship charts on an existing kube cluster
14:23:44 <sthussey> I think most of this needs to be put together in a cohesive spec
14:23:53 <mark-burnett> I think if we're going to implement a tiered approach, the components will need to be armada-managed
14:23:54 <mattmceuen> Yup, that's it.  In an eventual, target-state BYO{x} it would be nice to use an armada-based deployment
14:24:05 <sthussey> Ad hoc IRC discussion probably omits too many details to be valuable
14:24:18 <mark-burnett> Yeah, a spec would be useful here so that intent is really clear
14:24:26 <mark-burnett> What is in bounds and what is out
14:24:47 <mattmceuen> Sounds like good discussion for Rodolfo's weekly design call as well
14:25:01 <mattmceuen> To figure out what should go into the spec
14:25:06 <jayahn> speaking of design call, why it is so~~ difficult to find out this week's design meeting time. I found etherpad, I found design meeting is switching time, but not the exact information on this week's time. it should be really easy information to find.
14:25:31 <mark-burnett> Good point Jay, let me add it to the main etherpad for reference: https://etherpad.openstack.org/p/airship-team-meeting-agenda
14:25:34 <mark-burnett> I'll put that in there today
14:25:56 <mark-burnett> #action mark-burnett make sure the design call details are in this etherpad: https://etherpad.openstack.org/p/airship-team-meeting-agenda
14:26:33 <mark-burnett> On another note, there was some discussion in the infra team about how to facilitate screen sharing/phone calls while still achieving good accessibility
14:26:44 <jayahn> I don't want to move a topic away.. but, it should be really easy information to find like other openstack-meeting information.
14:27:20 <mark-burnett> As mattmceuen said, we need to make sure that the important parts of design conversations are captured in specs
14:27:27 <mattmceuen> Agree jayahn, any suggestions?
14:27:41 <jamesgu__> before we move on to next topic, with the discussion of a spec, sounds like the plan is to move Airskiff to Openstack proper?
14:27:41 <mattmceuen> on where we could put the info
14:27:50 <mattmceuen> Let me clarify
14:27:59 <mark-burnett> @jamesgu__ I think we need to figure out a plan before we do that
14:28:06 <mark-burnett> It's not clear there needs to be a new component here
14:28:10 <mattmceuen> re: airskiff - because it got some good attention at the PTG (#flattering)
14:28:25 <mattmceuen> Airskiff was intented first and foremost to be a dev environment
14:28:38 <mattmceuen> We discussed at the PTG using "airskiff approach" for two additional things
14:28:40 <mattmceuen> gating
14:28:44 <mattmceuen> byo{X}
14:29:03 <mattmceuen> I think those are great use cases, and I don't want to shoehorn anything so important into my github repo :)
14:29:06 <mattmceuen> So to your question
14:29:17 <roman_g> jamesgu__: as usual, all OpenStack projects meetings are described here, including Airship: http://eavesdrop.openstack.org/#Airship_Team_Meeting . Please, check it out.
14:29:28 <mattmceuen> I will be working w/ Drew this week to adjust his PS for additional gates per our discussion @ the PTG
14:29:52 <mattmceuen> I want to use the airskiff approach (which is really the openstack-helm approach that I borrowed) for some very lightweight gates
14:29:57 <mattmceuen> That will start out as nonvoting
14:30:08 <mattmceuen> And use the treasuremap manifests as much as possible
14:30:28 <mark-burnett> This probably belongs in the design call, but it seems to me that we could make a small change to armada and simply use that directly
14:30:31 <sthussey> I believe there is a meeting topic on testing methods
14:30:38 <mattmceuen> So that work will move into treasuremap proper as a new home, but if it makes sense I'll still keep airskiff around as a separate dev playground
14:31:35 <mark-burnett> Let's move on to new business
14:31:46 <mark-burnett> #topic Policy for idle patchsets
14:32:26 <mark-burnett> I don't have the links off hand, but there are a couple of older changes that are unlikely to merge and should probably be abandoned
14:32:57 <mark-burnett> We probably need a simple way of determining whether/when to abandon submitted changes
14:33:17 <mark-burnett> Suggestions?
14:33:55 <sthussey> I think 60 days of inactivity should be abandoned
14:33:58 <roman_g> Bot, adding comments to the change if it's stale for 4 weeks, and abandoning if no replies after 8 weeks.
14:34:11 <mark-burnett> Those sound really similar and fair to me
14:35:14 <roman_g> But does it hurt to have patch sets which are abandoned?
14:35:15 <mark-burnett> Should we try a manual version of what roman suggests and see how it goes?  Certainly people can recreate abandoned changes later if that is useful.
14:35:42 <roman_g> I mean, if author does not care to ask for reviews, then why would we care?
14:36:01 <roman_g> gerrit will not break
14:36:30 <evrardjp> mark-burnett: 365 days
14:36:41 <mattmceuen> You can also un-abandon PS
14:36:51 <evrardjp> yup
14:36:58 <mark-burnett> @evrardjp why do you propose that timeline specifically?
14:37:07 <evrardjp> habit :)
14:37:10 <mattmceuen> lol
14:37:10 <mark-burnett> ha, gotcha
14:37:10 <evrardjp> easy to check
14:37:17 <sthussey> I'd prefer to be a bit more agressive
14:37:33 <sthussey> As the cores, though it is not apparent, do try to keep the open PS list down
14:37:33 <roman_g> Gerrit auto-abandon changes which are stale for certain period of time: https://gerrit-review.googlesource.com/Documentation/user-change-cleanup.html
14:38:00 <evrardjp> by default it's to 0
14:38:03 <evrardjp> iirc
14:38:05 <sthussey> That looks to be an optional configuration.
14:38:21 <sthussey> Maybe this is something that Airship projects could tune in openstack-infra
14:38:29 <evrardjp> it's probably something we can ask infra
14:38:30 <evrardjp> hahah
14:38:32 <evrardjp> yeah
14:38:38 <evrardjp> maybe
14:38:54 <evrardjp> not sure if it's global or not
14:38:59 <mark-burnett> yeah, not clear
14:39:05 <evrardjp> if it's per gerrit instance it will not happen
14:39:20 <evrardjp> and it kinda looks like it: etc/gerrit.config  :)
14:39:29 <mark-burnett> Well, let's vote on a manual policy and see what happens about automation later
14:39:41 <evrardjp> I guess it's worth asking on infra to document the manual policy decision
14:39:49 <evrardjp> should someone ask again
14:40:45 <mark-burnett> #startvote How long should we leave changes inactive before abandoning?  Options: 1M, 2M, 1Y, Never Abandon.
14:40:45 <openstack> Begin voting on: How long should we leave changes inactive before abandoning? Valid vote options are Options, 1M, 2M, 1Y, Never, Abandon, .
14:40:46 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
14:40:59 <roman_g> Actually, documentation says that patch sets should auto-abandon in 2 weeks of no-touch https://docs.openstack.org/infra/system-config/gerrit.html#auto-review-expiry
14:41:17 <mattmceuen> wow, two weeks
14:41:25 <mark-burnett> Is that just one specific project?
14:41:28 <roman_g> #vote 2M
14:41:34 <mattmceuen> that's harsh for contributors that may not be e.g. full-time on the project, in my opinion
14:41:35 <evrardjp> not sure if it still applies.
14:41:47 <mark-burnett> #vote 2M
14:41:50 <portdirect> #vote 2M
14:41:50 <mattmceuen> #vote 2M
14:41:55 <aaronsheffield> #vote 1M
14:42:02 <jayahn> #vote 2M
14:42:09 <jamesgu__> #vote 2M
14:42:31 <evrardjp> I guess the winner is clear :)
14:42:49 <mark-burnett> It seems, but let's give it another minute in case someone has a strong objection
14:43:00 <sthussey> #vote 2M
14:43:46 <mark-burnett> Ok, ending in a efw seconds
14:44:01 <mark-burnett> #endvote
14:44:02 <openstack> Voted on "How long should we leave changes inactive before abandoning?" Results are
14:44:03 <openstack> 2M (7): mark-burnett, portdirect, jayahn, roman_g, mattmceuen, jamesgu__, sthussey
14:44:04 <openstack> 1M (1): aaronsheffield
14:44:23 <openstackgerrit> Drew Walters proposed openstack/airship-shipyard master: wip: plugins: Add Armada subdag/operator for helm tests  https://review.openstack.org/603236
14:44:39 <mark-burnett> Ok, so let's start enforcing a manual policy of giving change authors notice of the policy after ~1M and then abandoning old changes at 2M
14:45:39 <mark-burnett> #agreed We will abandon changes that have been idle for 2 months, and give authors notice of this policy at approximately 1 month of idle time.
14:45:52 <mark-burnett> #topic Testing Policy Reminder
14:46:16 <mark-burnett> Quick note on testing changes - in particular for promenade and drydock, which touch a lot of pieces
14:46:55 <mark-burnett> Please be sure to run the prom resiliency gate for promenade changes.  We have not been able to get this going in Zuul yet (or in AT&T-provided 3rd party gating), but it's pretty easy to run locally (if you have about 12G of ram).
14:47:05 <mark-burnett> It takes about 30 minutes to run on my laptop, for reference
14:47:31 <mark-burnett> For drydock, the situation is a bit trickier, but there is a similar test (the multi-node gate in airship-in-a-bottle).
14:47:46 <mark-burnett> Feel free to reach out for help with these, or even better start trying to get them working in zuul :D
14:48:56 <mark-burnett> #topic Collaboration Opportunities
14:49:09 <mark-burnett> I was super excited to talk to Jay and James at the PTG about working on airship :)
14:49:19 <mark-burnett> I don't have anything to add beyond the brief snippets in the etherpad
14:49:43 <jayahn> yeap. just want to do quick intro on this week's design call, and figure from there
14:49:53 <mark-burnett> Awesome, I'll make sure those details are added
14:49:57 <mark-burnett> to the etherpad, as above
14:50:02 <jayahn> thanks
14:50:29 <mark-burnett> #topic Development Update
14:51:02 <mark-burnett> Just a reminder to add notable development activities to https://etherpad.openstack.org/p/airship-dev-update-2018-10-05 so that I can write something up for the list
14:51:09 <mark-burnett> I'm targeting 10/5 this go around
14:51:29 <roman_g> would versions.yaml updater fit there?
14:51:35 <mark-burnett> Yes!
14:51:42 <mark-burnett> Good though :)
14:51:43 <mark-burnett> t
14:51:51 <mattmceuen> ++
14:52:21 <mark-burnett> #topic Reviews
14:52:45 <mark-burnett> I don't really have anything to say on this one
14:52:53 <mark-burnett> Others may have?
14:53:21 * mattmceuen is still clueless after long weekend
14:54:00 <mark-burnett> Ok, let's punt.  If it's an issue we can add it for next week.
14:54:18 <mark-burnett> #topic reviewbot noise
14:54:37 <mark-burnett> I think @roman_g raised the idea that every `git review` leading to an irc message is a bit spammy
14:55:10 <roman_g> Yes, I have raised it.
14:55:28 <roman_g> I (roman_g) look for questions from community members, and ask for reviews, and ask for help from developers. I don't look at openstackgerrit bot notifications - they only show to me that someone is working.
14:55:29 <mark-burnett> I personally agree with the opinion of keeping a single irc channel for now, so I'm not too excited about splitting even for a build-notification channel
14:55:58 <mark-burnett> I don't really use the notifications, as I just look through the gerrit list directly
14:56:15 <roman_g> Do I go and checkout everyone's review once I see notification from the bot? - No.
14:56:36 <roman_g> For me it's useless. So far.
14:56:58 <mark-burnett> I've seen this pattern be useful to some members on smaller teams, but I agree with you overall roman_g .
14:57:22 <mark-burnett> I would start a vote, but I think most people have gone
14:57:27 <mark-burnett> I think an hour is too long for us :/
14:57:31 <b-str> If there were a way to do a digest, that might be nice
14:57:33 <roman_g> May be notification on merges would be better.
14:57:56 <mark-burnett> @b-str interesting idea
14:58:09 <mark-burnett> @roman_g maybe so, yes, but that's not a call to action for devs
14:58:10 <mark-burnett> usually
14:58:17 <mark-burnett> Let's add it to next week for a vote
14:58:29 <mark-burnett> I don't think we should vote with 2 minutes left and waning attendence
14:58:43 <mark-burnett> #topic Marketing Deadlines
14:59:17 <mark-burnett> Looks like October 1 is the deadline for single page marketing doc and updated website content
14:59:35 <mark-burnett> I think there's a google doc for the 1 page, but I don't have it handy
14:59:35 <hogepodge> yes, our design team needs lead time to produce everything for Berlin
14:59:40 <mark-burnett> Right
15:00:06 <mark-burnett> What is the best way to give feedback for the website?
15:00:13 <mark-burnett> We can link the google doc for the 1-pager
15:00:13 <hogepodge> I've been flowing in a lot of content for the one pager, and will have that and some preliminary website content ready for our meeting on Thursday
15:00:21 <mark-burnett> ok cool
15:00:28 <mark-burnett> Thanks hogepodge
15:00:48 <mark-burnett> alright, let's wrap up
15:00:51 <mark-burnett> #topic roundtable
15:00:55 <mark-burnett> Any last minute thoughts?
15:01:07 <portdirect> did we have time to discuss -2 reviews?
15:01:10 <hogepodge> Yeah, we'll need major feedback from you starting Thursday, due by the end of the month (plus revised diagram drafts)
15:01:19 <mark-burnett> We already hit that topic @portdirect
15:01:43 <portdirect> must have missed it - damn i created it as well!
15:01:46 <portdirect> lol
15:01:47 <mark-burnett> :)
15:01:53 <mark-burnett> We can add it for next week if you like
15:02:01 <portdirect> yes please
15:02:03 <portdirect> thx
15:02:15 <mark-burnett> ok, let's close
15:02:18 <mark-burnett> #endmeeting