14:00:10 <mattmceuen> #startmeeting airship
14:00:11 <openstack> Meeting started Tue Mar  5 14:00:10 2019 UTC and is due to finish in 60 minutes.  The chair is mattmceuen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:14 <mattmceuen> #topic Rollcall
14:00:15 <openstack> The meeting name has been set to 'airship'
14:00:18 <mattmceuen> GM / GE everyone!
14:00:21 <Nishant_> o/
14:00:30 <dwalt> GM! o/
14:00:32 <mattmceuen> Agenda for today: https://etherpad.openstack.org/p/airship-meeting-2019-03-05
14:00:34 <hemanth_n> GM
14:00:52 <mattmceuen> We'll wait a few for folks to trickle in; please add anything you'd like to discuss to the agenda
14:00:52 <seaneagan> o/
14:01:28 <georgk> i
14:01:33 <georgk> hi
14:01:33 <levmorgan> o/
14:02:26 <mattmceuen> Ok - let's get started
14:02:34 <mattmceuen> #topic Armada Helm test timeout value change
14:02:39 <mattmceuen> dwalt: all yours
14:02:51 <dwalt> Thanks mattmceuen
14:03:24 <dwalt> Just a heads up: there is an Armada change that went in recently that changes the behavior of how Helm tests are run in Armada
14:03:30 <dwalt> #link
14:03:45 <dwalt> #link https://review.openstack.org/618585
14:03:48 <dwalt> woops :)
14:04:22 <dwalt> The timeout value for Helm tests is no longer derived from the wait timeout value and is a separate test.timeout key
14:04:50 <mattmceuen> dwalt, wasn't it also the case that the helm test was actually being included in the overall wait timeout?
14:05:07 <mattmceuen> Such that, if timeout was 5 min, and the actual deploy took 5 min, there wouldn't be any time left for test?
14:05:20 <dwalt> mattmceuen: yes, it was derived from the remaining time left from the wait timeout after an upgrade was completed
14:05:25 <dwalt> exactly
14:06:12 <dwalt> Now that the new default timeout value is 300, some longer tests may unexpectedly timeout. For instance, we saw this happen with Neutron in the Airship-Seaworthy site
14:06:23 <dwalt> #link https://review.openstack.org/639462
14:06:35 <dwalt> That's all, just more of a heads up
14:06:55 <mattmceuen> Got it - good one, thanks for bring it up
14:07:00 <dwalt> sure thing
14:07:19 <mattmceuen> #topic Airship comminity IRC meeting time change
14:07:32 <mattmceuen> Hey roman_g do we have you in yet perchance?
14:07:55 <mattmceuen> I have a handle on this one anyway: https://review.openstack.org/#/c/640359/
14:08:25 <mattmceuen> As discussed here & on the mailing list, there's a majority desire to shift the meeting time a bit - this formally moves it 2 hours later on the same days as now
14:08:55 <mattmceuen> So heads up -- today's meeting may be the last one at the current time!  However, I think it just depends on when the PS merges.
14:09:14 <mattmceuen> So reviews on that PS are appreciated - thanks
14:10:10 <mattmceuen> #topic Onboarding Environments / Dev Documentation
14:10:29 <mattmceuen> Hey sthussey, you were out last week but we talked about something you added to the agenda - looping back:
14:10:54 <mattmceuen> There is a variety of different tooling/yamls for standing up an Airship enviroment
14:11:17 <mattmceuen> I put in a storyboard item to try to align those a bit based on our discussion last week: https://storyboard.openstack.org/#!/story/2005123
14:11:50 <mattmceuen> The storyboard description got a little verbose -- if anyone would like to discuss / nitpick it, I can copy/paste into a spec; but I'll only do that if needed or helpful :D
14:12:11 <mattmceuen> In any case - feedback welcome from all on that (as is implementation!)
14:12:35 <mattmceuen> I think we brought up last week dwalt that you're working on aligning airskiff site to the treasuremap globals -- how's that going?
14:13:02 <sthussey> So we still want to maintain the automation for standing up 3 different flavors of dev/testing environments?
14:13:22 <mattmceuen> so dwalt just lost his connection, he may not be answering the question :)
14:13:52 <mattmceuen> the spec calls out aligning aiab single node tooling to the aiab multinode tooling to remove one of those
14:13:58 <mattmceuen> not spec, storyboard
14:14:12 <mattmceuen> as single node is a special case of multinode
14:14:30 <sthussey> Okay, I misread that as only the demo environment
14:15:12 <roman_g> o/
14:15:20 <roman_g> Hi. Just came. Sorry for being late.
14:15:38 <mattmceuen> I think (anyone correct me if wrong) that the single-node demo env is really the one that gets a lot of use, and the single-node dev site doesn't get a lot of use (since devs often use multinode aiab) - anyone know otherwise?
14:15:44 <mattmceuen> o/ roman_g! no worries
14:16:27 <sthussey> Can we note in there deleting the dev-minimal then?
14:17:02 <mattmceuen> sure thing - if anyone has any concerns between now & impl time, please bring it up; if so we can just migrate the dev-minimal site at the same time
14:17:38 <dwalt> Sorry for the connection issues. The patch to align Airskiff with the UCP global documents in Treasuremap is here: https://review.openstack.org/635218
14:18:07 <mattmceuen> As part of the discussion last week, also came up that it would be valuable to have some additional developer-centric documentation.  I created a story / tasks for that as well:  https://storyboard.openstack.org/#!/story/2005122
14:18:08 <dwalt> I haven't been able to revisit it this week, but it's very close. There are just a few secret substitutions that need to be cleaned up
14:18:19 <mattmceuen> awesome - ty dwalt
14:19:10 <mattmceuen> Interested on feedback on the content of the dev doc story.  Especially from folks who need it the most!  If it doesn't answer the right questions etc, please let me know and we can add more tasks
14:19:46 <roman_g> Will have a look
14:20:02 <levmorgan> Will do.
14:20:07 <mattmceuen> I made the tasks a bit granular because different authors have experience in different areas.  If anyone would like to author some content that is not called out as a task yet, though, please go ahead and add a task
14:20:31 <mattmceuen> I plan to tackle some of the content and would appreciate as much collaboration as possible :D
14:20:32 <mattmceuen> thanks guys
14:20:50 <mattmceuen> #topic     Divingbell gates are broken in upstream
14:21:31 <mattmceuen> roman_g:  I know you discussed this a bit with the OSH folks; where does this sit now - still trying to root cause the specific issue, right?
14:21:33 <roman_g> Roman is here. Slowly progressing.
14:22:07 <mattmceuen> Is there anything other folks can do to assist you in that?
14:22:10 <roman_g> I know that behavior changes between 2.11.0 and 2.12.0.rc1
14:22:45 <roman_g> Wel,, may be a quick Zoom session, to show me how i can quickly test different versions of helm/tiller
14:22:55 <roman_g> Would appreciate a lot.
14:23:13 <sthussey> is this the issue of how maps are handled?
14:23:25 <roman_g> yes.
14:23:46 <roman_g> patch from cheng1 did not help
14:24:11 <sthussey> Might also want to check with what version of Go tiller was built. May be a underlying change in Go's behavior
14:24:56 <roman_g> I can compile/recompile helm/tiller very fast, but I did not get to a point where I could easily use newly compiled helm/tiller for the chart renderring
14:25:29 <roman_g> I have go version go1.10.4 linux/amd64
14:25:52 <mattmceuen> roman_g I'll set up a troubleshooting session & send out on the ML.  seaneagan if you can join I think that would be helpful too.   I'm thinking it'll probably be Thurs or Fri
14:25:54 <roman_g> latest on Ubuntu 16.04.5 LTS
14:26:29 <mattmceuen> #action mattmceuen: set up troubleshooting session for helm mapping issue impacting divingbell gates
14:26:31 <roman_g> thank you, mattmceuen
14:26:41 <mattmceuen> thank you roman_g for tackling this
14:26:53 <roman_g> sthussey: good advice. Thanks.
14:27:09 <mattmceuen> #topic Deckhand & Shipyard - OpenSUSE builds
14:27:25 <roman_g> arunkant:
14:27:40 <roman_g> james is not here
14:27:45 <roman_g> Arun, are you here?
14:28:31 <mattmceuen> This one may be a good one for the ML :)
14:29:01 <roman_g> #action followup in ML for OpenSUSE builds of Airship
14:29:06 <mattmceuen> ty roman_g
14:29:25 <mattmceuen> #topic Minimirror: move spec and review on the fly patches
14:29:50 <dwalt> thanks for adding this again roman_g
14:30:00 <roman_g> :D
14:30:24 <roman_g> would you have a look?
14:30:44 <dwalt> There has been some new developments in this area, as it looks like we will soon be able to publish a mini-mirror image from openstack-helm-images. That means we can integrate this in AIAB and seaworthy
14:31:00 <dwalt> as for the spec, I still need to remove that. Thanks for the reminder
14:31:05 <mattmceuen> oh, that's awesome
14:31:14 <roman_g> it's piblished in openstack-helm-images already, as far as I can see
14:31:42 <dwalt> thank you evrardjp as well for your work in osh-images so that this can be possible!
14:31:51 <mattmceuen> +1
14:32:15 <roman_g> but there are some patches from Alex Volkov, which are non-merged, and will not be merged (because minimirror is in different repo now). For example, there is a good manual for the minimirrod.
14:32:19 <roman_g> *or
14:33:10 <mattmceuen> yeah, those will need to be abandoned or reworked against the new repo as appropriate
14:33:14 <mattmceuen> will take a look roman_g
14:33:36 <roman_g> thank you
14:33:46 <mattmceuen> alrighty, moving on:
14:33:49 <mattmceuen> #topic Airship talks accepted into the Denver Summit
14:33:53 <roman_g> #link https://review.openstack.org/#/q/minimirror - some of them seem to be good to be integrated into the openstack-helm-images repo
14:33:57 <mattmceuen> oops
14:34:03 <roman_g> sorry
14:34:13 <mattmceuen> my bad roman_g, pulled the trigger too early
14:34:46 <mattmceuen> https://etherpad.openstack.org/p/airship-meeting-2019-03-05
14:35:04 <mattmceuen> ^ that has an extract of the Airship-related sessions at the upcoming summit, FYI
14:35:34 <mattmceuen> Some of them by us in the meeting, some by other folks, and some are cross-project presentations that have tagged #airship
14:35:57 <mattmceuen> But good to see a lot of content and variety planned for the open infra summit around Airship!
14:36:37 <mattmceuen> Any other thoughts on this topic?
14:37:08 <roman_g> Congrats to winners :)
14:37:30 <roman_g> Look forward to watch the recording on youtube.
14:37:31 <mattmceuen> +1
14:37:57 <mattmceuen> #topic Ironic driver spec
14:38:32 <mattmceuen> we have hemanth_n here - pas-ha I believe we wanted to sync up a bit or have some Q&A on the Ironic spec, right?
14:39:45 <mattmceuen> I think we may be missing pas-ha here today
14:41:05 <mattmceuen> I believe the open questions were around Ironic functions not being exactly 1:1 with MaaS functions, and how to bridge the gap from a plugin perspective
14:41:29 <mattmceuen> There is discussion around that in the Spec, but I'm not certain what the outstanding questions are that needed to be discussed here
14:42:02 <hemanth_n> I will take a look at spec and will try to answer them ... and probably will reach to pas-ha
14:42:12 <mattmceuen> thanks hemanth_n - that would be awesome
14:42:31 <mattmceuen> Spec, for anyone who's interested:  https://review.openstack.org/#/c/613358/
14:42:43 <sthussey> It looks like someone from Dell also has some input on that spec
14:43:41 <mattmceuen> yep Prakash
14:44:10 <mattmceuen> He has been providing feedback on the spec as well and has expressed interest in collaborating on Ironic - Airship integration
14:44:54 <mattmceuen> We'll continue this on the spec review proper - thx guys
14:45:03 <mattmceuen> #topioc 1.0 release
14:45:16 <mattmceuen> This is your hogepodge!
14:45:18 <hogepodge> I added the topic
14:45:29 <roman_g> #topic 1.0 release
14:45:35 <mattmceuen> sigh
14:45:42 <mattmceuen> #topic 1.0 release
14:45:42 <hogepodge> We're looking at scheduling for the time between now and the summit, and the 1.0 release is supposed to happen in there
14:46:19 <hogepodge> I wanted to check on the status of the release, how it might bump up against the OpenStack Stein release, and other issues around it.
14:47:13 <hogepodge> We also have things like Foundation Newsletter and demos and work on the bare metal whitepaper that will also need to take the release into accound.
14:47:16 <hogepodge> account.
14:47:46 <mattmceuen> Good add.  Time is definitely flying between now and the summit.
14:48:14 <mattmceuen> Initial Ironic integration is the biggest thing we wanted to have in place for the 1.0 release
14:48:25 <mattmceuen> So that is one we need to stay on top of
14:49:13 <hogepodge> Will Ironic cause it to slip past the summit?
14:51:31 <mattmceuen> Remains to be seen, I am optimistic.  We don't need the integration to be 100% full-featured for the release IMO, but we did express it as something we should have in place.
14:51:47 <mattmceuen> I will sync up with pas-ha and get a better answer
14:52:46 <mattmceuen> Another area we wanted to firm up a bit is the "ease of use" around YAMLs.  I think we've come a long way since Berlin in a couple areas:
14:53:14 <mattmceuen> 1) the treasuremap repo has continued to mature, and we're publishing monthly releases that can be used as a basis for deployments
14:53:55 <mattmceuen> 2) The airship-spyglass project can be used to generate site configurations from xls files
14:54:39 <hogepodge> ok
14:55:11 <hogepodge> I think the preference would be to have a release with fewer features than a late release, mostly because of the summit platform
14:55:21 <hogepodge> but we can't have a broken release
14:55:29 <mattmceuen> Documentation was an additional area to firm up for 1.0.  The dev documentation brought up earlier is a good foundation for that.
14:55:39 <hogepodge> we can talk more at the community meeting this Friday
14:55:47 <hogepodge> (which is another topic to slip in under the wire)
14:55:51 <mattmceuen> Roger hogepodge - will proceed with that in mind
14:55:54 <mattmceuen> :D
14:55:59 <mattmceuen> go for it
14:56:06 <hogepodge> There's and OSF/Airship community meeting this Friday. I'll send details to the mailing list.
14:56:30 <hogepodge> For now we'll start weekly, but will move to biweekly if it makes more sense.
14:56:42 <mattmceuen> Sounds like a plan - ty for setting that up
14:57:12 <mattmceuen> #topic Roundtable
14:57:17 <mattmceuen> Just a couple mins left --
14:57:20 <mattmceuen> https://review.openstack.org/#/c/615387/
14:57:20 <mattmceuen> https://review.openstack.org/#/c/635507/ - openstack/airship-treasuremap - Add cache for results of requests to quay.io in Updater tool
14:57:31 <mattmceuen> ^ if we can get some review on these that would be awesome
14:57:41 <mattmceuen> Anything else to discuss today?
14:58:00 <levmorgan> Well
14:58:40 <levmorgan> Does anyone know about the coverage threshold in Zuul being raised to 86 percent (at least for Pegleg?)
14:59:44 <sthussey> I saw a PS that did that
14:59:58 <dwalt> #link https://review.openstack.org/634593/
15:00:29 <Nishant_> I see it 86 percent here - https://github.com/openstack/airship-pegleg/blob/master/tox.ini#L63
15:00:53 <levmorgan> Thanks!
15:01:31 <mattmceuen> Looks like tests were added as part of that change so that is good :)
15:01:36 <dwalt> +1
15:01:36 <mattmceuen> thanks lamt!
15:01:38 <sthussey> https://review.openstack.org/#/c/634593/6/tox.ini
15:01:41 <mattmceuen> we our out of time!
15:01:43 <mattmceuen> *are
15:01:48 <mattmceuen> #endmeeting