16:00:16 <dwalt> #startmeeting airship
16:00:16 <openstack> Meeting started Tue Mar 12 16:00:16 2019 UTC and is due to finish in 60 minutes.  The chair is dwalt. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:20 <openstack> The meeting name has been set to 'airship'
16:00:23 <dwalt> #topic Rollcall
16:00:30 <aaronsheffield> o/
16:00:35 <dwalt> hey everyone! mattmceuen is out today, so I'll be hosting
16:00:40 <dwalt> Here is our agenda: https://etherpad.openstack.org/p/airship-meeting-2019-03-12
16:00:58 <dwalt> Let's give it until 5 after for everyone to join and add items
16:01:11 <evgenyl> Hi
16:01:22 <michael-beaver> o/
16:01:51 <pas-ha> o/
16:02:23 <Nishant__> o/
16:04:18 <roman_g> щ.
16:04:21 <roman_g> o/
16:05:14 <jamesgu> o/
16:05:22 <dwalt> o/ to everyone trickling in! It's 5 after, let's go ahead and begin
16:05:24 <dwalt> #topic Divingbell overrides fixed
16:05:28 <dwalt> roman_g: the floor is yours
16:06:18 <sthussey> here
16:07:00 <roman_g> Just wanted to thank everyone who helped with fixing overrides issue
16:07:13 <roman_g> sthussey srwilkers portdirect * Craig
16:07:20 <roman_g> &
16:07:36 <srwilkers> o/
16:08:03 <portdirect> we do now need to work out what to do about armada though
16:08:18 <dwalt> ty for all of the hard word on that
16:08:19 <portdirect> as its goning to need to be rebuilt against helm 2.13
16:08:30 <portdirect> and i think there is an issue there?
16:09:01 <Nishant__> there is already a PS out there by Sean to pin armada to a stable HTK
16:09:09 <roman_g> portdirect: latest gates are green for armada, but yes, it needs to be checked
16:09:11 <dwalt> portdirect: I saw a patch from seaneagan about pinning helm toolkit today. Should we reconsider moving forward with that approach?
16:09:22 <Nishant__> https://review.openstack.org/#/c/642568/
16:09:29 <dwalt> thanks NISHANT_
16:09:33 <portdirect> im meaning not the armada chart, but the ability for armada to make use of the fix
16:09:40 <portdirect> in things like divingbell
16:09:52 <portdirect> as the fix requires helm 2.13
16:10:06 <portdirect> and armada talks to an older version of tiller atm
16:10:42 <portdirect> we need armada to support the `mergeOverwrite` function
16:10:42 <dwalt> I see. I think there was a patch from michael-beaver to update Armada to 2.13 yesterday as well
16:10:50 <portdirect> ah nice
16:10:51 <Nishant__> oh gotcha ! yep that needs to be thought through
16:10:53 <portdirect> you have a link
16:10:57 <dwalt> checking now
16:11:06 <dwalt> michael-beaver: do you have any updates on that front?
16:11:27 <michael-beaver> Yeah I threw that up yesterday, if we want to take that as the path forward I can brush it up and make sure it is using all the right functions
16:11:31 <seaneagan> yeah, armada and promenade both can't use helm 2.13.0 due to: https://github.com/helm/helm/issues/5408
16:11:41 <michael-beaver> I initially abandoned it since it looks like we were going to just pin the htk
16:11:42 <dwalt> #link https://review.openstack.org/642553
16:11:48 <seaneagan> will be fixed in helm 2.13.1
16:12:00 <portdirect> ok - so we blocked untill then seaneagan ?
16:12:12 <openstackgerrit> Kaspars Skels proposed openstack/airship-in-a-bottle master: Cert/key related improvements to gate-multinode  https://review.openstack.org/642585
16:12:24 <portdirect> as hacky as it is - can armada just use a 2.13 tiller and be happy?
16:13:10 <seaneagan> yes we are blocked from using helm 2.13's `mergeOverwrite` until then
16:14:01 <seaneagan> no that is the issue that we are using tiller flags that were accidentally removed in 2.13
16:14:10 <seaneagan> will be re-added in 2.13.1
16:14:29 <portdirect> ok - we probably need to work out how to better co-ordinate these fixes then
16:14:39 <portdirect> so we dont end up breaking each others projects
16:14:55 <portdirect> you have any idea when 2.13.1 is out?
16:15:27 <seaneagan> no, but here's all i know: https://github.com/helm/helm/milestone/62
16:15:29 <portdirect> could we use a pinned commit from master untill then to work round this? or we totally dependent on a release from helm?
16:16:38 <seaneagan> i think it would be possible but that may leave armada in an unreleasable state
16:16:54 <roman_g> add a gate to HTK with Armada?
16:17:16 <roman_g> (we already have divingbell gate, non-voting)
16:17:46 <dwalt> roman_g: We do gate HTK in Armada when there are chart changes, but maybe we should consider running that gate on every patch
16:18:17 <seaneagan> i think roman_g: meant the other way around?
16:18:20 <roman_g> vice versa
16:18:33 <roman_g> yes. add armada gate to HTK
16:18:34 <portdirect> this would be ok - though would need to be non-voting
16:18:44 <roman_g> yes, same as divingbell
16:19:54 <roman_g> #action roman_g check on adding armada non-voting gate to openstack-helm-infra (HTK)
16:20:15 <dwalt> that would be great. ty roman_g
16:20:57 <dwalt> as far as updating HTK for other project gates, are we content with the temporary pinning approach?
16:21:14 <dwalt> e.g. promenade, shipyard
16:21:53 <Nishant__> yes that could make sense
16:22:50 <seaneagan> i think ability to pin htk is good, should probably try to keep the pin pointed at master whenever possible
16:23:10 <dwalt> #action dwalt update remaining Airship gates that utilize HTK
16:23:27 <dwalt> seaneagan: agree
16:23:36 <dwalt> anything else on this before we move on?
16:24:02 <dwalt> #topic Minimirror: move spec and review on the fly patches
16:24:18 <dwalt> I see roman_g added this. I have a patch out right now to remove the Airship spec
16:24:27 <dwalt> did you have additional thoughts on this roman_g?
16:24:48 <dwalt> #link https://review.openstack.org/641767
16:25:17 <roman_g> yes. there are other patches under https://review.openstack.org/#/q/minimirror which need to be reviewed and moved to openstack-helm-addons
16:25:29 <roman_g> or -images
16:25:38 <roman_g> where the minimirror resides
16:26:03 <dwalt> Is there specific functionality to gain from these patches? My understanding was that most of these are obsolete with the recent additions to OSH-addons and OSH-images
16:26:35 <roman_g> nobody reviewed them. if they are obsolete - then those patches need to be abandoned
16:27:01 <roman_g> they might be useful
16:27:12 <dwalt> agreed. I can take another look and reach out to the author in case I missed over anything
16:27:33 <dwalt> #action dwalt reach out to author of stale mini-mirror patches
16:27:39 <roman_g> author (Andrey Volkov) has left the business, I've contacted him already
16:29:41 <dwalt> ty roman_g. We can revisit this next week after I cross-reference the patches against existing mini-mirror functionality
16:30:08 <dwalt> #topic Deckhand & Shipyard - OpenSUSE builds
16:30:53 <roman_g> jamesgu, arunkant - do oyu have any news on the patches?
16:31:23 <jamesgu> arun, can you provide updates?
16:31:25 <arunkant> roman_g: yes, those patches are ready for review
16:32:02 <arunkant> I have added the docs and addressed earlier comments ..so will appreciate more eyes on those reviews
16:32:12 <roman_g> thanks, arunkant, will have a look
16:32:29 <dwalt> arunkant: great! I will have another look later today as well. Thanks for all the work on this
16:32:39 <dwalt> + jamesgu
16:32:57 <roman_g> >> and agree on naming convention in multi-distro spec document (airship-specs repo), please?
16:33:14 <arunkant> roman_g: there is armada review for similar change
16:33:46 <roman_g> nice
16:33:52 <dwalt> roman_g: Does the spec call out a specific convention for the Dockerfiles?
16:34:11 <roman_g> no, and it would be good to have it there
16:34:20 <roman_g> to discuss it there and to have it there
16:34:20 <sthussey> I haven't looked, but did the docker image tags get adjusted?
16:34:36 <sthussey> because last time I looked, it seems like the different builds are going to trample on one another
16:35:10 <dwalt> sthussey: at first glance, that seems to be missing from the Armada change
16:35:45 <dwalt> #link https://review.openstack.org/#/c/637327/10/Makefile
16:35:55 <arunkant> So we are using Dockerfile.opensuse_leap15 for file names. And tag names are also updated for opensuse specific images in publish jobs
16:36:47 <roman_g> So. Can we have it discussed and agreed on in a specs/approved/multi-linux-distros.rst first, and then work on patches? This way we would have a standard across airship-* subprojects nad a standar for other distros to follow.
16:37:01 <dwalt> arunkant: the tag is adjusted on line  31
16:37:27 <dwalt> I believe you just need to add the distro to the tag
16:38:43 <roman_g> would be also good to check on OSH work, because they do work in this direction too
16:39:09 <sthussey> I'll check again, first review on that doesn't show the distro getting in the tag
16:39:33 <arunkant> dwalt: Is this the right place to specify tag for distro image: https://git.openstack.org/cgit/openstack/airship-armada/tree/.zuul.yaml?h=refs/changes/27/637327/10#n108
16:39:40 <sthussey> So for a tag of a given commit, the SUSE and the Ubuntu builds will be in a race condition to see which ends up with the tag
16:40:18 <dwalt> arunkant: it's on line 31 of the Makefile
16:40:35 <openstackgerrit> Sean Eagan proposed openstack/airship-armada master: Run chart job unconditionally  https://review.openstack.org/642817
16:40:36 <dwalt> appending the distro will prevent the race condition sthussey is referring to
16:41:07 <openstackgerrit> Kaspars Skels proposed openstack/airship-in-a-bottle master: Cert/key related improvements to gate-multinode  https://review.openstack.org/642585
16:41:10 <sthussey> I think it makes sense to change the image name
16:41:31 <sthussey> So we'd end up with something like quay.io/airshipit/drydock-opensuse:latest
16:41:41 <sthussey> rather than quay.io/airshipit/drydock:latest-opensuse
16:42:19 <sthussey> I haven't looked at the spec though
16:42:34 <dwalt> I like that better. arunkant: would you be able to update the spec to represent these two items?
16:42:35 <roman_g> looks good from layers squashing perspective
16:42:52 <dwalt> I'm happy to assist after the meeting if you have additional questions
16:43:08 <jamesgu> where does the OS version go in the image tag?
16:43:26 <sthussey> It goes in the image name, not the tag
16:43:44 <arunkant> dwalt: publish jobs use this https://github.com/openstack/airship-shipyard/blob/master/tools/gate/roles/build-images/tasks/airship-shipyard.yaml#L113
16:43:46 <sthussey> because the Ubuntu-based image and the SUSE-based image are basically not related in terms of Docker's view
16:43:48 <roman_g> The spec has not been updated yet. This is what I'm asking for - let's first discuss and agree details in a spec, and then go for implementation. Can we?
16:44:39 <jamesgu> yes agreed I think. so an example would be like this:  quay.io/airshipit/drydock-opensuse-15.0:lates
16:44:50 <sthussey> yep
16:45:09 <arunkant> roman_g: I thought that we need to add docs for how to add new distro support ..
16:45:34 <sthussey> @roman_g I have no argument against hammering out this standard in the spec and then following up with updates to the PS
16:45:51 <roman_g> arunkant: yes. after we get the spec agreed ))
16:45:54 <sthussey> Let's just be expedient about reviews and approval as I'm sure arunkant and jamesgu would like to get this finished out
16:46:09 <dwalt> ++ I am happy to look as soon as it's up
16:46:22 <jamesgu> we can do both at the same time.
16:46:22 <arunkant> roman_g: okay..then will update the spec first in that case..
16:46:36 <dwalt> arunkant: jamesgu: ty both
16:46:40 <sthussey> We'll need to update the ubuntu build as well
16:46:47 <dwalt> #action arunkant update multi-distro image spec
16:46:57 <roman_g> arunkant: thank you.
16:47:04 <sthussey> to look something like quay.io/airshipit/drydock-ubuntu-16.04:latest
16:47:56 <roman_g> would be good to see how other projects approach the same problem.
16:48:39 <roman_g> many projects build images based on ubuntu+centos+alpine
16:48:48 <dwalt> roman_g: I recommend looking at OSH-images. Though, I think arunkant and jamesgu have mostly followed that approach
16:49:02 <dwalt> arunkant: please also feel free to ping us here once it's up, so we can review it asap :)
16:49:17 <openstackgerrit> Kaspars Skels proposed openstack/airship-in-a-bottle master: Cert/key related improvements to gate-multinode  https://review.openstack.org/642585
16:49:41 <dwalt> okay, anything else here? We only have ~10 min remaining
16:49:56 <roman_g> dwalt: I know how OSH images are built, thanks. I'm thinking of other projects.
16:50:44 <sthussey> We can iterate the design - let's solve the issue in front of us today, not the issues in front of other projects when they made their decision
16:51:21 <dwalt> roman_g: Gotcha - we can definitely keep those mind when reviewing :)
16:51:28 <dwalt> #topic Participation in Google Summer of Code and Season of Docs
16:51:41 <dwalt> roman_g: I believe this is yours. Do you mind taking this?
16:51:44 <roman_g> sthussey: I'm not trying to solve other projects problems
16:52:09 <roman_g> All right. We have skipped Google summer of code.
16:52:32 <roman_g> But we have possibility to join season of docs.
16:52:52 <roman_g> How do we understand if we need that or not?
16:53:45 <dwalt> roman_g: I'm not familiar with the season of docs. Do you have any information on it?
16:53:48 <roman_g> Sseason of Docs program in one line: we ask for help on documentation, tech.writer works on documentation, we accept it, and google pays some bonus to the writer and to the mentor from the project
16:54:19 <sthussey> What is the effort to be accepted by Google?
16:55:01 <roman_g> 0) decide on work to do 1) fill in an application form 2) dedicate a mentor 3) work with tech.writer
16:55:24 <roman_g> >>     Create Airship Developer Guide - https://storyboard.openstack.org/#!/story/2005122
16:55:29 <roman_g> this is a list from Matt
16:55:41 <roman_g> which fits good
16:55:50 <roman_g> from my point of view.
16:56:40 <sthussey> https://developers.google.com/season-of-docs/docs/mentor-responsibilities
16:57:17 <dwalt> It sounds like a good opportunity, though I'd like to read about it a bit more before discussing
16:57:43 <dwalt> Does anyone have any experience with the program?
16:58:00 <roman_g> It's totally new program, opened yesterday.
16:58:16 <dwalt> ah yeah, just saw that
16:58:16 <roman_g> *announced
16:58:18 <dwalt> #link https://developers.google.com/season-of-docs/docs/timeline
16:58:41 <openstackgerrit> Sean Eagan proposed openstack/airship-promenade master: build: support helm-toolkit pinning  https://review.openstack.org/642825
16:58:47 <sthussey> May be worth talking w/ Lindsey as he is a technical writer
16:58:53 <openstackgerrit> Kaspars Skels proposed openstack/airship-in-a-bottle master: Cert/key related improvements to gate-multinode  https://review.openstack.org/642585
16:59:04 <dwalt> ++
16:59:19 <roman_g> sent an e-mail already, pending reply,and Matt & Pete got this email too
16:59:42 <roman_g> no reply yet
16:59:52 <dwalt> roman_g: great. Let's revisit this next week if you're okay with that
16:59:58 <roman_g> okok
17:00:05 <dwalt> That'll give everyone a chance to read about it, since it's so new
17:00:14 <dwalt> ty roman_g
17:01:13 <dwalt> Sorry to cut it short, but we are out of time. Thanks for the good discussion everyone! Please give these patches some extra attention if you have time:
17:01:26 <dwalt> https://review.openstack.org/#/c/635507/ - openstack/airship-treasuremap - Add cache for results of requests to quay.io in Updater tool
17:01:26 <dwalt> https://review.openstack.org/#/c/615387/
17:01:26 <dwalt> https://review.openstack.org/636229 (Shipyard suse image support only)
17:01:26 <dwalt> https://review.openstack.org/638301 (Deckhand suse image support only)
17:01:26 <dwalt> https://review.openstack.org/#/c/637327/ ( Armada suse image support only)
17:01:39 <dwalt> #endmeeting