16:00:22 <mattmceuen> #startmeeting airship
16:00:23 <openstack> Meeting started Tue Mar 19 16:00:22 2019 UTC and is due to finish in 60 minutes.  The chair is mattmceuen. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:26 <openstack> The meeting name has been set to 'airship'
16:00:28 <mattmceuen> #topic Rollcall
16:00:32 <mattmceuen> GM everyone!
16:00:43 <michaelbeaver> o/ GM
16:00:43 <mattmceuen> agenda for today: https://etherpad.openstack.org/p/airship-meeting-2019-03-19
16:00:49 <levmorgan> o/ sup!
16:00:50 <evgenyl> Hi!
16:00:57 <mattmceuen> Let's give it a few mins for folks to join
16:01:15 <roman_g> o/
16:01:20 <dwalt> o/
16:01:29 <mattmceuen> Please add anything you'd like to discuss today to the etherpad
16:01:56 <seaneagan> o/
16:02:24 <mattmceuen> #topic Multi-OS image builds
16:02:34 <roman_g> #action roman_g to move discussion to the mailing list to reach wider audience
16:03:07 <roman_g> There are controversial opinions, and we possibly need to involve RH/CentOS folks (if any)
16:03:15 <mattmceuen> Thanks for discussing this last week when I was out
16:03:25 <mattmceuen> The spec is now merged, so that's great.
16:03:40 <dwalt> is the spec update still open? roman_g
16:03:50 <roman_g> sure, it is
16:03:52 <mattmceuen> Roman has also put in a PS to update the spec -- thanks for bringing it to the ML Roman, I agree that's a good idea
16:04:20 <mattmceuen> Anything else we want to touch on for this topic here now?
16:04:26 <mattmceuen> (otherwise we can just use the ML)
16:04:34 <jamesgu__> a quick question
16:04:41 <mattmceuen> sure
16:05:07 <jamesgu__> how long do we keep those images on quay.io, with the commit id as the tag?
16:05:17 <roman_g> forever
16:05:25 <jamesgu__> I like that :-)
16:05:30 <sthussey> I believe quay.io has a 3 month TTL
16:05:40 <sthussey> if an image isn't pulled for 3 months, they remove it
16:05:42 <mattmceuen> aha
16:05:49 <mattmceuen> good compromise that
16:05:58 <roman_g> quay.io is owned by CoreOS, CoreOS is owned by Red Hat. As long as they sponsor quay.io - we would be there.
16:06:09 <mattmceuen> does quay impose any kind of space quota?
16:06:48 <jamesgu__> yeah we literally going to double or triple if the number of images
16:07:00 <sthussey> not that I know of
16:07:14 <mattmceuen> cool
16:07:27 <sthussey> Looks like it is longer than 3 months
16:07:35 <sthussey> The oldest Promenade image there is 9 months old
16:07:47 <mattmceuen> maybe someone's pulling it still?  Can you tell?
16:07:58 <mattmceuen> or does "9 mo old" mean "since last pull"
16:08:09 <sthussey> No, 9 months since tag creation
16:08:16 <sthussey> I can't imagine folks are still using it
16:08:55 <sthussey> Looks like most of the repos have the oldest tag at 9 months
16:09:14 <arunkant> related question...how frequently images are built and published on quay.io .
16:09:32 <sthussey> On every merge
16:09:39 <mattmceuen> it's part of the merge gating
16:10:30 <arunkant> Okay..so every merge of that repo or only when there is image related change?
16:11:16 <sthussey> At this point I believe every merge. There may be some filtering for docs
16:11:23 <sthussey> I'd have to look
16:12:05 <mattmceuen> https://github.com/openstack/airship-armada/blob/master/.zuul.yaml#L31-L33
16:12:07 <arunkant> Okay..thanks..so looks like commit-id will keep changing then as we only have one version of it
16:12:10 <mattmceuen> Every merge
16:12:51 <mattmceuen> Ok - one more coffee sip's worth of time before moving on
16:13:21 <mattmceuen> #topic 1.0 release status
16:13:45 <mattmceuen> So it's been quiet on this front, but gears are turning
16:14:08 <mattmceuen> alanmeadows was getting this out to the community, but then he had a happy addition to his family and is out for a bit
16:14:38 <mattmceuen> I should clarify:  this ^ is specifically about governance (one of the subpoints in the agenda)
16:15:16 <mattmceuen> We'll hopefully have some draft governance doc material out soon which we can discuss and iterate on
16:15:29 <mattmceuen> Re: 1.0 release status proper --
16:16:00 <mattmceuen> The biggest outstanding item for 1.0 is Ironic integration
16:16:16 <mattmceuen> And there's been some pivoting around what Airship's Ironic integration will look like
16:16:54 <mattmceuen> Short version -- since K8s cluster API integration with Ironic is going to happen anyway, we'd like to throw our weight behind that and help it succeed
16:17:16 <mattmceuen> Rather than a Drydock->Ironic native integration (which is what the spec calls for now)
16:17:46 <mattmceuen> This extends out the Ironic integration with Airship a bit, but it's definitely the right long-term direction as it will be aligned to the k8s community and the Ironic community
16:18:51 <mattmceuen> So by 1.0 we're planning to have progress and alignment on Ironic integration, but it likely won't be complete or prod ready, as it'll take time to build something reusable by Airship and others
16:19:12 <mattmceuen> my fingers are tired, any addn'l thoughts / questions?
16:19:59 <mattmceuen> alright - moving on
16:20:08 <mattmceuen> #topic Participation in Season of Docs
16:20:20 <mattmceuen> #action mattmceuen to look into this deeper
16:20:43 <mattmceuen> Thanks romang for bringing this up, I think it's potentially a really good thing (and worst case, it can't hurt to try it out)
16:21:04 <mattmceuen> I saw the convo last week, let me spend some time this week digging in if you don't mind
16:22:00 <roman_g> no problem. thank you
16:22:11 <mattmceuen> #topic Participation in Summer of Code 2020
16:22:25 <mattmceuen> I suppose this falls into the same boat huh :)
16:22:29 <roman_g> yep
16:22:58 <mattmceuen> #action mattmceuen to investigate Airship participation in summer of code 2020
16:23:07 <roman_g> at least someone accepted the meeting
16:23:20 <mattmceuen> #topic AIAB is still broken (from mailing list)
16:23:21 <roman_g> you will have to find time and discuss )
16:23:26 <mattmceuen> yes!
16:23:48 <mattmceuen> So AIAB - thanks to everyone who's put in patches to get this working again
16:24:17 <roman_g> Didn't try it, but gates show that it's still broken
16:24:40 <evgenyl> Yeah, here is an example https://review.openstack.org/#/c/643430/
16:25:49 <mattmceuen> Are the logs for that getting published publicly yet evgenyl?  I don't see them in that PS
16:25:55 <openstackgerrit> Kaspars Skels proposed openstack/airship-in-a-bottle master: [bug] Fix missing sudo for setting up virtmgr SSH keys  https://review.openstack.org/644610
16:26:35 <openstackgerrit> Kaspars Skels proposed openstack/airship-in-a-bottle master: [bug] Fix missing sudo for setting up virtmgr SSH keys  https://review.openstack.org/644610
16:26:40 <evgenyl> They are being published e.g. `https://artifacts.atlantafoundry.com/artifactory/cicd/logs/integration/airship/airship-in-a-bottle/100 : FAILURE`
16:27:11 <mattmceuen> whansinn had referenced a commit that worked; is that a recent commit (meaning he may be running it differently than the gate) or is that an older commit before something got broken?
16:27:24 <mattmceuen> that's awesome - thanks evgenyl
16:27:40 <roman_g> mattmceuen: that's very old commit
16:28:28 <roman_g> Feb 21, 2019
16:28:50 <sthussey> I mean, that isn't that old
16:29:33 <openstackgerrit> Evgeniy L proposed openstack/airship-in-a-bottle master: [TEST] Do not merge  https://review.openstack.org/643430
16:29:46 <roman_g> >10 commits ago
16:30:26 <mattmceuen> looks like the mariadb ingress was crashlooping, but cursory look at the logs didn't show anything that was a clear smoking gun to me
16:31:06 <mattmceuen> was looking at the wrong one
16:31:10 <mattmceuen> I0315 00:14:53.238599       6 controller.go:177] Configuration changes detected, backend reload required.
16:31:10 <mattmceuen> E0315 00:14:53.239610       6 controller.go:189] Unexpected failure reloading the backend:
16:31:10 <mattmceuen> template: nginx.tmpl:60:14: executing "nginx.tmpl" at <$cfg.EnableVtsStatus>: can't evaluate field EnableVtsStatus in type config.Configuration
16:31:10 <mattmceuen> W0315 00:14:53.239646       6 queue.go:130] requeuing configmap-change, err template: nginx.tmpl:60:14: executing "nginx.tmpl" at <$cfg.EnableVtsStatus>: can't evaluate field EnableVtsStatus in type
16:31:22 <mattmceuen> openstack mariadb ingress ^
16:32:22 <mattmceuen> dumb question, why do we have an ingress for mariadb?  Shouldn't service be enough?
16:33:11 <mattmceuen> Well I think we'd better take this offline and keep going
16:33:13 <roman_g> ¯\_(ツ)_/¯
16:33:26 <mattmceuen> but let's try to figure this out in the channel today
16:33:27 <roman_g> I didn't work on that yet
16:33:36 <sthussey> I believe they need an ingress for multi-master support
16:34:07 <mattmceuen> ok
16:34:27 <mattmceuen> #topic Who will be able to attend the Open Infra summit?
16:34:39 <mattmceuen> If you're going to the summit, please add your name to the list in the etherpad!
16:35:02 <mattmceuen> #topic  OpenStack to OpenDev transition
16:35:23 <mattmceuen> This is an important one -- roman_g has been our rep with the openstack infra team, can you please give us an overview roman_g?
16:35:33 <roman_g> Transition date is (so far) set to 4/19
16:35:40 <roman_g> Closest change to expect: massive change of git:// URLs to https:// (similar to https://review.openstack.org/#/c/642652/ )
16:35:51 <roman_g> #action: roman_g announce in mailing list
16:36:21 <roman_g> Need to discuss & decide whether we move openstack/airship-* to airship/airship-* or openstack/airship-* to airship/*
16:36:23 <mattmceuen> My understanding is that there will also be redirects between the old URLs and the new ones, to prevent a breaking interruption
16:36:26 <evgenyl> Will this be an alias or they are planning to remove the old one? :)
16:37:01 <roman_g> HTTP/HTTPS redirects would be supported fr reasonable future, of course
16:37:22 <sthussey> it seems we should transition public references to git.airshipit.org
16:37:22 <roman_g> Old tenant and repo will be removed
16:37:43 <roman_g> sthussey: that is an option
16:37:45 <mattmceuen> Agree sthussey
16:38:12 <roman_g> but it's not only git repo, but also e.g. zuul tenant, gerrit, and may be something else
16:38:43 <sthussey> git.airshipit.org points at gerrit I believe
16:38:48 <roman_g> git.airshipit.org would stay as-is (UI will change to Gitea)
16:39:04 <sthussey> I guess not
16:39:06 <roman_g> yes, it points at Gerrit. And will point at Gitea in the future
16:39:19 <mattmceuen> the `airship` namespace will be a really good thing.  When we were added to the `openstack` namespace we used `airship-` prefixes to be a poor-man's namespacing, so like roman_g says we'll need to figure out whether to retain `airship` in our project names, or not.
16:39:42 <mattmceuen> please mull it over and anticipate roman's email :)
16:39:49 <roman_g> Finally. Who makes this decision?
16:40:15 <mattmceuen> back to governance!  ha
16:40:16 <sthussey> as part of all this work, should consider if we move image hosting away from quay.io and into whatever OSF uses
16:40:35 <roman_g> OSF -> ODF
16:40:42 <sthussey> whatever
16:40:54 <roman_g> Do they use any? I haven't seen anything like that.
16:41:23 <mattmceuen> not sure
16:41:26 <mattmceuen> I don't think there's one yet
16:41:32 <mattmceuen> Not sure if any are planned though
16:41:45 <sthussey> It seems like it will be the artifact publication mechanism of the future
16:42:09 <roman_g> Who makes the decision? :) Otherwise I'll make life easy, and would select ``openstack/airship-* to airship/airship-*`` option
16:42:09 <sthussey> So even if they aren't hosting a private registry, it may be worth exploring alignment with anyone else producing OCI images
16:42:46 <mattmceuen> Agree.  I guess the cost/benefit of ODF hosting its own registry is something that needs to be explored.
16:42:47 <sthussey> I'd prefer dropping duplicate namespaces
16:43:22 <sthussey> So if they are going to namespace it under an `airship` umbrella, then drop the `airship-` prefix
16:44:01 <mattmceuen> To answer your question roman_g - I think the core team should vote on it after getting all input
16:44:28 <roman_g> sthussey and Rodolfo are for dropping the prefix, I'm for leaving the prefix. Other votes? Is it legitimate to decide here? Should I move discussion to the ML?
16:44:39 <mattmceuen> Hoping there will be consensus across the team after arguments are heard; if not we can split hairs about how to determine
16:44:49 <mattmceuen> let's let it marinate on the ML first
16:45:00 <mattmceuen> and let's share our rationales on the ML as well
16:45:01 <sthussey> I think it is worth putting spec-like in the ML with the full picture
16:45:08 <roman_g> OK. I have an action item on this already
16:45:10 <mattmceuen> I don't have a strong opinion either way... yet
16:45:15 <mattmceuen> thanks
16:45:33 <mattmceuen> anything else before we move on guys?
16:45:38 <roman_g> no
16:45:43 <mattmceuen> #topic Airship approach to various OpenStack efforts that really bring no value - e.g. Python 2 to 3 effort
16:45:50 <mattmceuen> Take it away sthussey
16:46:09 <sthussey> I think the description explains it mostly
16:46:33 <sthussey> but there have been several expeditions of instituting a formulaic code change across all of OpenStack
16:46:50 <sthussey> The most recent was moving from using the general `json` library to some oslo variant of it
16:46:51 <mattmceuen> For cross-project openstack initiatives -- I think this is where the delineation of "openstack proper" vs "open infra" / "open dev" will be helpful
16:47:18 <sthussey> In some cases, I think it is silly and a waste of time, but it isn't my time so I ignore it
16:47:35 <sthussey> In this case, it is actually detrimental because it introduces additional nodes the in dependency graph
16:48:02 <roman_g> Have we been approached to do some work on this kind of changes? Or are we expected to comply?
16:48:16 <sthussey> Someone else has opened the PS to do the work
16:48:17 <mattmceuen> In general I think openstack cross-project initiatives are limited to "openstack proper"
16:48:45 <mattmceuen> and can become "airship" cross-project initiatives too with the right discussion / rationale behind them
16:49:03 <mattmceuen> but today, all the projects are in the same namespace so the discussion was missed
16:49:20 <sthussey> I've resisted a hard line on this as it seems it should be a general approach agreeded upon across the airship community
16:50:04 <mattmceuen> my thought is, "all else equal" I'm happy to adhere to openstack norms and initiatives, since we're one larger community
16:50:05 <roman_g> can I have a link to that PS?
16:50:16 <mattmceuen> However, "all else equal" is key, and there needs to be discussion
16:50:29 <sthussey> @roman_g look for jacky06 as the owner
16:50:34 <roman_g> thanks
16:50:47 <roman_g> Are we expected to comply?
16:50:54 <roman_g> By rules.
16:50:55 <sthussey> I don't know.
16:51:02 <roman_g> mattmceuen?
16:51:02 <mattmceuen> Probably depends who you ask roman_g, but the answer is "no" formally
16:51:16 <mattmceuen> Some openstack cross-project things could be really valuable to us - like internationalization
16:51:28 <mattmceuen> and some are probably arguable value, and need to be discussed
16:51:41 <mattmceuen> Let's bring them up on a case by case basis here or in the ML
16:52:30 <sthussey> I think it is better to come up with a general viewpoint on it
16:52:45 <roman_g> again, governance question?
16:52:48 <sthussey> And I'm fine with "If the work standing on its own is valuable, then treat it as such"
16:52:59 <mattmceuen> ^ that
16:53:15 <sthussey> But not so much "This webpage so everyone should do X, so do X"
16:53:21 <sthussey> webpage says*
16:53:49 <mattmceuen> There should be no assumption that an openstack cross-project item impacts airship, since many of the items will be irrelevant to airship (e.g. release-schedule related things)
16:54:02 <openstackgerrit> Merged openstack/airship-in-a-bottle master: [bug] Fix missing sudo for setting up virtmgr SSH keys  https://review.openstack.org/644610
16:54:13 <mattmceuen> but I for one am certainly open to adoption openstack initiatives when they do stand on their own  merit for airship
16:54:19 <sthussey> good enough
16:54:59 * sthussey steps off his soapbox
16:55:07 <mattmceuen> I don't think we actually came to consensus on the json thing; let's take a look @ that offline and weigh in on the PS?
16:55:19 <mattmceuen> thanks for bringing this up sthussey :)
16:55:25 <roman_g> thanks.
16:55:31 <mattmceuen> #topic External gates for AIAB are enabled (archived logs are being published)
16:55:39 <mattmceuen> We touched on this already! nice!
16:55:48 <roman_g> I also have idea to change YAML library to the one which persists comments in YAML's and order of keys
16:56:19 <roman_g> at least for versions.conf utility
16:56:32 <roman_g> * versions.yaml
16:57:07 <mattmceuen> Sorry roman_g, I missing it - is that related to the AIAB publishing?
16:57:15 <roman_g> no, that
16:57:22 <roman_g> 's for previous topic
16:57:29 <roman_g> json library change request
16:57:32 <mattmceuen> ahh I see
16:57:56 <evgenyl> So currently AIAB gates are failing, people should be able to see the logs in the comments.
16:58:27 <mattmceuen> I'm not following the discussion between roman_g and evgenyl on the etherpad 100%; where did we land?
16:58:28 <dwalt> evgenyl: The comments keep disappearing for me. Do you know if there is a Gerrit preference to show them?
16:58:38 <roman_g> evgenyl: thank you!
16:59:20 <roman_g> dwalt: probably Toggle CI button, lower left corner.
16:59:30 <mattmceuen> yup that works for me
16:59:40 <dwalt> perfect. Thanks!
17:00:04 <mattmceuen> Is this a step toward becoming a third-party gate?  Or is this "instead of" a third party gate?
17:00:07 <roman_g> mattmceuen: we have logs published, but they need to be unarchived. I've pushed a PS for that
17:00:09 <evgenyl> I completely forgot about this button, and assumed everybody could see these comments..
17:00:15 <mattmceuen> ahh thanks roman_g
17:00:58 <mattmceuen> d'oh we're out of time folks
17:01:11 <mattmceuen> A couple of patches requesting review:
17:01:11 <mattmceuen> https://review.openstack.org/#/c/635507/ - openstack/airship-treasuremap - Add cache for results of requests to quay.io in Updater tool
17:01:11 <mattmceuen> https://review.openstack.org/#/c/638144/ - openstack/airship-divingbell - Enhance docs rendering; update documentation
17:01:33 <mattmceuen> Thanks very much to you all for your time and effort today, and on Airship in general
17:01:39 <mattmceuen> have a good one
17:01:44 <mattmceuen> #endmeeting