16:00:43 <mattmceuen> #startmeeting Airship
16:00:44 <openstack> Meeting started Tue Jun  4 16:00:43 2019 UTC and is due to finish in 60 minutes.  The chair is mattmceuen. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:47 <openstack> The meeting name has been set to 'airship'
16:00:47 <mattmceuen> let's try this again
16:00:55 <evgenyl> Hi everyone!
16:00:58 <mattmceuen> #topic Rollcall
16:01:02 <mattmceuen> o/ evgenyl
16:01:21 <ian-pittwood> o/
16:01:22 <michael-beaver> o/
16:01:25 <alexanderhughes> o/
16:01:25 <mattmceuen> Here's our agenda du jour:  https://etherpad.openstack.org/p/airship-meeting-2019-06-04
16:01:34 <mattmceuen> please add anything you'd like to discuss today
16:01:57 <howell> o/
16:02:06 <mattmceuen> and we'll give it a couple mins for folks to join
16:02:15 <nishantkr> o/
16:02:51 <arunkant> o/
16:03:35 <dwalt> o/
16:03:51 <mattmceuen> alright:  let's get started
16:04:08 <mattmceuen> #topic New project proposal: airshipctl
16:04:26 <mattmceuen> First -- we have a new project to propse / socialize prior to me putting in the request with infra, per our custom
16:04:48 <mattmceuen> as a reminder, there's a lot of discussion around the Airship 2.0-focused airshipctl command in this spec:     spec: https://review.opendev.org/#/c/659808/
16:05:00 <mattmceuen> The spec is not merged but is shaping up well
16:05:25 <mattmceuen> airshipctl will be a long time in the making, but it's important to have a place to put the code as pieces of it are ready for dev
16:06:02 <mattmceuen> howell has been working on the beginnings of the airshipctl project in github, with a pluggable framework to drop in functionalilty
16:06:08 <mattmceuen> https://github.com/ian-howell/airshipctl
16:06:28 <howell> right
16:06:30 <mattmceuen> I think it's ready to introduce into opendev/airship in preparation for broader development
16:06:34 <mattmceuen> can you walk us through it howell?
16:07:25 <howell> so as of right now, most of the work has been architectural work
16:07:38 <howell> that is, there's not much airship there yet
16:08:01 <howell> that said, the project is designed to be plugin-centric
16:08:19 <howell> so each subcommand to the root cli will act as a plugin
16:09:30 <howell> this lets us create a tool that does airship specific things, while also allowing consumers to create their own commands for their more specific needs
16:10:35 <mattmceuen> it's an awesome start -- and I know you did a lot of research into different plugin mechanisms, conventions, etc, so even though there's not a huge amount of code in there, there's a lot of your effort to make sure this starts out going the right direction
16:10:55 <mattmceuen> thanks also for the documentation to help people get up to speed
16:10:56 <howell> thanks :)
16:11:51 <mattmceuen> granted the project doesn't "do anything" but I'd encourage folks to walk through the one-page readme to get acclimated, especially if they haven't worked with go before
16:11:55 <mattmceuen> Any questions for Ian?
16:12:38 <mattmceuen> and, +1's / -1's for me putting in a request to add this to infra?
16:12:54 <ian-pittwood> +1
16:12:57 <nishantkr> +1
16:13:06 <alexanderhughes> +1
16:13:07 <evgenyl> ++
16:13:40 <arunkant> +1
16:13:43 <dwalt> +1
16:13:45 <jamesgu_> +1
16:13:50 <kskels> I would also be glad to hear learnings and all.. maybe just me
16:13:50 <michael-beaver> +1
16:13:58 <kskels> +1 for the project
16:14:10 <mattmceuen> #action mattmceuen to put in request to add airshipctl seed project to opendev
16:14:48 <mattmceuen> Agree howell, would be awesome to hear a summary of some of your learnings -- would you want to do that today or in an upcoming meeting maybe?
16:15:13 <howell> i'd prefer to prepare something if that's alright
16:15:21 <mattmceuen> yup for sure
16:15:50 <mattmceuen> alright - thanks all.  moving on to the next topic:
16:15:55 <mattmceuen> #topic Added ubuntu_xenial gate to Armada
16:16:11 <mattmceuen> michael-beaver -- this is yours & here's the PS  https://review.opendev.org/#/c/662565/
16:16:55 <michael-beaver> Yeah I guess this is just worth mentioning that we added an ubuntu_xenial Dockerfile and gate to Armada because all of the other Airship projects currently support xenial
16:17:35 <michael-beaver> There have been some discussions about moving to bionic instead of xenial for our ubuntu builds but until we get to that point it is good to have some consistency across the projects
16:18:00 <mattmceuen> Yes - thanks for adding that michael-beaver.  this is related to the multi-distro support changes that were begun recently, so now it's much easier to retain the bionic build while also adding xenial
16:19:02 <mattmceuen> I think this one bleeds into the next topic, but anything specifically around the Armada build change before we move on to the broader topic?
16:20:16 <mattmceuen> #topic Base image vulnerabilities - path forward: Ubuntu Xenial, Bionic, other.  Standardization across Airship?
16:20:35 <mattmceuen> alexanderhughes this one's yours, set the stage!
16:21:15 <alexanderhughes> mattmceuen: thanks.  Last week I raised some questions about projects Spyglass and Pegleg as being outliers among Airship in that they were using python:3.6 base images where all the others used xenial for their ubuntu builds (except armada previously covered)
16:22:06 <alexanderhughes> specifically in the case of vulnerabilities, the python:3.6 images when scanned with quay's security scanner were showing ~500 vulnerabilities with ~50 high.  I'd like to update each of those projects to a newer build, in the case of xenial there's ~130 vulnerabilites 0 high or bionic ~65 vulnerabilities 0 high
16:22:27 <alexanderhughes> what direction do we want to take for ubuntu builds in the short term, and in the longer term are we moving to bionic - or the loci build process that other openstack projects use?
16:23:06 <mattmceuen> Good topic alexanderhughes
16:23:26 <mattmceuen> So the first thing is, we want for a couple things to be true:
16:23:59 <mattmceuen> 1) we want to enable operators to provide their own builds of airship images, based on their own needs
16:24:08 <mattmceuen> ^ e.g. overrides
16:24:31 <mattmceuen> 2) we want to allow for multiple-os support in the community, based on user needs & prioritization
16:25:09 <mattmceuen> I think it's a matter of time until we update xenial reference images upstream to bionic, with a couple of key variables:
16:25:27 <mattmceuen> Folks who are interested in doing the work :)  the open source mantra
16:26:00 <mattmceuen> and, we would want to retain the xenial ones as long as they're needed / useful, and then not maintain them once they're not needed / useful
16:26:37 <mattmceuen> specificaly for the python:3.6 base images, I think it makes sense to align them to the same ubuntu (and opensuse) images used for the other images
16:27:08 <mattmceuen> other thoughts/questions/opinions?
16:27:26 <alexanderhughes> so in the short term the Airship standard should be xenial, and as project contributors get around to it add in bionic support?  longer term the needs will evolve and discuss more
16:28:21 <mattmceuen> I think so, with the subtle distinction that's I'd call it "default" rather than "standard"
16:29:37 <mattmceuen> y'all are quiet today!  the day I'm the person with the most opinions about image building is officially a slow news day :)
16:30:06 <alexanderhughes> :) we're all just in sync apparently
16:30:16 <mattmceuen> That's a much better way of phrasing it
16:30:32 <mattmceuen> Cool any other questions needing ironied out on that topic alexanderhughes?
16:30:35 <alexanderhughes> I'll push some changes for spyglass/pegleg to get onto xenial by end of week.  I'll look to get bionic done eventually
16:30:43 <mattmceuen> +1
16:30:43 <alexanderhughes> nope, I'm happy
16:31:11 <mattmceuen> Alright - that's officially the end of our list of prepared topics!
16:31:14 <mattmceuen> #topic Roundtable
16:31:36 <mattmceuen> Is anything else on our minds, team?
16:31:43 <mattmceuen> or review requests
16:32:40 <mattmceuen> in that case I'll give everyone some time back!
16:32:57 <mattmceuen> Feel free to drop any discussion into the channel ad-hoc
16:33:06 <mattmceuen> thanks everybody, & have a great week!
16:33:11 <alexanderhughes> thanks :)
16:33:15 <mattmceuen> #endmeeting