16:00:13 <mattmceuen> #startmeeting Airship
16:00:14 <openstack> Meeting started Tue Jun 11 16:00:13 2019 UTC and is due to finish in 60 minutes.  The chair is mattmceuen. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:18 <openstack> The meeting name has been set to 'airship'
16:00:21 <mattmceuen> #topic Rollcall
16:00:28 <alexanderhughes> \o/
16:00:28 <mattmceuen> Howdy Airshippers!
16:00:37 <kskels> hey hey!
16:00:51 <mattmceuen> https://etherpad.openstack.org/p/airship-meeting-2019-06-11
16:00:53 <michael-beaver> o/
16:00:53 <mattmceuen> ^agenda
16:01:00 <evgenyl> o/
16:01:03 <ian-pittwood> o/
16:01:37 <mattmceuen> I move that every year, we find the team meeting closest to international talk like a pirate day, and conduct the entire meeting talking like  pirates.  +1 / -1 vote?
16:01:48 <alexanderhughes> +1
16:01:52 <mattmceuen> I mean, we're frikkin Airship
16:02:16 <mattmceuen> #topic Governance
16:02:23 <mattmceuen> We have it:  https://opendev.org/airship/governance
16:02:43 <mattmceuen> Governance may not be the most exciting thing for all developers, but it's a real milestone
16:02:51 <roman_g> o/
16:03:03 <mattmceuen> It's part of being a grown-up project that can stand on its own two feet
16:03:11 <mattmceuen> so that's pretty cool
16:03:18 <evgenyl> When will we have the elections?
16:03:19 <mattmceuen> Thanks to alanmeadows for driving that
16:03:27 <mattmceuen> Excellenet question evgenyl
16:03:36 <mattmceuen> which leads us to our second order of business!
16:03:55 <mattmceuen> #topic New project request: `election`
16:05:04 <mattmceuen> I'd like to hold the first election, for the Technical Committee, as soon as possible.  I discussed with hogepodge and it would actually be good to get it started this week, since it's a three week process essentially, and there will be some conflicting / distracting conferences coming up if we wait very long
16:05:37 <openstackgerrit> Merged airship/spyglass master: Spyglass opensuse image support  https://review.opendev.org/659692
16:05:42 <mattmceuen> One thing we need is an `election` project, really just a place for folks to nominate.  I have one in github that I've modelled after starlingx and openstack itself
16:06:11 <mattmceuen> I'd like to pull the trigger ASAP to get it added into opendev, so that hopefully I can send out the instructions for nominating tomorrow if the stars align
16:06:47 <evgenyl> Can we do this within the governance repo?
16:07:07 <evgenyl> I'm trying to understand what is the differences between those two.
16:07:25 <mattmceuen> Maybe we could, but there are a couple reasons not to, potentially:
16:07:28 <evgenyl> We can have subdirectory elections/date.
16:07:50 <mattmceuen> 1. different sets of core reviewers in the target state -- folks running elections and folks deciding governance are not necessarily the same folks
16:08:18 <mattmceuen> 2. different lifecycles -- we expect governance not to change all that frequently, but the election repo will be changing pretty frequently as people nominate
16:08:44 <mattmceuen> 3. there's a good status quo established by openstack for elections, and we will use as much of their tooling as possible to make our lives easier :)
16:08:59 <mattmceuen> FYI - here's what I've put together in github -- https://github.com/mattmceuen/airship-election
16:10:05 <mattmceuen> evgenyl, what are your thoughts around consolidating into governance -- just to have fewer repos to deal with?
16:10:38 <hogepodge> o/
16:10:41 <roman_g> yes. we already have too many of them.
16:12:54 <mattmceuen> The openstack election project does a lot for you - it pulls contributors out of gerrit for the specified timeframes, generates emails for you, etcd - I hope to migrate that into our project as well.  For now I'm just using the openstack project directly fot that stuff and parameterizing for airship
16:13:11 <mattmceuen> o/ hogepodge
16:14:10 <evgenyl> Looks reasonable.
16:14:10 <mattmceuen> IMO the extra repo is worth it, although I'm happy to hear other opinions
16:14:15 <mattmceuen> cool
16:14:24 <evgenyl> Thanks for spending time explaining this!
16:14:34 <mattmceuen> For sure!
16:14:48 <mattmceuen> Any other questions  / discussions before we vote on making the repo?
16:15:28 <mattmceuen> Alright -- if you're ok with the `election` repo being created, please +1, and if not, please -1
16:15:34 <alexanderhughes> +1
16:15:37 <ian-pittwood> +1
16:15:42 <roman_g> +1, I'm fine
16:15:46 <roman_g> Thank you.
16:16:00 <kskels> +1
16:16:12 <evgenyl> +1
16:16:22 <nishantkr> +1
16:16:29 <mattmceuen> awesome - thank you all, sounds like consensus to me!
16:16:40 <jezogwza> +1
16:16:55 <mattmceuen> #action mattmceuen will push a request to get election repo added
16:16:59 <mattmceuen> Next topic:
16:17:05 <mattmceuen> #topic Code formatting standardization across projects
16:17:11 <mattmceuen> alexanderhughes this one's yours!
16:17:55 <alexanderhughes> mattmceuen: thanks, just a minor nitpick I've had when developing across projects and across my personal/work machines which have different beautifying settings.  do we have a "template" project that we can use for things like our yapf configs, zuul jobs etc
16:18:21 <alexanderhughes> as an example both armada https://opendev.org/airship/armada/src/branch/master/setup.cfg#L58 and promenade https://opendev.org/airship/promenade/src/branch/master/setup.cfg use yapf, some others don't in their pep8 gates but even between these two projects the styles enforced by yapf are configured differently
16:19:07 <ian-pittwood> On top of that some pep8 gates inconsistently ignore some rules
16:19:30 <mattmceuen> ignore the rules to work around issues?  or something else?
16:20:02 <ian-pittwood> I mean for flake8, sorry. You can have settings to ignore certain styling rules
16:20:16 <alexanderhughes> I hope my vision is the same as the other developers, but I'd like to see all of the projects under the Airship umbrella pretty consistent in coding styles, templates for zuul jobs etc and that doesn't seem to be the case.  it's minor in most areas
16:20:32 <alexanderhughes> yeah like some of the flake8 configs in projects ignore W504, others ignore W503, others ignore more than just one of those
16:21:30 <mattmceuen> I'm just wondering if there are specific reasons why we're ignoring specific errors -- i.e. if it's to work around issues rather than just preferring not to adhere to certain flake8 conventions
16:21:33 <ian-pittwood> Tangentially related, some projects use pbr and others don't. There's just a lot of differences from project to project
16:22:07 <mattmceuen> I think there are a couple of approaches
16:22:12 <mattmceuen> to driving more consistency
16:22:15 <openstackgerrit> PRATEEK REDDY DODDA proposed airship/promenade master: [WIP] Haproxy: Add pod/container security context  https://review.opendev.org/651574
16:22:23 <alexanderhughes> well in the case of Pegleg I think it is just "work" specifically around docstrings not be formatted according to pep8 some Tin Lam added some ignores on those that Ian and I haven't gotten around to addressing to remove the ignores
16:23:10 <openstackgerrit> PRATEEK REDDY DODDA proposed airship/promenade master: [WIP] Haproxy: Add pod/container security context  https://review.opendev.org/651574
16:23:10 <mattmceuen> gotcha
16:23:47 * mattmceuen So a couple approaches:
16:23:56 <mattmceuen> oops, didn't mean to be muttering that to myself
16:24:04 <mattmceuen> 1. propose changes to the rules in different projects, to get feedback from the folks in those projects
16:24:11 <mattmceuen> ^ piecemeal approach
16:24:27 <mattmceuen> 2. make a spec for a global config and get feedback from everyone in the spec
16:24:44 <mattmceuen> I think there are merits to both approaches
16:25:22 <roman_g> could all this checks be externalized to a (no, not to a separate repo :D ) common parent zuul job?
16:25:25 <mattmceuen> the benefit of #1 is that it'll likely drive more consistency faster, since "everybody" doesn't have to agree to "everything" all at the same time
16:25:34 <roman_g> 1. - we have it here: https://airshipit.readthedocs.io/en/latest/code-conventions.html#linting-and-formatting-standards
16:25:47 <roman_g> theoretically
16:25:53 <mattmceuen> :D theoretically
16:25:56 <roman_g> pep-8 and that's it
16:26:13 <ian-pittwood> we'll need to flesh that out a bit
16:26:53 <roman_g> alexanderhughes: would you update this section, and I could update project's linting jobs?
16:27:00 <mattmceuen> alexanderhughes - would you be interested in either of those things, either proposing some standardization patchsets to move the needle, or, go for a big spec?
16:27:26 <mattmceuen> yeah, could just make a PS to update the documentation rather than a new spec - I'm ok either way
16:27:39 <mattmceuen> the important thing will be making sure to get a lot of discussion around it first
16:27:45 <mattmceuen> (before merging I mean)
16:27:58 <alexanderhughes> yeah I'd be happy to propose an update to the documentation, gather feedback, and iron out the details.  once we get there, a central source of the config would be nice in the jobs
16:28:04 <openstackgerrit> Merged airship/spyglass master: Manifest undefined data validation  https://review.opendev.org/655683
16:28:17 <mattmceuen> awesome - that sounds like a plan then
16:28:20 <alexanderhughes> today's projects are in python which gets configured one way, tomorrow's projects look to be in go which will have a different formatting tool we'll want to think about that as well
16:29:13 <mattmceuen> go does its own thing and has an auto formatter built into the core tooling - hopefully that'll get us more standardization for free right out of the gate
16:29:43 <mattmceuen> thanks alexanderhughes and roman_g
16:29:50 <mattmceuen> anything else on this topic?
16:29:56 <alexanderhughes> nope
16:30:16 <mattmceuen> #topic Rename `airship-seaworthy` to just `seaworthy` ?
16:30:22 <mattmceuen> kskels, this one's yours!
16:30:41 <mattmceuen> kskels already has a patchset for this:  https://review.opendev.org/#/c/664458/
16:31:19 <kskels> I just felt that this annoyed me and as everything is airship - it seems redundant to have it there
16:31:34 <kskels> it would make cleaner and more streamlined feel to sites
16:31:50 <roman_g> you have my +2 already
16:32:10 <ian-pittwood> +1
16:32:22 <mattmceuen> Sounds reasonable to me too.  You updated the docs and the Jenkins stuff at the same time, so no concerns from me
16:32:31 <mattmceuen> I'll add it to the review list :)
16:33:15 <mattmceuen> Final topic for today is our old friend:
16:33:20 <mattmceuen> #topic Review Requests
16:33:29 <mattmceuen> https://review.opendev.org/#/c/661004/ treasuremap updater - Add cross-verification of Git commit ID'd and image tags
16:33:29 <mattmceuen> https://review.opendev.org/#/c/664016/ Pegleg removes duplicate shorthand flags in subcommands
16:33:29 <mattmceuen> https://review.opendev.org/#/c/663997/ Pegleg moves credentials logic into central source - config.py
16:33:29 <mattmceuen> https://review.opendev.org/#/c/663389/ Pegleg bugfix to Promenade encryption key source in pegleg genesis bundle
16:33:29 <mattmceuen> https://review.opendev.org/#/c/664458/ Rename airship-seaworthy to just seaworthy
16:34:28 <amalrajgenocidex> I'm implementing Airship airsloop and getting error while deploying genesis node
16:34:46 <amalrajgenocidex> The error is related to kubernetes API IP
16:35:06 <alexanderhughes> on the topic of Pegleg review requests can I get some help from the other cores on these?  I was added to pegleg-core but that doesn't help with review speed when I'm the one pushing patches
16:35:25 <mattmceuen> yep
16:35:29 <amalrajgenocidex> What IP should I specify for kubernetes API Ip?
16:36:05 <amalrajgenocidex> There is nothing mentioned in doc to setup Kubernetes API
16:36:23 <mattmceuen> Hi amalrajgenocidex -- yes, you shouldn't have to specify that
16:36:42 <mattmceuen> What error are you getting?
16:37:01 <mattmceuen> To wrap up the review requests -- please give those some review today or tomorrow team!
16:37:11 <mattmceuen> #topic Roundtable
16:37:21 <mattmceuen> Any other topics to bring up today?
16:38:03 <mattmceuen> In that case, I'll give you all 20min back!  Thanks for the great discussion today
16:38:11 <mattmceuen> #endmeeting