14:00:12 <mattmceuen> #startmeeting airship
14:00:13 <openstack> Meeting started Tue Jul  9 14:00:12 2019 UTC and is due to finish in 60 minutes.  The chair is mattmceuen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:17 <openstack> The meeting name has been set to 'airship'
14:00:17 <mattmceuen> #topic Rollcall
14:00:24 <mattmceuen> GM / GE everyone!
14:00:58 <mattmceuen> Agenda: https://etherpad.openstack.org/p/airship-meeting-2019-07-09
14:00:58 <michael-beaver> o/ GM
14:01:04 <MattCoachCarter> o/
14:01:04 <mattmceuen> we shall give it a few
14:01:08 <nishantkr> o/
14:01:14 <aaronsheffield> o/
14:01:14 <roman_g> o/
14:01:14 <obravo> Hi everyone
14:01:43 <alexanderhughes> p/
14:02:52 <mattmceuen> let us get this show on the road:
14:02:56 <mattmceuen> #topic Announcements
14:03:14 <mattmceuen> we have 5 hours left in the TC voting window
14:03:32 <mattmceuen> Contributors ought to have received emails with their voting link etc
14:03:52 <mattmceuen> Does anyone have any issues to report?  I haven't heard any, so hopefully everyone's all set
14:04:18 <mattmceuen> One note:  potentially due to me clicking the wrong thing, the Poll says something like "top voted person will get elected"
14:04:29 <mattmceuen> This is inaccurate, to clarify:  the top 5 will be elected
14:05:07 <mattmceuen> With the TC election under our belts, I hope to get the working committee nomination process kicked off next week
14:05:57 <mattmceuen> Details on the WC are here -- if you're interested in helping to make sure that the Airship community stays on the tracks on a day-to-day basis, I encourage you to run:     https://opendev.org/airship/governance#working-committee
14:06:42 <mattmceuen> Finally, voting on meeting times is going on for the SIG that will focus on lower-level design for Airship 2.0 manifest management (think: pegleg responsibility)
14:07:13 <mattmceuen> I don't have the link handy, but if you're interested in participating in that, I'll find the link and drop it in the agenda in a bit  (it's in Rodolfo's design meeting etherpad)
14:07:32 <mattmceuen> Any questions / discussion on any of this stuff team?
14:07:47 <roman_g> Not from me. Thank you, Matt.
14:07:58 <alexanderhughes> https://etherpad.openstack.org/p/Airship_OpenDesignDiscussions
14:08:06 <mattmceuen> ty alexanderhughes
14:08:32 <mattmceuen> ah, I guess the doodle vote itself was only sent out over the ML
14:09:07 <mattmceuen> never mind, reading the wrong thing:  that's sign up for the SIG for an airship UI, if you're interested please express such in the etherpad ^ !
14:09:22 <mattmceuen> Here's the vote for manifest SIG meeting time: https://doodle.com/poll/eedcsm4khtidxbxd
14:09:51 <roman_g> #link https://etherpad.openstack.org/p/Airship_OpenDesignDiscussions
14:10:03 <roman_g> #link https://doodle.com/poll/eedcsm4khtidxbxd
14:10:11 <mattmceuen> ty roman_g
14:10:22 <mattmceuen> Alright:  let's keep moving
14:10:32 <mattmceuen> #topic New meeting time
14:10:39 <mattmceuen> If you're here you have probably figured this out :D
14:11:02 <roman_g> Yes. It's just an announcement.
14:11:16 <mattmceuen> We can re-vote periodically, so let's see how this one works, hopefully it's good(ish) for everyone!
14:11:58 <hogepodge> Good morning from the west coast at the new meeting time :-)
14:12:15 <mattmceuen> howdy hogepodge :)  I know it's early, thanks for joining
14:12:38 <mattmceuen> #topic Follow up on PostgresHA
14:12:58 <mattmceuen> PS for integrating HA postgres into treasuremap yamls:  https://review.opendev.org/#/c/657667/
14:13:12 <mattmceuen> I have not had a chance to continue kicking the tires on this, with the US holiday last week
14:13:33 <mattmceuen> Still on my todo list for this week, or if anyone else gets a chance & has inclination, most welcome to as well
14:14:23 <roman_g> mattmceuen: if you'd be running it during my working hours - call me in
14:14:32 <mattmceuen> Cool, will do man
14:14:36 <roman_g> thanks
14:14:54 <mattmceuen> Next up:
14:14:59 <mattmceuen> #topic Follow up on Code formatting standardization across projects
14:15:22 <roman_g> alexanderhughes
14:15:57 <openstackgerrit> Pete Birley proposed airship/airshipctl master: WIP: Add a functional test  https://review.opendev.org/668555
14:15:58 <openstackgerrit> Ian Pittwood proposed airship/spyglass master: Combines all exceptions into a single file  https://review.opendev.org/667240
14:16:18 <alexanderhughes> Hi.  I've started getting some reviews on https://review.opendev.org/#/c/668897/ and https://review.opendev.org/#/c/668896/ (Go and Python respectively) formatting changes.  A sample of the Python formatting against Pegleg is included in the commit message for the Python doc changes.  Would appreciate more reviews, to pull the doc changes together
14:16:18 <alexanderhughes> and merge hopefully by EOW
14:16:46 <mattmceuen> that's awesome.  those are in the review list as well
14:17:59 <mattmceuen> Anything else on the formatting standards front?  I think we're good moving forward with those patchsets, ty alexanderhughes for putting those together
14:18:46 <mattmceuen> #topic Facilitating aiab / airskiff customizations
14:18:48 <alexanderhughes> Nope, we have a productive discussion on each of the programming language's doc patchsets.
14:18:57 <mattmceuen> +1
14:19:07 <mattmceuen> Ok, so -- to quickly recap this
14:20:03 <mattmceuen> Until Airship 2.0, we need a way to facilitate customizations to environments (prime examples being airskiff and aiab) for sets of overrides (examples of opensuse and tunsten fabric)
14:20:42 <mattmceuen> Last week we landed on seeing whether we could meet our needs using our existing 3-layer treasuremap manifest references
14:21:01 <mattmceuen> Before we dive into inventing a lot of new things for Airship 1.x
14:21:20 <mattmceuen> So here is my summary of where we're at:
14:21:57 <mattmceuen> We have a "sloop" type that tunes down globals for single-node use.  Airsloop and aiab sites inherit from that type and are fairly thin sets of overrides
14:22:27 <mattmceuen> We also have an airskiff site that inherits from a type called "single-node", which doesn't actually exist in treasuremap, unless I'm off my rocker
14:23:01 <mattmceuen> So essentially airskiff site is tuning down globals directly, to a single-node (single replica counts) context
14:23:16 <mattmceuen> Sound right to everyone so far?
14:23:54 <roman_g> seems legit
14:24:19 <mattmceuen> To make "airskiff" tunable, I would suggest we migrate the meat of to a type layer called "skiff", and then have skinny sites coming off of it for airskiff, and airskiff-opensuse, and anything else
14:24:47 <mattmceuen> Since it's basically skipping the type layer already, we have a degree of freedom there to accomodate the thin sites
14:24:49 <openstackgerrit> Merged airship/airship-in-a-bottle master: Replace repository links so they point directly to opendev.org  https://review.opendev.org/668107
14:25:46 <mattmceuen> For aiab, since the site level is already fairly thin, we could just clone/modify aiab site as aiab-tunstenfabric site
14:26:02 <mattmceuen> Has anyone come up with different insight or better ideas since last week?
14:26:46 <mattmceuen> and/or does that sound like a good plan :)
14:26:52 <obravo> I`m done with migrating TF to site level
14:26:59 <mattmceuen> oh nice obravo
14:27:06 <obravo> But it takes just no time to migrate to site-aiab level)
14:27:32 <mattmceuen> Does the idea of making an aiab-tunstenfabric site (using sloop type) seem reasonable to you?  And would it go along well with the work you're already doing?
14:28:26 <obravo> AS for me ,tree-like leveling might be a bit tricky for newstarters  , but it might bring more benefits in future
14:28:52 <michael-beaver> I definitely like that Airskiff plan, and I haven't thought of anything better for the TF
14:29:22 <mattmceuen> Agree obravo.  I think we need some solid reference material / how-to guide material detailing how to approach that
14:30:02 <mattmceuen> michael-beaver, I'm curious, do you know what the major differences between sloop type and airskiff (soon to be skiff type) are?
14:30:19 <mattmceuen> Or are they largely redundant, tuning stuff down to single replicas?  I haven't done a deep comparison
14:30:24 <openstackgerrit> Roman Gorshunov proposed airship/airship-in-a-bottle master: Update to work with new version of Promenade  https://review.opendev.org/664426
14:31:15 <michael-beaver> No I haven't looked into it too much, I've mostly been working at the site level with my recent changes and haven't been using the sloop type
14:31:26 <mattmceuen> yeah makes sense
14:32:23 <mattmceuen> dwalt, kskels, evgenyl might have some insight as well, but I don't think they were able to join today.  We should follow up with them at some point and see if that's an opportunity for future alignment
14:33:14 <mattmceuen> But for now, let's plan on that:  copy aiab -> aiab-tunstenfabric (obravo can do this in his PS), and refactor most of airskiff into a skiff type, and make a new airskiff-opensuse site off of it
14:33:32 <mattmceuen> I'll move on in a min unless there's anything else for this topic:
14:34:22 <mattmceuen> #topic Docs project now exists:  next steps
14:34:56 <mattmceuen> roman_g has been doing work in this area - want to drive us through it?
14:35:52 <roman_g> Just need reviews.
14:36:04 <roman_g> Pending for quite some time.
14:36:53 <roman_g> Kaspars has had a word on moving treasuremap documentation to docs repo
14:37:02 <roman_g> But he is not here today.
14:37:10 <hogepodge> roman_g: she’s on vacation right now, but have you chatted with asettle about it?
14:37:12 <mattmceuen> Yeah, I believe he's under the weather
14:38:34 <roman_g> hogepodge: just a bit. Copy is in meeting notes: Kaspars: I think we really need to discuss this - I feel like most treasuremap docs should stay where they are - e.g. code is where docs are to keep them in sync
14:39:29 <roman_g> We have treasuremap -related docs and more generic airship docs. probably need to agree on which specific documents to move.
14:39:43 <hogepodge> Ok, cool.
14:39:53 <mattmceuen> yeah, let's try to circle back with kskels later this week if possible.  I believe he's aligned on that princple but you're right that the devil is in the details
14:40:48 <openstackgerrit> Pete Birley proposed airship/airshipctl master: WIP: Add a functional test  https://review.opendev.org/668555
14:41:15 <mattmceuen> Alright, let's move onto the next topic:
14:41:27 <mattmceuen> #topic Decommission utils repo?
14:41:32 <mattmceuen> Good one to revist
14:42:08 <mattmceuen> this was discussed at the PTG - there was a path forward for retiring that one (as well as berth) identified and captured in the notes
14:42:16 <mattmceuen> just hasn't gotten done yet
14:42:32 <mattmceuen> around L93 here: https://etherpad.openstack.org/p/airship-ptg-train
14:43:05 <mattmceuen> #action mattmceuen to retire utils this week
14:43:05 <openstackgerrit> Alexander Hughes proposed airship/pegleg master: [WIP] Update Passphrase Catalog to support types  https://review.opendev.org/669743
14:43:22 <mattmceuen> Not a hard thing to do, just been a busy couple months :D
14:43:23 <roman_g> OK. They are set as retired, but the content stays, right?
14:43:53 <roman_g> I'll work on it, no problem.
14:44:14 <roman_g> #action roman_g retire utils and berth
14:44:53 <mattmceuen> yeah, there are instructions in there for how it's handled in openstack-infra -- multi step process
14:45:09 <mattmceuen> mostly unwinding all the project onboarding steps, in the right order
14:45:17 <mattmceuen> I believe the repo can be deleted at the end, though
14:45:48 <mattmceuen> It's ok roman_g, I can take care of that one
14:46:35 <mattmceuen> anything else on this topic guys?
14:46:57 <roman_g> Nope. We have plenty of repos to retire later.
14:47:20 <mattmceuen> yes, understanding the process will be helpful :)
14:47:32 <roman_g> With airship 2.0, with plugins, with k8s native airflow, etc. ;)
14:47:58 <mattmceuen> Alright, moving on:
14:48:00 <roman_g> and AIAB of course
14:48:09 <mattmceuen> Yep
14:48:20 <mattmceuen> #topic Low participation of Cores in IRC meetings and reviews
14:48:27 <roman_g> Mine.
14:48:29 <mattmceuen> ++
14:48:49 <roman_g> 12 Core team members, on IRC meetings we have at best 4. Usually 2.
14:49:52 <roman_g> On reviews - I didn't run stats, but we have lack of reviews from airship experts.
14:50:02 <mattmceuen> I agree.  To be fair though, there are other cores not in that list who are very active (and much appreciated)
14:50:06 <mattmceuen> But the point stands
14:50:23 <roman_g> Many changes are waiting for reviews for like a month or evem longer. Even simple changes.
14:50:43 <roman_g> *even
14:50:53 <mattmceuen> I'm interested in ideas from the team on how we can better facilitate / encourage / solicit reviews
14:51:15 <mattmceuen> We have the weekly plea for reviews - that helps some but is not sufficient
14:51:39 <alexanderhughes> Cores are voted in by cores.  Need an active base of cores, part of that voting process might be a guideline of an hour of reviews per day.  or X meaningful reviews per time period.  If we don't have active cores, add more and retire those that have moved on
14:52:32 <alexanderhughes> Similar to the committee seats having an expiration, cores might need to be periodically reviewed to see if it still makes sense
14:53:10 <ian-pittwood> +1
14:53:11 <mattmceuen> There are some conventions in the openstack community that I believe are good to consider
14:53:35 <mattmceuen> There's a formal process for removing a core reviewer, but it's messy and to be avoided
14:54:04 <mattmceuen> However I've had good luck with periodically reaching out 1:1 to folks who have drifted away to see if they still have interest/ability to retain core responsibilities
14:54:10 <mattmceuen> So that makes a good plan A
14:54:29 <roman_g> Many of current cores are experts in specific Airship components. We can't just remove them from reviewers team. We need to engage them. Community is small, we can't easily find/grow new experts.
14:54:37 <mattmceuen> ++
14:55:00 <mattmceuen> Everyone's busy too, and I get that (and experience that ;)
14:55:22 <mattmceuen> I will reach out with a personal plea for additional help from core reviewers
14:55:46 <mattmceuen> But I do ask that the team double down on code review.  I will commit to this as well.
14:56:04 <mattmceuen> As well as coming up with good ideas to help reviews happen more frequently and smoothly
14:56:35 <mattmceuen> Appreciate the discusssion on this topic team.
14:56:48 <mattmceuen> Last topic:
14:57:02 <mattmceuen> #topic Review requests
14:57:06 <mattmceuen> Speaking of the devil :)
14:57:24 <mattmceuen> If anyone was just inspired to do some code reviews, and wasn't sure where to look, boy can I help you out
14:57:27 <mattmceuen> https://review.opendev.org/#/c/669503/
14:57:27 <mattmceuen> https://review.opendev.org/#/c/668896/
14:57:28 <mattmceuen> https://review.opendev.org/#/c/668897/
14:57:28 <mattmceuen> https://review.opendev.org/#/c/667318/ - airship/election - rts formatting fixes
14:57:28 <mattmceuen> https://review.opendev.org/668650 - airship/election Add gate for docs build
14:57:28 <mattmceuen> https://review.opendev.org/#/c/666606/ - Airship mailing list for CI errors reporting; Cores: add +1's, please
14:57:28 <mattmceuen> https://review.opendev.org/#/c/668020/ - airship/docs docs and gates for docs
14:57:29 <mattmceuen> https://review.opendev.org/#/c/668664/ - airship/docs Import documentation from airsip-in-a-bottle
14:57:29 <mattmceuen> https://review.opendev.org/668665 - airship/airship-in-a-bottle Export all documents to Airship Docs project
14:58:10 <mattmceuen> I ask for a couple things here:
14:58:16 <mattmceuen> Let's get reviews on this list today
14:58:39 <mattmceuen> Let's keep a close eye on our areas of expertise and do reviews frequently and early on those
14:58:48 <mattmceuen> we have just a couple minutes left, anything else guys?
14:58:53 <alexanderhughes> the review request weekly to find priority reviews is helpful, but I find this link to be amazing for my daily coffee hour and reviews
14:58:55 <alexanderhughes> #link https://review.opendev.org/#/q/projects:airship%20status:open%20NOT%20label:Verified%253D-1%20NOT%20label:Workflow%253D-1%20NOT%20message:DNM%20NOT%20message:WIP%20NOT%20label:Code-Review%253E0%252Cself
14:59:42 <alexanderhughes> it's got a bunch of filters to show you just airship code that's really ready for review and you don't have an existing +1/+2 on.
15:00:07 <mattmceuen> Also I know some cores weren't here because they forgot the time change ;)
15:00:19 <mattmceuen> thanks alexanderhughes for that example - that's really good
15:00:25 <mattmceuen> thanks everyone, out of time!
15:00:32 <mattmceuen> have a great day + week
15:00:34 <mattmceuen> #endmeeting