14:00:40 <mattmceuen> #startmeeting airship
14:00:41 <openstack> Meeting started Tue Jul 16 14:00:40 2019 UTC and is due to finish in 60 minutes.  The chair is mattmceuen. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:44 <openstack> The meeting name has been set to 'airship'
14:00:46 <mattmceuen> #topic Rollcall
14:01:02 <mattmceuen> Hey everyone, GM / GE!  Here's our agenda, let's give it a few minutes:  https://etherpad.openstack.org/p/airship-meeting-2019-07-16
14:01:11 <mattmceuen> Please add items to discuss today to the agenda
14:01:16 <openstackgerrit> Ian Pittwood proposed airship/spyglass-plugin-xls master: Revise formatting of excel specs  https://review.opendev.org/668748
14:01:25 <michael-beaver> o/
14:01:28 <alexanderhughes> o/
14:01:44 <mattmceuen> I beleive this is the first week where we're overlapping the design call and team meeting a bit, so we will test our powers of multitasking
14:01:54 <nishantkr> o/
14:02:08 <itxaka> o/
14:02:22 <mattmceuen> o/ all
14:04:02 <mattmceuen> alright, I think we can get started
14:04:19 <mattmceuen> #topic Technical Committee election results
14:04:19 <dwalt> o/
14:05:09 <mattmceuen> We have completed our first round of Airship elections, which is a great thing for two reasons:  we now have a technical committee to help provide some steering, and, this is a milestone of maturity for Airship as a project
14:05:42 <mattmceuen> The results (and a link to drill-down details) can be found here: https://opendev.org/airship/election/src/branch/master/doc/source/results/2019/tc.rst
14:06:06 <mattmceuen> Congrats to Alex, Alexey, James, Jan-Erik, and Ryan!
14:07:08 <mattmceuen> alexanderhughes is here as well, and I think as a member of both the dev team and the TC, you'll be able to help bridge that gap, so special congrats / thanks-in-advance to you :D
14:07:27 <alexanderhughes> thanks :)
14:07:44 <openstackgerrit> Ian Pittwood proposed airship/spyglass-plugin-xls master: Revise formatting of excel specs  https://review.opendev.org/668748
14:08:27 <mattmceuen> I know the TC members are working to find meeting times that will work, so I expect we'll see that start to form up soon.
14:09:07 <alexanderhughes> yes, we're ironing out dates - initial proposal was for 06-August
14:09:26 <mattmceuen> That's excellent
14:09:31 <mattmceuen> In the spirit of no rest for the weary, we are planning to kick off our election for the Working Team today as well.  I'll follow the same 3-week election cycle as did the TC election
14:09:55 <mattmceuen> as a refresher, the WC description / mission:  https://opendev.org/airship/governance#working-committee
14:11:07 <mattmceuen> I will send out an email later today, and encourage anyone who is interested in contributing this way to nominate!
14:11:22 <mattmceuen> Any other thoughts / questions on all this electioning?
14:11:46 <alexanderhughes> good luck to those running, we'll appreciate all your efforts once the WC is established
14:11:48 <mattmceuen> Once the WC election is out of the way, we plan to repeat this process in a year.
14:13:14 <mattmceuen> Alright, moving on:
14:13:21 <mattmceuen> #topic Low participation of Cores in IRC meetings and reviews
14:13:42 <mattmceuen> I don't see who's topic this is, is it yours roman_g?
14:15:27 <mattmceuen> Let's return to this one later
14:15:33 <mattmceuen> #topic Reminder: we have a blog!
14:16:06 <mattmceuen> PSA since I'm not sure everyone's aware:  we do have an Airship blog, where various topics (and most recently, Airship 2.0 vision) have been getting socialized
14:16:11 <openstackgerrit> Sean Eagan proposed airship/armada master: [WIP] Implement prometheus metric collection  https://review.opendev.org/668980
14:16:16 <mattmceuen> openstack:  https://www.airshipit.org/blog/
14:16:38 <mattmceuen> Good reads there, so I invite you to take a look, the most recent is from last week
14:16:46 <itxaka> wgho and how you can contribute to that?
14:16:51 <itxaka> *who
14:17:11 <mattmceuen> I believe hogepodge can help coordinate that
14:17:25 <mattmceuen> as for "who" I think it would be "anyone with an idea and a story to tell" :)
14:17:28 <openstackgerrit> Merged airship/divingbell master: CI: Make Divingbell Ubuntu Job non-voting  https://review.opendev.org/671039
14:17:32 <itxaka> :+1
14:17:36 <itxaka> thanks
14:17:48 <mattmceuen> that would be a good topic to bring up in the bi-weekly sync between the airship team and the OSF:
14:18:16 <mattmceuen> https://wiki.openstack.org/wiki/Airship#OpenStack_Foundation_Touchpoint_Call_.E2.80.93_Biweekly
14:18:25 <mattmceuen> for anyone that has an idea for a blog post
14:18:45 <mattmceuen> (joining that call is not a requirement of course, just one way to discuss the idea with the OSF folks who help to facilitate the blog)
14:19:34 <mattmceuen> alexanderhughes had a good add:  Request - add social media links to blog to make sharing articles quick and easy
14:19:46 <mattmceuen> I am a lazy twitterer so I agree with this sentiment
14:20:31 <mattmceuen> hogepodge can we discuss that at some point? ^
14:21:18 <mattmceuen> If nothing else on this topic, moving on:
14:21:23 <alexanderhughes> did we have a hashtag we're using for promoting/socializing airship?  #airshipit for example?
14:21:50 <alexanderhughes> if we make sharing easier, might get more shares, and especially during times of PTG/summits I imagine information will flow faster
14:22:29 <mattmceuen> the airship handle itself is @airshipproject
14:23:12 <mattmceuen> looks like we do have #airshipit as an inconsistently used hashtag, sounds good to me if we standardize on it
14:23:35 <alexanderhughes> yeah would be nice to have something standard across the platforms, especially if we're leveraging our linkedin networks to gain more visibility to our progress
14:23:47 <mattmceuen> ++
14:25:00 <mattmceuen> ok, moving on!
14:25:08 <mattmceuen> #topic New project request: kubernetes-entrypoint migration
14:26:08 <mattmceuen> you're all probably familiar with the kubernetes-entrypoint project, which Airship (as well as OpenStack-Helm) use for sequencing startup of pods in charts
14:26:10 <mattmceuen> https://github.com/stackanetes/kubernetes-entrypoint
14:27:07 <mattmceuen> it's a part of the stackanetes project, which has not been under active development for some time.  However, we're still active users
14:28:51 <openstackgerrit> Merged airship/airshipctl master: Add a configuration file for golangci-lint  https://review.opendev.org/670166
14:29:02 <mattmceuen> Since Airship and OSH are the main consumers of this project, alanmeadows and portdirect have discussed moving the project into the airship namespace, and then retaining as many of the original core team as are still interested, making it easier to keep that project aligned to Airship & OSH, and to get further features in that we need
14:29:18 <mattmceuen> The kubernetes-entrypoint team is good with this approach
14:29:58 <mattmceuen> I wanted to socialize this move before it happens, and to have any discussion needed before formally +1 / -1'ing it here as is our custom
14:30:06 <mattmceuen> any questions?
14:30:10 <portdirect> +8?
14:30:27 <portdirect> i think this is a great move
14:30:29 <mattmceuen> lol
14:30:45 <portdirect> k8s entrypoint has served us very well - but needs some ongoing love
14:30:56 <mattmceuen> portdirect goes on vacation for a few days, and comes back with a bunch of +1's stored up, don't spend them all at once!
14:30:59 <portdirect> and i think airship would be a great home for it.
14:30:59 <mattmceuen> ++
14:31:07 <itxaka> ++
14:31:17 <ian-pittwood> ++
14:31:27 <mattmceuen> we'll also be sure to retain full git history so as to give credit where due
14:32:04 <mattmceuen> any additional votes (or questions)?
14:32:10 <michael-beaver> ++
14:32:12 <dwalt> +1 sounds good to me
14:32:16 <mattmceuen> great
14:32:20 <mattmceuen> sounds like consensus
14:32:50 <mattmceuen> #action mattmceuen to create project creation PS for kubernetes-entrypoint
14:32:56 <mattmceuen> thanks all
14:33:29 <mattmceuen> Alright, moving on!
14:33:34 <mattmceuen> #topic Roundtable
14:33:42 <mattmceuen> https://review.opendev.org/#/c/668896/
14:33:42 <mattmceuen> https://review.opendev.org/#/c/668897/
14:33:42 <mattmceuen> https://review.opendev.org/#/c/668020/ - airship/docs docs and gates for docs
14:33:42 <mattmceuen> https://review.opendev.org/668665 - airship/airship-in-a-bottle Export all documents to Airship Docs project
14:34:19 <alexanderhughes> did we want to circle back on the core participation item from earlier?
14:34:44 <mattmceuen> looks like the last couple are good to go now, no need for addn'l reviews on them at this time
14:34:53 <mattmceuen> alexhughes: yep
14:35:06 <mattmceuen> before we do, any additional review requests to add to list?
14:36:14 <mattmceuen> ok, great
14:36:29 <mattmceuen> roman_g:  do you want to revisit the participation topic from earlier?
14:37:27 <mattmceuen> or, any additional roundtable topics, team?
14:38:34 <dwalt> nothing on my end, seems quiet today :)
14:39:01 <mattmceuen> agree, hopefully this isn't the new meeting time working out sub-optimally or something
14:39:44 <mattmceuen> in that case, I'll give you all a few minutes back!
14:39:52 <mattmceuen> Thanks everyone, and have a great week
14:39:56 <mattmceuen> #endmeeting