14:00:11 <kskels> #startmeeting airship
14:00:15 <openstack> Meeting started Tue Oct  1 14:00:11 2019 UTC and is due to finish in 60 minutes.  The chair is kskels. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:18 <openstack> The meeting name has been set to 'airship'
14:00:26 <kskels> #topic Rollcall
14:00:48 <mattmceuen> o/
14:00:51 <roman_g> o/
14:00:54 <nishantkr> o/
14:01:16 <alexanderhughes> o/
14:01:37 <kskels> Let's give 1 more minute to all and remind that here is the agenda for today https://etherpad.openstack.org/p/airship-meeting-2019-10-01
14:01:44 <michael-beaver> o/
14:02:47 <kskels> #topic treasuremap
14:02:56 <howell> o/
14:03:08 <dwalt> o/
14:03:20 <kskels> latest treasuremap is out https://opendev.org/airship/treasuremap/src/tag/v1.5
14:03:23 <aaronsheffield> o/
14:03:28 <mattmceuen> woo hoo!!
14:03:41 <sthussey> here
14:03:46 <kskels> there are all the uplifts pulled in (no blacklisted items) which is great as of yesterday
14:04:15 <kskels> there were fixes done to Promenade overrides so now also k8s version and helm should have proper versions
14:04:51 <kskels> I think that's all there is for treasuremap anouncement
14:05:00 <mattmceuen> is there any way in opendev to show the commits in 1.5 vs 1.4?  Kind of a poor man's release notes?
14:05:27 <kskels> I'll take an action item on that - I'm pretty sure there must be
14:05:42 <roman_g> no. but there might be gitea plugin for that
14:05:52 <mattmceuen> cool - worth looking into
14:06:05 <mattmceuen> although we need to start doing some legit release notes as well
14:06:18 <kskels> yeah - I feel probably release notes are better anyway to be honest
14:06:51 <roman_g> #action Roman to add reno for release notes to treasuremap and document it
14:07:00 <openstackgerrit> varagini karthik proposed airship/porthole master: Chart/Dockerfile for Postgresql Utility Container  https://review.opendev.org/675866
14:07:16 <seaneagan> not sure about gitea, but: https://github.com/airshipit/treasuremap/compare/v1.4...v1.5
14:07:35 <mattmceuen> nice - ty seaneagan
14:08:03 <roman_g> https://github.com/go-gitea/gitea/issues/3780 go-gitea/gitea
14:08:08 <roman_g> Feature: Allow comparison of tags, etc. #3780
14:08:12 <kskels> maybe we should then start release notes section somewhere in https://airship-treasuremap.readthedocs.io/en/latest/
14:08:13 <roman_g> Status: Open
14:08:21 <kskels> initially just to give links to this "compare"
14:09:07 <sthussey> It will probably be difficult to build useful release notes without the underlying components doing the same
14:09:22 <roman_g> Probably would be good to show interest in this Gitea feature here https://github.com/go-gitea/gitea/issues/3780
14:09:43 * mattmceuen gets a kick out of gitea being hosted on github
14:09:50 <roman_g> sthussey: true.
14:09:52 <sthussey> The change 'Updated SHA X to SHA Y for Promenade'
14:10:04 <sthussey> not great
14:10:14 <sthussey> Of course overrides can be described directly in Treasuremap
14:10:34 <kskels> P.S. Small note on opendev.org -> github.com replication - the tags only show up after next commit to the repo as our triggers only replicate on commit (not on pushed tag!)
14:11:22 <roman_g> ^^^ - there is a possibility to trigger job in Zuul on tag creation
14:11:36 <roman_g> which could e.g. create same tag on github if needed
14:11:58 <kskels> the tag somehow gets pushed automatically - it's just that we need to wait on next merge..
14:12:04 <mattmceuen> we've talked about reno for a while, and I think we need to start somewhere, even if it's not 100% fidelity.  Treasuremap would be a good place to cut our teeth on it, since that's the thing that gets the most visibility w.r.t. release notes.   If roman_g can help us get reno into treasuremap, and we can develop good granularity/practices there, then maybe we can start migrating it into other projects?
14:12:36 <mattmceuen> agree on "sha updates" not being valuable
14:12:48 <mattmceuen> would take a little digging and manual updating by a human
14:13:17 <mattmceuen> we don't necessarily need to update the reno notes on each commit
14:14:12 <mattmceuen> kskels we've really hijacked your first agenda item haven't we :D  thanks for taking lead on getting the monthly release put together and well-tested, as usual!
14:14:38 <kskels> no worries, I will work with Roman to get the release notes going - I think it would be great and we have talked about it more before
14:14:45 <roman_g> mattmceuen: Gitea hosted Gitea https://github.com/go-gitea/gitea/issues/1029
14:14:58 <kskels> #topic nominations
14:15:21 <mattmceuen> roman_g: +1 to that
14:15:26 <mattmceuen> this one's mine
14:16:24 <mattmceuen> reminder of what we've discussed before - we want to fill our 5th working committee seat with a special election offset by three months; that sets the nomination period (one week) to begin on Oct 9
14:16:57 <mattmceuen> note that this time, Ericsson and AT&Tfolks are disqualified due to employer seat limits
14:17:16 <mattmceuen> others: please do consider nominating!
14:17:30 <mattmceuen> I'll send out an email but wanted to raise awareness early and often - that's all kskels
14:17:57 <kskels> #topic Ubuntu 18.04
14:18:14 <kskels> sthussey: you are up!
14:18:38 <sthussey> Work is starting for the Airship 1.x components to support Ubuntu 18.04
14:18:59 <sthussey> The question is whether this work should deprecate (either purposefully or just by not testing support) 16.04
14:19:24 <sthussey> It is EOL in 2021
14:20:01 <roman_g> does this chenge include only base image change?
14:20:13 <roman_g> *change
14:20:35 <sthussey> It is unrelated to container images
14:20:50 <sthussey> Related mainly to the OS requirement of the nodes running Kubernetes/Airship
14:20:51 <mattmceuen> speaking for AT&T downstream consumption - I think we'd be happy deprecating further work on top of 16.04
14:21:07 <roman_g> sthussey: thanks
14:21:34 <mattmceuen> and I'm not aware of anyone from other Airship consumers who need 16.04 - speak now or forever hold your peace :)
14:23:22 <kskels> this would be requiring probably fixes to AIAB as well, and potentially other pipelines
14:24:00 <mattmceuen> very true, we'll need to coordinate
14:24:12 <kskels> but same experience here, I would say I have heard a couple of times people asking for 1804 support - so generally seeing it as good thing!
14:24:48 <mattmceuen> +1
14:25:10 <kskels> #agreed
14:25:26 <kskels> mostly wanted to test the specialized tag - but at least no objections to supporting only 18.04
14:25:36 <kskels> I don't really see a reason for restricting it atrificially though
14:26:15 <kskels> should we need more discussion on 2nd part?
14:26:26 <kskels> "(either purposefully or just by not testing support) 16.04"
14:26:34 <kskels> e.g. if we shall purposefully disable it?
14:27:26 <mattmceuen> FWIW: Everyone who wants a non-ubuntu base operating system seems to be holding out for Airship 2.0
14:27:40 <mattmceuen> So I think Airship 1 will only be deploying Ubuntu
14:28:17 <mattmceuen> If everyone who wants Ubuntu wants 18.04, then it's probably not worth a ton of complexity to support both versions, if it's bigger than a breadbox
14:28:55 <kskels> +1
14:30:14 <openstackgerrit> Doug Aaser proposed airship/deckhand master: Fix encrypted doc rendering  https://review.opendev.org/684366
14:31:02 <kskels> ok, seems no more views! are we ready for next topic?
14:31:09 <mattmceuen> I think so
14:31:17 <kskels> #topic KubeCon
14:31:54 <mattmceuen> For folks who don't watch the mailinglist like a hawk
14:32:31 <mattmceuen> If anyone is planning on attending kubecon or mobile world congress - or if you're NOT planning, or don't know -- please fill out this quick survey: https://www.surveymonkey.com/r/JFNWPRX
14:32:57 <mattmceuen> We're working with the OSF to try to estimate headcount and interest in a mini-ptg-type sync up
14:33:09 <mattmceuen> that's all
14:34:07 <kskels> thank you Matt!
14:34:11 <kskels> topic Round Table
14:34:18 <kskels> #topic Round Table
14:34:26 <kskels> That was our last item before reviews
14:34:35 <kskels> any other item someone would like to bring up?
14:35:22 <mattmceuen> Nothing except let's please review the requests on the list - some of them are long in the tooth
14:35:39 <kskels> #topic Core Review
14:35:47 <kskels> https://review.opendev.org/#/c/675467/ - k8s-entrypoint (lint)
14:35:48 <kskels> https://review.opendev.org/#/c/675406/6 - k8s-entrypoint (test)
14:35:48 <kskels> https://review.opendev.org/#/c/674888/6 - k8s-entrypoint (go-modularize)
14:35:48 <kskels> https://review.opendev.org/#/c/675419/5  - k8s-entrypoint (CI)
14:35:48 <kskels> https://review.opendev.org/#/c/676700/ - Spec: Introduce isogen subcommand for airshipctl
14:35:48 <kskels> https://review.opendev.org/#/c/676121/ - Airshipctl: Add isogen subcommand for bootstrap
14:35:48 <kskels> https://review.opendev.org/#/c/675851/ - Airshipctl: Add logic to isogen subcommand
14:35:49 <kskels> https://review.opendev.org/#/c/679563/ - Airshipctl: Generate cloud init settings
14:35:49 <kskels> https://review.opendev.org/#/c/685049/ airship/docs Add Ansible code formatting documentation
14:35:50 <kskels> https://review.opendev.org/#/c/685047/ airship/docs Add Bash shell scripts formatting documentation
14:35:50 <kskels> https://review.opendev.org/#/c/685038/ airship/docs Add container image and Dockerfile conventions
14:35:51 <kskels> https://review.opendev.org/#/c/683209/ pegleg add support for global encryption
14:35:55 <roman_g> kskels: not Core, Code :)
14:36:26 <kskels> that's true! the reviews are also in the agenda link https://etherpad.openstack.org/p/airship-meeting-2019-10-01
14:36:28 <mattmceuen> lol
14:36:39 <openstackgerrit> varagini karthik proposed airship/porthole master: Chart/Dockerfile for Postgresql Utility Container  https://review.opendev.org/675866
14:36:40 <kskels> please do so! reviews are great and fun!
14:36:54 <kskels> have a good day everyone!
14:37:04 <kskels> #endmeeting