14:00:12 <aaronsheffield> #startmeeting Airship Community meeting 2018-08-14
14:00:13 <openstack> Meeting started Tue Aug 14 14:00:12 2018 UTC and is due to finish in 60 minutes.  The chair is aaronsheffield. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:16 <openstack> The meeting name has been set to 'airship_community_meeting_2018_08_14'
14:00:25 <aaronsheffield> #topic Attendance
14:00:29 <mattmceuen> GM! o/
14:00:31 <b-str> \o
14:00:36 <aaronsheffield> o/
14:00:56 <aaronsheffield> Please record your attendance on today's etherpad: https://etherpad.openstack.org/p/airship-meeting-2018-08-14
14:01:18 <seaneagan> o/
14:02:44 <roman_g_> o/
14:02:56 <aaronsheffield> #topic Old Business: PTG agenda: https://etherpad.openstack.org/p/AirshipPTG4
14:04:15 <aaronsheffield> #topic Current Business: Documentation repositories - airship-in-a-bottle & treasuremap for source; readthedocs, airshipit.org...
14:04:36 <b-str> What was remaining on this topic?
14:05:32 <b-str> it was brought up last week, but we didn't get to it.
14:06:44 <roman_g_> I have not been working on it. I've asked Scott to add openstack infra user as admin to docs at rtd site.
14:07:05 <roman_g_> This is a documented requirement from openstack infra folks
14:07:21 <roman_g_> But Scott asked for a good reasoning for that.
14:07:50 <roman_g_> I didn't manage yet to reach out to Ian (openstack-infra, Red Hat) to get comments on that.
14:07:58 <roman_g_> Hope to work on this this week.
14:08:16 <mattmceuen> We have docs scattered around a bit
14:08:34 <mattmceuen> Some stuff (but I believe some broken links to?) some of the readthedocs pages
14:08:51 <mattmceuen> Some newer documentation in airship-in-a-bottle
14:09:08 <roman_g_> Someone (Scott probably) was working on in-a-bottle, right.
14:09:19 <mattmceuen> Also some docs slated for Treasuremap - https://review.openstack.org/#/c/590581/
14:09:28 <mattmceuen> Repo nearly exists :)
14:09:32 <aaronsheffield> I've fixed some of the links in a couple open patch sets, but probably worth a pass through all of our repos to make sure they links point to the airship docs.
14:10:02 <mattmceuen> Agree
14:10:35 <mattmceuen> I've fixed a few in deckhand, have any of the other projects been gone through holistically?
14:11:06 <mattmceuen> Confirming / updating the doc links would be a good low hanging fruit for new contributors -- and reading the docs along the way :)
14:11:51 <aaronsheffield> Yesterday I went through airship-in-a-bottle and airship-armada to replace 'armada-helm.readthedocs' with 'airship-armada.readthedocs', but that's the only thing I looked for.
14:11:53 <roman_g_> If we are talking on Multi Node atlanta foundry site yamls for Treasuremap - they are ready and are on a review at the moment.
14:13:20 <roman_g_> versions.yaml is up to Thursday past week versions of all airship-* components, and other software is on versions pinned in OSH and on versions pinned in our labs
14:14:00 <mattmceuen> this is excellent - we can get a PS for that in as soon as Treasuremap project is created
14:14:14 <roman_g_> look forward to it
14:15:13 <b-str> should be able to copy the airship-specs publishing automation, at least to start.
14:15:40 <mattmceuen> Nice
14:16:52 <aaronsheffield> Anything else on documentation repos?
14:17:19 <aaronsheffield> #topic Current Business: Almost have new reference manifests :)
14:17:35 <mattmceuen> I think we pretty much covered that
14:17:40 <mattmceuen> I'll add a blurb
14:17:42 <mattmceuen> on intent
14:17:43 <aaronsheffield> https://review.openstack.org/#/c/590581/, looks like it just needs a Workflow +1
14:18:06 <mattmceuen> As soon as we get the project created, we'll push a PS for the manifests
14:18:36 <mattmceuen> They will be a multi-node reference implementation -- they won't have all the fancy features like CPU pinning and things like that out of box
14:19:03 <mattmceuen> But they'll be more of a basic out-of-box set of manifests that folks can use to  model after if they want to spin their own airship install
14:19:30 <mattmceuen> They'll also be run through CICD to continually ensure they're compatible with the latest & greatest upstream AIrship (and OSH) charts
14:19:38 <mattmceuen> That's all from me on that
14:20:58 <aaronsheffield> #topic New Business: AT&T's presentations/demo's/lightning talks selected for the OpenStack Berlin 2018 Summit
14:22:06 <aaronsheffield> #topic New Business: WIP Airship Community Brand & Project Messaging
14:22:19 <b-str> let's open that up to anyone's presentations related to Airship for the summit...
14:23:22 <mattmceuen> We do have a couple Airship related talks on the docket!  Actually one talk and one workshop:
14:23:22 <mattmceuen> https://www.openstack.org/summit/berlin-2018/summit-schedule/global-search?t=airship
14:24:59 <aaronsheffield> Anything else on Airship Presentations in Berlin?
14:25:55 <portdirect> mattmceuen: we should also get airship in as part of the osh project update
14:26:10 <portdirect> It's one of this biggest things that happened this cycle :D
14:26:34 <mattmceuen> +1 :) - as one of the big consumers of OSH I think that makes sense
14:26:49 <mattmceuen> Speaking of
14:26:57 <mattmceuen> Impromptu agenda item
14:27:15 <mattmceuen> Congrats to portdirect on being the new PTL of OSH in the upcoming Stein cycle!
14:27:50 <portdirect> Thx dude, gonna be a tough act to follow
14:27:59 <b-str> congrats!
14:28:04 <roman_g_> congrats! =)
14:28:25 <mattmceuen> That's all from me, at least, on summity things aaronsheffield
14:28:43 <aaronsheffield> From the bi-weekly Airship sync (Community Brand & Project Messaging), https://docs.google.com/document/d/1WMj1iT5JwsM0fPej_w_Kev2F7E5jNj7vICEjSPeJMyI/edit
14:29:55 <mattmceuen> ^^ our friends in the OSF are working on Branding-type things for Airship -- they asked if we could give their WIP a good review and add comments in the google doc
14:30:19 <mattmceuen> I am a bad person and have not yet, but I am redeeming myself by inviting everyone here to ;-)
14:31:40 <roman_g_> will have a look and comment
14:31:49 <mattmceuen> thanks roman_g_
14:32:22 <aaronsheffield> #action Review https://docs.google.com/document/d/1WMj1iT5JwsM0fPej_w_Kev2F7E5jNj7vICEjSPeJMyI/edit
14:32:47 <aaronsheffield> #topic New Business: New weekly design meeting on Thursdays -- 4-5 US central - currently 21-22:00 UTC, while DST is in effect
14:33:09 <aaronsheffield> Etherpad for those meetings: https://etherpad.openstack.org/p/Airship_OpenDesignDiscussions
14:33:59 <portdirect> Will these be in addition to community meeting?
14:34:02 <mattmceuen> I don't think this has been sent out on the mailing list yet
14:34:07 <b-str> yes, in addition
14:34:11 <mattmceuen> #action mattmceuen will send out a blurb
14:34:17 <mattmceuen> Rodolfo will lead this weekly portdirect
14:34:19 <portdirect> What's the scope?
14:34:30 <portdirect> I'll await the blurb ;)
14:34:49 <mattmceuen> Long-term it will be todefine forward-looking design for Airship
14:35:03 <mattmceuen> To begin with we'll start with some more overview-y material for new team members
14:35:15 <mattmceuen> As well as "how do we want to approach design in the community" type discussion
14:35:32 <mattmceuen> To continue the trajectory of all the Four Opens in action for Airship
14:37:17 <portdirect> Nice
14:38:36 <aaronsheffield> #topic Round Table (anything else not on the etherpad?)
14:39:59 <aaronsheffield> If nothing else, thanks everyone for attending.
14:40:01 <aaronsheffield> #endmeeting