15:00:28 <sarob> #startmeeting akanda
15:00:29 <openstack> Meeting started Mon Apr 27 15:00:28 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:34 <openstack> The meeting name has been set to 'akanda'
15:00:41 <sarob> roll call
15:00:44 <adam_g> o/ !
15:01:18 <sarob> \o/
15:03:01 <sarob> im pinging ryan and david
15:03:10 <ryanpetrello_> o/
15:03:28 <sarob> pinged
15:03:33 <sarob> :)
15:05:17 <davidlenwell> o/
15:05:22 <sarob> cool
15:05:39 <sarob> #link https://wiki.openstack.org/wiki/Meetings/akanda#Agenda
15:05:49 <sarob> pretty simple this morning
15:05:59 <sarob> lets review the bp
15:06:11 <sarob> #topic review blueprints
15:06:20 <sarob> #link https://blueprints.launchpad.net/akanda
15:06:42 <sarob> oh
15:06:56 <sarob> WELCOME Adam to the akanda team!!!!
15:07:15 <adam_g> thanks, sarob  :)
15:07:39 <davidlenwell> hey adam!
15:07:44 <sarob> fancy irc welcome
15:08:33 <sarob> so i took what was in trello
15:08:39 <ryanpetrello_> :D o/
15:08:52 <sarob> summarized a few of them, like oslo fix ups
15:09:10 <sarob> and here you go
15:09:49 <sarob> im going to merge specs dir
15:10:00 <sarob> for more details
15:10:22 <davidlenwell> details are good
15:10:28 <sarob> is there anything major missing from the bp
15:10:51 <sarob> assuming the title says enuf to understand
15:10:56 <sarob> what its about
15:11:02 <ryanpetrello_> probably something for image building?
15:11:17 <sarob> hmm, right
15:11:37 <sarob> that got munged
15:11:39 <ryanpetrello_> before Mark left, he was working on getting a process in place for easily building and uploading appliance images with the same tooling infra uses
15:11:49 <adam_g> DIB?
15:11:53 <davidlenwell> yes
15:11:56 <ryanpetrello_> (yep)
15:12:10 <davidlenwell> I'm also using DIB to build the image for the ingix thing we're doing
15:12:17 <ryanpetrello_> DreamHost folks have been using veewee *shudder*
15:12:19 <adam_g> +1 to DIB
15:12:32 <ryanpetrello_> we probably need a BP for building nightly + stable images from source
15:13:05 <ryanpetrello_> a lot of the work is done, but it's been on hiatus since Mark left
15:13:10 <adam_g> the ci-updates blueprints mentions it
15:13:27 <sarob> yeah, i jammed them together
15:13:36 <ryanpetrello_> k, that works
15:13:40 <ryanpetrello_> it's probably higher priority, though
15:13:47 <ryanpetrello_> davidlenwell got stuck on it because we don't have public images currently
15:14:03 <davidlenwell> ryanpetrello_:  so you saw my messages from last night ?
15:14:08 <ryanpetrello_> yep :)
15:14:12 <davidlenwell> nice ..
15:14:14 <adam_g> what about post-commit image builds?  the ironic team does something similar with their deploy ramdisk images, that uploads new builds to tarballs.openstack.org after each commit merges to relevant repos
15:14:33 <davidlenwell> adam_g:  +1
15:14:46 <davidlenwell> thats how we should handle it
15:14:51 <ryanpetrello_> yea, at this point, *anything* would work
15:14:59 <ryanpetrello_> I currently develop with the veewee-based image we use for DHC production
15:15:18 <sarob> adam_g +1
15:16:17 <sarob> so you guys want to start adding some details straight into the bp
15:16:29 <davidlenwell> I think thats wise ..
15:16:31 <sarob> i will patch the akanda repo for specs
15:16:42 <davidlenwell> sounds like a plan..
15:16:55 <sarob> so we can start creating specs for the bp real details
15:17:16 <sarob> im not going to worry about tox spec jobs for right now
15:17:42 <sarob> #action sarob patch akanda repo for specs
15:17:57 <sarob> #action team update existing bp with details
15:18:07 <sarob> so what about timing
15:18:39 <sarob> do we, can we branch kilo before the summit?
15:19:07 <sarob> what in this list needs to drop out?
15:19:43 <ryanpetrello_> I feel like rug-ha is pretty aggressive
15:20:03 <ryanpetrello_> given that I don't think we actually have a working akanda + kilo in-tree
15:20:06 <ryanpetrello_> (at all)
15:20:19 <ryanpetrello_> some of it's partially implemented in Mark's forks, some of it's still in his brain
15:20:39 <ryanpetrello_> but it's possible that he's made more progress on that front that I've been aware of
15:21:01 <davidlenwell> I hope he hasn't .. he is supposed to be on a honey moon
15:21:07 <davidlenwell> ;)
15:21:19 <sarob> "we" need to spread the joy and get
15:21:28 <sarob> the rest of us working on the bits
15:22:05 <davidlenwell> I'll be of more help on this by the time he gets back.. finally getting a working dev env going.. hopfully finishing the final bits of that todayw ith ryans help.
15:22:09 <ryanpetrello_> yea, that's probably first going to require actually getting you all spun up on dev environments with this stuff
15:22:18 <davidlenwell> that ^
15:22:42 <ryanpetrello_> brb, gotta grab a power adapter
15:23:42 <sarob> so lets assume that the trello dev sprint was correct
15:23:49 <sarob> that i moved over into bp
15:23:53 <sarob> for now
15:24:08 <sarob> we as a team focus on documenting the bp
15:24:26 <sarob> breaking them down into smaller, patchable pieces
15:25:05 <sarob> being that david is just getting in the flow
15:25:14 <sarob> and adam is just starting
15:25:24 <sarob> we have a bit a catch up to do
15:25:39 <adam_g> are we using specs to per review those details before they go into the BP? or just going straight into the BP for now?
15:25:41 <davidlenwell> I can work with adam to get him up to speed faster than I did
15:25:45 <adam_g> *peer
15:25:57 <sarob> davidlenwell: good plan
15:26:16 <sarob> adam_g: start with the bp for right now
15:26:32 <sarob> ill patch specs right after this meeting so
15:26:39 <adam_g> k
15:26:47 <sarob> you can start braindumping into there
15:26:50 <davidlenwell> I think some items will need specs before we should expect anyone to know what to do wit hthem
15:27:00 <sarob> davidlenwell: yeah
15:27:18 <sarob> we dont quite know where to start yet
15:27:38 <sarob> although getting the nightly images builds going is a good one to start
15:27:42 <davidlenwell> a lot can be derived from context .. but the less guessing the better for me anyways
15:27:52 <sarob> yeah
15:28:14 <davidlenwell> sarob: I think what adam was suggesting is that we forgott nightly builds and move to a post commit image build
15:28:23 <davidlenwell> that way we always have images that are up to date
15:28:39 <sarob> davidlenwell: yeah, i already merged the two in my head
15:28:44 <davidlenwell> which I think is smart
15:28:50 <sarob> very smarty
15:29:10 <adam_g> IMO image builds should be the artifact of successful devstack-tempest jobs run in the gate, so if we can get devstack jobs running against patches we are most of the way there.. is there a status on the devstack integration at this point?
15:29:22 <ryanpetrello_> +1
15:29:26 <ryanpetrello_> I was discussing this very thing w/ Mark
15:29:36 <ryanpetrello_> re: image build promotion
15:29:47 <sarob> so no pending patches in review
15:29:57 <sarob> clean slate!
15:29:59 <adam_g> i was planning on hacking the devstack support as part of my first deep dive into akanda/setting up a dev env
15:30:00 <ryanpetrello_> so there's ansible recipes to build out a devstack
15:30:08 <ryanpetrello_> but currently I'm using the DH image build (which I mentioned earlier)
15:30:12 <sarob> adam_g:
15:30:17 <adam_g> ah
15:30:18 <ryanpetrello_> Mark and I were working on getting a recipe to build out the appliance w/ dib before he left
15:30:22 <ryanpetrello_> and it had a few small kinks left
15:30:27 <ryanpetrello_> (that he was working on)
15:30:44 <ryanpetrello_> so we should probably prioritize that, a job that can build an appliance image from source + devstack + tempest
15:30:48 <davidlenwell> he did mention that to me before he left when I brought up dib for the ingix image
15:31:01 <adam_g> cool. i think a devstack plugin would be a good idea.. we can host it in one of the akanda repos and enable it in devstack via localrc
15:31:11 <ryanpetrello_> yep
15:31:15 <ryanpetrello_> that support's in Kilo, right?
15:31:19 <ryanpetrello_> the link to a plugin that devstack will download?
15:31:20 <adam_g> yup
15:31:23 <ryanpetrello_> I know hew as going that route, too
15:31:37 <ryanpetrello_> the stuff I was working on was just getting a devstack + appliance source job for Juno
15:31:41 <davidlenwell> when does mark return?
15:31:43 <ryanpetrello_> because as I mentioned, Kilo doesn't really work yet
15:31:45 <ryanpetrello_> (good question)
15:31:47 <ryanpetrello_> next week?
15:32:03 <sarob> i think tomorrow
15:32:08 <ryanpetrello_> oh, okay
15:32:36 <sarob> sooo, thats all i have for today
15:32:53 <sarob> we need to document the bp
15:33:05 <sarob> and create some specs for the biggins
15:33:26 <sarob> #topic any other business?
15:34:26 <sarob> any thing else meeting wise?
15:34:48 <davidlenwell> I'd like the express my exictement for our growing team! welcome adam_g!
15:35:07 <sarob> davidlenwell: +1
15:36:11 <sarob> okay, lets call this one
15:36:13 <adam_g> thanks guys, excited to be here :)
15:36:27 <sarob> :)
15:37:03 <sarob> #endmeeting