15:04:31 <sarob> #startmeeting akanda
15:04:32 <openstack> Meeting started Mon May  4 15:04:31 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:36 <openstack> The meeting name has been set to 'akanda'
15:04:48 <adam_g> o/
15:05:19 <sarob> Agenda
15:05:27 <sarob> #link https://wiki.openstack.org/wiki/Meetings/akanda
15:06:24 <sarob> Specs got merged
15:06:34 <sarob> So that was completed
15:06:54 <davidlenwell> sweet
15:07:05 <sarob> Next was to update the existing bp with details
15:07:14 <sarob> I did some of that
15:07:28 <sarob> Y'all have a pass at that
15:07:39 <davidlenwell> its on my list for early this week
15:07:54 <davidlenwell> might fit in a little .. however monday is meeting day.. so..
15:08:55 <sarob> Adam_g how about you?
15:09:11 <adam_g> i can do the same with the spec i had written last week
15:09:49 <sarob> Cool
15:10:50 <sarob> #topic workflow
15:11:43 <sarob> Adam_g and I were discussing launchpad workflow
15:12:29 <sarob> I'm thinking of running this closer to neutron style
15:12:42 <sarob> Many repos
15:12:51 <sarob> Single launchpad
15:13:04 <sarob> Using bug tags
15:13:36 <sarob> Loading up all the tarballs in one place
15:14:23 <sarob> Tracking the releases in one place
15:14:49 <sarob> As opposed to one launchpad project per repo
15:15:00 <davidlenwell> all of that sounds good..
15:15:04 <sarob> That's my preference
15:15:10 <sarob> Which one?
15:15:33 <davidlenwell> single launchpad / many repos
15:15:39 <adam_g> im fine iwth the single meta-project approach
15:15:41 <sarob> Okay
15:15:58 <sarob> Markmcclain join us ?
15:16:01 <davidlenwell> keep it simple ..
15:16:25 <sarob> Yeah, that was my objective
15:17:05 <sarob> Anything else on this?
15:17:31 <sarob> How about multi project bugs Adam_g
15:18:01 <adam_g> sarob, you'd have to just use bug tags to designate a bug affects multiple projects
15:18:17 <adam_g> er, sub-projects
15:18:34 <sarob> was that multi release too your sample bug
15:19:55 <adam_g> sarob, you can still target bugs to the 'akanda' project and target it specific a series (ie, juno)
15:20:38 <sarob> Okay
15:20:39 <adam_g> but its not going to be as fine grained as having multiple LP projects, ie able to say "this bug affects akanda-XXX kilo and liberty AND akanda-YYY juno + kilo)
15:20:52 <adam_g> should be okay though
15:21:07 <adam_g> i can't imagine that ever needing  that
15:21:15 <sarob> Alright, let's move on then
15:21:30 <sarob> #topic kilo release
15:21:55 <sarob> We set this Friday as the the kilo branch date
15:22:28 <davidlenwell> I have not had enough time to test our kilo code to know if we can hit that
15:22:29 <sarob> We get in docs
15:23:07 <adam_g> theres one patch from markmcclain up that should land, but its unit tests need fixing
15:23:38 <adam_g> the devstack plugin code in the akanda-rug repo should work now
15:24:10 <sarob> So we have this week
15:24:11 <adam_g> ive pushed https://review.openstack.org/#/c/179434/to build images during devstack deployment. enabling the plugin and running should stand up an akanda environment tho im still having some trouble with networking
15:26:17 <sarob_> Dropped off there
15:27:45 <davidlenwell> it happens you only missed one message
15:28:11 <sarob_> So
15:28:30 <sarob_> 5 days
15:30:36 <sarob_> Let's get the basics going
15:30:57 <davidlenwell> it aligns with several other goals.. I think we can do it
15:32:28 <sarob_> I'll may need a little help with the mechanics this first go around
15:32:53 <sarob_> I will reach out as necessary
15:33:54 <sarob_> I don't know the state of lbaas v2 API
15:34:18 <sarob_> Anyone know where markmcclain is on that one?
15:34:21 <davidlenwell> does anytone?
15:34:24 <davidlenwell> anyone
15:34:39 <davidlenwell> sorry .. this is no place for sarcasm
15:35:05 <adam_g> sarob_, nothing up on gerrit yet
15:35:12 <sarob_> It hard to read through your char
15:36:05 <sarob> did see a patch on cloud-init support
15:36:52 <sarob> rug-scaling and lbaasv2 api look likely to push then
15:38:09 <adam_g> oh, question about versioning.. is this 1.0 or 2015.1.0 ?
15:38:21 <sarob> follow openstack convention
15:38:34 <sarob> 2015.1.0 right?
15:38:47 <adam_g> ya
15:38:52 <davidlenwell> yep
15:39:03 <sarob> no new wheels invented
15:39:09 <davidlenwell> +1
15:39:40 <sarob> im thinking we need to vote as a group when we think akanda 2015.1.0 is stable
15:39:44 <sarob> after branching
15:40:16 <sarob> bugfixing and test tweaking should be our focus for next week
15:40:20 <sarob> sound right?
15:40:43 <davidlenwell> sounds good to me
15:44:27 <sarob> cool
15:44:32 <sarob> adam_g
15:44:37 <sarob> sound good to you?
15:44:45 <adam_g> i think so
15:45:11 <adam_g> bug fixes will either be batched up for a 2015.1.1 or 2015.2.0 ?
15:45:25 <sarob> #action kilo release 2015.1.0 for 08may15
15:45:51 <sarob> adam_g: whats your preference?
15:46:21 <adam_g> sarob, i guess it depends on how many bugs are being identified and fixed
15:46:31 <adam_g> and how fast trunk moves after friday
15:46:40 <sarob> adam_g: sounds about right to me
15:46:42 <adam_g> should be okay
15:46:51 <adam_g> to keep moving on 2015.2 and backport anything critical
15:47:12 <adam_g> or were you suggesting we push 2015.1.0, and continue to work there to stabalize?
15:47:41 <sarob> i thought both
15:47:44 <adam_g> okay
15:47:45 <adam_g> cool
15:47:54 <sarob> 2015.1.0 this fri
15:48:15 <adam_g> i just dont want to get stuck working on kilo for too long while the liberty ship is sailing, and then spend the first half of M trying to catch up to liberty
15:48:31 <davidlenwell> yeah.. its a viscious cycle
15:48:37 <sarob> minor bugs mean we tag 2015.1.1 following frid
15:48:54 <sarob> bigins mean 2015.2.0
15:49:10 <sarob> adam_g: i agree
15:49:33 <sarob> excellent segway
15:49:41 <sarob> #topic liberty blueprints
15:50:30 <sarob> i propose we find a slot of time on tuesday
15:50:34 <sarob> of summit
15:50:39 <sarob> for our design session
15:51:02 <sarob> i have a slew of bp
15:51:05 <sarob> #link https://blueprints.launchpad.net/akanda
15:51:13 <adam_g> +1
15:51:33 <sarob> and an etherpad teed up
15:51:38 <sarob> #link https://etherpad.openstack.org/p/liberty-akanda-design
15:52:00 <sarob> soo, in our spare time this week
15:52:30 <sarob> lets organize the pushed bp and new bp
15:52:37 <sarob> into a liberty release plan
15:53:18 <sarob> #action sarob rough version of liberty release plan in etherpad by end of this week
15:53:54 <sarob> ill take responsibility for it
15:54:23 <sarob> but y'all need to weigh in with what you want to see in this next 6 months
15:55:02 <sarob> thats all i got
15:55:37 <sarob> #topic any other business
15:55:53 <sarob> got 5 minutes
15:56:10 <davidlenwell> I don't have anything to add
15:56:39 <sarob> adam_g: ?
15:56:43 <adam_g> only thing
15:56:59 <sarob> hit me
15:57:00 <adam_g> if anyone is planning on doing some devstack work this week, please iterate on the devstack plugin hosted in the akanda-rug repo
15:57:13 <adam_g> instead of the akanda-devstack repo, lets make that go away
15:57:29 <sarob> +!
15:57:38 <davidlenwell> yes
15:57:51 <adam_g> its super easy to enable: https://github.com/stackforge/akanda-rug/blob/master/devstack/README.md
15:57:51 <adam_g> thats all from me
15:57:55 <sarob> cool
15:58:04 <sarob> so lets break
15:58:17 <sarob> #endmeeting