15:00:25 <sarob> #startmeeting akanda
15:00:27 <openstack> Meeting started Mon May 11 15:00:25 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:31 <openstack> The meeting name has been set to 'akanda'
15:00:33 <sarob> roll call
15:00:40 <adam_g> o/
15:01:39 <sarob> anyone else?
15:02:11 <sarob> hmm
15:02:23 <sarob> morning adam_g
15:02:46 <sarob> https://wiki.openstack.org/wiki/Meetings/akanda
15:02:51 <adam_g> hiya
15:03:12 <ryanpetrello> o/
15:03:20 <sarob> ryanpetrello: hey
15:03:43 <sarob> #topic review previous meeting actions
15:03:44 * ryanpetrello listens in the background
15:04:05 <sarob> kilo release rc1
15:04:06 <davidlenwell> o/
15:04:12 <sarob> davidlenwell: hey
15:04:18 <davidlenwell> morning
15:04:30 <sarob> https://launchpad.net/akanda/kilo/kilo-rc1
15:04:58 <sarob> first time running through the process was rough
15:05:11 <sarob> but the basics got done
15:05:52 <sarob> right after the meeting ill post some release bugs
15:05:55 <adam_g> i can look at getting tarballs going to tarballs.openstack.org this week as part of some other work ill be dig it hat area
15:06:06 <sarob> cool
15:06:18 <sarob> thats one of them
15:06:34 <sarob> i dont have rights to branch
15:07:10 <davidlenwell> I don't think you are meant to .. isn't it a jenkins job that does that bit?
15:07:24 <sarob> i can tag akanda-appliance and akanda-neutron, but not akanda-rug
15:07:52 <davidlenwell> ahh
15:08:02 <sarob> davidlenwell: no, its a shell script that ttx runs
15:08:12 <davidlenwell> I see
15:08:18 <adam_g> davidlenwell, you/someone should be able to create a tag in a repo and push to gerrit
15:08:45 <sarob> adam_g: yup, i can for two repos but not the a third
15:09:05 <sarob> thats the biggest issues
15:09:09 <sarob> for release right now
15:09:54 <sarob> im optimistic we can work them out with a little help from our friends in infra
15:10:07 <sarob> #action sarob post release bugs
15:10:27 <sarob> other action item from last week
15:10:38 <sarob> sarob post release steps
15:10:50 <sarob> ill be doing that today
15:11:09 <sarob> anything else from last week im missing?
15:11:43 <sarob> #action sarob post release steps
15:11:51 <sarob> okay moving on
15:12:13 <sarob> #topic kilo final 2015.1.0
15:13:00 <sarob> first bug tarball build instructions i will assign to myself
15:14:14 <sarob> its building akanda from tarballs for those people that hit tarballs.openstack or launchpad
15:14:21 <sarob> and want to build from there
15:14:36 <sarob> #action sarob tarball akanda build instructions
15:14:45 <sarob> sound about right?
15:15:02 <adam_g> ok
15:15:50 <sarob> do we have any other important docs missing?
15:16:46 <adam_g> none here
15:16:57 <sarob> okay that prob
15:17:15 <sarob> a difficult question first thing monday morning
15:17:22 <davidlenwell> indeed
15:17:46 <sarob> we all should take a few minutes today to review the docs and look for gaps
15:17:58 <sarob> #action team review docs.akanda.io for gaps
15:18:07 <ryanpetrello> should we build another stable appliance image?
15:18:21 <ryanpetrello> I noticed that the one we've been using isn't really up to date w/ HEAD of akanda-appliance
15:18:23 <sarob> yeah, meaning without https://bugs.launchpad.net/akanda/+bug/1451622
15:18:23 <openstack> Launchpad bug 1451622 in akanda "general devstack connectivity issues" [Critical,Confirmed] - Assigned to Adam Gandelman (gandelman-a)
15:18:50 <adam_g> ryanpetrello, id prefer we have a trunk image and a 'release' image
15:18:58 <sarob> oh my meetbot, you got smart
15:19:31 <sarob> adam_g: meaning branch then create tarballs?
15:19:32 <davidlenwell> +1 adam_g I like the idea of having both
15:19:51 <adam_g> sarob, huh? no, were talking about the appliance VM image
15:20:00 <sarob> or building from trunk everynight?
15:20:05 <adam_g> sarob, per-commit
15:20:08 <adam_g> as a pot job
15:20:11 <adam_g> *post job
15:20:19 <sarob> yeah, me likes that
15:20:19 <adam_g> in the same way we'd hae a head-of-trunk tarball
15:20:30 <adam_g> and then have a stable/kilo image somewhere
15:20:35 <adam_g> (if not tarballs.o.o)
15:20:41 <sarob> yuppers
15:20:57 <sarob> not critical for this week though
15:21:00 <sarob> is it?
15:21:10 <adam_g> well
15:21:18 <adam_g> we should have a kilo VM image that is known to work with the release
15:21:31 <davidlenwell> seems like that is important
15:21:39 <sarob> whatever
15:22:00 <adam_g> whether thats  built manually and stored on dreamobjets or elswhere, or automatically via bot and pushed to tarballs.o.o is not so critical me thinks
15:22:04 <sarob> who wants to take that on?
15:22:15 <adam_g> i can
15:22:22 <adam_g> i was looking at the post-commit builds friday
15:22:49 <markmcclain-mbl> Sorry plane landed late.... Yes I've been manually publishing one but automated would be nice
15:22:51 <adam_g> if anything, for the release, we can just update the image @ http://akandaio.objects
15:23:15 <adam_g> er, paste fail http://akandaio.objects.dreamhost.com/akanda_cloud.qcow2
15:23:17 <sarob> #action adam_g post ci job appliance VM image
15:24:16 <adam_g> k
15:24:40 <sarob> you think that will also fix https://bugs.launchpad.net/akanda/+bug/1451622
15:24:40 <openstack> Launchpad bug 1451622 in akanda "general devstack connectivity issues" [Critical,Confirmed] - Assigned to Adam Gandelman (gandelman-a)
15:24:45 <sarob> or one and the same
15:25:38 <adam_g> sarob, thats already been fixed
15:25:42 <adam_g> in akanda-rug, ill update
15:25:46 <sarob> cool
15:25:51 <sarob> diff then
15:25:58 <sarob> moving on
15:26:04 <sarob> basic driver support
15:26:11 <sarob> davidlenwell: you got that
15:26:13 <sarob> ?
15:26:19 <davidlenwell> yes
15:26:39 <sarob> can you focus on landing that soon
15:26:52 <sarob> before lbaasv2 api
15:26:53 <davidlenwell> will be pushing a wip this afternoon.. I have it mostly working but I am now trying to get tests to pass
15:26:59 <sarob> cool
15:26:59 <davidlenwell> yes
15:27:21 <sarob> #actiod davidlenwell basic driver support
15:27:47 <sarob> davidlenwell: any update on akanda-horizon repo empty prob?
15:28:12 <davidlenwell> I was obsorbed by the driver over the weekend so I didn't get to that
15:28:18 <davidlenwell> I can do it today
15:28:20 <sarob> no prob
15:28:44 <sarob> #action davidlenwell update stackforge/akanda-horizon repo
15:29:27 <sarob> thats the important things i could think to push before we release
15:29:39 <davidlenwell> okay
15:29:43 <sarob> any other bugs y'all can think of?
15:30:37 <davidlenwell> not this early on a monday .. no
15:30:56 <adam_g> apitalone.com
15:30:58 <adam_g> er
15:31:12 <adam_g> https://bugs.launchpad.net/akanda/+bug/1450616
15:31:12 <openstack> Launchpad bug 1450616 in akanda "Stopping an instance that goes into error state wait too long to try again" [Medium,Triaged] - Assigned to Mark McClain (markmcclain)
15:31:24 <adam_g> oh nvm, that was pushed to liberty
15:31:51 <sarob> yeah, theres a workaround
15:32:02 <markmcclain-mbl> Cover linuxbrisge issue issue?
15:32:22 <sarob> adam_g: has it handled
15:32:38 <adam_g> huh? what linuxbridge issue/
15:33:00 <sarob> this one https://bugs.launchpad.net/akanda/+bug/1451622 right?
15:33:00 <openstack> Launchpad bug 1451622 in akanda "general devstack connectivity issues" [Critical,Fix released] - Assigned to Adam Gandelman (gandelman-a)
15:33:22 <sarob> or im a confusing bugs?
15:33:45 <adam_g> sarob, yeah, thats a different thing AFAIK
15:33:51 <adam_g> markmcclain-mbl, eh/
15:33:58 <sarob> oh bummer
15:34:07 <sarob> whats the bug then
15:35:26 <markmcclain-mbl> DHCP offers get dropped when Q_PLUGIN is linuxbridge
15:37:09 <adam_g> markmcclain-mbl, do you know if thatas akanda-specific or bitrot due to that not being the devstack default?
15:38:15 <markmcclain-mbl> Spent some time on testing LB yesterday .. Ref impl works
15:38:44 <markmcclain-mbl> So must be specific to fact offer originates in a vm
15:40:51 <sarob> markmcclain-mbl: okay, so can you post a bug and we can start working this
15:41:26 <markmcclain-mbl> Sure when I get out of the crazy cab
15:41:58 * sarob thinks, arent we all in a crazy cab after all
15:42:51 <sarob> i am thinking we fix these important bugs then push a final release later this week
15:43:00 <sarob> soonest possible
15:44:51 <sarob> there are about 7 bugs assigned to 2015.1.0, but i dont see any of them as "high"
15:45:14 <sarob> general agreement?
15:45:15 <sarob> https://launchpad.net/akanda/+milestone/2015.1.0
15:45:38 <sarob> if so ill set importance to medium for all of them
15:45:59 <markmcclain-mbl> I'll double check the list at the hotel and ping the channel if any need more attention
15:46:01 <sarob> and if they dont get fixed this week, push them to lm1
15:46:11 <sarob> coolo
15:46:59 <sarob> so the idea is we release 2015.1.0 final once all the high and critical bugs are merged
15:47:27 <davidlenwell> makes sense to me
15:47:28 <sarob> sound about right
15:47:56 <sarob> that means we should merge the oslo updates too
15:48:36 <sarob> #action sarob release kilo 2015.1.0 final once all assigned high and critical are merged
15:49:05 <sarob> ill get the release bugs posts right after the meeting
15:49:43 <sarob> anything else release things?
15:50:10 <sarob> left my yoda translator on
15:50:32 <sarob> okay moving on
15:50:48 <sarob> #topic summit design session
15:51:03 <sarob> #link https://etherpad.openstack.org/p/liberty-akanda-design
15:51:53 <sarob> im going to see if hoge has any nooks or crannies available for tuesday summit time
15:52:03 <sarob> any preferences?
15:52:29 <sarob> or known available space other than the dev lounge?
15:53:03 <sarob> i guess we could retreat to the akanda dev hostel
15:53:26 <sarob> its only about two blocks from the summit
15:54:06 <adam_g> should be easy enough to just do it in the dev lounge
15:54:20 <davidlenwell> I think the dev lounge is a good idea
15:54:23 <adam_g> i dont think we need an entire room dedicated to us TBH
15:54:35 <sarob> hopefully the dev lounge is a bit less noisy than paris
15:54:41 <sarob> that kinda sucked
15:55:00 <davidlenwell> yeah .. it was loud wasn't it
15:55:14 <davidlenwell> i liked hong kongs dev lounge best out of all the summits
15:55:35 <sarob> atlanta was pretty good too
15:55:47 <sarob> lots of nooks and crannies
15:56:07 <sarob> food was iffy
15:56:20 <sarob> okay dev lounge then
15:56:29 <sarob> any proposed times on tuesday?
15:56:53 <markmcclain-mbl> Not 11 :)
15:56:56 * davidlenwell is open on tuesday except other akanda related things already scheduled
15:57:07 <adam_g> is the dev summit schedule posted somewhere?
15:57:18 <sarob> 8am then ;)
15:57:51 <markmcclain-mbl> Also we want to avoid nova/neutron migration mtg
15:58:05 <sarob> whens that?
15:58:24 <sarob> the neutron dev schedule is up?
15:59:45 <markmcclain-mbl> It's on cross proj track
15:59:55 <sarob> ah
16:00:39 <sarob> 3:40pm?
16:01:01 <sarob> i dont see it
16:01:37 <sarob> let figure out on ML
16:01:45 <sarob> over time
16:02:04 <sarob> #endmeeting