18:00:27 <sarob> #startmeeting akanda
18:00:27 <openstack> Meeting started Mon Jun 15 18:00:27 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:31 <openstack> The meeting name has been set to 'akanda'
18:00:55 <sarob> agena
18:01:05 <sarob> agenda
18:01:10 <sarob> #link https://wiki.openstack.org/wiki/Meetings/akanda
18:01:14 <sarob> roll call
18:01:23 <davidlenwell> o/
18:01:58 <puranamr> o/
18:02:10 <adam_g> o/
18:02:26 <sarob> morning!
18:03:17 <davidlenwell> morning
18:03:26 <sarob> markmcclain is on a plane, so probably wont hear from him this morning
18:03:57 <sarob> #topic progress on m1 bp
18:04:23 <sarob> first up,
18:04:27 <sarob> oslo updates
18:04:37 <sarob> adam_g: hows it going?
18:05:04 <adam_g> good
18:05:13 <adam_g> there are patches up for both oslo.messaging and oslo.log
18:05:26 <adam_g> need to finish 2 tests on oslo.log and then i'll squash those both down into one patch
18:05:35 <adam_g> then IIRC oslo.i18n is the only one left
18:05:52 <adam_g> they're all trivial except for the oslo.messaging migration, which i'd love to get a thorough review of
18:07:16 <sarob> doughellman available to help?
18:07:36 <sarob> too
18:07:47 <adam_g> dont ask me :)  dhellmann ^
18:08:22 * sarob irc fail
18:08:52 <sarob> we can loop him in
18:09:01 <sarob> any thing else on oslo?
18:10:20 <sarob> okay, moving on
18:10:35 <sarob> update on juno backports
18:10:55 <sarob> we did this the brute force way
18:11:08 <sarob> juno branched at kilo
18:11:23 <adam_g> i dont think there has been anything juno-specific identified yet
18:11:36 <sarob> ryanpetrello you around?
18:11:42 <adam_g> ryanpetrello identified a bug in iptabels SNT that he was working thru end of week last week, but it sounds like it affects master as well
18:11:50 <adam_g> so we'll need to merge and backport to kilo+juno i think
18:11:58 <sarob> adam_g: okay
18:12:28 <sarob> adam_g: i dont see the bug on the queue
18:12:47 <adam_g> i dont know if he's filed on yet
18:13:02 <sarob> okay, i follow up with him
18:13:29 <sarob> #action sarob follow up with ryanpetrello on iptables SNT bug
18:13:44 <sarob> next up
18:14:00 <sarob> rug managed ssh already implemened
18:14:08 <sarob> thanks to adam_g
18:14:19 <sarob> lbaas update
18:14:22 <sarob> next
18:14:30 <sarob> davidlenwell: whats going on?
18:15:29 <davidlenwell> So I meant to finish my driver patch over the weekend.. but we had a small family issue (devons hamster died) and I didn't get to it.. planning to get it finished this afternoon
18:16:13 <sarob> davidlenwell: bummer, sorry to hear that
18:16:31 <sarob> davidlenwell: i spoke with a few sources on lab puppies
18:16:55 <sarob> davidlenwell: only hunting variety available right now
18:16:58 <davidlenwell> yea.. the little guy didn't take it well .. so I spent a lot of time consoling and making him feel better.. I can get that info from you later when I see you
18:17:11 <sarob> davidlenwell: i will ping you if i hear different
18:17:16 <davidlenwell> sounds good
18:17:39 <sarob> davidlenwell: update for the record on your progress so far
18:17:50 <sarob> lbaas that is
18:18:25 <davidlenwell> the plan is to complete a patch first that introduces the concept of a driver into the rug.. with the first driver being written for the router
18:18:52 <davidlenwell> That is mostly done with the patch I had in flight ..but I need to take some lbaas specific stuff out of it
18:19:11 <adam_g> can we have a spec that describes the implementation instead of just a wip patch? sounds like a pretty big change
18:19:51 <davidlenwell> adam_g: that is probably a good plan..
18:21:26 <sarob> save the rest for the spec?
18:22:20 <davidlenwell> sure.. wil write a spec early this week
18:22:43 <sarob> okay
18:22:46 <sarob> next up
18:22:52 <sarob> doc updates
18:23:15 <sarob> i have listed out a bunch of stuff that i think needs to go into the docs
18:23:23 <sarob> on the bp
18:23:41 <sarob> i have just barely started on the bp with
18:23:53 <sarob> moving docs out of the rug repo
18:24:30 <sarob> the generally idea is to make the docs more first user friendly
18:24:47 <sarob> next up
18:24:52 <sarob> ci updates
18:25:10 <sarob> adam_g: you made some good progress last week
18:25:38 <adam_g> yea
18:25:53 <adam_g> the devstack job will probably show up as voting on our patches this week
18:26:15 <adam_g> theres a infra patch up to do that, that i just noticed needs a rebase
18:26:51 <adam_g> also, patches now call the appropriate webhooks at readthedocs and our docs there should be updated when necessary
18:27:53 <sarob> adam_g: yeah, right on
18:28:54 <sarob> #link https://review.openstack.org/#/c/190745/
18:29:42 <sarob> cool beans
18:29:48 <sarob> anything else?
18:30:00 <adam_g> not here
18:30:16 <sarob> #topic eol akanda-appliance-builder
18:30:24 <sarob> adam_g: take it away
18:30:31 <adam_g> oh
18:30:32 <adam_g> yea
18:30:48 <adam_g> we merged the DIB elements that we have in akanda-appliance-builder into the main akanda-appliance repo
18:31:04 <adam_g> to reduce a needless cross-project dependency
18:31:15 <adam_g> i have a doc patch up to update  instructions for building the appliance
18:31:27 <adam_g> #link https://review.openstack.org/#/c/191920/
18:31:59 <adam_g> so we need to either completely delete the akanda-appliance-builder repo, or just rm -rf * its source tree and replace with a readme  that points to the akanda-appliance repo
18:32:54 <sarob> the same question on the github/akanda repos
18:33:20 <sarob> im partial to wiping contents and updating the readme
18:33:37 <sarob> rather than maybe creating dead links
18:34:28 <sarob> anyone else have an opinion?
18:34:37 <adam_g> +1
18:34:47 <adam_g> im thinking more about removing refrences in openstack-infra
18:34:54 <adam_g> (jobs, etc)
18:34:59 <sarob> ah, right
18:35:06 <sarob> that two
18:35:32 <sarob> thats a trivial change, right
18:35:48 <sarob> unless im missing something
18:36:49 <adam_g> wiping the jobs yeah, im not sure what else goes into creating the repositories
18:37:28 <sarob> i can double check with ttx on leaving repo cruft
18:37:53 <sarob> he may have a opinion on that
18:37:59 <sarob> but its stackforge
18:38:05 <sarob> so prob not a strong one
18:38:44 <sarob> anyone else on this?
18:39:21 <sarob> puranamr or davidlenwell?
18:39:38 <puranamr> yes
18:40:06 <davidlenwell> well if we plan on moving into /openstack in the next year we should probably pretend like we are already there
18:40:38 <sarob> and that would change how we deal with dead repos?
18:40:56 <davidlenwell> we should delete dead repos
18:41:23 <puranamr> unless there needs to be some trail
18:41:28 <sarob> is that practice in github/openstack right now?
18:42:03 <davidlenwell> asfaik they keep that pretty clear of bit rot
18:42:36 <sarob> ill ping ttx and get back to y'all
18:42:57 <davidlenwell> sounds good
18:43:39 <sarob> #action sarob ask ttx on practice with dead repos, wipe contents or delete repo entirely
18:43:50 <sarob> #topic any other business
18:44:38 <sarob> any updates on m2 bp maybe?
18:45:13 <sarob> reduce vm footprint, rug circuit breaker, appliance ha, nodepool, octavia, vpnaas?
18:45:47 <sarob> i havent seen any patches, so im guessing nothing yet
18:46:44 <sarob> davidlenwell: has been working on the appliance provisioning driver arch
18:46:51 <sarob> thats all i got
18:47:26 <davidlenwell> yeah.. the stuff I am doing now will be the foundation to a lot of that stuff
18:47:48 <sarob> #info liberty m1 juno backports, rug ssh key implemented
18:48:46 <sarob> #info liberty m1 oslo updates, doc updates, ci updates, lbaas have good progress
18:49:22 <sarob> #info liberty m2 appliance provisioning driver is started, rest are pending
18:49:47 <sarob> should we call the meeting a few minutes early?
18:50:01 <adam_g> sure
18:50:52 <sarob> puranamr, davidlenwell: got anything else?
18:51:03 <davidlenwell> I'm good
18:51:26 <sarob> im just so so
18:51:37 <sarob> okay, im calling it
18:51:49 <sarob> cheers guys
18:52:05 <sarob> #endmeeting