18:01:00 <sarob> #startmeeting akanda
18:01:01 <openstack> Meeting started Mon Jul 20 18:01:00 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:05 <openstack> The meeting name has been set to 'akanda'
18:01:20 <sarob> hello everyone
18:01:23 <sarob> agenda
18:01:36 <sarob> #link https://wiki.openstack.org/wiki/Meetings/akanda#Agenda
18:01:40 <sarob> roll call
18:03:59 <puranamr> o/
18:04:52 <sarob> anyone else?
18:05:15 <sarob> markmcclain and davidlenwell wont be joing today
18:05:24 <sarob> okay
18:05:48 <sarob> first up on agenda
18:06:01 <sarob> #topic outstanding actions from last meeting
18:06:27 <sarob> #info semver numbering
18:07:13 <sarob> i spoke with adam_g` a bit before the meeting and it seems we both want to follow the neutron numbering
18:07:38 <sarob> puranamr: whats your opinion on this?
18:08:38 <puranamr> as per the discussion that we had last week on this topic, the split is bit vertical. Davidlenwell and I feel that we could continue the existing numbering scheme
18:09:04 <puranamr> on the other hand, sarob and adam_g feel to follow the neutron numbering
18:09:52 <sarob> davidlenwell_ was going to detail his thinking more in a review of https://review.openstack.org/#/c/197787/
18:10:00 <sarob> looks like that didnt happen
18:10:39 <sarob> the argument of following neutron lead doesnt sway you at all?
18:12:12 <puranamr> sarob: it is not about following the lead, but i am sure we r not in do-or-die situation at this point for semver. my 2 cents
18:13:08 <sarob> im not sure i follow do or die?
18:14:01 <sarob> maybe you mean we dont have to make this decision right now
18:14:03 <puranamr> i meant whether it has reached critical stage at this point? we were collecting opinions and still bit inconclusive
18:14:18 <sarob> ah, i see your point
18:14:23 <puranamr> thanks
18:15:14 <sarob> i can tag at 2015.2.0, then we can still decide semver issue at LM2 or ML3?
18:15:53 <puranamr> sure
18:16:13 <sarob> i will add this to the https://review.openstack.org/#/c/197787/ patch
18:16:32 <sarob> puranamr: add your thoughts above to the patch as well
18:16:42 <puranamr> sure sarob
18:16:56 <sarob> this is where we should be discussing this
18:17:01 <sarob> on the patch
18:18:08 <sarob> #info sarob will update https://review.openstack.org/#/c/197787/ patch with plan on tagging at 2015.2.0 for LM1 and continuing the discussion on semver for LM2
18:18:14 <sarob> moving on
18:18:29 <sarob> #topic critical bugs
18:18:46 <sarob> #link https://bugs.launchpad.net/akanda/+bug/1475781
18:18:48 <openstack> Launchpad bug 1475781 in akanda "ak-rug-serv consumes all the cpu" [Critical,New] - Assigned to davidlenwell (dlenwell)
18:18:50 <uvirtbot> Launchpad bug 1475781 in akanda "ak-rug-serv consumes all the cpu" [Critical,New]
18:19:05 <sarob> davidlenwell_: has been working on this
18:19:37 <sarob> i asked that he push a patch on what he knows so far
18:19:40 <sarob> #link https://review.openstack.org/#/c/203279/
18:19:58 <sarob> adam_g`: is going to take a look today as well
18:20:05 <sarob> next bug
18:20:52 <sarob> #link https://bugs.launchpad.net/akanda/+bug/1473629
18:20:53 <openstack> Launchpad bug 1473629 in akanda "Akanda-rug local repo part of install is set to master for stable branches" [Critical,New]
18:20:53 <uvirtbot> Launchpad bug 1473629 in akanda "Akanda-rug local repo part of install is set to master for stable branches" [Critical,New]
18:21:38 <sarob> this should be just a devstack install plugin.sh fix to assign the correct branch
18:21:57 <sarob> but when I attempted to run my patch
18:22:04 <sarob> for stable/juno
18:22:14 <sarob> heat and keystone fail
18:22:54 <sarob> i get different failures for stable/kilo
18:23:07 <sarob> sooo, that makes me concerned
18:23:26 <sarob> i will update the bug on this info
18:23:35 <puranamr> sarob: when i ran it y-day, I got error in keystone as well
18:24:25 <sarob> #link https://review.openstack.org/#/c/201717/
18:24:30 <sarob> for stable/kilo
18:25:16 <sarob> and https://review.openstack.org/#/c/202256/
18:25:21 <sarob> for stable/juno
18:25:40 <sarob> puranamr: let me know what you figure out
18:25:58 <puranamr> sarob: sure will update
18:26:06 <sarob> next critical bug
18:26:17 <sarob> #link https://bugs.launchpad.net/akanda/+bug/1473628
18:26:19 <openstack> Launchpad bug 1473628 in akanda "Ssh key is required to start the appliance" [Critical,Triaged] - Assigned to Sean Roberts (sarob)
18:26:19 <uvirtbot> Launchpad bug 1473628 in akanda "Ssh key is required to start the appliance" [Critical,Triaged]
18:27:48 <sarob> i can't debug this until https://bugs.launchpad.net/akanda/+bug/1475781 is solved
18:27:49 <openstack> Launchpad bug 1475781 in akanda "ak-rug-serv consumes all the cpu" [Critical,New] - Assigned to davidlenwell (dlenwell)
18:27:52 <uvirtbot> Launchpad bug 1475781 in akanda "ak-rug-serv consumes all the cpu" [Critical,New]
18:28:37 <sarob> moving on
18:28:49 <sarob> #topic progress on LM2
18:29:01 <sarob> #link https://launchpad.net/akanda/+milestone/liberty-2
18:29:23 <sarob> lets talk about vm footprint bp
18:29:26 <sarob> #link https://blueprints.launchpad.net/akanda/+spec/reduce-vm-footprint
18:29:54 <sarob> puranamr: whats your thoughts
18:30:32 <puranamr> sarob: couple of strategies have been thought about the vm footprint
18:31:17 <sarob> lay on us
18:31:24 <sarob> lay it on us
18:31:27 <puranamr> one is to customize the software (which becomes part of the vm), this will be a maintainence nightmare maye be,
18:31:56 <puranamr> second option is to have customizable scripts that can rip through the non-essential ones making it leaner
18:32:10 <sarob> puranamr: automation around stripping down distrib
18:32:20 <puranamr> sarob: yes
18:32:46 <sarob> puranamr: we can do both
18:32:59 <puranamr> the impact of reduction has not been validated in the light of how well the performance will be affected
18:33:05 <adam_g`> o/ sorry im late
18:33:06 <sarob> puranamr: write up the scripts to support stripping down
18:33:42 <sarob> puranamr: plus provide golden images for those that want a proven image
18:33:50 <sarob> adam_g`: np
18:33:56 <puranamr> sarob: sounds ok
18:34:13 <sarob> dump your thoughts into the bp
18:34:27 <puranamr> as i outlined above, with stripping the performance angle may need further investigation too
18:34:29 <puranamr> sarob: sure
18:34:37 <sarob> and lets post your spec this week
18:34:46 <puranamr> sarob: yes
18:34:52 <sarob> puranamr: tomorrow i can work with you
18:35:02 <puranamr> sarob: thanks
18:35:10 <sarob> puranamr: your bp will likely get pushed to ML3, but
18:35:27 <sarob> puranamr: lets do all the right steps
18:35:28 <puranamr> yes i understand
18:35:37 <puranamr> agreed
18:35:53 <sarob> adam_g`: we are updating on ML2 bp
18:36:07 <adam_g`> ok
18:36:12 <sarob> you have two of em
18:36:55 <sarob> you should rename nodepool to peez i think
18:37:14 <sarob> and we should review, merge your specs this week
18:37:31 <adam_g`> cool
18:37:48 <adam_g`> theres actually a dependency now between the rug-ha and the nodepool/pez one
18:37:55 <adam_g`> the rug-ha stuff needs to happen first
18:37:57 <sarob> #link https://review.openstack.org/#/c/193680/
18:38:07 <sarob> #link https://review.openstack.org/#/c/194882/
18:38:10 <adam_g`> not sure if thats noted in my spec, will update if not
18:38:17 <sarob> cool
18:38:41 <sarob> adam_g`: any thing you wanted to add to the semver from the log?
18:39:15 <adam_g`> not much
18:39:30 <sarob> #action puranamr will update https://blueprints.launchpad.net/akanda/+spec/reduce-vm-footprint desc and sarob will work with him to post spec tomorrow
18:39:57 <sarob> adam_g`: okay, so im going to post my semver intention
18:40:35 <sarob> then tag back to late jun 2015.2.0 and post the tarballs
18:40:40 <adam_g`> ive honestly not been following the semver things in other proejcts over the last month, only the one thread thats been kicking on the ML
18:41:32 <sarob> yeah, think not following semver of some version number will start to be confusing for the distributions
18:41:48 <sarob> as we get into working closely with them
18:42:03 <sarob> so we need to make the cut over something this release
18:42:11 <sarob> sometime that is
18:42:45 <adam_g`> semvers are going to confuse distros
18:43:17 <sarob> #action adam_g` will update his rug scale and rug ha spec will dependancy info
18:43:31 <sarob> adam_g`: meaning the switch over?
18:44:09 <sarob> #topic semver continued
18:44:14 <adam_g`> sarob, ya that, and the entire idea of a non-global version for a given openstack release is going to confuse anyone wondering what versions of stuff is to be packaged together
18:44:56 <adam_g`> that said, if neutron is going with 7.0.0 it makes sense for us to version akanda-neutron similarly, to indicate compat.  if we're versioning akanda-neutron 7.0.0, it'd be confusing to have akanda-rug 1.0.0.
18:45:06 <sarob> okay, but i think the genesis of semver here was at the distro request
18:45:14 <adam_g`> sarob, no, it wasnt
18:45:36 <sarob> adam_g`: ill have to go back and read doug's email again
18:45:37 <adam_g`> its that some projects want to follow different release schedules other than the 201x.x 6-month thing
18:45:48 <adam_g`> esp wrt stable releases
18:45:58 <adam_g`> anyway..
18:46:05 <sarob> adam_g`: my memory was that was a contributing factor
18:46:12 <sarob> adam_g`: yeah, no matter
18:46:17 <adam_g`> semvers is going to make distros lives hell :)
18:46:28 <sarob> adam_g`: ship has sailed
18:46:37 <adam_g`> for us, it doesnt really matter. we can just use the same neutron version across all our projects and essetnially get the same thing we have with the 201x.x scheme
18:46:47 <adam_g`> its just that i feel weird about naming a akanda-rug 1.0.0 akanda-rug 7.0.0
18:46:57 <sarob> adam_g`: sure
18:47:16 <adam_g`> so +1 7.0.0 from me
18:47:29 <sarob> lets have a hearty debate on https://review.openstack.org/#/c/197787/
18:47:37 <sarob> adam_g`: yeah, me too
18:47:54 <sarob> adam_g`: add your +1 to the patch
18:48:06 <sarob> adam_g`: so we can put this to bed by LM2
18:48:25 <sarob> #topic any other business
18:48:40 <sarob> speak now my friends
18:49:12 <adam_g`> I'd like to request that we all start getting into the habbit of filing bugs for all issues we run into, with lots of detail and debugging info
18:49:23 <adam_g`> the worst that is going to happen is it gets closed because its not a bug
18:49:34 <puranamr> adam_g`: agreed
18:49:51 <adam_g`> i'm going to start being a PITA about this moving forward. as in, if theres no LP bug about it the issue doesn't exist :)
18:50:11 * sarob needs to share
18:50:29 * sarob til it hurts
18:50:39 <sarob> adam_g`: point taken
18:50:57 <adam_g`> in addition to getting issues fixed easily across the team, good bugs have a side effect of encouraging new contributors to get involved via low hanging fruits / easily-reproducible isses
18:51:05 <sarob> #action team needs to overshare with bug details as they show up
18:51:09 <adam_g`> cool! :)
18:51:27 <sarob> adam_g`: otherwise its not teamwork
18:51:48 <sarob> adam_g`: ill be as hard on myself for failing here so far
18:52:10 <puranamr> good point adam_g`
18:52:25 <sarob> adam_g`: and getting known good configurations out into the docs asap as well
18:52:51 <adam_g`> no worries, we're a new project and we just need to enforce good habits early while we're still small
18:53:13 <sarob> #action sarob known good configurations as a priority for https://blueprints.launchpad.net/akanda/+spec/liberty-doc-updates
18:53:23 <sarob> adam_g`: roger that good buddy
18:53:36 <sarob> anything else?
18:54:17 <puranamr> nothing more from my side!
18:54:45 <sarob> adam_g`: im going to sneak over to zell's for a lunch before going to the airport
18:54:52 <sarob> adam_g`: got time to join?
18:55:21 <adam_g`> sarob, when is your flight?
18:55:30 <sarob> 2:30
18:56:04 <adam_g`> sarob, ah probably not. wont be able to leave here for another 30 min or so and im on the other side of town
18:56:16 <sarob> ah, bummer
18:56:21 <sarob> until next time
18:56:27 <sarob> and with that
18:56:32 <sarob> lets break
18:56:39 <sarob> talk to y'all soon
18:57:12 <sarob> #endmeeting