18:00:43 <sarob> #startmeeting akanda
18:00:44 <openstack> Meeting started Mon Aug 31 18:00:43 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:47 <openstack> The meeting name has been set to 'akanda'
18:00:58 <davidlenwell> o/
18:00:59 <adam_g> o/
18:01:05 <sarob> hello hello
18:01:11 <davidlenwell> jello
18:01:19 <sarob> agenda can be found here
18:01:21 <sarob> #link https://wiki.openstack.org/wiki/Meetings/akanda
18:02:37 <sarob> lets start
18:02:55 <sarob> #topic outstanding actions
18:02:57 <markmcclain> o/
18:03:43 <sarob> #info semantic versioning
18:04:00 <sarob> released https://bugs.launchpad.net/akanda/+bug/1470673
18:04:02 <openstack> Launchpad bug 1470673 in akanda "pbr version numbering doesn't match semantic versioning" [Critical,Fix released] - Assigned to Sean Roberts (sarob)
18:04:26 <sarob> and
18:04:45 <sarob> #info stable/juno versioning
18:04:54 <sarob> in progress https://bugs.launchpad.net/akanda/+bug/1481877
18:04:55 <openstack> Launchpad bug 1481877 in akanda "stable/juno branches are versioned incorrectly" [Critical,In progress] - Assigned to Sean Roberts (sarob)
18:05:19 <sarob> almost done, but dependent on
18:05:24 <sarob> #link https://review.openstack.org/#/c/209616
18:05:47 <sarob> or duplicate
18:05:49 <sarob> #link https://review.openstack.org/#/c/218840
18:06:11 <adam_g> i just apporved the duplicate, ill ditch mine
18:06:21 <sarob> adam_g: roger
18:06:57 <sarob> thats all the outstanding actions
18:07:06 <sarob> did i miss anything?
18:08:17 <sarob> okay, moving on
18:08:26 <sarob> #topic critical bugs
18:09:06 <sarob> we covered the current ones
18:09:16 <sarob> with the outstanding actions
18:09:20 <sarob> so moving on
18:09:50 <sarob> #topic progress on liberty rc1 bp
18:10:06 <sarob> #info appliance provisioning driver
18:10:21 <sarob> #link https://blueprints.launchpad.net/akanda/+spec/appliance-provisioning-driver
18:10:34 <sarob> whats the latest davidlenwell?
18:11:06 <davidlenwell> I have the appliance provisioning driver code very close to the review state.. It technically is passing functional tests. Right now I am in the process of cleaning up the inline documentation and getting the unit tests to pass.
18:11:39 <davidlenwell> Hoping that by the end of today.. or early wednesday (taking tomorrow off) will have all the driver related patches ready for review.
18:11:39 <adam_g> davidlenwell, which functional tests are you referencing/
18:11:53 <adam_g> do we need to block review on unit tests and docstrings?
18:12:13 <davidlenwell> well the way I am looking at it .. maybe
18:12:34 <davidlenwell> I could still make a change in the driver .. based on how it needs to be tested .. will know more later today
18:13:36 <davidlenwell> adam_g:  the gate functional test
18:14:53 <davidlenwell> Also I've found that having good inline docs shortens the review cycles because you don't have to guess or ask as many questions about why I decided to lay it out the way that I did.. so yeah I think inline code docs are important
18:15:29 <sarob> we are all eager to dig in
18:15:47 <davidlenwell> I know.. targeting the end of my day today to have everything up and ready
18:16:09 <sarob> davidlenwell: sounds good
18:16:42 <adam_g> cool
18:17:44 <markmcclain> cool
18:17:56 <sarob> #info lbaasV2
18:18:09 <sarob> #link https://blueprints.launchpad.net/akanda/+spec/lbaas-v2-support
18:18:24 <davidlenwell> this is still blocked on the previous topic..
18:18:33 <davidlenwell> slated to begin right after this work lands
18:18:38 <sarob> got it
18:18:49 <sarob> the patch
18:19:33 <sarob> there is no outstanding patch for that right?
18:19:43 <sarob> #link https://review.openstack.org/#/c/181545/
18:19:55 <sarob> #link https://review.openstack.org/#/c/195814/
18:20:00 <sarob> will likely be
18:20:05 <sarob> abandoned?
18:20:34 <adam_g> yea
18:21:20 <sarob> think you can update the driver spec
18:21:23 <sarob> #link https://review.openstack.org/#/c/209232/
18:21:33 <sarob> this week for merge as well?
18:23:07 <davidlenwell> yes
18:23:18 <davidlenwell> it will be
18:23:18 <sarob> cool
18:23:31 * sarob it will so
18:23:39 * sarob it will be so
18:23:41 <sarob> shoot
18:24:07 <sarob> #topic rug scaling
18:24:24 <sarob> #link https://blueprints.launchpad.net/akanda/+spec/rug-scaling
18:25:25 <sarob> adam_g: all in review, right
18:25:33 <adam_g> yup
18:26:23 <sarob> markmcclain: you were working on testing multinode failure scenarios
18:26:29 <sarob> markmcclain: with the code
18:26:36 <sarob> markmcclain: any luck so far
18:26:51 <markmcclain> most of that was manual.. not automated testing
18:27:02 <sarob> markmcclain: right
18:27:20 <sarob> markmcclain: crawl before we run
18:27:26 <markmcclain> correct
18:28:54 <sarob> markmcclain: so any luck putting the code through paces?
18:30:22 <markmcclain> so good so far
18:32:35 <markmcclain> did we lose sarob?
18:32:52 <sarob> markmcclain: nope
18:32:56 <sarob> still here
18:33:27 <sarob> #topic nodepool support
18:33:45 <sarob> oops
18:34:11 <sarob> #topic progress on liberty rc1 bp
18:34:18 <sarob> #info nodepool support
18:34:30 <sarob> #link https://blueprints.launchpad.net/akanda/+spec/nodepool-support
18:34:47 <sarob> adam_g: any update
18:34:52 <adam_g> sarob, i hope to get started with some patches for that today
18:35:04 <adam_g> just to get it moving a bit
18:35:06 <sarob> adam_g: cool
18:35:16 <sarob> look forward
18:35:30 <sarob> anything else on this?
18:36:47 <sarob> adam_g: anything else on this?
18:36:55 <adam_g> nope, not atm
18:36:59 <sarob> #info doc updates
18:37:12 <sarob> #link https://blueprints.launchpad.net/akanda/+spec/liberty-doc-updates
18:37:20 <sarob> this is moving slowly
18:37:38 <sarob> i am currently going through the existing documentation
18:38:16 <sarob> and separating the general what is akanda sections and the rest
18:38:32 <sarob> i should have patch up today
18:38:54 <sarob> any other comments on rc1 bp?
18:39:38 <sarob> okay moving on
18:39:46 <sarob> #topic any other business
18:39:56 <sarob> i have two things
18:41:24 <sarob> scheduling our first mitaka dev summit prep session
18:42:02 <sarob> and scheduling a hack session for september in SFO area
18:43:34 <sarob> around 17 september for the mitaka prep sound good?
18:43:46 <sarob> or exactly
18:44:17 <adam_g> huh?
18:44:48 <markmcclain> I've got to be atlanta that day
18:45:07 * markmcclain steps away for another meeting
18:45:22 <sarob> next week instead then
18:45:49 <sarob> we can debate further on the akanda channel narrow the date time
18:46:03 <adam_g> i dont understand, you're suggestion we meet in SF for something next week?
18:46:11 <sarob> no sorry
18:46:13 <adam_g> or is this an online meeting
18:46:32 <sarob> i was putting both meetings out there
18:46:48 <sarob> first one is mitaka design summit prep next week
18:46:50 <sarob> online
18:47:09 <sarob> on etherpad that we will use for the summit
18:47:31 <adam_g> oh, ok
18:48:03 <sarob> second is f2f in SFO area the week of 20th, like 21-22 maybe if schedules work out
18:48:38 <sarob> markmcclain: has something on the 22 that he may be able to move
18:48:48 <adam_g> i likely wont be able to make it, but dont block on me
18:49:54 <sarob> adam_g: different date work better for you or travel itself before the summit
18:50:09 <adam_g> sarob, its the travel thing
18:50:14 <sarob> adam_g: roger
18:53:07 <sarob> i think we can remote adam_g in for 21-22
18:53:28 <adam_g> k
18:54:00 <sarob> so lets plan on 9th at 11am PDT for mitaka summit planning to start off
18:54:28 <sarob> and 21-22 for f2f plus adam_g remote
18:54:40 <sarob> sound good y'all?
18:55:03 <adam_g> we can plan this later
18:55:12 <adam_g> 5 min left
18:55:22 <sarob> sure, lets continue the discussing in channel
18:55:23 <adam_g> (mark is not here anymore so no sense getting agreement w/o him)
18:55:59 <sarob> adam_g: right, i have had a prelim discussion with him, but yeah, lets verify
18:56:46 <sarob> #action sarob set date/time for mitaka summit plan session and september f2f
18:57:17 <sarob> anything else?
18:58:23 <sarob> beuller?
18:58:30 <sarob> beuller?
18:59:04 <adam_g> nope
18:59:11 <sarob> okay, i guess thats it
18:59:15 <sarob> cheers
18:59:25 <sarob> #endmeeting