18:01:29 <sarob> #startmeeting akanda
18:01:30 <openstack> Meeting started Mon Sep 14 18:01:29 2015 UTC and is due to finish in 60 minutes.  The chair is sarob. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:34 <markmcclain> o/
18:01:34 <openstack> The meeting name has been set to 'akanda'
18:01:38 <davidlenwell> o/
18:02:54 <adam_g> o/
18:03:24 <sarob> good morning
18:03:26 <sarob> everyone
18:03:43 <elo> hello
18:03:58 <sarob> elo: hey eric
18:04:03 <sarob> agenda
18:04:12 <sarob> #link https://wiki.openstack.org/wiki/Meetings/akanda
18:04:19 <sarob> first item
18:04:48 <sarob> electing a project PTL in preparation for mitaka
18:05:01 <sarob> #topic  electing a project PTL in preparation for mitaka
18:05:04 <sarob> better
18:05:19 <sarob> i put it out there that
18:05:33 <sarob> i have enjoying running the dev meetings
18:05:48 <sarob> but its time to elect a technical leader
18:06:22 <sarob> adam gandelman has shown his technical leadership in the project
18:06:48 <sarob> so i lean toward him, but
18:07:02 <sarob> this is a public project so we need to discuss it
18:07:23 <markmcclain> +1 to adam_g
18:07:36 <davidlenwell> also +1 to adam_g
18:07:39 <sarob> open for discussion on the topic
18:07:57 <sarob> ryanpetrello: you around?
18:08:02 <davidlenwell> but it wouldn't hurt to discuss the alternitive of markmcclain taking that roll would it?
18:08:14 <sarob> certainly not
18:08:43 <sarob> its all up for discussion
18:08:44 <adam_g> im fine with takin over if its me
18:08:59 <sarob> markmcclain: what are your thoughts?
18:10:20 <sarob> i didnt see any responses when I put the PTL discussion out on the ML
18:10:31 <sarob> so i thought we should open discuss here
18:10:56 <markmcclain> I've kicked around the different scenarios while I be happy to serve as PTL
18:11:32 <markmcclain> but from a project community and community perspective I think would be a better fit for the next cycle
18:11:48 <markmcclain> *I think adam_g would be a better fit for the next cycle
18:12:16 * markmcclain fingers aren't typing fast enough today
18:13:05 <elo> I'm too new to project to contribute
18:13:20 <sarob> markmcclain: so if i understand correctly, you are offering to be PTL for mitaka cycle?
18:13:36 <sarob> markmcclain: or for the remainder of liberty?
18:13:53 <davidlenwell> he's saying he'd be happy to do it but he thinks adam_g is a better fit for next cycle
18:13:56 <markmcclain> sarob: quite the opposite.. I think adam_g would be good PTL
18:14:30 <markmcclain> and selecting a ptl for remainder of L and all of M makes sense since the other projects are going through the same process currently
18:16:23 <sarob> markmcclain: got it same PTL for the rest of L and M
18:16:31 <markmcclain> right
18:18:07 <sarob> okay if no more discussion then lets vote
18:19:09 <sarob> #startvote adam gandelman as PTL for the remainder of L cycle and all of M cycle
18:19:10 <openstack> Unable to parse vote topic and options.
18:19:21 <sarob> #startvote adam gandelman as PTL for the remainder of L cycle and all of M cycle?
18:19:22 <openstack> Begin voting on: adam gandelman as PTL for the remainder of L cycle and all of M cycle? Valid vote options are Yes, No.
18:19:23 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
18:19:32 <sarob> #vote yes
18:19:35 <markmcclain> #vote yes
18:19:41 <davidlenwell> #vote yes
18:20:05 * adam_g abstains
18:20:05 <sarob> ryanpetrello: ?
18:20:20 <sarob> i guess thats majority
18:20:34 <sarob> #showvote
18:20:55 <sarob> #endvote
18:20:56 <markmcclain> ryanpetrello is off today
18:20:56 <openstack> Voted on "adam gandelman as PTL for the remainder of L cycle and all of M cycle?" Results are
18:21:18 <sarob> 3 yes
18:21:25 <sarob> 1 abstain
18:21:28 <sarob> 1 not present
18:21:36 <sarob> congrats adam_g
18:21:49 <adam_g> w00t thanks guys
18:22:18 <sarob> moving on
18:22:36 <sarob> #topic akanda F2F hack
18:23:01 <sarob> we had discussed a few different times
18:23:27 <sarob> 28-29 september seems to be the best dates
18:23:33 <sarob> in portland
18:23:49 <sarob> are we in agreement still that is the right place and time?
18:24:02 <markmcclain> works for me
18:24:16 <sarob> elo?
18:24:30 <elo> yes. I'm in town that week already
18:25:01 <sarob> davidlenwell, adam_g?
18:25:03 <adam_g> +1
18:25:56 <sarob> im pretty sure davidlenwell is good as well
18:26:34 <davidlenwell> yea
18:26:43 <davidlenwell> sorry .. i knew you knew that so I didn't speak up
18:27:04 <sarob> so we need to start prepping for mitaka and get a some work prepped for the f2f
18:27:35 <adam_g> i think we should first worry about getting our liberty release in order
18:28:09 <sarob> adam_g: what do you think the f2f focus should be?
18:28:31 <sarob> adam_g: like scheduled work that is
18:29:07 <adam_g> sarob, oh right, yes. we can discuss future M development in portland.
18:29:15 <adam_g> well, assuming we get our L released next week :)
18:30:10 <sarob> adam_g: yeah, so we should organize the f2f schedule very soon
18:31:09 <adam_g> yup
18:31:11 <sarob> i was thinking we can schedule a 30 minutes or so over irc sometime this week
18:31:24 <adam_g> we can just create an etherpad people can dump ideas into as they get htem?
18:31:33 <sarob> adam_g: sounds good
18:31:50 <sarob> lets share over ML then?
18:32:03 <adam_g> https://etherpad.openstack.org/p/akanda-mitaka-planning
18:32:07 <adam_g> #link https://etherpad.openstack.org/p/akanda-mitaka-planning
18:32:16 <adam_g> #action everyone start dumping ideas for M planning into https://etherpad.openstack.org/p/akanda-mitaka-planning
18:33:07 <sarob> #action everyone start dumping ideas for M planning into https://etherpad.openstack.org/p/akanda-mitaka-planning
18:33:21 <sarob> moving on
18:33:34 <sarob> #topic critical bugs
18:33:49 <sarob> #link https://bugs.launchpad.net/akanda/+bug/1481877
18:33:50 <openstack> Launchpad bug 1481877 in akanda "stable/juno branches are versioned incorrectly" [Critical,In progress] - Assigned to Sean Roberts (sarob)
18:34:17 <sarob> #link https://review.openstack.org/217814
18:34:28 <sarob> #link https://review.openstack.org/217808
18:34:38 <sarob> #link https://review.openstack.org/217812
18:34:46 <sarob> should all be ready to merge
18:34:57 <sarob> i had a typo in the commit msg
18:35:14 <sarob> thx markmcclain
18:35:16 <adam_g> cool
18:35:23 <adam_g> #link https://bugs.launchpad.net/akanda/+bug/1491593
18:35:24 <openstack> Launchpad bug 1491593 in akanda "tenant created networks cannot be deleted by the tenant" [High,In progress]
18:35:29 <adam_g> #link https://bugs.launchpad.net/akanda/+bug/1491593
18:35:37 <adam_g> i have patches up for those two
18:36:02 <adam_g> oops
18:36:14 <adam_g> #link https://bugs.launchpad.net/akanda/+bug/1492056
18:36:14 <openstack> Launchpad bug 1492056 in akanda "A missing appliance instance is caught by alive check, not the missing instance" [High,In progress]
18:36:59 <adam_g> sarob, can you create an rc1 release milestone so i can start targeting bugs accordingly?
18:37:21 <adam_g> also, FYI we decided a couple of weeks ago that our rc1 would go out next week with the rest of em
18:37:29 <sarob> #link https://launchpad.net/akanda/+milestone/liberty-rc1
18:37:32 <markmcclain> adam_g: good catch
18:37:58 <adam_g> sarob, ah cool
18:38:14 <sarob> adam_g: need to change the date though
18:38:57 <sarob> #action sarob update rc1 release to match neutron
18:39:41 <sarob> looks like
18:39:43 <sarob> #link https://bugs.launchpad.net/akanda/+bug/1490331
18:39:44 <openstack> Launchpad bug 1490331 in akanda "akanda-appliance stable/juno test.unit.drivers.test_hostname.HostnameTestCase test is failing" [Critical,In progress] - Assigned to Ryan Petrello (ryan-petrello)
18:39:55 <sarob> was already merged, just not updated
18:40:02 <adam_g> thats a stable/juno bug
18:40:14 * adam_g untargets
18:40:37 <sarob> adam_g: yup
18:41:13 <sarob> so we need some reviews on your bug patches adam_g
18:41:39 <sarob> anything else before bp update?
18:42:09 <adam_g> markmcclain, maybe you know if this is a bug or expected https://bugs.launchpad.net/akanda/+bug/1491673
18:42:10 <openstack> Launchpad bug 1491673 in akanda "newly created router briefly reports as ACTIVE before it is built" [Undecided,New]
18:42:41 <adam_g> we can chat about that after
18:42:43 <adam_g> sarob, okay to move on
18:42:50 <sarob> #topic progress on liberty rc1
18:43:10 <markmcclain> adam_g: yeah.. it's a quirk we've tolerated for a bit
18:43:19 <adam_g> markmcclain, ah ok
18:43:25 <sarob> #info appliance provisioning driver
18:43:27 <sarob> #link https://blueprints.launchpad.net/akanda/+spec/appliance-provisioning-driver
18:43:33 <sarob> davidlenwell: update
18:44:14 <davidlenwell> in the process of fixing all the tests that fail in https://review.openstack.org/#/c/215227/9
18:46:57 <sarob> anything else?
18:47:11 <sarob> base driver patch
18:47:20 <sarob> #link https://review.openstack.org/#/c/215226/12
18:47:32 <sarob> and driver ffactory patch
18:47:34 <sarob> #link https://review.openstack.org/#/c/215220/16
18:47:50 <sarob> should be ready to merge after those tests are landed?
18:48:32 <davidlenwell> Thre will be new patches on the driver factory that includes tests
18:48:45 <sarob> okay good
18:49:00 <davidlenwell> but the base driver patch will likely stay as is
18:49:26 <sarob> got it
18:49:29 <sarob> moving on then
18:50:02 <sarob> #info LBaaSv2
18:50:26 <sarob> #link https://blueprints.launchpad.net/akanda/+spec/lbaas-v2-support
18:50:41 <sarob> i believe you plan on starting tomorrow
18:50:53 <davidlenwell> work on that blue print will start tomorrow.. plan to get it finished in a few days
18:51:01 <sarob> cool
18:51:03 <sarob> moving on
18:51:10 <sarob> #link rug scaling
18:51:14 <sarob> #link https://blueprints.launchpad.net/akanda/+spec/rug-scaling
18:51:25 <sarob> adam_g: your patches are out there
18:51:31 <adam_g> yep
18:51:47 <sarob> we as a team need to review
18:52:18 <sarob> #action team needs to review rug scaling patches pending
18:52:42 <sarob> #info nodepool/pez
18:52:52 <sarob> #link https://blueprints.launchpad.net/akanda/+spec/nodepool-support
18:53:09 <adam_g> just fished up a working POC on friday
18:53:09 <sarob> adam_g: how is that coming?
18:53:22 <adam_g> i'll clean that stuff up and hopefully have it in a state others can start banging on it this week
18:53:36 <sarob> cool
18:53:44 <sarob> anything else?
18:53:48 <adam_g> good thing is that pez is its own standalone service and default/existing behavior will be preserved
18:54:04 <adam_g> so we shouldn tneed to block release if its still in an experimental state
18:54:14 <sarob> got it
18:54:34 <sarob> #info docs updates
18:54:53 <sarob> #link https://blueprints.launchpad.net/akanda/+spec/liberty-doc-updates
18:55:08 <sarob> first quarter of this is merged
18:55:25 <sarob> ill get more pushed up this week
18:55:36 <sarob> #topic any other business
18:56:19 <markmcclain> none from me
18:57:32 <sarob> anyone else?
18:57:42 <adam_g> sarob, shall i plan on chairing the meeting next week?
18:57:51 <sarob> yes, plz
18:58:02 <adam_g> 10-4
18:58:08 <sarob> roger roger
18:58:18 <sarob> i guess that is it
18:58:25 <sarob> cheers everyone!
18:58:42 <sarob> #endmeeting