18:01:04 <adam_g> #startmeeting akanda
18:01:05 <openstack> Meeting started Mon Oct 12 18:01:04 2015 UTC and is due to finish in 60 minutes.  The chair is adam_g. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:08 <adam_g> o/
18:01:08 <openstack> The meeting name has been set to 'akanda'
18:01:28 <markmcclain> o/
18:02:22 <adam_g> anyone else around? davidlenwell ryanpetrello elo1 rods ?
18:03:21 <janonymous_> o/
18:03:51 <adam_g> ok, guess we'll get started
18:04:05 <adam_g> #topic remaining liberty work
18:04:14 <adam_g> #link https://etherpad.openstack.org/p/akanda-mitaka-planning
18:04:23 <adam_g> ive got a list of links here of stuff that we need to get merged
18:04:35 <adam_g> we started to slowly chip away at it last week but we really need this stuff landed today or tomorrow
18:04:45 <adam_g> all tests should be green, if there are any failing let me know and i'll make them green again
18:04:59 <adam_g> the driver framework and associated LBAAS driver are in, so thats good
18:06:10 <adam_g> markmcclain, you mentioned there wer some concerns about the akanda-neutron repo's lack of coverage. is that something we need to addres in L or can we fix up first thing in mitaka?
18:08:39 <adam_g> im thinking, as part of our initial mitaka planning, we can audit the repo and figure out exactly what is still needed and what can be cut
18:10:22 <adam_g> well. seems to be crickets here, so ill just plow through for the bot
18:10:37 <adam_g> #topic remaining liberty bugs
18:10:52 <adam_g> https://bugs.launchpad.net/akanda/+bug/1482389
18:10:52 <openstack> Launchpad bug 1482389 in akanda kilo "demo tenant instance connectivity issues /w devstack because arp spoofing protection" [Critical,In progress] - Assigned to Mark McClain (markmcclain)
18:11:26 <adam_g> markmcclain fixed in master. im not sure if kilo is still affected or if we've determined that issue to be strictly security group related
18:11:34 <adam_g> markmcclain, please untarget from kilo if its not needed there anymore
18:11:43 <adam_g> https://bugs.launchpad.net/akanda/+bug/1502993
18:11:43 <openstack> Launchpad bug 1502993 in akanda "the nginx-plus dib element does not work" [Undecided,New]
18:11:51 <adam_g> still no progress there, unless davidlenwell has something to report
18:12:09 <adam_g> #link  https://bugs.launchpad.net/akanda/+bug/1502993
18:12:18 <adam_g> #link  https://bugs.launchpad.net/akanda/+bug/1502993
18:12:27 <adam_g> https://bugs.launchpad.net/akanda/+bug/1502993
18:12:40 <adam_g> https://bugs.launchpad.net/akanda/+bug/150299
18:12:41 <openstack> adam_g: Error: malone bug 150299 not found
18:12:48 <adam_g> wtf?
18:13:00 <markmcclain> adam_g: sorry ... will untarget it
18:13:16 <adam_g> markmcclain, oh, cool
18:13:44 <adam_g> https://bugs.launchpad.net/akanda/+bug/1496866 'nameserver is not set correctly in the appliance' is still open. i need to hit up the dreamhost folk to see what they've been doing to workaround, and put that into a patch
18:13:44 <openstack> Launchpad bug 1496866 in akanda "nameserver is not set correctly in the appliance" [Undecided,New]
18:14:05 <adam_g> #link https://bugs.launchpad.net/akanda/+bug/1491593
18:14:06 <openstack> Launchpad bug 1491593 in akanda "tenant created networks cannot be deleted by the tenant" [High,In progress] - Assigned to Adam Gandelman (gandelman-a)
18:14:29 <adam_g> still open but there is a patch open to address it that is on the list for liberty that should be merging soon
18:14:40 <adam_g> #mitaka summit planning
18:14:44 <adam_g> derp
18:14:50 <adam_g> #topic mitaka summit planning
18:15:11 <adam_g> #link https://etherpad.openstack.org/p/akanda-mitaka-planning
18:15:28 <adam_g> we've got a running list going on this pad of things we'd like to chat about in tokyo
18:16:04 <adam_g> we should also start thinking about a time/place to meetup and work through it. im thinking we need more than a single 1 hr session this time, i wouldn't be opposed to an entire day but thats probably unlikely with everyone elses schedules
18:16:18 <adam_g> as we get closer to the summit, maybe we can all put our preferred time blocks on the bottom of the pad
18:16:32 <markmcclain> yeah that's smart
18:17:22 <stanchan> Is there an official spot for astara @ tokyo?
18:17:37 <stanchan> hi all
18:17:43 <adam_g> stanchan, not an official track
18:17:55 <adam_g> so its on us to schedule our 'official' meeting time+spot among ourselves
18:18:12 <stanchan> hallway then... I would love to attend any meetings you have
18:18:12 <adam_g> to that end, ive added a section to the bottom of https://etherpad.openstack.org/p/akanda-mitaka-planning for people to note when they are avaiable and we can try to find something that works for everyone
18:18:38 <stanchan> ok
18:18:40 <adam_g> #action everyone look through your tokyo schedules and note when you are available for astara mitaka dev session at https://etherpad.openstack.org/p/akanda-mitaka-planning
18:19:00 <adam_g> hopefully we can find a good chunk of time
18:19:22 <markmcclain> yeah... would nice to see if we can squeeze in 2 time blocks
18:19:45 <adam_g> yup
18:19:47 <adam_g> moving on
18:19:57 <adam_g> #topic project governance, rename, etc.
18:20:32 <adam_g> so for anyone who missed it last week, the TC voted to move akanda into the openstack namespace in the form of the astara project
18:20:47 <adam_g> so \o/ there, and thanks to sarob and markmcclain for driving that over the last couple of months
18:21:02 <markmcclain> super excited about it
18:21:17 <adam_g> we are on the list of things that infra will be moving from stackforge/ -> openstack/ this week
18:21:27 <adam_g> we need to also coordinate the project rename
18:21:48 <adam_g> im going to add something to the infra irc meeting that happens tomorrow so we can get that on their radar and get some TODOs that we need to get done for that to happen
18:22:21 <adam_g> this makes cutting our liberty release a bit hairy, because we might be releasing the astara liberty release from the akanda repositories
18:22:30 <adam_g> in the event that the rename cannot happen in time
18:23:05 <adam_g> markmcclain, i know we've chatted about it a handful of times but just to solidify it in meeting logs, lets figure out how we do this
18:23:29 <adam_g> assuming the project repositories cannot be renamed until after tokyo
18:23:48 <adam_g> we can at least update the setup.cfg's across projects to rename the things to astara-*
18:24:06 <markmcclain> right.. I was thinking we could up update console-scripts with entries for both akanda and astara
18:24:12 <adam_g> we can probably also upadate entry points
18:24:15 <adam_g> and config files
18:24:27 <markmcclain> with the akanda script links being marked as deprecated
18:24:34 <adam_g> markmcclain, oh, good idea
18:24:43 <markmcclain> I don't think we'll need to update any of the entry points
18:24:59 <adam_g> right, so just add a second set /w the astara-* names
18:25:12 <markmcclain> yeah.. I can propose that after this meeting is up
18:25:15 <adam_g> config files are user-specified, but we can just update the default
18:25:22 <markmcclain> right
18:25:51 <adam_g> do we want to be ambitious and actually scrap through code and rename references? or save that for mitaka?
18:26:17 <markmcclain> I don't there is anything in the entry points that is akanda specific, so I think we can move the code around in M
18:26:25 <adam_g> #action markmcclain to add new astara-* console scripts to the rug
18:26:42 <markmcclain> also putting the binaries in place now will allow us to update the test configs
18:27:04 <adam_g> markmcclain, which do you mean?
18:27:28 <markmcclain> updates to invoke astara-rug-service vs akanda-rug-service
18:28:01 <adam_g> k
18:28:12 <adam_g> we also need LP infra in place
18:28:26 <adam_g> we just mirror the existing layout for now?
18:28:41 <markmcclain> right... I think we should consolidate down to 1 LP
18:28:57 <markmcclain> or possibly 2 (1 rug and 1 appliance)
18:29:25 <adam_g> markmcclain, i dont remember, do we need an associate LP project for each git repo?
18:29:31 <adam_g> *associated
18:29:51 <markmcclain> I don't think so, but not 100% sure
18:29:58 <adam_g> it seems we wouldnt, the LP projects other than 'akanda' are basically idle at this point
18:30:37 <adam_g> the releases and bugs are all tracked in 'akanda' so i think we can get away with 1
18:30:48 <adam_g> and have multiple git repos pointing there on the openstack side
18:30:56 <adam_g> anyway
18:31:02 <adam_g> #actino adam_g get LP project setup and ready for astara
18:31:10 <adam_g> #action  adam_g get LP project setup and ready for astara
18:31:37 <adam_g> anything else to note here?
18:32:28 <adam_g> okay, moving on
18:32:33 <adam_g> #topic open discussion
18:33:17 <adam_g> ill be offline next week so i wont be here to chair the meeting. any volunteers ?
18:33:47 <markmcclain> I'll be around
18:33:55 <adam_g> cool
18:34:08 <markmcclain> I'm also happy to skip since it will be travel week and we can organize a meeting time via the ML
18:34:19 <adam_g> sure
18:34:32 <adam_g> ill be popping on wednesday to hopefully finish up the final liberty release cutting
18:35:13 <adam_g> also forgot to mention in the liberty release planning that we'll be cutting the RC this week, hopefully wednesday
18:35:37 <adam_g> anything else?
18:35:44 <markmcclain> nothing from me
18:36:10 <adam_g> right on. well i guess ill call it
18:36:11 <adam_g> #endmeeting