15:01:39 <sshnaidm> #startmeeting ansible-sig
15:01:40 <openstack> Meeting started Tue Feb 11 15:01:39 2020 UTC and is due to finish in 60 minutes.  The chair is sshnaidm. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:44 <dtantsur> o/
15:01:45 <openstack> The meeting name has been set to 'ansible_sig'
15:02:00 <sshnaidm> who is available today
15:02:09 <sshnaidm> dtantsur, hey
15:02:15 <gtema> me in 10 minutes
15:03:04 <sshnaidm> ack
15:03:10 <dtantsur> sshnaidm: I suggest you ping people explicitly
15:03:20 <dtantsur> it's easy to forget about the changed time
15:03:26 <sshnaidm> ok, maybe we need to maintain a list of people :)
15:04:02 <dtantsur> ping whoever responded about the time :)
15:04:16 <sshnaidm> mordred, mnaser cloudnull odyssey4me noonedeadpunk jrosser
15:04:25 <jrosser> o/ hello
15:04:28 <noonedeadpunk> o/
15:04:33 <mordred> sshnaidm: this is the new time then I suppose? :)
15:04:36 <sshnaidm> I'm taking names from etherpad, maybe not all are in this channel
15:04:42 <sshnaidm> mordred, yes!
15:05:04 <sshnaidm> new time, convenient for all now
15:05:19 <sshnaidm> and new place
15:05:36 <dtantsur> yeah, the API SIG slot was occupied temporarily :)
15:06:01 <cloudnull> o/
15:06:19 <sshnaidm> just a reminder, the agenda is in
15:06:24 <sshnaidm> #link https://etherpad.openstack.org/p/openstack-ansible-modules
15:06:34 <sshnaidm> feel free to add there
15:06:54 <sshnaidm> so moving on
15:07:12 <sshnaidm> first item - pushing a first version of collection to galaxy
15:07:30 <sshnaidm> I'd propose to do it manually now so people can start testing/using it
15:07:52 <dtantsur> does galaxy have any sort of alpha versions?
15:08:00 <mordred> sshnaidm: oh yeah - I was gonna connect with you on getting that set up once I was back in real life
15:08:11 <sshnaidm> mordred, great
15:08:25 <sshnaidm> dtantsur, well, it has versioning
15:08:49 <sshnaidm> dtantsur, but if you want to install something before 1.0.0 you need to set an explicit version
15:08:57 <dtantsur> ah! nice
15:09:05 <mordred> cool., so we can install this manual test one as 0.1
15:09:07 <sshnaidm> (there is a request to change it from Paul to have *)
15:09:34 <dtantsur> (sorry, my knowledge of ansible is very spotty)
15:09:41 <sshnaidm> mordred, yeah, maybe not to release it until it's removed from ansible upstream
15:09:51 * sshnaidm stairs on gundalow
15:10:08 <dtantsur> they don't conflict, do they?
15:10:30 <sshnaidm> dtantsur, if shortly - it's complicated
15:10:34 <dtantsur> I think it's actually good to collect feedback before ansible presses the big red button?
15:10:58 <noonedeadpunk> I'd say it would be great to have some migration time on hands
15:10:59 <sshnaidm> dtantsur, absolutely, the sooner we can use collection the better
15:11:18 <sshnaidm> noonedeadpunk, sorry, what do you mean?
15:11:45 <noonedeadpunk> Like be able to start using some "stable" collections before ansible got modules dropped from their root
15:12:23 <sshnaidm> noonedeadpunk, I'm not sure people use devel branch of ansible
15:12:41 <sshnaidm> noonedeadpunk, but for better safety - yes, of course
15:12:57 <sshnaidm> btw the patch to do this:
15:13:01 <sshnaidm> #link https://github.com/ansible/ansible/pull/66790
15:13:24 <sshnaidm> noonedeadpunk, it affects 2.10 only and currently it's devel branch
15:13:45 <sshnaidm> ok, so I think we have an agreement here
15:13:47 <odyssey4me> o/
15:14:06 <sshnaidm> #action sshnaidm to be in touch with mordred to push the first version of collection to galaxy
15:14:21 <sshnaidm> mordred, let's please schedule a time for it
15:14:38 <sshnaidm> mordred, just ping me whenever you're available
15:15:03 <sshnaidm> any objections, comments about this topic?
15:15:12 <mordred> sshnaidm: will do - we can do it this week - first step is I need to make sure I know how to log in myself :)
15:15:23 <sshnaidm> mordred, ack :)
15:15:38 <sshnaidm> mordred, I pushed something to my accounts, so should be fine
15:15:51 <sshnaidm> we also have stage version of galaxy to play there
15:16:01 <sshnaidm> (nice thing, btw ^^ )
15:16:09 <sshnaidm> ok, moving on
15:16:52 <sshnaidm> I need an advice from infra or people that did releases, how do I run job after patch is merged? Should I use something like post-merge pipeline..?
15:17:38 <sshnaidm> I'd happy to receive examples of tag/release jobs in openstack to learn from, or link to docs
15:17:43 <dtantsur> the release team has a release pipeline, dunno if we can use it
15:18:14 <mordred> yes - release pipeline - or we might want to use the promote pipeline instead
15:18:23 <sshnaidm> as I understand we need to run build job, pass artifacts to child functional jobs, then merge it, but then to push collection to galaxy
15:18:24 <mordred> release pipeline is for running jobs after a tag event
15:18:50 <sshnaidm> mordred, so we agreed to use tags before, maybe release pipeline is what we want here?
15:19:10 <sshnaidm> mordred, to define pushing job in release pipeline?
15:19:18 <mordred> yes- if we're going to be pushing to galaxy on tag events, it should go in release pipeline
15:19:34 <sshnaidm> ok
15:20:15 <sshnaidm> so I'll focus on build&test jobs right now, we still have time before pushing anything..
15:20:39 <sshnaidm> dtantsur, do you use tagged releases in ironic?
15:20:50 <dtantsur> sshnaidm: all official projects do, I think
15:20:57 <dtantsur> and most non-official
15:21:10 <sshnaidm> dtantsur, I see
15:22:03 <sshnaidm> any other ideas how to organize jobs for build & push or related topics?
15:22:30 <sshnaidm> if no, then moving on
15:22:37 <dtantsur> sshnaidm: similarly to upstream release procedure, create a check job to verify you can release
15:23:00 <dtantsur> I mean, do most of verifications before you try to build and upload something
15:23:11 <dtantsur> (for python projects it's stuff like setup.cfg validation)
15:23:20 <sshnaidm> dtantsur, what kind of verifications?
15:24:01 <sshnaidm> dtantsur, I think in this case it will be galaxy.yml verification
15:24:08 <dtantsur> yeah, for example this
15:24:14 <dtantsur> I'm not familiar with ansible packaging to be sure
15:24:16 <sshnaidm> it's actually responsible for pushing
15:24:43 <sshnaidm> yeah, it's kind of setup.cfg+requirements.txt, but for ansible
15:24:51 <dtantsur> right
15:25:01 <sshnaidm> ack, noted
15:25:21 <sshnaidm> ok, moving on
15:25:36 <sshnaidm> Openstack Ansible modules on PTG - is there intererest to have a discussion/session/track there? Should it be part of SDK session or other?
15:25:53 <dtantsur> 1. Yes, 2. Depending on the overall format?
15:26:10 <gtema_> 1 - yes
15:26:24 <sshnaidm> as I saw, and mordred can confirm, we have something like "Tracks" now..? Maybe it can be used?
15:26:52 <mordred> shrug - I do not know ... I'd be more than happy for there to be some sort of meeting if people will be in vancouver
15:27:06 <mordred> otoh - if people are not going to be in vancouver, then it's not super awesome :)
15:27:11 <dtantsur> sshnaidm: if we can, say, dedicate 1-2 slots, then we can go independent
15:27:20 <dtantsur> if it must be a part of some wider track, I guess we can go with the SDK
15:27:37 <dtantsur> mordred: many of us won't know until much later :(
15:27:51 <sshnaidm> mordred, let's hope and plan for good
15:28:40 <sshnaidm> it's easier to remove tracks than to search for adding them later
15:28:47 <mordred> good point
15:29:15 <sshnaidm> do you know if SDK has its own space?
15:29:20 <sshnaidm> like room and hours
15:29:23 <mordred> and I agree with dtantsur - either just grab 1-2 slots, or we can make an SDK track
15:29:30 <mordred> sshnaidm: I don't think we've requested anything
15:29:48 <sshnaidm> mordred, how to "grab slots" actually?
15:30:09 <sshnaidm> what is the procedure
15:30:50 <sshnaidm> ok, I think we can discover this later then
15:31:05 <sshnaidm> I think we agree on 1-2 slots and that's fine
15:31:27 <sshnaidm> ok, open discussion then
15:31:34 <sshnaidm> do you have something to talk about?
15:32:09 <dtantsur> I think the first step is to say "yes, we're going to be present" out loud
15:32:34 <sshnaidm> dtantsur, and together
15:33:42 <sshnaidm> ok, so if no other topics, I think we're good?
15:34:00 <sshnaidm> thanks everyone to participation
15:34:02 <mordred> sshnaidm: I'll see what I can find out about getting track slots
15:34:11 <sshnaidm> mordred, great, thanks
15:34:23 <sshnaidm> #endmeeting