15:01:14 <sshnaidm> #startmeeting ansible-sig
15:01:15 <openstack> Meeting started Tue Feb 18 15:01:14 2020 UTC and is due to finish in 60 minutes.  The chair is sshnaidm. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:18 <openstack> The meeting name has been set to 'ansible_sig'
15:01:31 <sshnaidm> who is available today?
15:01:34 <noonedeadpunk> o/
15:02:08 <mordred> o/
15:02:38 <sshnaidm> dtantsur, odyssey4me jrosser mnaser cloudnull just fyi, openstack ansible modules meeting started
15:02:42 <dtantsur> o/
15:03:32 <sshnaidm> agenda is:
15:03:35 <sshnaidm> #link https://etherpad.openstack.org/p/openstack-ansible-modules
15:03:49 <sshnaidm> so from action items:
15:04:18 <sshnaidm> we'll deal with pushing collection and ptg stuff later this week, as mordred pointed above
15:04:21 <holser> o/
15:05:03 <sshnaidm> job for build&push collections is in WIP https://review.opendev.org/#/c/708372/
15:05:08 <mordred> yah. stupid virtualenv
15:05:10 <odyssey4me> o/
15:05:48 <odyssey4me> re: virtualenv - https://github.com/ansible/ansible/pull/67407 may help make it easier to do better things
15:06:24 <sshnaidm> thanks odyssey4me
15:06:44 <sshnaidm> we have also a few reviews pending, please get some in your time
15:06:47 <mordred> odyssey4me: yah- in fairness to the virtualenv devs, they heard and responded pretty quickly
15:07:04 <mordred> sshnaidm: ++ reviews
15:07:38 <sshnaidm> yeah, I think we can proceed as a start with mordred patch, at least it has +2 from me and I saw gtema worked on it
15:08:04 <sshnaidm> for using a class for openstack module
15:08:24 <mordred> sshnaidm: cool - I thnik that'll open the door for us to clean and simplify in a bunch of places
15:08:33 <sshnaidm> #link https://review.opendev.org/#/c/698044/
15:08:39 <sshnaidm> mordred, totally
15:09:09 <sshnaidm> another problem that we hit a few times and should be handled there is matching various options and openstacksdk versions
15:09:13 <mordred> also - those checks were complex enough that last time I tried to required_if them it didn't work -but maybe required_if is better todauy - or maybe you're smarter :)
15:09:20 <mordred> yah
15:10:04 <sshnaidm> mordred, I think it worked for me, maybe it's ok now
15:10:42 <mordred> sweet
15:10:46 <sshnaidm> for being more compatible with various openstcksdk versions, I'd propose a job matrix to test code
15:10:55 <mordred> I totally agree - doing as much with those declarations is nicer
15:10:59 <mordred> ++
15:11:10 <sshnaidm> openstacksdk versions to test:
15:11:10 <sshnaidm> master
15:11:10 <sshnaidm> 0.36.1 (stable/train)
15:11:10 <sshnaidm> 0.27.0 (stable/stein)
15:11:10 <sshnaidm> 0.17.3 (stable/rocky)
15:11:10 <sshnaidm> Ansible:
15:11:12 <sshnaidm> devel
15:11:14 <sshnaidm> 2.9
15:11:16 <sshnaidm> 2.8
15:11:31 <sshnaidm> as I noticed the minimum required version is 0.12 and it's rocky
15:12:24 <mordred> yeah - I mean - one definitely needs at least whatever version we did the shade merge from - I think that's 0.12
15:12:28 <sshnaidm> https://github.com/openstack/ansible-collections-openstack/blob/master/plugins/module_utils/openstack.py#L112
15:12:46 <sshnaidm> mordred, so it shouldn't work for queens at all?
15:13:00 <mordred> for queens you'd need to use shade
15:13:02 <mordred> BUT
15:13:30 <mordred> it's important to point out that it has never been these modules intentions to release match with openstack releases- master openstacksdk should totally work with queens - or even diablo
15:13:46 <mordred> so while I do think we shoudl support some older sdks within reason
15:14:05 <mordred> it's also important that we point out to people in docs that they do _not_ need an older version of something to work with an older cloud
15:14:49 <sshnaidm> mordred, so you mean we don't want "max_version"
15:14:53 <odyssey4me> mordred: yeah, the issue has actually been people adding arguments to modules which don't work with the sdk at older versions - for example https://review.opendev.org/708119 is upping the minimum if certain parameters are used
15:14:55 <sshnaidm> only min_version
15:14:57 <mordred> (I know we have vendors shipping stuff side-by-side, so running modules with older versions of libraries may be unavoidable in some cases - but it would be really nice if we could get those vendors to update sdk :) )
15:15:08 <mordred> sshnaidm: ++
15:15:25 <mordred> odyssey4me: ++
15:15:42 <sshnaidm> great
15:16:01 <sshnaidm> #action sshnaidm to point about min and max version in docs
15:16:31 <sshnaidm> wrt docs
15:16:47 <sshnaidm> I just copypasted this from ansible: https://review.opendev.org/#/c/704558/
15:17:09 <sshnaidm> so if somebody wants to update this doc, please feel free to hijack this patch :)
15:17:20 <sshnaidm> consider it as a wiki :)
15:17:41 <sshnaidm> #link https://review.opendev.org/#/c/704558/
15:17:57 <mordred> haha
15:18:22 <odyssey4me> heh, *hint* at ekultails and mordred there :p
15:19:32 <sshnaidm> well, we need something to show to new contributors, after they are shocked after github->gerrti switch
15:20:25 <sshnaidm> maybe I'll add there a "transition" section with links how to create gerrit acc, etc
15:20:37 <sshnaidm> ok, moving on
15:20:40 <sshnaidm> so we agree on proposed jobs matrix, right?
15:21:18 <mordred> yes. although we might want to start with ansible-devel being non-voiting - just because sometimes the devel branch can itself be flaky
15:21:48 <sshnaidm> mordred, yeah, good point, maybe same with master openstacksdk?
15:21:59 <sshnaidm> or no, it's actually under our control
15:22:12 <sshnaidm> I think we can run these jobs later on openstacksdk branches and master, to prevent breakages for ansible module actually
15:22:29 <sshnaidm> or at least fast fixing them
15:22:42 <sshnaidm> dtantsur, no objections, right? ^
15:23:20 <mordred> yeah - master openstacksdk should be fine - it's gated :)
15:23:28 <sshnaidm> great
15:23:36 <dtantsur> ++
15:23:45 <sshnaidm> so, this is it for agenda today, please feel free to raise topics for open discussions
15:23:45 <mordred> I just replied to that docs patch above (and I'll take a stab at a new patch update) - but we should totally do co-gating with openstacksdk
15:24:12 <sshnaidm> mordred, cool
15:25:35 <sshnaidm> gtema, thanks for working on tags stuff https://review.opendev.org/#/c/705343/
15:25:49 <sshnaidm> I'm quite lost in this tags thing..
15:26:11 <gtema> wlcm, still thinking for the better way and would like to ask perhaps not to merge anything tag related
15:26:27 <odyssey4me> sshnaidm mordred wrt ansible-devel - I suspect that once the collections split out happens, core will be more stable... that said, it might be better for us to do a periodic job for devel rather than gate on it
15:27:35 <sshnaidm> odyssey4me, from my experience periodic jobs are less important for people
15:27:53 <sshnaidm> odyssey4me, and it's visible only if someone is looking for it in particular
15:28:03 <mordred> odyssey4me: yeah - I'd hope it'll be more stable then - and also the things in it that impact *US* should be fairly low
15:28:05 <sshnaidm> odyssey4me, I'd compromise on non-voting job
15:28:25 <sshnaidm> gtema, you can always -2 these patches :)
15:28:34 <gtema> I know
15:29:05 <sshnaidm> gtema, I'll mention this in ML after a mtg, but you know...
15:29:08 <odyssey4me> sshnaidm: fair enough - although non-voting jobs tend to be ignored... but at least they're more visible
15:29:38 <sshnaidm> odyssey4me, yeah, and you can get feedback for your change immediately
15:29:45 <gtema> mordred: any chance to refer in the zuul job definition project on the different connection? github repo with job definition does require-project in opendev
15:30:13 <gtema> sorry for missusing channel
15:30:52 <mordred> gtema: yes - cross-source stuff works perfectly fine
15:31:22 <gtema> do I need required-projects: -opendev/opendev/refstack-client?
15:31:42 <gtema> opendev/openstack/refstack-client
15:31:44 <gtema> ok, thks
15:31:59 <sshnaidm> opendev.org/openstack/.. I think
15:32:12 <mordred> yeah - opendev.org/openstack/refstack-client ... you'll need to have those in your zuul - is this in opendev's zuul?
15:32:22 <gtema> nope, in mine
15:32:38 <gtema> enabling refstack tests of my cloud
15:32:41 <mordred> kk. yeah - just make sure you have both repos in the main zuul config
15:32:49 <gtema> thks
15:33:00 <sshnaidm> all right
15:33:01 <mordred> you don[t ACTUALLY need the opendev.org prefix if it's unique
15:33:15 <sshnaidm> mordred, or, is it just a default?
15:34:02 <sshnaidm> ok, I think I can finish the meeting and feel free to continue
15:34:05 <mordred> zuul will figure it out
15:34:14 <sshnaidm> #endmeeting