15:01:37 <dtantsur> #startmeeting ansible-sig
15:01:38 <openstack> Meeting started Tue Apr 14 15:01:37 2020 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:41 <openstack> The meeting name has been set to 'ansible_sig'
15:01:51 <dtantsur> heya! anyone up to talk about some ansiblezz?
15:02:41 <dtantsur> noonedeadpunk, mordred, mnaser, odyssey4me, gtema and whoever I forgot
15:02:45 <noonedeadpunk> o/
15:02:51 <odyssey4me> o/
15:03:15 <dtantsur> I don't have any agenda to go over, so if nobody has any topics, we can exchange nods and move on with our lives
15:03:32 <dtantsur> but I think mordred wanted to do some bike shedding?
15:03:35 <odyssey4me> I wonder if zbr may have something too.
15:04:02 <odyssey4me> Oh goody, we do love a good bike shed.
15:04:35 <dtantsur> #link https://review.opendev.org/#/c/713056/3/meta/action_groups.yml
15:04:47 <dtantsur> there are some naming questions. the one about ironic/ironic_node made me think hard
15:05:40 <dtantsur> well, first question: ironic vs baremetal
15:05:49 <dtantsur> do we need to rename now?
15:06:04 <dtantsur> or maybe we keep the os_ prefix for the ironic bits until we sort them out? (this has a risk of never getting done)
15:06:33 <mordred> dtantsur: well - I don't think we necessarily need either ironic or baremetal in the name
15:06:49 <mordred> oh wait - no, I'm stupid
15:07:27 <dtantsur> if I recall correctly, 'ironic' creates a node/ports, while ironic_node can update/set maintenance/power/deploy....
15:07:32 <dtantsur> (or the other way around)
15:07:37 <mordred> dtantsur: we can always do another rename in the future - but with the addition of the openstack.cloud prefix, I think now might be a good opportunity
15:07:55 <mordred> dtantsur: I think the other way around
15:08:08 <dtantsur> I think it was counter-intuitive :) lemme check
15:08:34 <mordred> yup - you're right
15:08:40 <mordred> we'll let's DEFINITELY change that
15:09:01 <zbr> o/
15:09:06 <dtantsur> I think os_ironic -> ironic_node, while os_ironic_node -> mmmmmm
15:09:09 <mordred> how about ironic -> baremetal_node and ironic_node -> baremetal_node_action
15:09:15 <dtantsur> yeah, like that
15:09:34 <dtantsur> I mean, I don't like it either, but that seems to be the least evil
15:09:57 <odyssey4me> does it make any sense at all to combine them instead?
15:10:08 * odyssey4me throws a cat among the pigeons
15:10:14 <mordred> now - ironic is a bit special ... we COULD make a second collection for it - openstack.ironic
15:10:59 <mordred> (I feel strongly that the other modules should all be in one collection - but the ironic stuff has a pretty radically different usage vector more frequently than not)
15:11:11 <dtantsur> odyssey4me: it does, except that nobody probably has time for that
15:11:30 <jrosser> for the renaming i was quite unsure about what to do with the 'single word' modules, those somehow feel suboptimal
15:11:52 <jrosser> particularly when someone is looking for "wheres the module to do ....."
15:12:03 <mordred> yeah - sshnaidm and I had some back and forth today on the review
15:12:09 <dtantsur> jrosser: which example do you have in mind?
15:12:44 <mordred> listener and member are two examples where they definitely need new names :)
15:12:47 <jrosser> zone, pool, memeber
15:12:54 <mordred> and pool
15:13:03 <dtantsur> right
15:13:26 <mordred> yeah. zone ... zone should be dns_zone
15:13:32 <mordred> good point
15:13:38 <jrosser> having some kind of namespace like that is ++ for usability
15:13:46 <dtantsur> agreed
15:13:53 <jrosser> dns_<blah>  this stuff is all for designate....  and so on
15:14:00 <dtantsur> baremetal_ for ironic
15:14:02 <dtantsur> yeah
15:14:10 <mordred> well - at least when the term is generic
15:14:13 <dtantsur> are we in agreement re renaming ironic stuffs?
15:14:15 <mordred> we don't need compute_server :)
15:14:22 <odyssey4me> heh, and there I was wondering whether it was gonna create me a solaris zone
15:14:38 <dtantsur> #agreed os_ironic -> baremetal_node, os_ironic_node -> baremetal_node_action (and iterate from that)
15:14:41 <dtantsur> ^^^?
15:14:46 <mordred> what do y'all think about federation_identity_provider - would identity_provider be ok - or should we keep federation in there
15:14:50 <mordred> dtantsur: ++
15:14:59 <jrosser> federation_idp maybe
15:15:03 <dtantsur> do we have or anticipate any other identity providers?
15:15:05 <jrosser> idp is a well understood term there
15:15:13 * dtantsur didn't know idp
15:15:17 <mordred> jrosser: oh - that's a good point
15:15:26 <mordred> dtantsur: well - for folks setting up federation, idp will make sense
15:15:43 <dtantsur> who doesn't like a good tla? :)
15:15:47 <odyssey4me> yeah, federation_* would be good for idp, mapping, etc
15:16:00 <odyssey4me> oh, mapping is not exclusive to federation :/
15:16:20 <odyssey4me> I don't think. Lemme check.
15:16:42 <mordred> odyssey4me: it looked like it was a federation mapping
15:16:47 <odyssey4me> Oh, it is exclusive to federation. Never mind.
15:16:56 <mordred> dtantsur: should ironic_inspect be baremetal_inspect?
15:17:18 <dtantsur> yeah, fine with me
15:17:21 <mordred> kk
15:17:29 <mordred> and - should we do lb_ instead of loadbalancer_ ?
15:17:32 <odyssey4me> while IDP is well known in that space, identity_provider is more explicit. Could we not have the long one with a short alias?
15:17:49 <odyssey4me> and do the same with lb_ vs loadbalancer_
15:17:56 <odyssey4me> or maybe do the short one with a long alias
15:18:06 <dtantsur> mmm, neat
15:18:07 <mordred> odyssey4me: I believe we can
15:19:11 <mordred> dtantsur: we have port - which I was arguing could just stay that way, since it's a basic thing - but I think ironic also has ports -s hould we call port network_port? or is port good enough for the normal case here?
15:20:55 <dtantsur> I'm fine with 'port' vs 'baremetal_port'
15:21:00 <dtantsur> this is the way it is with OSC
15:21:19 <dtantsur> actually, keeping an eye on OSC may be a good idea
15:22:05 <mordred> ++
15:23:06 <odyssey4me> yeah, I'll bet a lot of bike shedding has happened in OSC/SDK and we can ride the bike after it's been fixed.
15:23:15 <dtantsur> indeed
15:23:42 <dtantsur> any other aspects we should discuss explicitly?
15:23:48 <mordred> yeah. I've collected these in the review - I'll make a pass through osc
15:23:55 <mordred> then push up an actual full rename patch
15:25:11 <dtantsur> cool
15:25:30 <dtantsur> anything else?
15:27:05 <dtantsur> okay, thanks folks!
15:27:34 <dtantsur> #endmeeting