15:00:14 <sshnaidm> #startmeeting ansible-sig
15:00:14 <openstack> Meeting started Tue Apr 21 15:00:14 2020 UTC and is due to finish in 60 minutes.  The chair is sshnaidm. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:18 <openstack> The meeting name has been set to 'ansible_sig'
15:00:38 <sshnaidm> #https://etherpad.opendev.org/p/openstack-ansible-modules
15:00:44 <sshnaidm> topic agenda ^^
15:01:25 <sshnaidm> dtantsur, mordred odyssey4me gtema mnaser jrosser and everybody who is interested
15:01:36 <sshnaidm> who is available today?
15:01:41 * mordred waves
15:02:09 <gtema> me strugling with trailing with witespaces
15:02:34 <dtantsur> o/
15:03:06 <mordred> gtema: sed -i 's/ *$//'
15:03:08 * odyssey4me waves
15:03:15 <sshnaidm> gtema, I'm sure you're winning this battle :)
15:03:29 <jrosser> hello
15:03:33 <sshnaidm> ok, let's start then
15:04:03 <sshnaidm> first question about modules bugs and issues: Openstack Ansible modules bugs and issues - where to submit, how to document it (LP, Github, BZ, Jira, ...)
15:04:19 <sshnaidm> I saw people still submit issues in Ansible repo for our modules
15:04:49 <sshnaidm> I think we need to make it more visible where to submit bugs, and decide what to use for it
15:04:58 <odyssey4me> it'll happen until collections become more of a thing, I imagine
15:05:18 <mordred> yeah - I think it's unavoidable for them to be in ansible/ansible github for now - since that's what most people use
15:05:19 <sshnaidm> iirc we talked about storyboard before
15:05:35 <mordred> yeah - that's where sdk bugs are - so for things that target both things it would make the most sense to go there
15:06:13 <sshnaidm> although I expect issues to be opened in github repo of modules :)
15:06:41 <mordred> I agree - but I think that'll get better once people are using the collection
15:06:52 <mordred> that's gonna be a problem for all of the split collections :)
15:07:00 <sshnaidm> yeah
15:07:12 <sshnaidm> I'm fine to try storyboard for that, just need to document it in the repo. Any objections or other suggestions?
15:07:19 <dtantsur> no objections
15:07:31 <odyssey4me> no objections here
15:07:44 <sshnaidm> then I'll go over all issues with some message where to open them
15:07:55 <sshnaidm> I think you need ubuntu login for storyboard, right?
15:08:10 <mordred> yeah - at least for now (one day we will fix that)
15:08:22 <sshnaidm> and no need to sign ICL or kind of
15:08:27 <mordred> nope
15:08:42 <sshnaidm> mordred, yeah, would be great to login with github
15:08:58 <mordred> I wonder if ansibullbot could learn about location of issue tracker for things that moved so it could leave a comment
15:09:17 <dtantsur> automating it would be awesome
15:09:20 <sshnaidm> mordred, right, will ask on ansible channel
15:09:31 <sshnaidm> this would be great
15:09:49 <mordred> sshnaidm: seems liek a thing that isn't just us - even if a lot of the split collections are just in another gh project
15:10:00 <sshnaidm> #action sshnaidm to discover if ansibullbot can post new location of collection in issues
15:10:16 <sshnaidm> mordred, yeah, totally
15:10:28 <sshnaidm> anyway they'll need to clean this pipeline of issues
15:10:38 <mordred> although - I suppose it's harder for issue than for PRs
15:10:45 <mordred> since they can't exactly do path matching
15:11:03 <mordred> I don't envy that task :)
15:11:22 <sshnaidm> mordred, I think I handled all PRs before, posted there info
15:11:32 <sshnaidm> need to check if there are new ones maybe..
15:12:02 <sshnaidm> actually github allows search by "openstack" keyword, so it's ok
15:12:11 <mordred> ah - cool.
15:12:32 <sshnaidm> ok, moving on
15:12:38 <sshnaidm> PTG session - when and how, preparing an etherpad
15:12:55 <sshnaidm> we are going to do a virtual one as you know
15:13:08 <sshnaidm> and I hope more people will attend than in usual one
15:13:14 <gtema> gimme etherpad link
15:13:37 <sshnaidm> #action sshnaidm to create an etherpad for modules PTG
15:13:41 <sshnaidm> gtema, ^^ :)
15:13:45 <gtema> :D
15:14:16 <sshnaidm> mordred, so, are we going to have a modules section in SDK sessions as we talked before?
15:14:56 <sshnaidm> #link https://etherpad.opendev.org/p/openstack-ansible-modules-ptg
15:14:59 <sshnaidm> gtema, ^
15:15:54 <sshnaidm> so please feel free to add topics to discuss, it will help to determine the scope and time needed for us
15:17:02 <sshnaidm> any ideas or special requests for PTG session of modules?
15:17:19 <dtantsur> funny hats?
15:17:35 <sshnaidm> dtantsur, which color? :)
15:17:37 * gtema hides his head
15:17:41 <dtantsur> :D
15:17:53 <dtantsur> sshnaidm: let's have a preliminary bike shedding call! \o/
15:18:31 <sshnaidm> dtantsur, no objections :)
15:19:01 <gtema> shedding or schredding?
15:19:04 <sshnaidm> would be openstack-ansible team interested to participate and discuss? mnaser jrosser noonedeadpunk
15:19:34 <sshnaidm> if so, please add your questions as well: https://etherpad.opendev.org/p/openstack-ansible-modules-ptg
15:19:42 * noonedeadpunk reading back
15:20:03 <sshnaidm> noonedeadpunk, we are planning ptg session for openstack ansible modules
15:20:34 <noonedeadpunk> I think that might be interesting
15:20:50 <noonedeadpunk> I think jrosser already did some dnm patch to use collections
15:20:57 <sshnaidm> noonedeadpunk, great, feel free to sign in
15:21:20 <sshnaidm> ok, while waiting for mordred to confirm about a session
15:21:30 <jrosser> yes I have some wip patches for OSA
15:21:51 <sshnaidm> jrosser, using openstack ansible collection?
15:22:24 <sshnaidm> would be interesting to look at
15:23:05 <sshnaidm> ok, moving on
15:23:25 <gtema> wait, someone did/will fill in https://openstackfoundation.formstack.com/forms/june2020_virtual_ptg_survey?
15:23:46 <jrosser> my computer is just sulking, I’ll drop a link here when I can
15:24:11 <sshnaidm> gtema, hmm.. not sure what it is
15:24:20 <sshnaidm> gtema, is it for projects..?
15:24:22 <mordred> gtema: oh - poo, no I haven't. I filled out the original in-person one
15:24:29 <gtema> well, afaiu it is to schedule a slot itself
15:24:33 <mordred> sshnaidm: you want to fill that out?
15:24:38 <gtema> https://ethercalc.openstack.org/126u8ek25noy
15:24:44 <noonedeadpunk> sshnaidm: https://review.opendev.org/#/q/topic:osa-collections+(status:open+OR+status:merged)
15:24:48 <sshnaidm> mordred, yeah, np
15:24:50 <gtema> were some mails from Kendal
15:25:04 <sshnaidm> mordred, but do we need it if we have it in scope of sdk?
15:25:16 <mordred> sshnaidm: lemme dig in
15:25:23 <mordred> and I'll let you know :)
15:25:33 <sshnaidm> mordred, yeah, tell me if I need to fill something
15:25:54 <jrosser> https://review.opendev.org/#/q/topic:osa-collections
15:26:14 <sshnaidm> jrosser, thanks
15:26:28 <sshnaidm> #link https://review.opendev.org/#/q/topic:osa-collections
15:27:41 <sshnaidm> ok, we'll handle ptg times with mordred, hope to choose the convenient hours for all :)
15:27:53 <sshnaidm> moving on
15:28:01 <sshnaidm> Releasing first version - ?
15:28:15 <gtema> we didn't already???????
15:28:33 <sshnaidm> afaik no, only if mordred did.. ?
15:28:46 <gtema> it was ironic (not baremetal)
15:29:17 <mnaser> sorry i got disconnected
15:29:29 <sshnaidm> #link https://galaxy.ansible.com/openstack/cloud
15:30:06 <sshnaidm> mnaser, if you're interested in openstack ansible modules PTG session, please add topics: https://etherpad.opendev.org/p/openstack-ansible-modules-ptg
15:30:39 <mordred> sshnaidm: yeah - sorry - I meant to get up the rename patch last week
15:30:57 <mordred> I think we got the list of renames collected that people like though
15:31:35 <sshnaidm> mordred, do you want to do it after renaming? I'm not sure ansible merged their routing functionality yet..
15:32:36 <sshnaidm> mordred, maybe we can release version 1 manually first time, I don't expect any problems with it
15:32:47 <sshnaidm> "what can go wrong?" (c)
15:33:11 <mordred> hahaha
15:34:04 <mordred> I think we can actually probably do it either way - we'll use symlinks and routing and stuff to make the old names work still
15:34:52 <sshnaidm> mordred, yeah, and we can add deprecate messages if people use old names
15:34:54 <mordred> lemme play a little this afternoon and see how bad it is - if it works ok - then yeah, maybe we go ahead and cut a 1.0 as it is now
15:34:56 <mordred> yeah
15:34:59 * sshnaidm learnt how to do it
15:35:06 <mordred> cool
15:35:11 <sshnaidm> great
15:35:21 <sshnaidm> ok, moving on
15:35:30 <sshnaidm> Openstack module class - whether we go with it and how to handle authorization better
15:35:41 <mordred> I like your patch!
15:35:51 <mordred> I think it makes things nicer
15:35:59 <gtema> I am all for this generalization, and I want to implement tagging on top of it
15:36:02 <sshnaidm> yeah, I have a patch to use it for another module https://review.opendev.org/#/c/721580/
15:36:17 <sshnaidm> gtema, that would be great
15:36:23 <gtema> and wrt this patch, do we really want "from .. import"
15:36:30 <gtema> I was newer fan of those
15:36:36 <mordred> oh - and I see your deprecae message!
15:37:04 <sshnaidm> gtema, yeah, tried it as I saw somewhere in ansible people use it
15:37:24 <sshnaidm> gtema, I'm not sure it's the best solution though, but kind of simplifying things
15:37:25 <mordred> yeah - I'm also not a fan - I think it's less readable personally
15:37:27 <gtema> I know it works, but I do not like it - it is so hard to get where you are
15:37:31 <mordred> yeah
15:37:46 <sshnaidm> ok, not objections to remove it
15:37:49 <mordred> cool
15:38:09 <sshnaidm> mostly added it because it gives a better autocomplete in ide :D
15:38:56 <sshnaidm> so, I'd encourage people to add things more to OpenstackModule class if you see something common in modules
15:39:28 <mordred> ++
15:39:40 <gtema> they all have this stuff in common, so I see nothing blocking to move them all, it's just a big change
15:39:42 <mordred> I think there's probably more than one thing we can clean up
15:39:45 <gtema> and people hate me for that
15:40:00 <mordred> gtema: we love your big changes!@
15:40:01 <sshnaidm> gtema, we can do it module by module
15:40:16 <gtema> oh thank you guys
15:40:23 <gtema> you pleased my day
15:40:52 <gtema> where adding in downstream one service in SDK and OSC is generating +4k lines in one day
15:41:23 <sshnaidm> downstream SDK?
15:41:31 <gtema> yupp, we have that as well
15:41:43 <sshnaidm> nice
15:41:51 <gtema> an extensions for the public clouds, with services not part of vanilla
15:42:03 <gtema> or behaving stupidly different
15:42:38 <sshnaidm> I see, so modules can behave different as well?
15:43:04 <gtema> sure, if cloud does not offer Octavia, but decides to live further with Neutron LB
15:43:16 <gtema> there is no other way around
15:43:42 <sshnaidm> right
15:43:48 <gtema> and other fun stuff (i.e. in the volume backup the snapshot is mandatory)
15:44:50 <sshnaidm> ok, so any other topics to talk?
15:45:01 <sshnaidm> any ideas for improvement
15:45:04 <sshnaidm> complaints
15:45:05 <gtema> btw question to the round: how many public clouds are there in the wild without shared SNAT?
15:45:22 <mordred> gtema: what do you mean?
15:45:25 <gtema> my one is willing to deprecate it and I am fighting with all possible ways
15:45:32 <gtema> external_router
15:46:08 <mordred> so - they want to have floating ips but they want to make each project set up something themselves?
15:46:13 <gtema> or it is called external_gateway
15:46:21 <mordred> sorry - I'm still coffeeing and am a little slow
15:46:29 <gtema> nope, it's to give VM access to internet without FIP
15:46:41 <gtema> shared_snat as prop on the router
15:46:46 <mordred> ah - nod
15:46:47 <sshnaidm> gtema, so dhcp just allocates external IP
15:46:58 <mordred> access to internet without fip is important
15:47:23 <gtema> well, even that is not really fitting - in the backend they all get router somehow through a set of public IPS
15:47:40 <mordred> otherwise vms can't do things like "apt-get install"
15:47:53 <mordred> (for vms that are intended to otherwise be private)
15:47:55 <gtema> I know it is important, but not sure this is used by lots of installations
15:48:16 <mordred> I'm pretty sure it works on every cloud out there
15:48:24 <gtema> unfortunately is not enforced in RefStacl either
15:48:28 <gtema> RefStack
15:48:33 <sshnaidm> gtema, we use it in 3party jobs
15:48:35 <mordred> well - nothing about sane networking is enforced in refstack
15:48:50 <dtantsur> who would need sane networking?
15:48:51 <mordred> but yeah - I'm pretty sure I know of _no_ clouds that make you get a FIP to get outbound network access
15:49:02 <dtantsur> stay at home with your filthy packages!
15:49:11 <mordred> gtema: so I'd actually argue that literally every FIP-using cloud I'm aware of works this way
15:49:15 <gtema> you can deploy an analog of AWS NAT instance gateway
15:49:29 <mordred> I don't know what that is - I don't work on AWS
15:49:30 <gtema> and do "manual" routing/SNATting
15:49:36 <mordred> that sounds very stupid
15:49:36 <dtantsur> requiring a FIP for outbound access does sound evil to me
15:49:44 <gtema> me neither, just know they do it this way
15:49:49 <dtantsur> double-stupid if you have quotas for FIPs
15:49:52 <mordred> yup
15:49:59 <gtema> of course you do :D
15:50:30 <mordred> in fact - we have clouds we use where we're only getting IPv6 addresses on the nodes
15:50:44 <mordred> and they use a shared SNAT to get outbound access to ipv4 even
15:50:53 <gtema> hehehehe, we wait for IPv6 for some years still
15:51:05 <mordred> clouds without ipv6 are so broken
15:51:08 <dtantsur> ++
15:51:09 <mordred> it's 2020
15:51:19 <dtantsur> c'mon, it's Germany, we have a good proportion of IPv6 support here
15:51:22 <gtema> oh yeah, life is at all so broken
15:51:23 <mordred> all of the crazy nat brokeness goes away when you just go ipv6
15:51:35 <mordred> like - NAT in clouds only exists for historical reasons
15:51:38 <mordred> it's not a good design
15:51:47 <gtema> guys, you know whom I am talking about - I can not do much against
15:51:48 <mordred> it's just necessary when the cloud is broken because it doesn't have v6
15:51:50 <sshnaidm> dtantsur, lucky, we don't have even one ISP providing ipv6
15:52:14 <mordred> gtema: I do - they're obsessed with chasing AWS decisions, even when they're bad, and even when AWS would tell you that they're bad
15:52:24 <dtantsur> sshnaidm: Oo
15:52:46 <gtema> I would have told you lots of new stories if we would have meet in person
15:52:54 <dtantsur> sigh
15:53:07 <dtantsur> we need a drink-and-tell call after the PTG
15:53:22 <gtema> unfortunately virtually would be quite hard
15:53:22 <sshnaidm> dtantsur, add this to etherpad :)
15:53:48 <dtantsur> added
15:53:52 <gtema> cool
15:54:02 <sshnaidm> I never drank virtually, but I've heard people do it and even for money..
15:54:16 <dtantsur> wait, I could earn money all this time???
15:54:29 <sshnaidm> dtantsur, a lot of opportunities!
15:54:37 <gtema> you could have done this, but it is perhaps too late
15:55:15 <sshnaidm> ok, let's end the meeting
15:55:16 <sshnaidm> #endmeeting