16:00:25 <edleafe> #startmeeting api-sig
16:00:26 <openstack> Meeting started Thu Aug 17 16:00:25 2017 UTC and is due to finish in 60 minutes.  The chair is edleafe. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:27 <cdent> but on eavesdrop we have any entry
16:00:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:31 <openstack> The meeting name has been set to 'api_sig'
16:00:35 <edleafe> see?
16:00:40 <cdent> yeah, I get that
16:00:43 <edleafe> Now to check the logs
16:00:59 <elmiko> we're gonna have to fix up the wiki page agenda and maybe another spot or two
16:00:59 <cdent> but: oh never mind, you did update eavesro
16:01:05 <cdent> that’s what I was really asking: https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:01:09 <cdent> I mean http://eavesdrop.openstack.org/#API_Special_Interest_Group
16:01:18 <edleafe> yep, http://eavesdrop.openstack.org/meetings/api_sig/2017/
16:01:18 * elmiko is so confused
16:01:33 <cdent> elmiko: don’t worry, just accept it as the natural state of the universe
16:02:16 <edleafe> in case you didn't see: https://review.openstack.org/493896
16:02:17 <elmiko> ohmmmmm
16:03:13 * cdent thinks that edleafe should run the show today
16:03:24 <cdent> because he’s clearly more on top of things than me or elmiko
16:03:30 <elmiko> +1
16:03:37 <edleafe> well, since I was doing the name change stuff
16:04:15 <edleafe> #chair cdent elmiko edleafe
16:04:15 <openstack> Current chairs: cdent edleafe elmiko
16:04:19 <cdent> yeah, I hadn’t realized how far along you had got
16:04:33 <edleafe> I had some time one afternoon...
16:04:49 <elmiko> very nice edleafe =)
16:05:06 <elmiko> and what is this word "time" you speak of?
16:05:32 <edleafe> elmiko: well, it lasted so quickly I can't remember :)
16:05:38 <elmiko> LOL
16:06:19 <elmiko> we really should have become "openstack-comedy-hour-sig", so much easier to attract newcomers
16:06:50 <edleafe> #topic previous meeting action items
16:06:51 <edleafe> #link http://eavesdrop.openstack.org/meetings/api_wg/2017/api_wg.2017-08-10-16.00.html
16:07:00 <edleafe> The only one was mine
16:07:21 <elmiko> is there more to do still?
16:07:36 <edleafe> #action edleafe to continue with the renaming work as time permits
16:07:42 <cdent> we have an open question on how/whether to deal with launchpad and git
16:07:44 <edleafe> elmiko: there's that 'time' thing agan
16:07:46 <edleafe> again
16:07:51 <elmiko> ;)
16:08:13 <elmiko> cdent: ah, right. good point
16:08:33 <edleafe> Yeah, I started looking at launchpad, but ran out of time
16:08:38 * cdent consider adding purplerbot to this channel just so I can transclude dtantsur
16:08:39 <edleafe> it wasn't obvious
16:08:46 <cdent> infra probably knows?
16:09:00 <edleafe> probably
16:10:02 <edleafe> #topic open mic and new biz
16:10:14 <edleafe> I guess this is more "new" biz
16:11:01 <edleafe> Anything else interesting to discuss?
16:11:12 <elmiko> are we ready to move forward on https://review.openstack.org/#/c/487847/ ?
16:11:30 <elmiko> i wasn't sure if we needed something more before approving and starting to email folks
16:11:48 <cdent> I think we should probably move that along, so we can start publishing something about it before ptg
16:12:08 <elmiko> agreed, i'd like to give folks at least a few weeks to consider it
16:12:14 <cdent> I’ve added a blurb about it in the description for api-wg^wsig room that will be published somewhere
16:12:21 <elmiko> +1
16:12:36 <edleafe> I haven't seen it since ps3 - looking now
16:13:08 <elmiko> cool
16:13:23 <edleafe> ah, mostly just typo fixes
16:14:03 <elmiko> yeah, i think i may have added something to address a concern from dtantsur
16:14:08 <edleafe> I added a +1. We don't need to send this for wider review, as it's not a guideline?
16:14:30 <elmiko> that's what i was thinking
16:15:08 <elmiko> it also modifies the index/toc page for the guidelines site to separate these wg/sig oriented process docs from the actual guidelines
16:16:02 <edleafe> So cdent - your view on merging this?
16:16:08 <cdent> yes
16:16:27 <edleafe> yes - as in "yes, let's merge it"?
16:16:39 <cdent> yes, let's
16:16:48 <cdent> in fact I’m happy to do so
16:16:49 <edleafe> done
16:16:51 <elmiko> hehe
16:17:13 <cdent> sharked
16:17:13 <elmiko> \o/
16:17:30 <edleafe> elmiko: Now that all PTLs are set, will you be sending something to them about this?
16:18:45 <elmiko> sure, i can take that action
16:19:01 <elmiko> is there a convenient link to a governance repo with the emails?
16:19:17 <elmiko> #action elmiko email ptls about guided review process
16:19:18 <edleafe> #action elmiko to send an email to all PTLs regarding the guided review process at PTG
16:19:24 <elmiko> ops
16:19:24 <edleafe> jinx
16:19:27 <elmiko> =)
16:19:31 <edleafe> #undo
16:19:32 <openstack> Removing item from minutes: #action elmiko to send an email to all PTLs regarding the guided review process at PTG
16:19:36 <elmiko> first round is on me in denver ;)
16:19:56 <edleafe> #undo
16:19:57 <openstack> Removing item from minutes: #action elmiko email ptls about guided review process
16:20:02 <edleafe> #action elmiko to send an email to all PTLs regarding the guided review process at PTG
16:20:12 <edleafe> ok, now you only have to do it once :)
16:20:20 <elmiko> much appreciated =)
16:20:30 <edleafe> Any other new biz?
16:20:40 <cdent> more on the ptg:
16:20:48 * cdent looks for link
16:21:14 <cdent> okay with the blurb here: https://docs.google.com/document/d/1rM-LjcJTxzrffNZ_R1cN3yW9bIJsE5i2Udj8c-yJfss/edit#heading=h.75oe5h7u76xv
16:21:16 <cdent> ?
16:21:30 * elmiko looks
16:21:50 <cdent> general question is what we gonna do with all that time and space
16:21:54 <elmiko> yeah
16:22:02 <elmiko> your blurb lgtm
16:22:18 <cdent> additional point: join openstack-ptg to discuss and gain access to using ptgbot (did you get mail about that, or was it only me?)
16:22:28 <elmiko> will we be able to schedule something so that people know when we might talk about the guidelines?
16:22:36 <elmiko> i did not
16:22:47 <edleafe> nor I
16:23:27 <elmiko> also, should we have a microversion therapy session?
16:23:35 <elmiko> XD
16:24:00 <edleafe> elmiko: I found this page: https://wiki.openstack.org/wiki/Governance/CurrentPTLs
16:24:10 <edleafe> but it's a tad out-of-date :)
16:24:27 <elmiko> yeah, hmm
16:24:46 <elmiko> i'll go through the ptl announcements on the dev list, maybe there is a comprehensive list
16:24:57 <edleafe> elmiko: this looks better: http://git.openstack.org/cgit/openstack/governance/tree/reference/projects.yaml
16:24:58 * cdent forwards the ptgbot email
16:26:00 <elmiko> ooh! thanks edleafe++
16:26:14 * edleafe starts looking in his spam folder, with all the rest of cdent's emails
16:26:19 <elmiko> i'll get this email out before cob tomorrow
16:26:23 <cdent> I thought I had fixed that?
16:26:26 * elmiko chuckles
16:26:41 <elmiko> you fixed edleafe's killfile? XD
16:27:27 * edleafe thinks he gurt cdent's feelings
16:27:33 <edleafe> s/gurt/hurt
16:28:00 <cdent> aw, no, I suffer from running my own mail server which means the big dogs don’t like to accept my mail
16:28:23 <elmiko> that unfriendly of them
16:28:32 <edleafe> that was my problem too
16:28:41 * elmiko checks his junk folder
16:29:05 <edleafe> but now I route everything through gmail, and it works fine
16:29:29 <elmiko> nah, i don't have it
16:29:49 <edleafe> I got it
16:30:09 <cdent> what’s the right address for you elmiko ?
16:30:25 <elmiko> msm@redhat.com
16:30:39 <cdent> that is the one I used
16:30:44 * cdent stews
16:30:46 * elmiko really needs to get elmiko@redhat.com
16:31:08 <elmiko> yeah, i don't see it in junk either
16:31:17 * cdent sends it via gmail
16:31:29 <elmiko> and thus dies the free internet...
16:31:34 * elmiko plays taps
16:31:43 <edleafe> it's been dead for some time
16:31:51 <edleafe> at least email has
16:31:51 <cdent> splitters
16:32:30 <elmiko> too true edleafe
16:32:41 <elmiko> got it cdent
16:32:48 <edleafe> ok, let's move on
16:32:48 <edleafe> #topic guidelines
16:32:48 <edleafe> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:32:52 <edleafe> #link https://review.openstack.org/#/q/status:open+project:openstack/api-sig,n,z
16:32:52 <cdent> anyway, the point of ptgbot is to make it easy to announce to the world at large about room schedules:
16:33:04 <cdent> http://ptg.openstack.org/ptg.html
16:33:29 <elmiko> yeah, looks cool
16:33:39 <edleafe> The only interesting thing to discuss is cdent's extension thing: https://review.openstack.org/491611
16:33:41 <cdent> I haven’t had a chance to get back to the extensions thing.
16:33:49 <cdent> your suggestions, edleafe, are helpful
16:33:59 <cdent> I’m unsure on how much of mordred’s considerations to include
16:34:55 <edleafe> Heh, it all starts to sound the same
16:35:13 <edleafe> "Don't do X. But since everyone's already doing X, ..."
16:35:36 <elmiko> i like edleafe's update to the paragraph i was stuck on
16:36:16 <elmiko> i'll add my thoughts on the review
16:37:27 <elmiko> cdent: re: mordred's comments, i'm not sure either
16:38:02 <edleafe> any other reviews on your minds?
16:38:40 <cdent> i don’t think anything else has had action
16:39:21 <edleafe> #topic bug review
16:39:22 <edleafe> #link https://bugs.launchpad.net/openstack-api-wg
16:39:29 <edleafe> Nothing new there
16:39:46 <edleafe> #topic weekly newsletter
16:39:47 <edleafe> #link https://etherpad.openstack.org/p/api-sig-newsletter
16:39:53 <edleafe> Volunteers?
16:40:09 * cdent is half asleep
16:41:19 * edleafe pokes elmiko
16:41:25 <elmiko> yup, i can take it
16:41:51 <edleafe> hehehe
16:41:54 <elmiko> =)
16:41:57 <cdent> that was more painful than usual, this day has some oooph on it
16:42:12 <elmiko> cdent: that's a bummer =(
16:42:37 <edleafe> oops, bad link there
16:42:40 <cdent> I think it is post RC fatigue combined with pre-PTG fatigue combined with ?
16:42:44 * edleafe should update that
16:43:06 <edleafe> #link https://etherpad.openstack.org/p/api-wg-newsletter
16:43:47 <edleafe> #action edleafe to move newsletter etherpad after newsletter is sent
16:44:10 <edleafe> So... anything else? Or can we tuck cdent into bed?
16:44:13 <elmiko> cool, i'll ping in sdks when i've got something
16:44:18 <elmiko> i'd say tuck cdent in
16:44:23 <cdent> probably for the best
16:44:29 * elmiko gets out _Goodnight Moon_
16:45:18 <edleafe> #endmeeting