16:00:47 <elmiko> #startmeeting api-sig
16:00:48 <openstack> Meeting started Thu Aug 24 16:00:47 2017 UTC and is due to finish in 60 minutes.  The chair is elmiko. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:52 <openstack> The meeting name has been set to 'api_sig'
16:01:38 <elmiko> #chair edleafe cdent
16:01:38 <openstack> Warning: Nick not in channel: cdent
16:01:40 <openstack> Current chairs: cdent edleafe elmiko
16:01:45 <dtantsur> o/
16:01:57 <elmiko> hey
16:02:00 <cdent> o/
16:02:14 <cdent> sorry, was busily trying to convince other TC that code complexity is a real problem
16:02:19 <elmiko> #link https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:02:21 <elmiko> no worries
16:02:42 <elmiko> wow, that sounds like an intense discussion with lots of code samples
16:02:58 <cdent> we got an edleafe ?
16:03:15 <elmiko> haven't heard from him, but he's around somewhere
16:03:57 <elmiko> maybe give him a minute or 2?
16:05:18 <elmiko> #topic previous meeting action items
16:05:25 <elmiko> #link http://eavesdrop.openstack.org/meetings/api_sig/2017/
16:05:50 <elmiko> so, i did my email thingie
16:06:22 <elmiko> only got 2 responses, one was an out-of-office notice, the other was a suggestion about hitting more PTLs
16:06:45 <cdent> did you not hit all the ptls?
16:06:58 <elmiko> but, i did get into a chat with the PTL for sahara and he was considering if they should do a review
16:07:06 <elmiko> i *think* i did
16:07:13 <elmiko> i used the list from the governance rpo
16:07:17 <elmiko> *repo
16:07:39 <dtantsur> I'm still interested, but I did not have any time to wrap my head around it
16:08:07 <cdent> well, seeing as we don’t have a ton of topic prepare for the ptg, we may be able to take walkins
16:08:14 <elmiko> yeah
16:08:19 <elmiko> this was the list i used
16:08:20 <elmiko> https://github.com/openstack/governance/blob/master/reference/projects.yaml
16:08:31 <cdent> #link ptg etherpad https://etherpad.openstack.org/p/api-ptg-queens
16:08:34 <elmiko> there was some concern that maybe the queens PTLs had not been added yet
16:08:47 <elmiko> ack, i can send the email again just to be certain
16:10:08 <elmiko> anything else about the ptl list or action items?
16:10:17 <cdent> a valid point. but I also think rc2 is an issue. and also, for many this api stuff is not really all that relevant in the grand scheme
16:10:26 <elmiko> great point
16:10:54 <cdent> so I think if we get one or two respondents _this year_, that’s a success
16:10:57 <cdent> (unfortunately)
16:11:01 <elmiko> agreed
16:11:10 <elmiko> and i can send the email again when we are like 1 week out from the ptg
16:11:15 <cdent> it’s useful to have the service written up, something we can point to
16:11:18 <cdent> that’s a good idea
16:11:35 <elmiko> #action elmiko send ptl email again 1 week before ptg
16:11:40 <elmiko> just so i don't forget
16:11:41 <cdent> (I’ve remembered where edleafe is: he had an appointment and will not be here today, I’m supposed to assign all actions to him)
16:11:49 <cdent> ✔
16:11:49 <elmiko> LOL
16:11:52 <dtantsur> :D
16:12:04 <elmiko> #action edleafe take care of stuff
16:12:11 <cdent> +2W
16:12:15 <elmiko> hahaha
16:12:17 <cdent> and so it shall be
16:12:24 <elmiko> moving along
16:12:24 <elmiko> #topic open mic and new biz
16:12:45 <elmiko> anything here to review?
16:12:47 <cdent> ed has the ball on SIG namign stuff
16:12:52 <cdent> I don’t know the state
16:12:57 <elmiko> ack
16:13:06 <elmiko> for posterity
16:13:08 <elmiko> #link https://etherpad.openstack.org/p/api-ptg-queens
16:13:33 <cdent> elmiko are you signed up for ptgbot: http://ptg.openstack.org/ptg.html
16:13:40 <cdent> I think we got edleafe signed up
16:14:02 <elmiko> i looked at it, don't think i'm authorized to do anything though
16:15:28 <elmiko> do i need to make a request in the ptg channel?
16:15:30 <cdent> you have to ask in #openstack-prg
16:15:37 <cdent> sorry #openstack-ptg
16:15:51 <elmiko> ack
16:15:53 <elmiko> thanks
16:16:14 <diablo_rojo_phon> elmiko: I can get you access in a bit once you hop in the channel.
16:16:34 <cdent> elmiko: you’ll like the bot because it says “ack” a lot
16:16:36 <elmiko> ah, sweet
16:16:41 <elmiko> =)
16:16:50 <elmiko> gotta ack
16:16:59 <elmiko> diablo_rojo_phon: i just dropped a message in there
16:17:14 <elmiko> ok, anything else we should cover here?
16:17:27 <elmiko> actually, i just thought of something
16:17:31 <cdent> api-sig diner
16:17:34 <cdent> dinner
16:17:41 <cdent> I’m thinking monday is best
16:17:49 <elmiko> did we come up with any sort of agenda for talking with the sdk folks?
16:17:57 <elmiko> agreed, monday works for me
16:18:21 <cdent> as far as I can tell flanders put more stuff on the sdk etherpad (linked from that series of email) but I got no real sense of next actions
16:18:22 <dtantsur> currently the ironic folks also seems to prefer monday for our dinner..
16:18:32 <dtantsur> but this may change (and you may ignore me anyway)
16:19:14 <cdent> aw, it wouldn’t be the same without you
16:19:25 <elmiko> maybe sunday night?
16:19:27 <cdent> but I think elmiko may be leaving on tuesday? and I’m busy sunday
16:19:36 <elmiko> yeah, i'm out tuesday afternoon
16:20:18 <elmiko> ok, well if you don't make the dinner dtantsur, maybe you can make the api-sig barcrawl
16:20:19 <cdent> monday it is
16:20:36 <dtantsur> okay, maybe it's not going to end up on Monday. the ironic party, I mean..
16:20:39 <cdent> various emails suggest that where the hotel is is a bit of a wasteland
16:20:54 <cdent> but we’ll cross that bridge closer to the time
16:21:02 <elmiko> #agreed api-sig ptg dinner on monday night
16:21:10 <elmiko> sounds good
16:21:20 <dtantsur> it looked a wasteland on the google street view indeed
16:21:24 <cdent> speaking of: I will miss the next two meetings. I’ll be flying the next one, and at some “edge” conference the next one.
16:21:40 <elmiko> noted
16:21:46 <elmiko> #topic guidelines
16:22:00 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:22:07 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-sig,n,z
16:22:27 <elmiko> the extensions peice is coming along nicely
16:22:32 <cdent> the only one in any reviewable state is mine and I think that needs more local review before being frozen
16:22:34 <cdent> jinx
16:22:35 <elmiko> should we wait for more +1s before going to freeze?
16:22:36 <elmiko> haha
16:22:41 <elmiko> i
16:22:48 <elmiko> i'm good with waiting for more reviews
16:23:26 <elmiko> and i guess at some point we'll need to circle back around on mordred's PRs?
16:24:22 <cdent> yes, I was thinking about that this morning and wondered whether one of us needs to pick them up, but then decide there was too much other stuff on my radar to think about that
16:24:27 <cdent> (so stopped)
16:24:53 <elmiko> well, at the least we could talk about it at the ptg (assuming no movement by then)
16:24:59 <cdent> tru
16:25:05 <elmiko> i fear i'm in the same boat as you, work-wise
16:25:47 <cdent> speaking of ptg topics, I wrote this as sort of a get my thoughts aligned for when people ask about them: https://anticdent.org/microversion-conversion-therapy.html
16:26:17 <elmiko> very groovy
16:26:34 <elmiko> should we post a sign about "microversion therapy $0.05" ?
16:27:00 <cdent> sure, why not
16:27:41 <elmiko> ok, so that can also be a possible topic if we get enough people interested
16:27:56 <cdent> yeah it’s already on the etherpad
16:28:06 <elmiko> awesome
16:28:22 <elmiko> #topic bug review
16:28:32 <elmiko> #link https://bugs.launchpad.net/openstack-api-wg
16:28:38 <elmiko> #link https://bugs.launchpad.net/openstack-api-sig
16:28:41 <cdent> I closed a bug (the placement needs a service type one)
16:28:45 <cdent> and I added some comments on https://anticdent.org/microversion-conversion-therapy.html
16:28:49 <cdent> whooops not that
16:28:56 <elmiko> hehe
16:28:57 <cdent> #link singular resource https://bugs.launchpad.net/openstack-api-wg/+bug/1593310
16:28:58 <openstack> Launchpad bug 1593310 in openstack-api-sig "guidance required on the basic form for representing a singular resource" [Undecided,New]
16:29:06 <elmiko> yeah, you've been burning down our tech debt
16:29:09 <elmiko> cdent++
16:29:26 <cdent> that one may need some discussion, there are effectively three options: top level, nested by type, something like jsonapi
16:29:42 <cdent> lifting and shifting people to jsonapi is likely impossible (also it is weird)
16:29:50 <cdent> we have a mixture of the other two options throughout openstack
16:29:52 <elmiko> yeah, i could see that
16:30:23 <elmiko> when you say "nested by type", that is a resource contained in a json object with it's key being the type?
16:30:50 <elmiko> {"mytype": ....}
16:30:50 <cdent> yeah top-level: /foo/id -> {‘name’: ‘barney’}
16:30:57 <elmiko> ack
16:31:08 <elmiko> i really like your note about getting some outside input
16:31:10 <cdent> nested: /foo/id -> {‘foo’: {‘name’: ‘barney’}}
16:31:33 <elmiko> i have a feeling i know what i'd push as a guideline, but i like hearing other opinions
16:31:37 <cdent> jsonapi: /foo/id -> {data: {‘type’: ‘foos’, ‘name’: ‘barney’}}\
16:32:01 <cdent> (and there are other keys besides data
16:32:06 <elmiko> right
16:32:38 <elmiko> i've looked at jsonapi, like you mention it would be nearly impossible to get that across the projects
16:32:40 <cdent> I don’t like nested because I think that’s an indicator that you must have bad URIs, but then again, it is all over the place
16:33:00 <elmiko> interesting
16:33:11 <elmiko> i thought nested would be better as it's more explicit
16:34:11 <cdent> I think it probably really comes down to what I’m used to/used before
16:34:20 <elmiko> gotcha
16:34:23 <cdent> and no _real_ reason
16:34:44 <elmiko> yeah, i've heard explanations about why nested might be preferred, but never about top level
16:34:59 <elmiko> and the nested explanations probably also suffered from perception bias
16:36:10 <cdent> probably strong typers!
16:36:21 <elmiko> exactly
16:36:23 * elmiko chuckles
16:36:53 <cdent> anyway, I’ll link this to that bug, so we have some additional info
16:36:59 <elmiko> great, thanks
16:37:01 <cdent> and try to incorporate what I hear from others
16:37:18 <elmiko> if we get lonely at ptg, we can start an argument about it XD
16:37:38 <cdent> arguments++
16:37:46 <elmiko> hehe
16:38:08 <elmiko> ok, then, moving along
16:38:13 <cdent> I suspect it is my turn for the newsletter?
16:38:30 <elmiko> #topic weekly newsletter
16:38:40 <elmiko> #link https://etherpad.openstack.org/p/api-sig-newsletter
16:38:48 <elmiko> or we can dice off for it or something?
16:39:21 <cdent> heh, unless you for some reason really want to do it I’ll get it this time since I’ll be gone for the next two
16:39:44 <elmiko> sounds good
16:39:45 <elmiko> thanks
16:40:18 <elmiko> well then, safe travels cdent and we'll see you in denver =)
16:40:20 <cdent> i’ll ping you when I need a proof
16:40:25 <cdent> yeah, looking forward to it
16:40:26 <elmiko> thanks dtantsur
16:40:29 <elmiko> great cdent
16:40:35 <elmiko> #endmeeting