16:00:48 <edleafe> #startmeeting api-sig
16:00:57 <openstack> Meeting started Thu Sep  7 16:00:48 2017 UTC and is due to finish in 60 minutes.  The chair is edleafe. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:58 <elmiko> beat me to it
16:00:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:02 <openstack> The meeting name has been set to 'api_sig'
16:01:07 <dtantsur> o/
16:01:09 <edleafe> #chair cdent elmiko edleafe
16:01:15 <openstack> Warning: Nick not in channel: cdent
16:01:16 <openstack> Current chairs: cdent edleafe elmiko
16:01:26 <edleafe> #link https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:01:48 <edleafe> cdent isn't around; I think he's enjoying his time between vmware visit and PTG
16:01:53 <elmiko> gotcha
16:02:34 * dtantsur will have to run after roughly 30 mins
16:03:01 <edleafe> dtantsur: it shouldn't take that long :)
16:03:02 <edleafe> #topic previous meeting action items
16:03:03 <edleafe> #link http://eavesdrop.openstack.org/meetings/api_sig/2017/
16:03:19 <edleafe> Only action was for elmiko to send another note to PTLs, and that was done
16:03:27 <edleafe> Still no takers?
16:03:27 <elmiko> \o/
16:03:30 <elmiko> nah
16:03:43 <elmiko> i think dtantsur and tellesnobrega are the only people who have expressed any interest
16:04:09 <elmiko> i also am putting together my test case to use, so we'll have something to discuss on that front
16:04:27 <edleafe> Maybe we should follow up with the PTLs later asking why: did they not feel that it was needed, or did they not want to appear dumb, or...
16:04:37 <elmiko> great idea
16:04:50 <dtantsur> what I hear is: changing API is too hard, so we probably just leave it as it is..
16:04:54 <elmiko> we could put together a google form and mail it out after the ptg ?
16:04:58 <dtantsur> it may be different for people who itnroduce moar new API
16:05:04 <edleafe> We can use the docs from the test case to explain it better
16:05:09 <elmiko> good point dtantsur
16:05:25 <elmiko> edleafe: that's what i was hoping, something to seed our example case
16:05:26 <edleafe> dtantsur: yeah, I didn't want them to think that was the goal
16:05:48 <edleafe> dtantsur: it was more for new/planned APIs and changes
16:06:17 <dtantsur> then maybe we should reach out to people who just plan on joing the big tent (or how is it called now?)
16:06:39 <dtantsur> they have bigger chances of needing our guidance
16:07:05 <elmiko> yeah, if we could have something that new projects could evaluate early in their process that would be excellent
16:07:06 <edleafe> It's now "the cozy condo"
16:07:13 <elmiko> LOL
16:07:27 <dtantsur> meaning: reach out not only to the official PTLs, but to leaders of the candidate projects
16:07:30 <dtantsur> yep :D
16:07:56 <elmiko> i think they missed a great opportunity to call it the Big Bike Shed
16:07:58 <edleafe> Do we have a resource listing such people?
16:08:06 <edleafe> elmiko: :)
16:08:09 <dtantsur> may require some manual work..
16:08:17 <edleafe> truth in packaging
16:08:17 <elmiko> not sure if the governance repo has anything like that
16:08:34 <elmiko> but yeah, we'll probably have to pepper the mailing lists
16:08:39 <dtantsur> we can start with proposed governance changes
16:08:41 <edleafe> yeah, I'm only aware of them when they apply for inclusion
16:08:44 <dtantsur> there are like 4 projects proposed IIRC
16:08:52 <cdent> I’m not really here
16:08:55 <edleafe> cdent could help with that
16:08:59 <edleafe> if he were here
16:09:03 <dtantsur> WHO IS TALKING??
16:09:10 <cdent> what can I help with?
16:09:13 <elmiko> is there any way we could get a blog post put up on the official openstack.org site?
16:09:31 <elmiko> or maybe superuser or something
16:09:52 <edleafe> cdent: sending the PTL invitation to new projects that are not yet in the ${BIG_TENT_REPLACEMENT}
16:10:00 <elmiko> cdent: we're discussing how we can reach out to new projects before they have joined the community, to help get the api messaging out earlier in their process
16:10:17 <dtantsur> then there is this Mogan project, which is Nova-for-Bare-Metal
16:10:25 <cdent> I’d say watch the commit logs for project-config, not governance
16:10:29 <dtantsur> they introduce new APIs on top of a nova-ish thing
16:10:59 <cdent> as governance will only get you stuff that is wanting to be "official"
16:11:04 <cdent> by then it is usually too late
16:11:39 <elmiko> yeah
16:12:03 <edleafe> cdent: can you maybe get a list of such groups to elmiko?
16:12:30 <cdent> i can take that action, but it won’t be today
16:12:50 * mlavalle waves at cdent
16:13:15 <elmiko> i think we're talking about sending this email after the ptg, is that accurate?
16:13:16 * cdent waves at mlavalle
16:13:20 * edleafe demands that cdent drop whatever he's doing and serve elmiko instead
16:13:24 <elmiko> haha
16:13:30 <cdent> I’ve missed these special moments
16:13:32 <dtantsur> lol
16:14:05 <edleafe> elmiko: if it were a week earlier, I'd go for it, but perhaps it's best to do it after PTG
16:14:12 <elmiko> agreed
16:14:50 <edleafe> ok, let's move on
16:14:51 <edleafe> #topic open mic and new biz
16:14:51 <edleafe> Only one item:
16:14:51 <edleafe> Turn PTG etherpad into more of a schedule
16:14:52 <edleafe> #link https://etherpad.openstack.org/p/api-ptg-queens
16:15:03 <elmiko> will there be any projects in attendence at the ptg who are prospects?
16:15:03 <edleafe> We've kind of started that
16:15:27 <edleafe> elmiko: prospects for... ?
16:16:06 <elmiko> projects that want to join the ${BIG_TENT_REPLACEMENT}
16:16:16 <edleafe> I wouldn't expect them
16:16:27 <elmiko> ok, i didn't think so, but had to ask =)
16:16:29 <edleafe> One of the perks of being official is that you get space at PTG
16:16:34 <elmiko> right
16:16:46 <edleafe> Some official groups are doing virtual PTGs even
16:16:51 <edleafe> keeping costs down
16:16:57 <elmiko> interesting
16:16:58 <edleafe> and avoiding flying into the US
16:16:59 <cdent> elmiko: if you look at the etherpad for the SWG/TC room there’s some stuff on the new groups that are currently applying, some of which will be at ptg
16:17:14 <elmiko> cdent: ack, thanks!
16:18:09 <edleafe> I posted some proposed time boxes for the items on the PTG agenda
16:18:19 <edleafe> As elmiko already noted, some are a bit optimistic
16:18:53 <edleafe> I just wanted to signal that they were the types of topics that could fill any amount of space given to them
16:18:56 <elmiko> i think your thought process on the shorter ones was well reasoned
16:19:05 <dtantsur> do we have a slot for reading mordred's literature aloud?
16:19:08 <edleafe> So it was best to give them small targets
16:19:13 <elmiko> dtantsur: lol +1
16:19:26 <edleafe> dtantsur: let's do that after lunch when people will already be sleepy
16:19:29 <TheJulia> dtantsur: wouldn't that be mordred ranting? :)
16:19:31 <dtantsur> lol
16:19:34 <elmiko> haha
16:19:52 <dtantsur> TheJulia: we will be reading, mordred will be ranting..
16:19:56 <edleafe> We can take turns reading it in our best mordred voice
16:19:58 <dtantsur> an ideal API SIG meeting
16:20:08 <dtantsur> edleafe: you won't enjoy my accent :)
16:20:27 <edleafe> dtantsur: heh
16:21:07 <edleafe> Any other topics for new biz?
16:21:52 <mordred> gah. I REALLY need to update two docs for the ptg ...
16:21:55 <mordred> so many things, so little time
16:22:37 <edleafe> mordred: yeah, quit goofing off!
16:23:10 <edleafe> #topic guidelines
16:23:10 <edleafe> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:23:13 <edleafe> #link https://review.openstack.org/#/q/status:open+project:openstack/api-sig,n,z
16:23:28 <edleafe> No guideines listed as api-sig (yet!)
16:23:35 <edleafe> cdent
16:23:37 <edleafe> geez
16:23:53 <edleafe> cdent's extensions guideline looks pretty good
16:23:55 <cdent> wut?
16:24:03 <edleafe> is it freeze-able?
16:24:13 <elmiko> +1
16:24:19 <dtantsur> I'd say it's very straightforward
16:24:36 <dtantsur> "please don't do what ironic is doing with its API"
16:24:48 <edleafe> I haven't reviewed the latest version, so I'll do that after the meeting, and unless I find a stopper, I'll freeze it
16:24:53 <edleafe> Sound good?
16:24:57 <cdent> yes
16:24:57 <dtantsur> ++
16:25:30 <edleafe> #action edleafe to review https://review.openstack.org/#/c/491611/ and freeze it if no problems are found
16:25:33 <elmiko> edleafe: sounds good
16:25:51 <edleafe> Anything else for guidelines?
16:26:42 <edleafe> moving on...
16:26:43 <edleafe> #topic bug review
16:26:44 <edleafe> #link https://bugs.launchpad.net/openstack-api-sig
16:26:50 <edleafe> No new bugs
16:26:57 <edleafe> Any bug comments?
16:27:38 <elmiko> that link errors out for me
16:27:46 <elmiko> is it just because there are no bugs yet?
16:28:21 <edleafe> hmmm
16:28:32 <edleafe> I thought when I changed the name, the link would also follow
16:28:50 <edleafe> When I click the api-sig link, it redirects to the api-wg bug page
16:29:00 <elmiko> hrm
16:29:20 <edleafe> I'll check it out after the meeting
16:29:34 <elmiko> thanks
16:29:37 <edleafe> which leads us to...
16:29:38 <edleafe> #topic weekly newsletter
16:29:38 <edleafe> #link https://etherpad.openstack.org/p/api-sig-newsletter
16:30:03 <edleafe> elmiko: will you do the honors? Since cdent isn't here, of course
16:30:09 <elmiko> edleafe: sure thing
16:30:26 <edleafe> ok, ping us in -sdks when you're ready
16:30:35 <edleafe> Anything else before we close?
16:30:46 <elmiko> question about the freeze
16:30:58 <elmiko> should i hold off on the newsletter till you read that review?
16:31:37 <edleafe> ok, I'll do that first and then ping you
16:31:46 <elmiko> ack, i'll fix up the rest and just wait on that
16:31:52 <edleafe> you can write it up as if it will be frozen, but don't send it until it is
16:31:58 <elmiko> yup
16:32:28 <edleafe> I hope everyone has safe travels to the PTG! See you in Denver!
16:32:35 <edleafe> #endmeeting