16:00:19 <cdent> #startmeeting api-sig
16:00:23 <openstack> Meeting started Thu Oct 19 16:00:19 2017 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:26 <openstack> The meeting name has been set to 'api_sig'
16:00:28 <cdent> #chair elmiko edleafe
16:00:28 <openstack> Current chairs: cdent edleafe elmiko
16:00:40 <cdent> somebody else want to run the show? I’m all typed out?
16:01:15 <dtantsur> o/
16:01:19 <elmiko> p/
16:01:36 <edleafe> \o
16:01:58 <elmiko> i can run it, but i need like 2 minutes
16:01:58 <cdent> welcome back dtantsur
16:02:03 <cdent> thanks elmiko
16:02:38 <dtantsur> \o/ I'm getting increasingly more time free of paperwork and running around the city
16:02:41 <elmiko> alrighty then
16:02:47 <elmiko> \o/ dtantsur
16:03:03 <elmiko> #link https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:03:12 <elmiko> #topic previous meeting action items
16:03:31 <elmiko> i sent my email to the -sig ml
16:03:39 <elmiko> and added a survery
16:03:42 <elmiko> lol
16:04:04 * dtantsur suspects he needs to subscribe :D
16:04:06 <elmiko> edleafe: i saw you making some noise about the video, any response?
16:04:16 <edleafe> #link http://lists.openstack.org/pipermail/openstack-sigs/2017-October/000122.html
16:04:20 <edleafe> No response yet
16:04:23 <elmiko> #link https://goo.gl/forms/x3YPuhBcJP7n9Odt1
16:04:27 <cdent> i’m pretty sure there aren’t all that many subscribers to that list
16:04:30 <elmiko> none on the survey either
16:04:48 <elmiko> yeah, made me wonder if i should send that survey link to other lists?
16:05:00 <edleafe> That's a good question then: where do the SDK-type people hang out?
16:05:11 <elmiko> +1
16:05:11 <cdent> elmiko: you made question 3 required, but if you say no to question two it doesn’t make sense?
16:05:21 <elmiko> oops, good point. i'll fix that
16:05:49 * dtantsur has to google "APAC business hours"
16:05:50 <elmiko> ok, should be changes
16:05:55 <dtantsur> I'm not sure what it formally means
16:06:00 <dtantsur> I wonder if it's obvious for everyone else
16:06:04 <edleafe> APAC == asia pacific
16:06:09 <elmiko> i figured 9-5ish for APAC ppls
16:06:21 <dtantsur> I know what APAC means, but that region is big
16:06:25 <edleafe> So China, Japan, Australia, etc
16:06:29 <edleafe> ah
16:06:30 <dtantsur> which times in UTC do you have in mind?
16:06:42 <elmiko> and the description has this "This form is to gauge interest from the OpenStack community about meeting times for the API-SIG as they pertain to the APAC(Asia Pacific) timezones. The meetings are currently scheduled to occur weekly on Thursday at 16:00UTC."
16:06:51 <elmiko> i have no times in mind yet, i wanted to gauge interest
16:06:59 <elmiko> we'll get to that if there are ppl who want the meeting
16:07:18 * dtantsur skips the survey then
16:08:05 <elmiko> David Flanders raised a point about opening up the discussion surrounding supporting people on that side of the globe with a more convenient meeting time
16:08:19 <elmiko> we were happy to have the conversation, this survey is a first attempt
16:08:31 <cdent> I think until we see evidence of sdk discussion on any of the email lists, we’re chasing ghosts
16:08:47 <cdent> and we should encourage talk on the lists
16:08:55 <elmiko> +1
16:09:10 <edleafe> yeah, emails among a few people are far from ideal
16:09:11 <elmiko> i'll leave the survey open for awhile and hopefully it will get in front the right ppl
16:09:16 <cdent> we have an established pattern of irc for this meeting, mostly to discuss guidelines, but in general email is the only medium that has global accessibility
16:09:46 <elmiko> and i am more than happy to repost the survery on dev-ml and any other ml that is appropriate
16:09:59 <dtantsur> ironic tried experimenting with having an alternate meeting in APAC time
16:10:00 <elmiko> maybe i should reach out to Melvin to see if he has ideas on where to post?
16:10:01 <dtantsur> did not work out
16:10:09 <elmiko> we had one for api-wg too, same result
16:11:03 <edleafe> Nova alternates, but neither are convenient for APAC
16:11:17 <elmiko> it's a tough swing to make
16:11:29 <elmiko> anything else on this topic?
16:11:55 <elmiko> #topic open mic and new biz
16:11:58 <edleafe> Just that email might be better than meetings
16:12:41 <elmiko> ack, mind replying to my email on sig-ml with that thought?
16:12:57 <edleafe> will do
16:12:59 <elmiko> thanks
16:13:08 <elmiko> 2 topics on the new biz
16:13:24 <elmiko> lightning talk and new guideline, not sure who added these
16:13:39 <cdent> edleafe I reckon
16:14:35 * elmiko passes mic to edleafe
16:14:40 <edleafe> well, matt riedemann asked about the "changes-since" guideline
16:14:45 <edleafe> we don't have one
16:14:55 <dtantsur> is it something like updated_at>=..?
16:15:05 <edleafe> So I thought we'd discuss: should we create one?
16:15:11 <dtantsur> because then it feels like we should just use it + operators (we have something about them, don't we?)
16:15:24 <cdent> I feel like it’s come up before, either as a proposed thing, or maybe somewhere in the old wiki pages
16:15:46 <edleafe> dtantsur: that depends on the table definition, but in general, yeah
16:15:53 <cdent> dtantsur: it is effectively update_at>=<something> yes
16:15:59 <cdent> but there’s precedent somewhere
16:16:02 <dtantsur> I thought updated_at is (semi-)standard
16:16:13 <elmiko> cdent: yeah, this sounds familiar
16:16:16 <cdent> and because updated_at isn’t always present, it provides a bit of an abstraction
16:16:21 <edleafe> cdent: I thought that there should have been something, as it's not an esoteric question
16:17:39 <edleafe> dtantsur: I've seen 'last_updated', 'modified_time'; variations like that
16:17:44 <dtantsur> that's sad
16:17:52 <dtantsur> I was about to suggest to make updated_at standard :)
16:18:10 <edleafe> Well, yeah, that would be part of the guideline to add
16:18:49 <cdent> dtantsur: I think updated_at presumes a database table is present, one that is backed by oslodb and the timestamp mixin
16:19:02 <cdent> all of which is far more assumption than we want to be making
16:19:27 <dtantsur> how would you calculate changes-since without having such source of information?
16:19:45 <dtantsur> not necessary oslodb, anything that can hold a timestamp and do queries about it
16:19:54 <cdent> well _something_ in the store has timestamp
16:20:01 <cdent> but it might not be updated at, and it might not be a db
16:20:17 <cdent> and the api-wg^wsig doesn’t want to presuppose backends
16:20:27 <dtantsur> I don't see how this assumes a backend
16:20:38 <cdent> it would, of course, be just as abstracted to say that updated_at>= abstracts to whatever
16:21:07 <cdent> but the pre-existing pattern with sort keys and sort operators is that they _do_ map to fields on the resources
16:21:11 <cdent> and changes-since does not
16:21:15 <dtantsur> assumptions here are: 1. it's possible to know updated_at for the entity, 2. it's possible to compare updated_at values to timestamps more or less efficiently
16:21:26 <cdent> I don’t really mind that, just dredging up my recollections
16:21:50 <cdent> yes
16:23:14 <dtantsur> I'm not sure how to implement changes-since, if any of these assumptions is missing..
16:23:34 <cdent> if the entity has no times, then yeah, it is impossible
16:24:29 <elmiko> seems like we have some fodder here to at least start a guideline?
16:24:47 <cdent> prolly
16:25:32 <elmiko> dtantsur you interested in taking the lead on this one?
16:25:32 <edleafe> I'm a little swamped at the moment, but would happy to take a crack at it soon-ish
16:25:37 <dtantsur> similarly for created_at/exists-since?
16:25:49 <elmiko> edleafe: ack
16:25:49 <dtantsur> elmiko: I can, but I don't have a use case personally
16:25:54 <elmiko> ahh, ok
16:26:22 <elmiko> should we just leave it open till next time then?
16:26:37 <dtantsur> I was planning on a more interesting guideline about tasks and long running processes (remember ironic discussion at the PTG?)
16:26:44 <edleafe> elmiko: sure, perhaps by next week my patch series will have progressed enough
16:26:48 <elmiko> dtantsur: +1
16:26:50 <cdent> do we agree that it is even a good idea? I’m nonplussged.
16:27:13 * cdent needs a guideline for typing
16:27:17 <edleafe> cdent: it's boring, sure, but so are a lot of the guidelines :)
16:27:20 <elmiko> i think if projects are going to keep track of some sort of "modified at" type field, then we should have a guideline
16:27:37 <elmiko> edleafe: ++
16:27:41 <cdent> true
16:27:43 <dtantsur> elmiko: as I said, I thought it's standard :) we have created_at and updated_at in our base model
16:27:49 * cdent cruises the abandoneds
16:28:02 <dtantsur> dunno if it's the same for other projects, but I guess we copy-pasted it from nova :)
16:28:04 <elmiko> dtantsur: right, but it seems like there is some debate about how it is implemented across projects
16:28:09 <elmiko> haha
16:28:25 <elmiko> ok, so what about the lightning talk topic. any movement on this?
16:29:19 <edleafe> well, that's sort of what the email to the sig list was about
16:29:31 <cdent> (heh, there are three abandoned pagination guidelines)
16:30:03 <elmiko> wow, that list *is* dead...
16:30:24 <dtantsur> cdent: only the strongest of us can do pagination correctly! and only the wisest can tell the others how to do it
16:30:29 <elmiko> i wonder if we just need to ping dff directly?
16:30:36 <elmiko> dtantsur: XD
16:31:11 <edleafe> elmiko: maybe, but that's more non-list email traffic
16:31:16 <edleafe> I'd like it to be less
16:31:28 <edleafe> if he has some ideas, he should respond on the list
16:31:46 <cdent> edleafe++
16:32:01 <cdent> he’s probably busy, there are a series of openstack days this week
16:32:18 <elmiko> edleafe: yeah... =(
16:32:55 <elmiko> getting short on time for prep stuff
16:33:06 <edleafe> #action edleafe to follow-up on the openstack-sigs list about the lightning talk video
16:33:17 <elmiko> thanks edleafe
16:33:26 <elmiko> #topic guidelines
16:33:34 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:33:40 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-sig,n,z
16:33:57 * dtantsur notes that openstack/api-sig is not a thing
16:34:32 <cdent> dtantsur: I think that’s a form of optimism or wishful thinking
16:34:39 <edleafe> dtantsur: yeah, that involves a github change that's kind of messy
16:35:03 <dtantsur> edleafe: we don't have to rename, we can leave a placeholder and just import the contents
16:35:07 <edleafe> I put that link there in case we ever bite the bullet and move stuff
16:35:35 * dtantsur is probably not expressing himself clearly
16:36:00 <dtantsur> I mean, create a new repo from the old one (with importing its history); replace the contents of the old one with a redirect/placeholder
16:36:19 <elmiko> github does auto-redirects for repo renames
16:36:28 <elmiko> not sure about the cgit stuff
16:36:32 <edleafe> dtantsur: doesn't that require someone who's an owner of the OpenStack GitHub repo?
16:36:35 <cdent> github isn’t the concern is it? it’s cgit.o.o?
16:36:39 <elmiko> yeah
16:36:44 <dtantsur> edleafe: nope
16:36:58 <edleafe> cdent: you're right
16:37:00 <dtantsur> the first item is how you create a new repo, infra can import it for you
16:37:20 <dtantsur> the second item is just a patch, similar to how dead projects are replaced with only a README
16:39:00 <edleafe> dtantsur: I'll look into it more when I have some free time (hah!)
16:39:08 <elmiko> ok, so more infra work to be sorted before we merge the sig rename patch?
16:39:22 <dtantsur> "free time"? is it some fancy English I don't know?
16:39:27 <elmiko> LOL
16:39:54 <elmiko> #topic bug review
16:39:58 <edleafe> elmiko: no, we can merge that patch now
16:40:06 <elmiko> #link https://bugs.launchpad.net/openstack-api-wg
16:40:11 <elmiko> edleafe: ack, thanks
16:40:15 <edleafe> elmiko: it's a process :)
16:40:36 <elmiko> edleafe: i'm gonna +W unless someone stops me
16:40:47 <cdent> do it
16:40:54 <elmiko> done
16:40:54 <dtantsur> we probably need a bug about this changes-since thingy
16:41:31 <elmiko> wow, bug list is shrinking. kudos to whomever is doing this =)
16:41:46 * dtantsur suspects bug-stealing gnomes
16:42:20 <elmiko> haha
16:43:22 <elmiko> anyone object to adding a bug about the changes-since stuff?
16:43:32 <cdent> no, of course not
16:43:42 <elmiko> #action dtantsur add bug about changes-since topic
16:43:44 <elmiko> XD
16:43:52 <dtantsur> ack :)
16:43:56 <cdent> it will help us^wdtantsur to remember
16:44:11 <elmiko> hehe =)
16:44:13 <elmiko> #topic weekly newsletter
16:44:21 <elmiko> #link https://etherpad.openstack.org/p/api-sig-newsletter
16:44:29 <dtantsur> I just typed "api-sigh" in my personal notes
16:44:36 <dtantsur> I think you're all are to blame :D
16:44:43 <elmiko> i am not a good candidate for newsletter this week, i have a meeting right after this
16:44:45 <cdent> yay!
16:44:46 <elmiko> dtantsur: LOL
16:45:04 <edleafe> sigh
16:45:05 <cdent> I think we’ve got the makings of a teen drama
16:45:09 <elmiko> haha
16:45:18 <edleafe> I guess it's my turn
16:45:26 <cdent> the opening credits involve a dreamy dtantsur doodling on his trapper keeper
16:45:36 <cdent> <3 api-sigh
16:45:43 <elmiko> ++
16:45:47 <elmiko> and thanks edleafe
16:45:52 <cdent> yes, thank you edleafe
16:45:59 * dtantsur opens google translate
16:45:59 <elmiko> also, i will out for next meeting, conference travel
16:46:09 <elmiko> *be out
16:46:28 <elmiko> but if anyone wants to have a pint in dublin, look me up XD
16:46:49 <dtantsur> elmiko: say hi to lucasagomes, if you meet him
16:46:58 <elmiko> i would love to meet up with him
16:47:16 <dtantsur> he has run away from us to the glorious land of virtual networking
16:47:22 <elmiko> any last minute items?
16:47:32 <elmiko> dtantsur: yeah, i heard something about that
16:47:40 <cdent> i got nothing
16:47:52 <elmiko> i guess we get back like 12 minutes of our day then
16:47:54 <dtantsur> nothing here too
16:47:56 <elmiko> thanks everybody =)
16:48:01 <dtantsur> thanks!
16:48:02 <elmiko> #endmeeting