16:00:16 <edleafe> #startmeeting api sig
16:00:18 <openstack> Meeting started Thu Dec 14 16:00:16 2017 UTC and is due to finish in 60 minutes. The chair is edleafe. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:22 <openstack> The meeting name has been set to 'api_sig'
16:00:24 <edleafe> #chair cdent elmiko edleafe dtantsur
16:00:25 <openstack> Current chairs: cdent dtantsur edleafe elmiko
16:00:27 <elmiko> o/
16:00:29 <dtantsur> o/
16:01:09 <edleafe> Sorry if I'm a bit distracted today. Following the discussion in #opensatck-tc about the year-long release cycle
16:01:30 <edleafe> cdent is also busy there
16:01:41 <edleafe> #link https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:01:54 <elmiko> i can drive things here edleafe, if you'd like
16:02:09 <edleafe> it's ok
16:02:12 <edleafe> #topic previous meeting action items
16:02:13 <edleafe> #link http://eavesdrop.openstack.org/meetings/api_sig/2017/
16:02:57 <edleafe> two items from last week
16:03:00 <edleafe> mugsie to explain api-ref automation potential
16:03:04 <edleafe> edleafe to investigate open meeting times at 2200UTC
16:03:41 <edleafe> I've sent two emails to the dev list requesting people respond to a survey about what day would work for them
16:03:42 <mugsie> damn, I did not do that
16:03:50 <elmiko> on the latter, nothing ever came from the survey =(
16:03:54 * mugsie adds to todays list
16:04:05 <elmiko> unless you made a new survey edleafe
16:04:13 <edleafe> So far only 2 people have responded
16:04:18 <elmiko> ack
16:04:36 <elmiko> sounds like the other survey...
16:04:55 <edleafe> Another (based in India) has said that 2200UTC is too early
16:05:04 <elmiko> ouch
16:05:15 <elmiko> but hey, at least a couple are responding
16:05:30 <edleafe> But if we made it later, that would be tough for me'
16:05:45 <edleafe> Two people don't really justify holding a meeting
16:05:48 <elmiko> right, same problem we had last time we did this
16:06:15 <elmiko> i missed you email, was the second meeting time proposed as a meeting or more like open office hours?
16:08:00 <edleafe> a meeting
16:08:27 <edleafe> #link http://lists.openstack.org/pipermail/openstack-dev/2017-December/125304.html
16:08:50 <elmiko> just wondering aloud if doing the latter might help people out, but also be less compute intensive ;)
16:08:57 <elmiko> thanks for the link!
16:09:32 <edleafe> I'm not sure. IMO, most of the things we could cover in office hours would be better in email
16:09:35 <cdent> office hours is potentially a good idea, but I'm not sure we are doing enough lately to warrant it?
16:09:41 <cdent> jinxish
16:09:55 <elmiko> good points
16:10:29 <edleafe> Well, it's clear that there isn't an overwhelming demand for APAC meetings
16:10:44 <edleafe> Let's maybe hold off until the new year and revisit this
16:10:51 <elmiko> +1
16:10:53 * cdent concurs
16:11:08 <dtantsur> yep
16:11:10 <edleafe> #agreed Revisit APAC meetings in January
16:11:26 * edleafe is glad he gave cdent an opportunity to concur
16:12:01 <cdent> I feel pretty good about that too
16:12:10 <edleafe> #topic open mic and new biz
16:12:25 <edleafe> mugsie already said that he spaced out on the api schema thing
16:12:47 <elmiko> i happned to talk with Melvin for a few minutes at kubecon, i basically was asking him about how we might get more engagement from the sdk side of the house
16:12:59 <elmiko> he was very receptive to the idea of helping to open more communications there
16:13:06 <edleafe> the other item is the SDK Certification proposal
16:13:08 <edleafe> #link SDK Certification proposal https://docs.google.com/spreadsheets/d/1cdzFeV5I4Wk9FK57yqQmp5JJdGfKzEOdB3Vtt9vnVJM/edit#gid=0
16:13:27 <edleafe> Is that something that we should steer?
16:13:28 <elmiko> so, i think if we do make some moves towards attracting more sdk folks, we could certainly reach out with anything we might want help in distributing
16:14:02 <elmiko> edleafe: hmm, that seems like a big step up for us
16:14:20 <elmiko> but certainly in-line with newer objectives, i'm not sure
16:14:22 <dtantsur> not sure I get the proposal, did I miss some ML thread?
16:15:31 <cdent> dtantsur: I doubt, there's a lot of stuff going on lately that doesn't seem to be going on in email or adequately reflected there :(
16:15:40 * dtantsur #sadpanda
16:15:47 <edleafe> dtantsur: http://lists.openstack.org/pipermail/openstack/2017-December/045844.html
16:16:06 <dtantsur> thanks edleafe
16:17:00 <mugsie> should the SDK certification be wider than just "core" projects ?
16:17:20 <dtantsur> for which defintion of "core"? nova,neutron,glance,cinder,keystone?
16:17:26 <dtantsur> * swift
16:17:38 <edleafe> mugsie: I ithink that's part of it
16:17:41 <mugsie> nova + friends and swift
16:18:16 <edleafe> IOW, what is the minimum aan SDK must support to be considered "official"
16:18:18 <elmiko> seems like starting with the "core" is a reasonable first goal
16:18:24 <cdent> am I seeing correctly that there were no responses to that thread?
16:18:31 <mugsie> cdent: yes
16:18:41 <edleafe> cdent: yeah, and not much on the spreadsheet
16:18:47 <mugsie> elmiko: is it though? most of the SDK's support much more
16:18:51 <edleafe> the SDK folks don't seem to be very lively
16:19:01 <dtantsur> does it somehow related to the trademark business?
16:19:14 <dtantsur> like SDK for OpenStack is something that supports whatever trademark requirements are..
16:19:17 <edleafe> dtantsur: it's modeled on Interop, so I think so
16:19:43 <elmiko> mugsie: i think for a cert program, getting the basics in the first draft is reasonable to me
16:19:58 <mugsie> elmiko: I don't
16:20:13 <elmiko> mugsie: i'm curious, what would your list include?
16:20:36 <mugsie> LBaaS + DNS at the very least
16:20:44 <mugsie> Orchestration as well actually
16:21:23 <dtantsur> well, if we go beyond core, we're going to argue a lot :)
16:21:28 * dtantsur votes for ironic, of course
16:21:29 <elmiko> we probably need a better definition of "core" then, i see those are pretty fundamental to having a working openstack sdk
16:21:59 <cdent> there's a map that ttx has created which tries to describe coreness, differently from what it was in the passed
16:22:03 <mugsie> elmiko: well, core is currently a term used for compute-starter-kit / OpenStack Powered Platform
16:22:11 <cdent> but it often seems different from "operational cloud" too
16:22:19 <elmiko> for clarity, i was thinking about things like sahara as not being needed for a first draft cert program
16:22:33 <elmiko> mugsie: ack, my bad then
16:22:48 <mugsie> elmiko: ah, OK - that makes sense :)
16:23:13 <mugsie> I would like a new term that is "what I need to get my application on the internet"
16:23:32 <elmiko> ++
16:24:01 <edleafe> mugsie: and that will depend on the application, no?
16:24:19 <mugsie> edleafe: yes, that is true.
16:24:48 <edleafe> I'm really not sure of the value of this effort, though
16:24:59 <edleafe> if an SDK can't do basic stuff, who would use it?
16:25:02 <mugsie> "what I need to get 90% of applications on the internet"
16:25:17 <edleafe> if an SDK does what you need well, who cares if it's "official"?
16:25:26 <mugsie> edleafe: that is a good point. who is driving this?
16:25:40 <elmiko> edleafe: ++
16:25:42 <edleafe> I would assume Melvin and the User Committee
16:26:32 <elmiko> would be cool to know if there is a request for this from the users
16:27:15 <edleafe> well, it *is* the User Committee... :)
16:27:51 <edleafe> So let's just keep this on the radar. If it starts to gain support, we should definitely be involved
16:28:06 <edleafe> Anything else for new biz?
16:29:01 <cdent> I think the idea of the certification is not to certify, but to help SDKs improve in a guided fashion
16:29:37 <dtantsur> I'm not sure we should guide everyone to concentrate on core projects..
16:29:41 <edleafe> cdent: that's a good point
16:29:43 <elmiko> i think if we end up discussing this more, we should definitely reach out to Melvin in advance to see if we can drum up some interest from the user committee in attending our meetings
16:29:43 <dtantsur> there may be more domain-specific SDKs
16:30:23 <edleafe> I know that when I wrote the OpenStack SDK for Rackspace, my only guide was "support everything!"
16:30:36 <dtantsur> heh, that's a good goal :)
16:31:00 <elmiko> nice
16:31:43 <edleafe> moving on...
16:31:45 <edleafe> #topic guidelines
16:31:45 <edleafe> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:31:48 <edleafe> #link https://review.openstack.org/#/q/status:open+project:openstack/api-sig,n,z
16:32:29 <edleafe> The only real change was that Gilles updated the API-schema doc
16:32:40 <edleafe> I haven't looked at it yet
16:33:10 * dtantsur neither
16:33:30 <cdent> not a huge change, provides a bit more context, needs still more justification about _why_
16:34:14 <edleafe> ok
16:34:23 <edleafe> I'll try to oget to it later
16:34:38 <edleafe> #topic bug review
16:34:39 <edleafe> #link https://bugs.launchpad.net/openstack-api-wg
16:34:39 <edleafe> #link https://bugs.launchpad.net/openstack-api-sig
16:35:14 <edleafe> No new bugs
16:35:25 <edleafe> Anyone want to discuss a bug?
16:35:39 <elmiko> i've always enjoyed the monarch butterfly...
16:37:12 <edleafe> I'm a Black Swallowtail man myself
16:37:14 <edleafe> https://photos.app.goo.gl/KEKb0SJTaR3G0zIj1
16:37:15 <cdent> I had a bug in a house I once lived in that I called Early
16:37:18 <cdent> Earl!
16:37:45 <elmiko> edleafe: very cool!
16:38:07 <edleafe> elmiko: raised that one from a caterpillar
16:38:18 <elmiko> dude, so neat
16:38:32 <edleafe> #topic weekly newsletter
16:38:33 <edleafe> #link https://etherpad.openstack.org/p/api-sig-newsletter
16:38:39 <edleafe> Any volunteers?
16:38:57 <elmiko> i can take it this week
16:39:51 <cdent> thanks elmiko
16:40:11 <edleafe> cool, thanks
16:40:15 <edleafe> Anything else?
16:40:21 * dtantsur has nothing
16:40:25 <elmiko> nothing here
16:40:28 <cdent> do we want a meeting next week or the week after?
16:40:36 <edleafe> ooh good point
16:40:38 <cdent> or should we take a holiday break of some kind?
16:41:16 <elmiko> ++
16:41:18 <edleafe> Let's have our next meeting in 3 weeks
16:41:20 <edleafe> Jan 4
16:41:24 <edleafe> Sounds good?
16:41:25 <elmiko> i'm good with that
16:41:26 <cdent> works for me
16:41:28 <dtantsur> ++
16:41:42 <edleafe> #agreed Skip the next two meeting dates for the holidays
16:42:18 <edleafe> So everyone enjoy your holidays, and we'll see you back here in January!
16:42:37 <elmiko> likewise! =)
16:42:41 <dtantsur> o/
16:43:14 <edleafe> #endmeeting