16:02:53 <cdent> #startmeeting api-sig
16:02:53 <openstack> Meeting started Thu Feb  1 16:02:53 2018 UTC and is due to finish in 60 minutes.  The chair is cdent. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:54 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:56 <openstack> The meeting name has been set to 'api_sig'
16:03:03 <cdent> #chair dtantsur elmiko edleafe
16:03:04 <dtantsur> o/
16:03:05 <openstack> Warning: Nick not in channel: elmiko
16:03:06 <openstack> Current chairs: cdent dtantsur edleafe elmiko
16:03:18 <cdent> sorry about the slight delay, lost track of time
16:03:33 <cdent> #link Agenda https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:03:52 <cdent> #topic old biz
16:03:56 <cdent> there was no meeting last week
16:04:04 <cdent> and the week before had no action items
16:04:17 <cdent> #topic new biz
16:04:38 <cdent> #link action apis thread: http://lists.openstack.org/pipermail/openstack-dev/2018-January/126334.html
16:05:14 <dtantsur> a chance to say what we think about such actions? :)
16:05:16 <cdent> that ^ was a thread on the dev list that invited our input on dealing with "actions" in uris. our input was invited but I think everyone was sufficiently distracted that they mimssed it
16:05:28 <cdent> sure, if you like
16:05:59 <dtantsur> probably not overly constructive though
16:06:42 <cdent> perhaps, but I do think the thread deserves a bit of attention, even though it is somewhat old now
16:06:44 <edleafe> \o (sort of)
16:06:56 <elmiko> o/
16:07:04 <elmiko> sorry, missed the calendar bing
16:07:06 * edleafe is on a phone meeting
16:07:21 <cdent> elmiko: no worries, the only reason I remembered is because dtantsur was on the ball
16:07:39 <elmiko> dtantsur++
16:07:52 * elmiko pulls up agenda
16:07:56 <cdent> we were discussing how this thread http://lists.openstack.org/pipermail/openstack-dev/2018-January/126334.html invited our attention
16:08:03 <cdent> be we haven't given it any (yet)
16:08:19 <dtantsur> I kinda agree that if we do actions, we should make them explicit in the URL
16:08:23 <elmiko> ooh, action resources, my favorite =)
16:08:46 <dtantsur> because, discoverability, all the things
16:09:35 <elmiko> dtantsur: like explicit url to a resource based action?
16:09:57 <dtantsur> elmiko: like, using /<object>/actions/<action> not just /<object>/actions
16:10:04 <elmiko> ack
16:10:08 <dtantsur> I mean, both are evil, but the former is a lesser one IMO
16:10:12 <elmiko> yeah
16:10:14 <edleafe> so are they saying "let's not get tied up with this RESTy stuff"?
16:10:48 <edleafe> i.e., don't use POST /resource with an action in the body?
16:10:48 <dtantsur> edleafe: not sure I get you, but they're picking between several non-REST approaches :)
16:10:58 <elmiko> imo, i like the idea of tightly scoped urls to define the action, but then having the actions be resources based for tracking and asynch behaviors
16:11:16 <edleafe> dtantsur: yeah, that's my point. They are considering everythine *except* the REST way
16:11:21 <dtantsur> right
16:11:47 <dtantsur> which gets us down the rabbit hole of how to express e.g. a server stop in a restful way :)
16:12:04 <mugsie> we track these sort of things as tasks, which are resources in their own right
16:12:12 <elmiko> mugsie++
16:12:14 <dtantsur> mugsie: right, this is the best approach IMO
16:12:26 <mugsie> https://developer.openstack.org/api-ref/dns/#zone-import -> https://developer.openstack.org/api-ref/dns/#zone-ownership-transfers-accepts
16:12:28 <dtantsur> but if we're speaking about existing APIs, this means a complete rewrite
16:12:57 <mugsie> or ... 2 ways of doing the same thing at least temporarily
16:13:11 <elmiko> i don't think we should accept the non-resource based style for a guideline simply because it's a lot of old code
16:13:30 <edleafe> mugsie: what is the conceptual difference between 'action' and 'task'?
16:13:40 <elmiko> i know it's a tough pill to swallow, but we can't advise folks to use the non-resource methodology
16:14:01 <mugsie> edleafe: nothing - it was just our word choise
16:14:08 <mugsie> choice*
16:14:16 <dtantsur> elmiko: I agree. I'm trying to imagine how we can lead this conversation to not end up with "- You should do X. - No way"
16:14:30 <edleafe> mugsie: ok, that's what I thought
16:14:46 <mugsie> but we diud make sure we kept track of old tasks, and they all get an ID, and have a status that progresses as the task /action  is performed
16:15:05 <elmiko> dtantsur: ack
16:15:27 <elmiko> that's a tough problem to solve, i'm not sure how we make a good guideline without upsetting some folks
16:15:29 <edleafe> elmiko: I think the approach should be: "Use this RESTful approach. Until you can get there, this non-RESTful approach is the least sucky, so try for that"
16:15:37 <elmiko> edleafe++
16:15:44 <elmiko> yes, give folks a way to get there
16:15:58 <cdent> Does someone want to volunteer to join the thread?
16:16:05 <edleafe> IOW, never endorse a non-RESTful approach as our recommendation
16:16:13 <cdent> or even some ones
16:16:15 <elmiko> edleafe++
16:16:22 <dtantsur> edleafe: that's what I would say, yes
16:16:30 <edleafe> cdent: I guess I can reply
16:16:31 <elmiko> cdent: i can join, might not be today though
16:16:35 <dtantsur> I can jump on it too
16:16:39 <elmiko> \o/
16:16:44 <edleafe> well, let
16:16:46 <edleafe> ugh
16:16:52 <edleafe> let's not repeat ourselves
16:16:55 <elmiko> ++
16:17:01 <edleafe> we should really just have one API-SIG response
16:17:10 <elmiko> that's fair
16:17:25 <cdent> #action edleafe to jump on the email thread
16:17:50 <cdent> Any other new biz or open discussion?
16:17:56 <edleafe> cdent: with my knees, I think I'll step lightly :)
16:18:13 <cdent> it's a soft landing
16:18:25 * elmiko chuckles
16:18:27 <cdent> One open discussion topic might be "oh hey, that PTG thing is coming round again"
16:18:37 <dtantsur> \o/
16:18:46 * dtantsur has applied for a visa.. fingers crossed
16:19:07 <cdent> you need a visa dtantsur ? bummer
16:19:14 <cdent> anybody definitely not going?
16:19:29 <dtantsur> cdent: sucks to have such a passport :(
16:19:45 <elmiko> cdent: i don't think i'll be there
16:19:48 * dtantsur mumbles something about the foundation considering visas when deciding on a venue
16:19:56 <edleafe> I'm coming, but IBM is dragging its heels on approving
16:19:59 <cdent> elmiko: nooooooooooo!
16:20:01 <elmiko> although, i'm willing to video call in if folks would like
16:20:04 <edleafe> Already bought airline tix
16:20:15 <elmiko> sorry cdent =(
16:20:21 <dtantsur> elmiko: it may work depending on the room equipment
16:20:27 <dtantsur> elmiko--
16:20:28 <edleafe> elmiko: video Guinness isn't as good
16:20:30 <elmiko> cool
16:20:35 <elmiko> haha, yeah
16:20:38 <dtantsur> heh
16:21:07 <elmiko> do we know what days are the api-sig stuff?
16:21:15 <cdent> yeah, one sec
16:21:16 <elmiko> (maybe i can make a case for a short journey)
16:21:45 <cdent> #link ptg sched: https://docs.google.com/spreadsheets/d/e/2PACX-1vRmqAAQZA1rIzlNJpVp-X60-z6jMn_95BKWtf0csGT9LkDharY-mppI25KjiuRasmK413MxXcoSU7ki/pubhtml?gid=1374855307
16:21:49 <dtantsur> Monday?
16:21:59 <cdent> yeah, only a day this time
16:22:06 <edleafe> elmiko: isn't the airline tix the biggest cost? Or are they worried that you will be slacking off on your day job?
16:22:12 <dtantsur> fine, I'll have time to check out the city
16:22:34 <dtantsur> on Tue, I mean
16:22:46 <cdent> without microversions to discuss, we just don't have that much to say...
16:22:52 <elmiko> edleafe: little of column a, little of column b
16:23:07 <dtantsur> cdent: what do you mean by "without"? ;)
16:23:14 <dtantsur> we ALWAYS have microversions to discuss
16:23:14 <elmiko> and not so much slacking, just that our group doesn't do any openstack anymore
16:23:20 <elmiko> haha
16:23:28 <edleafe> elmiko: so the $$ will be the same. You can just work remote on Tues, Wed, etc
16:23:33 * dtantsur gently reminds about his SDK guideline to bike shed on
16:23:54 <elmiko> edleafe++
16:24:00 <elmiko> i'll take one more pass at getting approval
16:24:05 <cdent> dtantsur: I was meaning more that the great existential battles about microversions are behind us
16:24:15 * dtantsur is less optimistic
16:24:42 <edleafe> cdent: We could bikeshed on what to rename "microversions" to!
16:24:44 <dtantsur> if we ever try to push them to more projects, the past battle will seem just a shadow of the horrible present
16:24:53 <cdent> the battles weren't won, people just got fatigued and decided there were better things to do
16:24:53 <dtantsur> edleafe: !!!
16:25:56 <dtantsur> do I remember it right that somebody proposed "microversion everything" as an openstack-wide goal?
16:26:51 <cdent> I think it has been on the etherpad, but never made it past that
16:26:55 <edleafe> dtantsur: I think that was suggested, but goals are supposed to be achievable in one cycle
16:27:03 <dtantsur> .. or ever ;)
16:27:19 <dtantsur> okay then. if it ever becomes serious, we're gonna have a new round.
16:27:21 <mugsie> and I suspect some projects would just outright refuse to do it :P
16:27:49 <edleafe> It does seem odd that the way to ensure that you don't break an API (via microversions) is only possible by breaking your API (by switching to microversions)
16:28:05 <dtantsur> edleafe: why breaking?
16:28:20 <dtantsur> I recall us switching quite smoothly (well... from this standpoint)
16:28:42 <edleafe> dtantsur: most projects that have objected have raised breakage as a reason for not wanting to implement
16:28:45 <dtantsur> we just declared whatever we had 1.1 or something like that
16:28:55 <dtantsur> curious
16:29:08 <dtantsur> I was objecting because I find it confusing and error-prone
16:29:09 <edleafe> Some have v1, v2, etc
16:29:41 <dtantsur> we had v1, so we just froze it at the point of switch. then we can v1+microversion for newer things
16:29:47 <dtantsur> but this is side-tracking a bit, sorry :)
16:30:16 <elmiko> i wonder if the backward compatiblity nature of microversions scares ppl as well?
16:30:16 <cdent> regarding the ptg, we should probably prepare some topics
16:30:23 <elmiko> ++
16:30:28 <elmiko> how about actions?
16:30:34 <dtantsur> actions++
16:30:39 <cdent> let's do that at
16:30:43 <cdent> #link ptg etherpad https://etherpad.openstack.org/p/api-sig-ptg-rocky
16:30:47 <dtantsur> and I'm quite serious about microversions in SDKs, it's unlikely we merge them
16:31:11 <dtantsur> and I'd probably meet people from SDKs before we do anyway
16:33:30 <edleafe> I think with SDKs we're going to have the same problem as with "capabilities"
16:33:47 <edleafe> There are multiple levels that are all being called the same thing
16:34:02 <edleafe> dtantsur tried to separate the definitions
16:34:30 <edleafe> but it does seem that there is more of a spectrum of SDK focus
16:35:07 <cdent> It's question that's come up a lot, so we can do a service by providing some help with making it a real conversations
16:35:18 <cdent> #topic guidelines
16:35:32 <cdent> #link pending guidelines https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:36:07 <cdent> doesn't look like anything is ready for freeze, conversations continues on dtantsur's thing (a good starting point for the conversation)
16:36:14 <cdent> the schema thing is languishing a bit?
16:36:18 <elmiko> re: ptg, seems like i'm getting some traction, so keep your fingers crossed
16:36:28 <dtantsur> \o/
16:36:36 <elmiko> i said you guys are getting really pushy
16:36:55 <cdent> mordred's tome will probably come back to life eventually but not clear when
16:37:03 <mordred> uhoh
16:37:05 <mordred> yah
16:37:08 <dtantsur> elmiko: we haven't even started ;)
16:37:11 <mordred> I keep getting distracted by other things
16:37:15 <dtantsur> mordred: o/ anything to discuss at the PTG?
16:37:16 * elmiko chuckles
16:37:21 <cdent> elmiko: I think you can tell your boss you owe me a (very expensive) beer
16:37:30 <elmiko> cdent: LOL
16:37:32 <elmiko> indeed
16:37:40 <mordred> dtantsur: I'd loe to chat with you about the sdk/microversion stuff at least
16:37:59 <dtantsur> mordred: totally! I've proposed a topic on https://etherpad.openstack.org/p/api-sig-ptg-rocky
16:38:06 <mordred> and would also like to talk with y'all and maybe public cloud folkks about the cloud profile thing I need to update
16:38:09 <mordred> dtantsur: woot
16:38:09 <dtantsur> if they don't send me to hell with my visa request ofc..
16:38:23 <cdent> mordred: https://etherpad.openstack.org/p/api-sig-ptg-rocky
16:38:55 * mordred added line
16:39:03 <cdent> word
16:39:20 <cdent> #topic bugs
16:39:21 <dtantsur> mordred: some details would not hurt
16:39:23 <cdent> #link bugs https://bugs.launchpad.net/openstack-api-wg/+bugs?orderby=-id&start=0
16:39:34 <cdent> no new bugs, no progress on existing bugs
16:39:43 <dtantsur> stability!
16:39:51 <cdent> I reckon winter is the hardest api-sig season
16:40:12 <edleafe> yes, especially feature FREEZE
16:40:26 * elmiko facepalm
16:40:30 <cdent> /o\
16:40:54 <cdent> #topic newsletter
16:40:57 <cdent> #link newsletter https://etherpad.openstack.org/p/api-sig-newsletter
16:41:00 <cdent> any takers?
16:41:15 <edleafe> I'm doing the email reply, so prolly not me
16:41:21 <elmiko> i can take it
16:41:30 * cdent cookies elmiko
16:42:04 <elmiko> i'll ping folks in like 15-20
16:42:11 <cdent> anyone have anything to add to the record before I end the meeting?
16:42:53 <cdent> okay then, thanks everyone for showing up, a pleasure as always
16:42:58 <cdent> #endmeeting