16:00:08 <elmiko> #startmeeting api sig
16:00:09 <openstack> Meeting started Thu Feb  8 16:00:08 2018 UTC and is due to finish in 60 minutes.  The chair is elmiko. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:12 <openstack> The meeting name has been set to 'api_sig'
16:00:19 <elmiko> #chair cdent elmiko edleafe dtantsur
16:00:20 <openstack> Current chairs: cdent dtantsur edleafe elmiko
16:00:28 <elmiko> #link https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:00:29 <dtantsur> o/
16:00:30 <edleafe> \o
16:00:45 <cdent> oh hi
16:00:51 <elmiko> #topic previous meeting action items
16:01:02 <elmiko> #link http://eavesdrop.openstack.org/meetings/api_sig/2018/
16:01:27 <elmiko> only action item was for edleafe, any status on that?
16:01:57 <edleafe> yeah, I replied, and got the usual response
16:02:19 <elmiko> ack
16:02:24 <edleafe> lemme get the link
16:02:31 <elmiko> thanks
16:02:53 <edleafe> #link edleafe email reply on REST APIs: http://lists.openstack.org/pipermail/openstack-dev/2018-February/126891.html
16:03:37 <elmiko> ok, so i guess we'll just watch and see
16:03:40 <cdent> given copious time we could probably have a rousing discussion (on list) about all the various reasons and probably bring some people into the church (and scare others) but copious time? not so much
16:03:49 <edleafe> It's hard to deal with "REST is a very loose standard" POV
16:03:57 <elmiko> ++
16:04:18 <elmiko> i know we've talked about discussing this at the ptg, any of you think it will make the nova agenda?
16:04:30 <edleafe> cdent: In the process of writing that,  I couldn't find a guideline that explicitly says the REST is the way to do APIs
16:04:30 <elmiko> or cinder for that matter
16:04:48 <elmiko> ooh, the meta-guideline guideline
16:04:54 <cdent> edleafe: I've resisted us stating that because we have no examples. None of the existing apis are "high" REST
16:05:04 <cdent> I much prefer that we state they are HTTP APIs
16:05:12 <edleafe> elmiko: not likely for nova
16:05:13 <cdent> that are resource oriented
16:05:21 <cdent> nova has big backlog ...
16:05:25 <elmiko> ack
16:05:34 <cdent> (but see later link in bugs topic)
16:05:35 <elmiko> this is pretty minor for them i take it?
16:05:52 <edleafe> cdent: I think we should be at least clear that REST == HTTP
16:06:04 <elmiko> ++
16:06:37 * cdent shrugs
16:06:47 * dtantsur sometimes wishes we just used JSON RPC
16:06:49 <cdent> I think it just invites nitpicking
16:06:49 * dtantsur hides
16:06:59 * edleafe runs after dtantsur
16:07:03 <elmiko> lol
16:07:04 <cdent> Because I was tempted to nitpick your statement...
16:07:40 <elmiko> cdent: agreed about inviting nitpicking
16:07:42 <edleafe> cdent: but nitpickis what you do best!
16:07:48 * elmiko chuckles
16:08:06 <elmiko> #topic open mic and ongoing or new biz
16:08:15 <elmiko> nothing on the agenda, any topics folks wish to bring up?
16:08:30 <edleafe> nada from me
16:08:36 <elmiko> i am a go for ptg btw, got my tickets and hotel res
16:08:39 <cdent> i suppose ptg agenda ought to be a thing
16:08:41 <dtantsur> \o/
16:08:42 <cdent> elmiko: woot!
16:08:45 <elmiko> =)
16:08:51 * dtantsur still waits for a visa decision
16:08:57 <edleafe> oh, wait
16:09:02 <elmiko> next question, is there any sort of discount code available for the ptg reg?
16:09:08 <edleafe> do we want a group picture at PTG?
16:09:13 * edleafe doesn't
16:09:28 <elmiko> i'm amenable to a group pic
16:09:39 <cdent> no pic
16:09:44 <dtantsur> elmiko: IIRC PTG costs what it costs
16:09:52 <elmiko> dtantsur: ack, thanks
16:10:20 <edleafe> elmiko: yeah, the discount is for PTG attendees to go to Summit
16:10:50 <elmiko> ahhh, ok
16:11:19 <elmiko> #link https://etherpad.openstack.org/p/api-sig-ptg-rocky
16:11:32 <elmiko> i haven't checked recently, anything new here?
16:12:05 <cdent> no
16:12:07 <elmiko> seems like a good start for topics
16:12:29 <dtantsur> we have on topic with "microversion" in its title, it can take the whole day with ease
16:12:38 <elmiko> true dat
16:13:03 <elmiko> i think we should add a review topic with regards to our interactions with the sdk/user-committee folks
16:13:27 <elmiko> it's something that seemed big last time, would be nice to do a retrospective
16:14:04 <edleafe> elmiko: +1
16:14:24 <dtantsur> "have we made any?" good question to start with :)
16:14:36 <cdent> yeah, makes sense. media choice a factor probalby. but I also think none of us are very devoted lately due to other obligations
16:15:13 <elmiko> well, and i don't want it to be an issue for just us
16:15:15 <dtantsur> yep
16:15:24 <qwebirc40453> hello guys
16:15:27 <elmiko> like, in denver the sdk/user folks seemed eager to join what is happening
16:15:31 <dtantsur> on the bright side, I'm probably no longer a PTL :) so I should have more time
16:15:32 <qwebirc40453> is it heat place?
16:15:42 <elmiko> qwebirc40453: this is the api-sig meeting
16:15:44 <dtantsur> qwebirc40453: hi, nope
16:15:59 <elmiko> dtantsur: heh, congrats? ;)
16:16:00 <dtantsur> qwebirc40453: are you looking for #openstack-heat or some meeting?
16:16:05 <dtantsur> elmiko: \o/
16:16:05 <qwebirc40453> someone can help how to find heat ?
16:16:24 <elmiko> qwebirc40453: join #openstack-heat
16:16:51 <cdent> dtantsur: if you get more time can you share it around please?
16:17:03 <edleafe> qwebirc40453: http://eavesdrop.openstack.org/ has a list of all IRC meetings
16:17:09 <dtantsur> heh
16:18:15 <elmiko> anything else about ptg?
16:18:46 <cdent> naw mate
16:19:21 <elmiko> #topic guidelines
16:19:28 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:19:34 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-sig,n,z
16:20:24 <elmiko> looks like dtantsur's still needs some mods
16:20:45 <dtantsur> maybe, I haven't looked into recent comments
16:20:51 <elmiko> i have not read Gilles, any thoughts on that one?
16:20:53 <dtantsur> end-of-queens release drill
16:21:43 <elmiko> seems like the api schema thing is a much heavier doc that i expected
16:22:20 <elmiko> although, this does circle the wadl/openapi/etc bowl again
16:22:29 <cdent> yes
16:22:42 <edleafe> It did feel a bit SOAP-y
16:23:05 <cdent> basically, I think the gist is that gilles is doing a thing and his life would be easier if it were official
16:23:15 <mugsie> Gilles is asking me to update the yaml thing in os-api-ref, but I don't think I will be putting much more time into it without more than just gilles asking for it
16:23:18 <cdent> but few other people are motivated for it to be a thing
16:23:25 <cdent> jinx-ish
16:23:33 <mugsie> :)
16:23:47 <edleafe> cdent: the question for me is should we be making this a OpenStack-wide suggestion?
16:24:01 <cdent> I personally don't think so
16:24:08 <edleafe> IOW, are we taking the position that all APIs should have this sort of schema?
16:24:14 <elmiko> and doesn't this also hit on the fact that openapi is not going to work for microversions?
16:24:19 <cdent> But I don't want my biases to be too controllking (only somewhat)
16:24:32 <edleafe> elmiko: good point
16:24:34 <mugsie> edleafe: well, the plugin allows any project using the api-ref to have one, but ymmv with how useful; it is
16:25:02 <elmiko> was there ever any discussion about using openapi for the current version only?
16:25:18 <cdent> elmiko: in a microversion environment does "current version" mean anything
16:25:32 <cdent> especially in a world where time's arrow is not reliable
16:25:35 <elmiko> cdent: maybe tip or master is a better way to put it
16:25:49 <cdent> (time's arrow weirdness is the whole reason for microversions)
16:25:53 <elmiko> right
16:26:01 <elmiko> but there is a version at the head of the arrow
16:26:04 <cdent> elmiko: who would use that? deployments aren't master...
16:26:12 <elmiko> yeah, good point
16:26:40 <cdent> the goal, from gilles, is being able to create client code that works against real deployments
16:26:55 <elmiko> i love this topic as an academic point, but it always feels like we will never have something that is openstack-wide
16:27:42 <elmiko> cdent: i just don't see how we enshrine that without creating a new standard schema or something that covers the uniqueness of openstack apis (read: microversions)
16:28:25 <elmiko> i'm gonna add this as a stretch topic for ptg, if Gilles is there it might be worth exploring more
16:28:33 <cdent> Yeah, me neither, which is part of why I tend to not care about it. But I also don't care about it because I prefer artisinal client code, made by real hipsters
16:28:44 <elmiko> L O L
16:28:45 <cdent> yeah, that makes sense
16:28:47 <elmiko> that is the best
16:29:01 <elmiko> cdent: qotd material right there
16:29:52 <cdent> you can have that one for free
16:30:12 <edleafe> https://twitter.com/EdLeafe/status/961638228838305795
16:31:11 <elmiko> edleafe++
16:31:37 <elmiko> ok, so looks like nothing ready for freeze
16:31:41 <elmiko> and nothing frozen
16:31:48 <elmiko> #topic bug review
16:31:54 <elmiko> #link https://bugs.launchpad.net/openstack-api-wg
16:32:01 <elmiko> #link https://bugs.launchpad.net/openstack-api-sig
16:32:20 <elmiko> looks like we have a topic here about a caching bug in nova
16:32:26 <elmiko> #link https://bugs.launchpad.net/nova/+bug/1747935
16:32:27 <openstack> Launchpad bug 1747935 in openstack-api-sig "Openstack APIs and RFC 7234 HTTP caching" [Medium,Confirmed]
16:32:30 <elmiko> anyone here to champion this?
16:33:06 <cdent> oh, I did that
16:33:29 <cdent> I wanted to draw attention to it because there seems to be some disagreement on a) whether it counts as a bug
16:33:46 <cdent> b) what guidance on it would mean
16:34:21 <edleafe> Yeah, good points
16:34:30 <edleafe> I also disagree with the need for a new version
16:34:48 <edleafe> If a consumer is not getting the requested information, that's a bug
16:35:06 * cdent nods
16:35:12 <dtantsur> I think flows in fundamental HTTP implementation bits should be bugs indeed
16:35:18 * dtantsur wonders if ironic is affected by the same
16:36:22 <mugsie> dtantsur:  would say nearly all projects are
16:36:44 <dtantsur> then we certainly should mention it somewhere in our guidelines
16:36:50 <edleafe> dtantsur: +1
16:37:12 <elmiko> i tend to agree with dtantsur
16:37:34 <cdent> when I first joined the api-wg I mentioned a lot of this stuff and at that time it was considered a non-problem compared to the existing problems
16:37:47 <cdent> I would guess that we've come far enough to start getting into these kinds of details
16:37:53 <cdent> especially as we've got a real bug
16:37:59 <elmiko> ++
16:38:01 <cdent> (which I'm incredibly grateful for)
16:38:43 <edleafe> progress!
16:39:53 <cdent> if anyone, besides me, would like to weigh in on the bug that it is in fact a bug the original author will be grateful
16:40:13 <cdent> he wrote to me prviately to express "what do I do now?" frustration
16:41:01 <elmiko> ack
16:41:02 <edleafe> I'm afraid that Sylvain will ignore me; having someone else reply would probably be a bit more convincing
16:41:12 <elmiko> i can reply
16:41:43 <elmiko> unless dtantsur wants to
16:41:46 <elmiko> or maybe we both should?
16:42:01 <dtantsur> I can, sure
16:42:46 <elmiko> #action dtantsur reply to https://bugs.launchpad.net/nova/+bug/1747935
16:42:48 <openstack> Launchpad bug 1747935 in openstack-api-sig "Openstack APIs and RFC 7234 HTTP caching" [Medium,Confirmed]
16:42:48 <cdent> thanks everyone
16:42:59 <elmiko> #action elmiko reploy to https://bugs.launchpad.net/nova/+bug/1747935
16:43:05 <elmiko> reploy!
16:43:43 <elmiko> just want to note, that it's nice to see our bug list shring a little bit
16:43:57 <elmiko> is there anything we can do to help reduce those bugs? (i have not looked in awhile)
16:44:47 <elmiko> it looks like many of them will require deeper discussion than just pushing a quick fix
16:44:59 <edleafe> elmiko: IIRC, many of them are TODOs
16:45:02 <elmiko> yeah
16:45:05 <elmiko> ok, cool
16:45:07 <cdent> and we have no spoons
16:45:30 <elmiko> #topic weekly newsletter
16:45:34 <elmiko> volunteers?
16:45:44 <elmiko> #link https://etherpad.openstack.org/p/api-sig-newsletter
16:45:58 <cdent> I guess it's been awhile since I have
16:46:01 <elmiko> i can do it, but it will have to wait until my next meeting
16:46:02 <edleafe> It's been a while for me too
16:46:05 <dtantsur> I can do it after dinner
16:46:17 <elmiko> we need a random-bot for this XD
16:46:23 <edleafe> I'll do it
16:46:28 <cdent> it's pretty cool the way we wall waited about 30 seconds and then boom
16:46:31 <cdent> thanks edleafe !
16:46:32 <elmiko> LOL
16:46:34 <edleafe> cdent already does too many newsletters
16:46:34 <dtantsur> hehe
16:46:35 <elmiko> thanks edleafe !
16:46:53 <cdent> I totally need another newsletter to secure my future
16:46:59 <elmiko> ++
16:47:05 <edleafe> the wait wasn't intentional - split focus is to blame
16:47:16 <elmiko> any last minute words of wisdom or cool jokes to share?
16:47:35 <cdent> only in the sense of open biz gossip
16:47:46 <dtantsur> I can complain about nova API
16:47:49 <dtantsur> if you want to :)
16:47:52 <elmiko> hmm, maybe we should end this
16:47:57 <cdent> I've been doing some experimentation with placement lately and I can make some observations
16:48:07 <elmiko> i saw your blog post, interesting read
16:48:13 <cdent> there's more to come
16:48:19 * dtantsur was cursing people while working on rust-openstack
16:48:19 <edleafe> Yeah, I'll ping when the newsletter is ready for review
16:48:22 <elmiko> i didn't quite understand it all, but i'm curious cdent
16:48:29 <dtantsur> link?
16:48:32 <cdent> but from an api-sig standpoint: it is _way_ fast
16:48:33 <elmiko> dtantsur: rust-openstack++
16:48:50 <cdent> dtantsur: here is a starting point (pointing back to earlier posts): https://anticdent.org/placement-container-playground-2.html
16:48:56 <dtantsur> thanks cdent
16:49:05 <elmiko> dtantsur: link for where i get started on rust-openstack?
16:49:06 <cdent> it is _way_ faster than the nova api
16:49:21 <elmiko> that's interesting
16:49:33 <cdent> it's because it does so little
16:49:38 <dtantsur> elmiko: it's very early alpha, all I have is https://github.com/dtantsur/rust-openstack
16:49:48 <elmiko> dtantsur++
16:50:01 <dtantsur> elmiko: I want to get it to 0.1 by the PTG, then people can actually hack on it and play with it
16:50:05 <cdent> In my efforts to break stuff I keep breaing everything else.
16:50:06 <dtantsur> but I'm mostly done with breaking changes already
16:50:15 <elmiko> dtantsur: very cool!
16:50:29 <elmiko> cdent: lol
16:50:30 <cdent> is awesome to see rusty things
16:50:37 <elmiko> agreed =)
16:50:52 <dtantsur> btw I could use input on https://github.com/dtantsur/rust-openstack/issues/10
16:51:04 <dtantsur> this is where I track the proposed API design
16:51:06 <edleafe> So much breakage!
16:51:30 <elmiko> and see, we're talking about sdk things!
16:51:32 <elmiko> ;)
16:51:47 <dtantsur> \o/
16:51:50 <elmiko> ok, have a good weekend all o/
16:51:56 <dtantsur> \o
16:52:01 <elmiko> #endmeeting