16:00:07 <elmiko> #startmeeting api sig
16:00:08 <openstack> Meeting started Thu Apr 12 16:00:07 2018 UTC and is due to finish in 60 minutes.  The chair is elmiko. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:11 <openstack> The meeting name has been set to 'api_sig'
16:00:13 <elmiko> #chair cdent elmiko edleafe dtantsur
16:00:14 <openstack> Warning: Nick not in channel: cdent
16:00:15 <openstack> Warning: Nick not in channel: dtantsur
16:00:16 <openstack> Current chairs: cdent dtantsur edleafe elmiko
16:00:18 <edleafe> elmiko: you beat me
16:00:22 <edleafe> was just typing in the same
16:00:25 <elmiko> haha, sorry
16:00:32 <elmiko> by all means, you can take the wheel =)
16:00:54 <edleafe> no worries
16:00:59 <elmiko> looks like dtantsur is pto
16:01:08 <cdent> every
16:01:09 <cdent> single
16:01:09 <cdent> time
16:01:11 <elmiko> haha
16:01:28 <elmiko> #link https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:01:36 <elmiko> #topic previous meeting action items
16:01:41 <cdent> I now have a new meeting immediately after this one as well. Joy!
16:01:45 <elmiko> #link http://eavesdrop.openstack.org/meetings/api_sig/2018/
16:01:51 <elmiko> yeesh, i know the feeling ;)
16:01:57 <edleafe> cdent: lucky bastard!
16:01:58 <elmiko> so, i did 2/3 on my items
16:02:09 <elmiko> i updated the openapi doc with our discussions from last week
16:02:18 <elmiko> and i sent an email to Gilles, but i have not heard back yet
16:02:29 <elmiko> the update to the microversions pr is gonna take me some time
16:02:56 <elmiko> and, i have several conferences coming up over the next 3-4 weeks, so i think i shouldn't add it as an action. more an ongoing thing for me
16:03:09 <edleafe> elmiko: sounds fine
16:03:41 <elmiko> looks like we still need a few more reviews on
16:03:43 <elmiko> #link https://review.openstack.org/#/c/554234/
16:04:09 <elmiko> #topic open mic and ongoing or new biz
16:04:13 <edleafe> I reviewed it, but didn't comment, as I'm the patch author
16:04:22 <elmiko> ah, good point
16:04:39 <cdent> sorry, meant to vote, just did, I'm +1
16:04:43 <elmiko> cool
16:04:49 <elmiko> maybe we should merge that this week?
16:05:06 <cdent> as not-a-content change? sure
16:05:17 <elmiko> yeah
16:05:18 <elmiko> cool
16:05:27 <edleafe> yeah, no content changes
16:05:56 <elmiko> ok, i can merge it after this or cdent can
16:06:04 <cdent> goferit
16:06:28 <elmiko> so, the only topic we have is forum sessions. but i don't think there is anything new here?
16:07:08 <elmiko> could be a very short meeting today
16:07:24 <elmiko> any other topics to discuss in open biz?
16:07:57 <edleafe> none from me
16:08:35 <elmiko> moving along then
16:08:39 <elmiko> #topic guidelines
16:08:51 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:08:58 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-sig,n,z
16:09:27 <elmiko> seems like no -1s on this for freeze,
16:09:29 <elmiko> #link https://review.openstack.org/#/c/554921/
16:09:34 <elmiko> so, merge it?
16:09:53 <cdent> yup
16:10:07 <elmiko> i don't think anything else is ready for freeze
16:10:12 <cdent> ah, hmmm, we didn't freeze that one properly
16:10:18 <cdent> but I think that's okay
16:10:24 <elmiko> we didn't?
16:10:31 <cdent> I suspect the newsletter is more effective
16:10:32 <elmiko> (he says as he merges_
16:10:37 <cdent> it's fine
16:10:46 <elmiko> we announced it on the newsletter though
16:10:51 <cdent> but there's a script that adds all the liasions
16:10:55 <elmiko> oh, we should have emailed everybody. is that it?
16:10:58 <elmiko> yeah...
16:10:59 <elmiko> whoops
16:11:14 <edleafe> yeah, the liaisons weren't notified
16:11:31 <elmiko> hmm, i just hit the merge like seconds before cdent said that. should we do anything?
16:11:37 <cdent> no
16:11:38 <edleafe> otherwise they'd be listed as reviewers
16:11:41 <cdent> it really is all fine
16:11:42 <elmiko> yeah
16:11:56 <cdent> just for next time: do you know the tools?
16:12:15 <elmiko> no, i don't
16:12:24 <elmiko> i haven't used the script before
16:12:36 <cdent> they are describe in the process doc:
16:12:52 <cdent> grep for add-reviewers.py in http://specs.openstack.org/openstack/api-wg/process.html
16:13:11 <elmiko> yup, i see it
16:13:27 <elmiko> also, i just noticed, we should fix our entry on the index page for specs.openstack.org
16:13:31 <elmiko> still says working group
16:14:02 <cdent> ah, indeed
16:14:12 <cdent> I'll do that
16:14:16 <elmiko> sweet, thanks!
16:14:26 <cdent> #action cdent fix specs.openstack.org api-wg/sig naming
16:14:41 <elmiko> i think that's it for guidelines
16:14:50 <elmiko> #topic bug review
16:15:00 <elmiko> #link https://bugs.launchpad.net/openstack-api-wg/+bugs?orderby=-id&start=0
16:15:06 <elmiko> #link https://bugs.launchpad.net/openstack-api-sig/+bugs?orderby=-id&start=0
16:15:29 <elmiko> hm
16:15:38 <elmiko> i think we missed the "closes" comment for
16:15:40 <elmiko> #link https://bugs.launchpad.net/openstack-api-wg/+bug/1756464
16:15:41 <openstack> Launchpad bug 1756464 in openstack-api-sig "Errors guidelines reference service name, should be type" [Medium,Confirmed] - Assigned to Chris Dent (cdent)
16:15:58 * cdent fixes
16:16:03 <elmiko> thanks!
16:16:17 <elmiko> oh no, it's there
16:16:23 <elmiko> maybe just slow to update or something
16:17:07 <cdent> hmmm, merging the http guidelines changes has thrown my cache-headers thing (which is taking it's sweet time getting to reality) into merge conflcit
16:17:26 <cdent> expected, but meh
16:17:27 <elmiko> yeah, just saw that
16:17:43 <elmiko> seems like we could move to freeze that soon(TM)
16:17:57 * edleafe makes more work for cdent
16:18:09 <cdent> you keep doing that
16:18:19 <cdent> I'll fix the conflict this evening
16:18:39 <elmiko> cool
16:18:54 <elmiko> otherwise, i don't see anything on the bugs that stands out
16:20:04 <elmiko> although we might do another triage review at some point
16:20:23 <elmiko> #topic weekly newsletter
16:20:31 <elmiko> #link https://etherpad.openstack.org/p/api-sig-newslette
16:20:33 <edleafe> My turn, I think
16:20:41 <cdent> bless you
16:20:41 <elmiko> fair enough, thanks!
16:21:03 <elmiko> any other last minute topics or things we should discuss?
16:21:18 <edleafe> elmiko: still can't make it to Vancouver?
16:21:22 <cdent> no sir, thank you for running things
16:21:25 <elmiko> edleafe: i don't think so
16:21:28 <edleafe> :(
16:21:33 <elmiko> yeah...
16:21:40 <edleafe> win 16
16:21:45 <edleafe> doh!
16:21:49 <elmiko> =)
16:22:19 <elmiko> ok, i think we can get back like 38minutes =)
16:22:21 <elmiko> thanks!
16:22:24 <edleafe> stupid irssi!
16:22:29 <elmiko> #endmeeting