16:00:37 <dtantsur> #startmeeting api sig
16:00:38 <openstack> Meeting started Thu Jun 21 16:00:37 2018 UTC and is due to finish in 60 minutes.  The chair is dtantsur. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:39 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:41 <openstack> The meeting name has been set to 'api_sig'
16:00:47 <dtantsur> #chair cdent elmiko edleafe dtantsur
16:00:48 <openstack> Current chairs: cdent dtantsur edleafe elmiko
16:00:51 <elmiko> =D
16:00:56 <dtantsur> #link https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:01:10 <dtantsur> okay, let's now give some time for people to join :)
16:01:21 <elmiko> sounds good
16:01:52 <dtantsur> #topic previous meeting action items
16:01:53 <edleafe> \o
16:01:59 <cdent> oh hai
16:02:05 <dtantsur> #link http://eavesdrop.openstack.org/meetings/api_sig/2018/api_sig.2018-06-14-16.00.html
16:02:22 <dtantsur> whatever huzzah means, we promised to say it to edleafe more
16:02:26 <edleafe> Guess I didn't do mine yet
16:02:39 <elmiko> huzzah edleafe !
16:02:52 <edleafe> https://www.urbandictionary.com/define.php?term=huzzah
16:02:55 <elmiko> dtantsur: huzzah, kinda like hooray!
16:03:08 <dtantsur> TIL
16:03:10 <elmiko> risky click...
16:03:25 <edleafe> I'll send an email to Gilles via the dev list now that SB is up and running
16:03:29 <elmiko> ++
16:03:30 <dtantsur> yeah, you never know what comes out of urbandict
16:03:34 <elmiko> right
16:03:48 <edleafe> thought you were going to say "you never know what comes out of edleafe"
16:03:57 <dtantsur> that's quite true as well :D
16:04:10 <dtantsur> #action edleafe to send an email to Gilles re SB
16:04:28 <elmiko> edleafe: LOL
16:04:50 <dtantsur> #topic open mic and ongoing or new biz
16:04:59 <dtantsur> Any Forum Followup Required?
16:05:13 <elmiko> i don't think so
16:05:28 <dtantsur> anything except for graphql coming out of it?
16:05:38 <elmiko> i do want to point out for the record, that the graphql work seems to have started
16:05:49 <dtantsur> huzzah!
16:05:58 <elmiko> and Gilles had an email about an early working version of neutron with network queries in place
16:06:01 <edleafe> huh, just noticed that Action Items, by person, says that I have to say huzzah to myself more
16:06:05 <elmiko> well played dtantsur ;)
16:06:10 <cdent> I create a new thing about errors based on irc conversation yesterday
16:06:19 <elmiko> edleafe: that could get weird around the house
16:06:38 <dtantsur> elmiko: you cannot be sure that I'm not just a google's new neural network learning from the messages on this meeting, can you?
16:07:25 <edleafe> A neural network would be more interesting
16:07:28 <elmiko> no, i really can't XD
16:07:28 <edleafe> :-P
16:07:31 <elmiko> also,
16:07:34 <elmiko> #link http://lists.openstack.org/pipermail/openstack-dev/2018-June/131557.html
16:07:36 * dtantsur readjusts his weights
16:08:16 <dtantsur> #link https://review.openstack.org/#/c/575898/ first graphql patch for neutron
16:08:22 <elmiko> we just need a good markov chain to write our newsletters and we'll be all set
16:08:35 <dtantsur> elmiko: oh, so edleafe is not not one? Oo
16:08:37 * dtantsur hides
16:08:57 <edleafe> surprising, isn't it?
16:09:11 * edleafe is more of a block(head)chain, not markov
16:09:12 <dtantsur> yeah
16:09:18 <elmiko> haha
16:09:21 <elmiko> comedy gold today
16:09:39 * dtantsur wants neutron API in a blockchain, graphql is boring
16:09:42 <dtantsur> anyway
16:09:48 <dtantsur> any more new biz?
16:10:11 <elmiko> do we have any idea about days for the ptg?
16:10:23 <elmiko> i'm trying to be ahead of the game this time around
16:10:28 <dtantsur> I suspect Monday. I also suspect that I'm not going this time.
16:10:33 <edleafe> You mean the dates?
16:10:45 <elmiko> no, more just what days would we have api sig sessions
16:11:40 <edleafe> elmiko: just tell them that we will be meeting every day, so that you don't have to leave early
16:11:40 <elmiko> i'd like to come if possible, i just don't think i can do the whole stretch
16:11:45 <elmiko> LOL
16:11:47 <elmiko> i wish
16:12:27 <dtantsur> I guess we'll have to wait for the official process
16:12:39 <elmiko> fair
16:12:46 <elmiko> that's it from me
16:12:57 <edleafe> elmiko: just plan on Mon-Tue
16:13:05 <edleafe> It'll be one of those days for sure
16:13:12 <dtantsur> yeah, it's unlikely to change
16:13:25 <dtantsur> (until next year when everything gets messed up again)
16:13:39 <elmiko> edleafe: that's kinda what i was thinking
16:14:28 <edleafe> When the process starts, we'll make sure it's when you can be there
16:14:36 <cdent> I wouldn't be as sure about the structure of the ptg being what it was before
16:14:55 <cdent> since it is now "anybody who contributes to openstack in any way", not project teams, it may need a different structure
16:14:57 <dtantsur> cdent: I thought this one will still be boring, and theeeeen
16:15:07 <dtantsur> hmmm
16:15:40 * dtantsur wants to just get everyone in one huge bar for 3 days. would solve all problems.
16:16:07 <elmiko> haha
16:16:13 <cdent> It does seem like being snowed in is really useful
16:16:32 <elmiko> it worked for me, but i was pretty much just alone in my hotel XD
16:16:52 <cdent> constraints are good
16:17:11 <elmiko> ++
16:17:32 <dtantsur> we discussed the options for a social thing in Berlin with a local user group. get everyone wasted in a hangar was one of the options :D
16:18:16 <dtantsur> on this positive note, ready to move on?
16:18:39 <dtantsur> #topic guidelines
16:18:47 <dtantsur> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:18:49 <dtantsur> #link https://review.openstack.org/#/q/status:open+project:openstack/api-sig,n,z
16:18:58 * dtantsur wonders if the first link worked...
16:19:24 <dtantsur> #link https://review.openstack.org/#/c/577118/ Expand error code document to expect clarity
16:19:43 <dtantsur> I haven't read this yet, but the direction seems valid
16:19:54 <cdent> i tried to duplicate what we said in irc
16:19:57 <elmiko> me neither, but i will add it to my queue
16:19:59 <cdent> but it may be incomplete
16:21:35 <dtantsur> okay, I'll read it as well
16:22:43 <dtantsur> I guess we can move on?
16:23:00 <cdent> aye
16:23:01 <dtantsur> don't think we have guidelines for freeze
16:23:07 <edleafe> yup
16:23:10 <dtantsur> #topic bug review
16:23:24 <dtantsur> so, the agenda still have lp links
16:23:37 * dtantsur checks previous minutes
16:23:38 <cdent> oh whoops, I meant to fix that
16:24:07 <dtantsur> #action cdent to fix THAT
16:24:12 <dtantsur> :D
16:24:13 <edleafe> heh
16:24:15 <dtantsur> #undo
16:24:16 <openstack> Removing item from minutes: #action cdent to fix THAT
16:24:23 <edleafe> Actually, I should do that
16:24:31 <edleafe> since I was doing all the renaming stuff
16:24:34 <cdent> go for it
16:24:35 <dtantsur> #action edleafe to update the agenda with storyboard links
16:24:44 <cdent> I have a weekly todo to update the agenda and I ignored it this week
16:24:49 <dtantsur> huzzah!
16:25:15 <cdent> huzzah!
16:25:43 <dtantsur> #link https://storyboard.openstack.org/#!/project/1039
16:26:08 <elmiko> i like how well huzzah has been integrated since the beginning of the meeting, well done team!
16:26:12 <dtantsur> do we need an action item to rename it to api-sig?
16:26:17 <dtantsur> \o/
16:26:42 <edleafe> dtantsur: that's already started
16:26:48 <dtantsur> nice!
16:26:53 <dtantsur> oh, sorry
16:26:56 <dtantsur> huzzah!
16:27:00 <edleafe> it should get done the next time that gerrit is taken down
16:27:11 <dtantsur> and storyboard as well?
16:27:46 * cdent hopes gerrit stays down
16:28:08 <dtantsur> lol
16:28:30 <edleafe> dtantsur: they will rename all the things
16:28:39 <dtantsur> RENAME ALL THE THINGS
16:28:41 <cdent> even edleafe! huzzah!
16:29:02 * edleafe wonders what my new name will bwe
16:29:06 <edleafe> *be
16:29:14 <dtantsur> so, I guess we're ready for our favourite part?
16:29:24 <dtantsur> since no bugs seem any new
16:29:37 <dtantsur> #topic weekly newsletter
16:29:45 <dtantsur> #link https://etherpad.openstack.org/p/api-sig-newsletter
16:29:47 * cdent is still on the phone and also sitll in office hours, so step backwards
16:29:48 <edleafe> I did last week
16:29:54 <elmiko> i can take it
16:30:03 <dtantsur> elmiko: great! thanks
16:30:11 * dtantsur needs beer quite urgently
16:30:12 <cdent> thanks elmiko, huzzah!
16:30:12 <elmiko> will ping in sdks when it's ready
16:30:25 <edleafe> kewl
16:30:36 <dtantsur> anything else? :)
16:30:49 <dtantsur> we have 30 minutes in case we want to mock each other for longer
16:30:55 <cdent> :)
16:31:35 <edleafe> huzzah!
16:31:49 <dtantsur> indeed :)
16:31:53 <dtantsur> thanks all
16:32:00 <dtantsur> #endmeeting