16:00:46 <elmiko> #startmeeting api sig
16:00:47 <openstack> Meeting started Thu Jul  5 16:00:46 2018 UTC and is due to finish in 60 minutes.  The chair is elmiko. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:48 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:50 <openstack> The meeting name has been set to 'api_sig'
16:00:53 <elmiko> #chair cdent elmiko edleafe dtantsur
16:00:53 <openstack> Current chairs: cdent dtantsur edleafe elmiko
16:01:01 <elmiko> #link https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:01:09 <elmiko> #topic previous meeting action items
16:01:15 <elmiko> #link http://eavesdrop.openstack.org/meetings/api_sig/2018/
16:01:31 <elmiko> looks like no actions last week
16:01:32 <cdent> o/
16:01:42 <elmiko> #topic open mic and ongoing or new biz
16:01:51 <elmiko> so, anything new to discuss?
16:01:53 <edleafe> \o
16:02:32 <cdent> do we want to discuss the earlier placement 400 x 404 with path fragment constraints issue (in a more generic sense, given that isn't resolved)?
16:02:56 <elmiko> that isn't ringing a bell for me, more context?
16:03:19 <cdent> the gist is: if /foo/{uuid} is passed a non-uuid for {uuid} is that a 404 or a 400?
16:03:38 <elmiko> ooh, good question
16:04:00 <edleafe> My position was it was dependent on the definitions
16:04:01 <elmiko> my gut reaction is 404, but i could totally see the argument for 400
16:04:14 <edleafe> If it was specified that that part must be a UUID, then 400
16:04:14 <dtantsur> I'd vote for 404 in case the restriction on it being UUID is ever lifted
16:04:18 <edleafe> Otherwise, 404
16:04:25 <dtantsur> we did it in ironic actually
16:04:27 <elmiko> also, i think it depends how much you view the URI as API
16:04:34 <cdent> the complicating factor here is we are talking about a PUT here
16:04:43 <cdent> where the PUT can be a create
16:04:55 <dtantsur> ohhhhmmmmm
16:05:02 <elmiko> interesting
16:05:06 <dtantsur> I think this particular case is 400 indeed
16:05:23 <dtantsur> we're trying to create a resource from invalid information
16:05:31 <elmiko> yeah, i would agree. in this _specific_ case, 400 with a good error response seems appropriate
16:05:35 <edleafe> Well, if I did a PUT /people/cdunt, I would expect the system to not know that I meant 'cdent', and blindly create it
16:05:52 <dtantsur> if you can create /people/cdunt - yes
16:06:19 <dtantsur> if you can only create /people/<UUID> ... I guess it's weird for a creation to return 404, right?
16:06:33 <dtantsur> yeah, this example is funny
16:06:56 <elmiko> sweet corner case though!
16:07:01 <edleafe> dtantsur: yeah, it's gotta be a 400 in that case
16:07:10 <cdent> "yeah, this example if funny" is exactly right
16:07:14 <cdent> is!
16:07:16 <cdent> sigh
16:07:21 <elmiko> sounds like we have some consensus about 400 then, does that help cdent ?
16:07:59 <cdent> it does. it's what was already in place, but it wasn't interesting enough when it was initially raised that it's a bit like a warming up exercise here
16:08:14 <elmiko> haha, yes!
16:08:31 <elmiko> so, if the current impl is 400, how does the error code look?
16:10:46 <cdent> this is brand new today, haven't looked at it closely as I had other concerns with the surrounding code
16:10:55 <elmiko> cool
16:11:02 <elmiko> any other topics for open biz?
16:11:26 <cdent> not from me
16:12:06 <elmiko> #topic guidelines
16:12:09 <edleafe> nope
16:12:13 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:12:20 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-sig,n,z
16:12:37 <cdent> I made the requested changes on my two proposals
16:12:49 <elmiko> i reviewed one, but not the other. i'll get on that
16:12:53 <dtantsur> ditto
16:13:05 <elmiko> should we freeze this one?
16:13:08 <elmiko> #link https://review.openstack.org/#/c/577118/
16:13:14 <elmiko> does it need the freeze process?
16:13:32 <elmiko> i guess it does since it's an addition
16:13:54 <edleafe> yep
16:14:14 <edleafe> Shall I?
16:14:26 <elmiko> indeed =)
16:14:34 <cdent> goferit
16:15:44 <edleafe> done. Sending out the liaison notices now
16:15:58 <elmiko> thanks edleafe
16:17:07 <edleafe> Hmmm
16:17:07 <edleafe> error: could not add Nikolay Starodubtsev: Nikolay Starodubtsev does not identify a registered user or group
16:17:11 <edleafe> error: could not add Fei Long Wang: Fei Long Wang does not identify a registered user or group
16:17:26 <edleafe> Looks like some stale info in the liaison file
16:18:24 <elmiko> cdent: i added a note, but on your other review i agree with the idea of expanding the schema to include underscore
16:18:43 <cdent> elmiko: i'm glad you agree with me, otherwise I might have to cut you
16:18:49 <elmiko> LOL
16:19:03 <cdent> should I fix that as part of that change or a different one?
16:19:08 * edleafe hides from cdent
16:19:14 <dtantsur> :D
16:19:18 <elmiko> is this the next new trend in software development practices? prison-yard dev?
16:19:36 <dtantsur> threat-driven development
16:19:45 <elmiko> i'm ok with either cdent, adding another pr gives us more focus for arguing about hyphens though ;)
16:19:54 <cdent> https://www.youtube.com/watch?v=mAh--lH0H3U
16:20:58 <elmiko> i like the way this sounds =)
16:21:22 <elmiko> any other comments about guidelines?
16:21:39 <cdent> the live versions are much better
16:21:56 <cdent> catch the undertone of physical abuse a bit better
16:22:42 <cdent> #action cdent to follow up to make a new change about _ being okay in error.cores
16:22:45 <cdent> #undo
16:22:46 <openstack> Removing item from minutes: #action cdent to follow up to make a new change about _ being okay in error.cores
16:22:56 <cdent> #action cdent to follow up to make a new change about _ being okay in error.codes
16:23:02 <elmiko> ++
16:23:11 <elmiko> #topic bug review
16:23:17 <elmiko> #link https://storyboard.openstack.org/#!/project/1039
16:23:18 <edleafe> error.cores == imporssible!
16:23:37 <elmiko> haha
16:23:46 <edleafe> The GraphQL folks are using our storyboard: https://storyboard.openstack.org/#!/story/2002782
16:23:48 <elmiko> nice to see the graphql story(?) in here
16:24:09 <cdent> story is the right term, yes
16:24:27 <dtantsur> yeah, but the tasks should probably target neutron, not us
16:24:29 <elmiko> are those things on the front page considered stories and the things under it tasks? (trying to learn the jargon here)
16:24:38 <elmiko> cool, thanks cdent
16:24:47 <dtantsur> yep, stories consist of tasks
16:24:54 <dtantsur> tasks are bound to a project, stories are global
16:25:36 <edleafe> dtantsur: it could be us or neutron, but since the process started with us, and if successful, will extend to other projects, it feels like this is a good place
16:25:45 <elmiko> interesting, so i guess that's the question, do experimental tasks get bound to their /home/ project?
16:26:00 <dtantsur> edleafe: a task is where the change lands
16:26:17 <dtantsur> so if the task is a change to openstack/neutron, it should be against neutron
16:26:35 <dtantsur> otherwise gerrit will get confused (as well as people like me)
16:26:50 <edleafe> now I'm confused
16:27:09 <edleafe> the story is in api-wg, but the tasks for that story are not?
16:28:46 <dtantsur> edleafe: stories are global, they are not bound to any project
16:28:57 <dtantsur> only tasks are
16:29:12 <dtantsur> as I said a week or two ago, it's the whole paradigm change
16:29:54 <elmiko> do we need to do anything here? like, can the tasks be adjusted after they are created?
16:29:57 <cdent> so the reason those stories show up in the api-wg project is because they have api-wg tasks?
16:31:15 * cdent does a little dance
16:31:33 <dtantsur> right
16:32:40 <elmiko> any other new bugs(stories)(?) to talk about?
16:32:51 <edleafe> So we didn't need to convert to SB for the GraphQL people to use SB?
16:33:02 <elmiko> seems like maybe not
16:33:17 <dtantsur> neutron has :) well, it's good to have a task for us
16:33:23 <dtantsur> like "keep discussing on the meetings" :)
16:33:51 <elmiko> brb
16:35:36 <elmiko> ok, sorry gas workers just showed up. they are digging up my front yard apparently
16:35:42 <elmiko> any other bug topics?
16:35:53 * cdent lights a match
16:35:58 <elmiko> haha, yeah really ;)
16:36:19 <cdent> i think we've beaten the bug topic into the ground
16:36:20 <elmiko> #topic weekly newsletter
16:36:29 <elmiko> #link https://etherpad.openstack.org/p/api-sig-newsletter
16:36:29 <cdent> I have volunteered
16:36:31 <elmiko> \o/
16:36:39 <cdent> so I'll ping people when I have a version
16:36:42 <elmiko> cool
16:36:55 <elmiko> any parting words that folks want to get in the record?
16:36:57 <cdent> but it will be a few minutes, I'm going to go sit outside for a few minutes
16:37:06 <edleafe> no hurry
16:37:17 <elmiko> sounds good to me =)
16:37:26 <elmiko> ok, thanks everybody. have a good weekend!
16:37:27 <cdent> ramparting
16:37:31 <cdent> imparting
16:37:35 <cdent> departing
16:37:40 <elmiko> haha
16:37:44 <elmiko> #endmeeting