16:00:15 <elmiko> #startmeeting api sig
16:00:16 <openstack> Meeting started Thu Aug  2 16:00:15 2018 UTC and is due to finish in 60 minutes.  The chair is elmiko. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:19 <openstack> The meeting name has been set to 'api_sig'
16:00:22 <elmiko> #chair cdent elmiko edleafe dtantsur
16:00:23 <openstack> Current chairs: cdent dtantsur edleafe elmiko
16:00:29 <dtantsur> o/
16:00:31 <elmiko> #link https://wiki.openstack.org/wiki/Meetings/API-SIG#Agenda
16:00:34 <elmiko> hey folks =)
16:00:38 <edleafe> geez, just one second before I hit return to start the meeting!
16:00:48 <elmiko> hahaha
16:00:53 * edleafe needs to type faster
16:01:10 <elmiko> it is a sort of free-for-all at the start there
16:01:15 <cdent> o/
16:01:26 <elmiko> and here i thought i was waiting before hitting return
16:01:53 <elmiko> #topic previous meeting action items
16:01:54 <edleafe> oh sure, rub it in. We all get it, you can type fast
16:02:00 <elmiko> #link http://eavesdrop.openstack.org/meetings/api_sig/2018/
16:02:10 <elmiko> in fairness, i just cut and pasted
16:02:17 <dtantsur> heh
16:02:27 <elmiko> there, now the secret is out
16:02:51 <elmiko> so, how far did everyone make it through the draft?
16:03:00 <edleafe> I did
16:03:08 * edleafe gives himself a cookie
16:03:13 <cdent> I read the whole thing
16:03:16 * elmiko gives edleafe another cookie
16:03:25 * edleafe gives cdent a cookie too
16:03:27 <elmiko> i made it about 80% through
16:03:27 <cdent> I even gossiped about the parts I didn't agree with with someone
16:03:33 * elmiko gives cdent another cookie
16:03:41 <elmiko> ooh, bonus points for cdent !
16:03:46 <cdent> ikr
16:03:54 <edleafe> Which parts were those?
16:04:00 <cdent> The part I didn't agree with was about not using specific 4xx responses
16:04:18 <dtantsur> I disagree with a few things, this being one of them
16:04:24 * dtantsur tries to remember
16:05:06 <dtantsur> overall the thing did not read like something breaking
16:05:09 <edleafe> I read it nearly a week ago, so the specifics are a bit fuzzy
16:05:22 <elmiko> for the most part, i found it to be quite sane, my concern for us is going through it more closely to ensure that we haven't make guidance that contradicts (assuming we adopt it as a starting point for something)
16:05:27 <dtantsur> a lot of "do not", but not much "instead do"
16:05:30 <cdent> yeah, it wasn't particularly revolutionary, sort of gentle intro to REST with some pragmatism added in
16:05:42 <elmiko> ++
16:06:17 <dtantsur> I think we had something contradicting, but I cannot remember
16:06:23 * dtantsur needs to re-read it
16:06:41 <edleafe> I felt that a large part of our HTTP guidelines could have been replaced with "hey, read this"
16:07:10 <cdent> I wasn't really expecting it to provide much in the way of guidance for us, more sort of a lemon zesty refresher from the outside world, squeezed upon our staid interiors
16:07:19 <elmiko> that would really help spread the load of our guidance edleafe , i'm ++
16:07:30 <cdent> it _would_ be good to link to it
16:07:56 <edleafe> Somehow reading an IETF draft proposal doesn't conjure up "lemon zesty" in my mind
16:07:57 <cdent> perhaps where we say "in the absence of direct guidance look at the rfcs" we could also say "and this good overview"
16:08:04 <elmiko> i'm kinda curious about our next steps here, like should we review it at a more detailed level? publish a link? wait for it to finalize?
16:08:05 <cdent> because in the end what we want is to be globally consistent
16:08:19 <elmiko> agreed cdent
16:08:27 <cdent> I can take that action
16:08:37 <elmiko> sweet, thanks!
16:08:38 <cdent> #action cdent add links to mnot http protocol thing
16:08:50 <edleafe> I think our guidelines need to be more succinct than this draft
16:09:00 <cdent> yes
16:09:01 <edleafe> But yeah, linking to it would be excellent
16:09:17 <cdent> there's much refactoring and refining it would be good to do
16:09:27 <edleafe> that draft is almost as wordy as a mordred patch!
16:09:32 <elmiko> haha
16:09:39 <dtantsur> lol
16:09:40 * elmiko notes "almost"
16:09:49 <cdent> unpossible
16:09:55 <mordred> nothing is that wordy
16:10:03 <elmiko> =D
16:10:13 <elmiko> any other comments on this topic?
16:10:40 <cdent> The showrunners for the api-sig have mordred pop up over the backstage wall for a few million $$ every few episodes
16:10:45 <cdent> and then he fades away
16:10:53 <elmiko> LOL
16:10:56 <dtantsur> :D
16:10:57 <elmiko> so good
16:11:00 <elmiko> #topic open mic and ongoing or new biz
16:11:20 <elmiko> i guess we didn't clean up the kruft here, but anything to discuss that is not the draft thingie?
16:11:45 <cdent> anything we need/want to think about PTG-wise?
16:12:12 <edleafe> I was thinking that the PTG would be a good place to discuss the draft thingy in more detail
16:12:16 <elmiko> who is going to be there?
16:12:25 <edleafe> I'm hoping to go
16:12:41 <edleafe> But IBM is still dragging their collective feet on travel approval
16:12:43 * mordred would like to actually meet with y'all this ptg instead of not doing that like I have done at the last few
16:12:57 <mordred> edleafe: I do not want to visualize IBM's collective feet
16:12:59 <cdent> edleafe: you could almost drive up and camp in the halls
16:13:06 * elmiko chuckles
16:13:07 <edleafe> heh
16:13:15 <cdent> i'll be there
16:13:25 <edleafe> mordred: actually, just my grand-boss
16:13:32 <elmiko> it's very unlikely that i will be there
16:13:39 <elmiko> which makes me sad =(
16:13:41 <edleafe> You say that every time
16:13:45 <elmiko> haha, i know
16:13:47 <edleafe> and then you show up
16:13:53 <elmiko> but this time i feel the winds have changed
16:14:05 <elmiko> road trip?
16:14:36 <mordred> elmiko: I'd suggest that your employer is crazy if they think they should not send you to the PTG
16:14:47 <mordred> but, you know, that may just be me
16:14:59 * cdent will fly to detroit, pick up elmiko, go visit cdent's niece in Louisville, then drive to denver?
16:15:01 <cdent> ROAD TRIP
16:15:06 <elmiko> ROAD TRIP
16:15:15 <cdent> sadly my flights are already booked :(
16:15:21 <cdent> otherwise that's a great idea
16:15:26 <elmiko> mordred: yeah, i just know some things are changing for our travel budget and i am loathe to push too hard
16:15:32 * dtantsur is not going
16:15:37 <edleafe> Sounds like National Lampoon's Vacation
16:16:13 <cdent> So it might be just me and mordred coming up with ways to enshrine and work around microversion simultaneously
16:16:23 <elmiko> sounds like it
16:16:26 <mordred> cdent: we can make so many decisios
16:16:29 <mordred> decisions
16:16:31 <cdent> \o/
16:16:38 <elmiko> and hopefully some sort of update on the graphql situation (assuming one of them is there)
16:16:39 <mordred> or more probably decisios
16:16:58 <edleafe> Yeah, still no reply from Gilles
16:17:15 <elmiko> ack
16:17:23 <dtantsur> I'll be looking forward to maybe see some of you in Berlin
16:17:52 <cdent> I'll be there too.
16:17:58 <cdent> After that things will start getting vague
16:18:09 <edleafe> It's funny - IBM tends to spend more on travel later in the year
16:18:20 <edleafe> Probably be easier to get to Berlin than to Denver :)
16:18:40 <elmiko> i thought about submitting a talk for berlin, but it was really stretching it
16:19:14 * dtantsur submitted two talks
16:19:22 <elmiko> nice! good luck =)
16:19:33 <cdent> At some point I'll start an etherpad for the PTG
16:19:40 <elmiko> thanks cdent
16:19:41 <cdent> #action cdent start etherpad for api-sig at ptg
16:20:03 <edleafe> cdent is action man this week
16:20:09 <elmiko> yea seriously
16:20:10 <cdent> dtantsur, mordred : did you make your microversion proposal?
16:20:13 <elmiko> someone get that man a cookie
16:20:18 <dtantsur> cdent: we did
16:20:41 <dtantsur> and now I suspect *SOMEONE* did not vote for it ;)
16:20:52 <mordred> we're gonna tell everyone about microversions
16:20:55 * cdent does not vote
16:21:05 <edleafe> what?? Everyone LOVES microversions!!
16:21:11 <elmiko> "microversion, it's way of life maaaan"
16:21:18 <cdent> it's too tedious going through all the proposals
16:21:23 <cdent> espeically since I never go to presentations...
16:21:25 <cdent> doesn't seem right
16:21:37 <dtantsur> well, I watch the most interesting ones in recording
16:21:37 <mordred> cdent: but BUZZWORD BUZZWORD is awesome because BUZZWORD BUZZWORD!
16:21:45 <dtantsur> so I still feel the right to vote for good stuff
16:21:45 <elmiko> hahaha
16:22:33 * cdent saves all his voting karma for destroying brexit
16:22:42 <elmiko> nice
16:22:54 <elmiko> anything else for open biz?
16:23:15 * edleafe thinks cdent doesn't understand voting karma
16:23:19 <elmiko> #topic guidelines
16:23:27 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:23:33 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-sig,n,z
16:23:44 <cdent> no news is good news?
16:23:54 <elmiko> i think there is nothing go on here this week for guidelines
16:23:56 <elmiko> yea
16:24:07 <elmiko> #topic bug review
16:24:12 <elmiko> #link https://storyboard.openstack.org/#!/project/1039
16:24:24 <elmiko> looks like the same story here as well
16:24:26 <cdent> same again
16:24:36 <elmiko> #topic weekly newsletter
16:24:41 <elmiko> #link https://etherpad.openstack.org/p/api-sig-newsletter
16:24:45 <edleafe> Before you do that...
16:24:47 <elmiko> any volunteers?
16:24:48 <edleafe> I just remembered
16:24:58 <elmiko> should i switch back the topic?
16:25:13 <edleafe> Infra will be doing the rename for the sig on Friday
16:25:19 <elmiko> ooh, cool
16:25:25 <dtantsur> \o/
16:25:47 <elmiko> do we need to update anything more than the agenda wiki?
16:25:48 <edleafe> So we can toss all our API-WG business cards
16:25:52 <elmiko> hahaha
16:26:07 <edleafe> I don't think so, but we'll see
16:26:15 <elmiko> cool, thanks for the update edleafe
16:26:29 <edleafe> Making sure that the github links still work and stuff like that
16:26:35 <cdent> I had some really cool business cards
16:26:52 <cdent> https://www.youtube.com/watch?v=cISYzA36-ZY
16:27:14 <elmiko> lol, knew it
16:27:25 <cdent> (this is clearly the most fun hour all week, for me)
16:27:31 <elmiko> =)
16:27:43 <elmiko> i'm happy to have been part of it
16:28:02 <elmiko> now, who's gonna write the newsletter?
16:28:04 <edleafe> same here
16:28:13 <edleafe> I wrote it last week
16:28:22 <elmiko> ok, edleafe is off the hook
16:28:37 <cdent> I can do it
16:28:38 <elmiko> i think it's only fair that i do it since cdent was kind enough to take all the actions this week
16:28:46 <elmiko> either way
16:28:46 <cdent> oh yeah, yeah, that
16:28:50 <cdent> go for it
16:28:57 <elmiko> k, i'll ping in a bit
16:29:01 <elmiko> thanks everybody!
16:29:13 <elmiko> now's your chance for a last word =D
16:29:20 <edleafe> word
16:29:25 <elmiko> #endmeeting