#openstack-sdks: API-SIG

Meeting started by dtantsur at 16:00:31 UTC (full logs).

Meeting summary

    1. https://etherpad.openstack.org/p/openstack-ansible-modules (dtantsur, 16:02:18)
    2. https://github.com/theforeman/foreman-ansible-modules/pull/591 might have some useful background (gundalow, 16:08:37)
    3. https://github.com/theforeman/foreman-ansible-modules/pull/591 some helpful background (dtantsur, 16:09:01)
    4. AGREED: Import the existing modules as they are and freeze them. Keep syncing until ansible removes them from tree. (dtantsur, 16:23:57)
    5. ACTION: to collaborate with pabelanger to create sync zuul jobs (sshnaidm, 16:24:31)
    6. ACTION: sshnaidm to collaborate with pabelanger to create sync zuul jobs (sshnaidm, 16:25:07)
    7. AGREED: No periodic sync, just one-time migration with temporary freezes on both sides (ending with `git rm` and `migrated_to: openstack.FOO` on the ansible side) (dtantsur, 16:38:40)
    8. AGREED: Do the migration in the middle of January 2020 (dtantsur, 16:44:10)
    9. https://bit.ly/2OUz1Xa (sshnaidm, 16:47:13)
    10. ACTION: sshnaidm To raise the licensing topic on legal-discuss (dtantsur, 16:55:21)
    11. AGREED: to keep modules compatible with Ansible collections API (sshnaidm, 17:00:17)


Meeting ended at 17:00:56 UTC (full logs).

Action items

  1. to collaborate with pabelanger to create sync zuul jobs
  2. sshnaidm to collaborate with pabelanger to create sync zuul jobs
  3. sshnaidm To raise the licensing topic on legal-discuss


Action items, by person

  1. pabelanger
    1. to collaborate with pabelanger to create sync zuul jobs
    2. sshnaidm to collaborate with pabelanger to create sync zuul jobs
  2. sshnaidm
    1. sshnaidm to collaborate with pabelanger to create sync zuul jobs
    2. sshnaidm To raise the licensing topic on legal-discuss


People present (lines said)

  1. sshnaidm (97)
  2. dtantsur (97)
  3. gtema (54)
  4. gundalow (51)
  5. pabelanger (40)
  6. jistr (13)
  7. openstack (6)
  8. ekultails (4)
  9. mnaser (2)
  10. elmiko (2)
  11. dasp (1)
  12. openstackgerrit (1)
  13. cloudnull (1)


Generated by MeetBot 0.1.4.