16:00:48 <sshnaidm> #startmeeting api-sig
16:00:49 <openstack> Meeting started Thu Jan 23 16:00:48 2020 UTC and is due to finish in 60 minutes.  The chair is sshnaidm. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:52 <openstack> The meeting name has been set to 'api_sig'
16:00:58 <odyssey4me> heh, somehow I'm in three meetings at once :)
16:01:07 <sshnaidm> who is available?
16:01:17 <gtema> me
16:01:21 <sshnaidm> if there are conflict we can change time meeting
16:01:33 <dtantsur> I'd prefer to, to be honest
16:01:52 <dtantsur> and since we're occupying the API SIG slot, we should probably set up a special meeting for our working group
16:01:58 <sshnaidm> ok, will create a poll in etherpad about a new time
16:02:02 <dtantsur> an hour earlier later would work for me, for example
16:02:07 <dtantsur> * or later
16:02:25 <dtantsur> sshnaidm: you can start a doodle or similar
16:02:34 <sshnaidm> dtantsur, yeah, good idea
16:02:43 <odyssey4me> yeah, or we could agree on a SIG meeting time... when trying to get https://review.opendev.org/697278 done I couldn't find an appropriate set time for the SIG to set the  schedule
16:03:14 <dtantsur> odyssey4me: if we don't use one of the meeting channels, we can probably use any time that works for us
16:03:14 <sshnaidm> ok, we'll see in doodle which is best
16:03:46 <odyssey4me> dtantsur: yep, easy enough - I just wanted to make it easy to communicate and get updates
16:03:54 <sshnaidm> #action sshnaidm to choose better time for sig meeting
16:04:09 <sshnaidm> So, as you can know from openstack-discuss list the tranisition is in the progress. Tracking of it is in our etherpad: https://etherpad.openstack.org/p/openstack-ansible-modules
16:04:18 <sshnaidm> In these weeks I'd ask everybody for reviewes asap not to block peoples workflow, please. Take a look: https://review.opendev.org/#/c/703342/
16:04:28 <sshnaidm> We have in CI the same job that was running before in Ansible PRs, so we're covered at least the same as before now.
16:04:44 <sshnaidm> went over all PRs in github for OS ansible modules and left a message about tranistion, but it can be still merges. We'll sync all things when modules will be removed from 2.10 completely. It will happen in next 3 weeks when ansible folks fix their sync of docs from collections.
16:04:44 <sshnaidm> Meanwhile I'll prepare these PRs in ansible github.
16:05:55 <sshnaidm> There are some issues with collection names and using them in roles/playbooks, so we'll need to mention the full collection names for now, "FQCN"
16:06:01 <sshnaidm> gtema, to your question ^
16:06:54 <gtema> yupp. But I think once modules are removed in ansible it is fine
16:07:08 <sshnaidm> gtema, in 2.10 only though
16:07:11 <gtema> I think we also need to agree to accept new modules WITHOUT os_ prefix
16:07:44 <sshnaidm> gtema, yeah, so another requirement from ansible team was not renaming till 2.11
16:08:06 <sshnaidm> since it can cause problems with collection and their usage, which may change any time
16:08:17 <gtema> also I will revive mordred's patch for implementing base Module class in the module_utils, it makes life easier (did this for my own collection same)
16:08:18 <sshnaidm> I think we can wait a little with renaming
16:08:43 <sshnaidm> gtema, yeah, just need to rebase it
16:08:51 <gtema> sshnaidm: ansuble guys want that in our repo we do not rename modules?
16:08:59 <gtema> i thought it was ok with BOTMETA
16:09:02 <sshnaidm> we are good now to develop new modules, we already have a few in reviews
16:09:26 <sshnaidm> gtema, it's not so easy, turns out, and things are changing fast there
16:10:00 <gtema> crap, it's like with Openshift - things are changing and thus no release possible. What are you doing there at RedHat ;-)
16:10:11 <sshnaidm> just talked this week with bcoca, Paul, gundalow on ansible-devel and to be safe it's worth to wait with renaming
16:10:12 <dtantsur> drinking
16:10:23 <gtema> that's for sure
16:10:42 <sshnaidm> gtema, yeah, it's our main purpose here :D
16:10:51 <gtema> ok, but then let's agree on accepting new modules without prefix
16:11:15 <gtema> you drink, and I am dying 4th day already
16:11:18 <sshnaidm> gtema, I'm not sure if it worth it, when finally renaming we can do it in bulk
16:11:23 <odyssey4me> sounds sensible to me, I guess the ask for preventing renames for a while is to allow a deprecation period
16:11:56 <odyssey4me> if the deprecation notice is up, but new modules don't have the prefix - then we're good
16:11:59 <sshnaidm> gtema, and to have it with os_ is keeping consistency
16:12:20 <gtema> ok, #agreed
16:12:46 <sshnaidm> so that all I have from ansible team for now
16:13:03 <gtema> what about release jobs?
16:13:05 <sshnaidm> we're good to add more tests, more jobs
16:13:14 <sshnaidm> gtema, yeah, good point
16:13:16 <gtema> I would be happy to start consuming collection from my projects
16:13:27 <sshnaidm> I stole a pushing job from Paul and working on it
16:13:55 <sshnaidm> need to ping mordred about pushing to galaxy, because he has the access only
16:14:22 <sshnaidm> maybe it's worth even to push what we have now and then to do it with releases and push-job
16:14:52 <sshnaidm> I'm only for early usage to see if everything is ok, etc
16:15:18 <sshnaidm> #action sshnaidm to add a publishing job
16:16:01 <sshnaidm> #action mordred to publish collection or to share access for galaxy namespace
16:16:05 <gtema> yeah, the interesting issue I found using collection on galaxy - you can't update/delete pushes
16:16:17 <gtema> so whatever we push - stay there with this name forever
16:16:22 <sshnaidm> gtema, yeah, you need a new version
16:16:35 <gtema> or at least until you redhat guys drink another beer
16:17:00 <gtema> I know about new ver, I mean before pushing you really need to be sure it works
16:17:19 <sshnaidm> gtema, you can submit issues for galaxy, btw, I submitted one about editing namespace and it was solved
16:17:27 <sshnaidm> SURPRISINGLY
16:18:06 <gtema> oh yes, suprisingly. You also need to open issue to add maintainers to your org, ...
16:18:14 <gtema> and lot's of things are "undocumented"
16:18:23 <sshnaidm> gtema, you can add them, I did
16:18:24 <gtema> so my life is great
16:18:35 <sshnaidm> no need to open issue for that
16:19:06 <gtema> I do not see any other candidate users to add, only some "preconfigured" roots or so
16:19:37 <sshnaidm> gtema, try on #ansible-galaxy
16:19:54 <gtema> yeah, when I will have time for that
16:20:00 <sshnaidm> chouseknecht is the guy
16:20:15 <gtema> thks
16:20:29 <sshnaidm> ok, is there something about new fancy ansible modules for openstack you wanna talk more?
16:20:52 <sshnaidm> 3
16:20:54 <sshnaidm> 2
16:20:56 <sshnaidm> 1
16:20:58 <gtema> nope, I would be offering one more for volume backups
16:21:10 <sshnaidm> gtema, great
16:21:10 <dtantsur> I guess sshnaidm is developing ironic stuff?
16:21:22 <dtantsur> (and we need to sync on that one day)
16:21:23 <sshnaidm> dtantsur, right, looking at node cleaning module now
16:21:34 <sshnaidm> dtantsur, yep, will ping you when have something
16:21:40 <dtantsur> I wonder if we need a spec-like or RFE-like process from now on
16:21:55 <sshnaidm> dtantsur, and I need a way to test it and better w/o devstack
16:21:57 <dtantsur> to have some formal discussion about interfaces rather than just landing whatever looks sane
16:22:08 <dtantsur> sshnaidm: w/o devstack - tripleo undercloud?
16:22:20 <sshnaidm> dtantsur, even better just ironic standalone
16:22:26 <dtantsur> bifrost? ;)
16:22:47 <sshnaidm> dtantsur, just container with ironic? like ironic-dev I had
16:23:05 <dtantsur> installing ironic is easy, it's harder when you need it to actually DO anything
16:23:05 <sshnaidm> dtantsur, but I couldn't auth with it and current Openstack ansible auth
16:23:25 <dtantsur> the current openstack ansible auth is broken for at least some cases
16:23:53 <dtantsur> a VM with bifrost (we have vagrant support) can be more helpful
16:23:55 <sshnaidm> dtantsur, yeah, so maybe we can find a way, but if not - tripleo standalone job then :)
16:24:15 <dtantsur> or that (although it won't allow you to actually do things with VMs)
16:24:19 <sshnaidm> dtantsur, well, I can't run vm
16:24:36 <sshnaidm> dtantsur, we don't have nested on upstream clouds
16:24:40 <dtantsur> okay, we can discuss it outside of the meetings
16:24:44 <dtantsur> I meant your laptop :)
16:24:46 <sshnaidm> dtantsur, cool
16:24:57 <dtantsur> sshnaidm: and FWIW I do use devstack on a VM in RDO cloud. it works.
16:25:14 <sshnaidm> dtantsur, rdo cloud is different story :)
16:25:30 <dtantsur> okay, we can discuss ironic stuffs on #openstack-ironic, I won't hold the meeting
16:25:33 <sshnaidm> ok, let's take it offline then
16:25:43 <sshnaidm> ok, if nothing else...
16:25:51 <sshnaidm> #endmeeting