#openstack-meeting-3: api wg

Meeting started by ycombinator_ at 00:08:11 UTC (full logs).

Meeting summary

  1. roll call (ycombinator_, 00:08:39)
  2. agenda (ycombinator_, 00:10:58)
    1. https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (ycombinator_, 00:11:01)

  3. summit review (ycombinator_, 00:12:02)
    1. https://etherpad.openstack.org/p/kilo-crossproject-api-wg (sigmavirus24, 00:13:38)

  4. additional meeting time (ycombinator_, 00:14:58)
    1. https://review.openstack.org/#/c/132668/ (ycombinator_, 00:14:59)

  5. wiki page updates (ycombinator_, 00:18:03)
    1. https://wiki.openstack.org/wiki/API_Working_Group (ycombinator_, 00:18:06)

  6. APIImpact flag (ycombinator_, 00:21:01)
    1. https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z (ycombinator_, 00:21:09)
    2. https://review.openstack.org/#/c/132342/ (ycombinator_, 00:22:04)

  7. review 201-header-and-body (ycombinator_, 00:26:09)
    1. https://review.openstack.org/#/c/133087/ (sigmavirus24, 00:26:15)
    2. https://review.openstack.org/#/c/133087/ (ycombinator_, 00:26:18)
    3. ACTION: ycombinator_ will update https://review.openstack.org/#/c/133087/ with 1. synchronous creation should respond with 201, asynchronous with 202; body is optional and 2. in either synchronous or asynchronous creation, there must be a location header (sigmavirus24, 00:36:11)

  8. reviews (ycombinator_, 00:36:43)
    1. https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z (ycombinator_, 00:36:47)
    2. ACTION: sigmavirus24 will comment on https://review.openstack.org/#/c/132248/ re: no 204 for creation (ycombinator_, 00:40:32)
    3. https://review.openstack.org/#/c/133087/ (etoews, 00:45:35)
    4. https://review.openstack.org/#/c/133087/ (etoews, 00:45:56)
    5. ACTION: miguelgrinberg to start conversation with cyeoh re: https://review.openstack.org/#/c/131320/ (ycombinator_, 00:46:02)
    6. ACTION: etoews to update proposal for 201 header and body in https://review.openstack.org/#/c/133087/ (ycombinator_, 00:55:24)


Meeting ended at 01:00:59 UTC (full logs).

Action items

  1. ycombinator_ will update https://review.openstack.org/#/c/133087/ with 1. synchronous creation should respond with 201, asynchronous with 202; body is optional and 2. in either synchronous or asynchronous creation, there must be a location header
  2. sigmavirus24 will comment on https://review.openstack.org/#/c/132248/ re: no 204 for creation
  3. miguelgrinberg to start conversation with cyeoh re: https://review.openstack.org/#/c/131320/
  4. etoews to update proposal for 201 header and body in https://review.openstack.org/#/c/133087/


Action items, by person

  1. etoews
    1. etoews to update proposal for 201 header and body in https://review.openstack.org/#/c/133087/
  2. miguelgrinberg
    1. miguelgrinberg to start conversation with cyeoh re: https://review.openstack.org/#/c/131320/
  3. openstack
    1. ycombinator_ will update https://review.openstack.org/#/c/133087/ with 1. synchronous creation should respond with 201, asynchronous with 202; body is optional and 2. in either synchronous or asynchronous creation, there must be a location header
    2. sigmavirus24 will comment on https://review.openstack.org/#/c/132248/ re: no 204 for creation
    3. miguelgrinberg to start conversation with cyeoh re: https://review.openstack.org/#/c/131320/
    4. etoews to update proposal for 201 header and body in https://review.openstack.org/#/c/133087/
  4. sigmavirus24
    1. sigmavirus24 will comment on https://review.openstack.org/#/c/132248/ re: no 204 for creation
  5. ycombinator_
    1. ycombinator_ will update https://review.openstack.org/#/c/133087/ with 1. synchronous creation should respond with 201, asynchronous with 202; body is optional and 2. in either synchronous or asynchronous creation, there must be a location header


People present (lines said)

  1. ycombinator_ (70)
  2. sigmavirus24 (66)
  3. miguelgrinberg (36)
  4. etoews (24)
  5. openstack (3)
  6. annegentle (1)


Generated by MeetBot 0.1.4.