#openstack-meeting-3: api wg

Meeting started by etoews at 16:00:30 UTC (full logs).

Meeting summary

  1. agenda (etoews, 16:01:30)
    1. https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (etoews, 16:01:39)

  2. api definition formats (etoews, 16:02:09)
    1. https://github.com/elmiko/sahara-doc (elmiko, 16:03:29)
    2. http://paste.openstack.org/show/152783/ (elmiko, 16:05:06)
    3. ACTION: etoews update the scope section of the wiki page and include api definition format (etoews, 16:07:05)
    4. https://github.com/bendyworks/caravan (sigmavirus24, 16:12:29)
    5. https://github.com/swagger-api (elmiko, 16:13:26)
    6. https://github.com/cloudkeep/barbican/wiki/Application-Programming-Interface (etoews, 16:18:50)
    7. https://github.com/bendyworks/caravan/blob/master/lib/endpoint_definitions/users/user.yml etoews (sigmavirus24, 16:21:44)
    8. ACTION: elmiko to generate swagger doc for barbican and commit to github somewhere (etoews, 16:23:12)
    9. https://github.com/bendyworks/caravan#interpol-endpoint-validation (etoews, 16:24:44)
    10. ACTION: etoews start discussion about api def formats on ml (etoews, 16:30:56)
    11. ACTION: sigmavirus24 reply to discussion with benefits moz saw from using an api def format (etoews, 16:31:25)

  3. previous meeting action items (etoews, 16:34:46)
    1. http://eavesdrop.openstack.org/meetings/api_wg/2014/api_wg.2014-12-11-00.00.html (etoews, 16:34:53)
    2. https://review.openstack.org/#/c/141229/ (etoews, 16:37:26)
    3. ACTION: etoews start discussion on ml about doing more analysis of current design and not creating guidelines in a vacuum (etoews, 16:43:26)

  4. APIImpact (etoews, 16:46:01)
    1. https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z (etoews, 16:46:06)
    2. https://review.openstack.org/139775 should be simple enough (sigmavirus24, 16:47:01)

  5. open topics (etoews, 16:56:50)


Meeting ended at 17:00:17 UTC (full logs).

Action items

  1. etoews update the scope section of the wiki page and include api definition format
  2. elmiko to generate swagger doc for barbican and commit to github somewhere
  3. etoews start discussion about api def formats on ml
  4. sigmavirus24 reply to discussion with benefits moz saw from using an api def format
  5. etoews start discussion on ml about doing more analysis of current design and not creating guidelines in a vacuum


Action items, by person

  1. elmiko
    1. elmiko to generate swagger doc for barbican and commit to github somewhere
  2. etoews
    1. etoews update the scope section of the wiki page and include api definition format
    2. etoews start discussion about api def formats on ml
    3. etoews start discussion on ml about doing more analysis of current design and not creating guidelines in a vacuum
  3. sigmavirus24
    1. sigmavirus24 reply to discussion with benefits moz saw from using an api def format


People present (lines said)

  1. etoews (123)
  2. sigmavirus24 (54)
  3. elmiko (47)
  4. stevelle (8)
  5. annegent_ (6)
  6. isviridov (6)
  7. ryansb (4)
  8. dtroyer (3)
  9. openstack (3)
  10. isviridov_away (1)


Generated by MeetBot 0.1.4.