#openstack-meeting-3: api wg

Meeting started by etoews at 00:00:36 UTC (full logs).

Meeting summary

  1. agenda (etoews, 00:02:21)
    1. https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (etoews, 00:02:27)

  2. previous meeting action items (etoews, 00:03:07)
    1. http://eavesdrop.openstack.org/meetings/api_wg/2014/api_wg.2014-12-18-16.00.html (etoews, 00:03:20)
    2. ACTION: etoews update the scope section of the wiki page and include api definition format (etoews, 00:10:45)
    3. ACTION: elmiko to generate swagger doc for barbican and commit to github somewhere (etoews, 00:10:55)
    4. ACTION: etoews start discussion about api def formats on ml (etoews, 00:11:06)
    5. ACTION: sigmavirus24 reply to discussion with benefits moz saw from using an api def format (etoews, 00:11:18)
    6. https://wiki.openstack.org/wiki/API_Working_Group/Current_Design/Metadata (etoews, 00:12:26)

  3. APIImpact (etoews, 00:16:46)
    1. https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z (etoews, 00:17:01)
    2. https://review.openstack.org/#/c/136253/ (miguelgrinberg, 00:22:48)
    3. ACTION: sigmavirus24 will start a discussion on the ML about migrating to API WG standards (sigmavirus24, 00:50:33)

  4. guidelines (etoews, 00:51:18)
    1. https://review.openstack.org/#/c/145579/ (sigmavirus24, 00:51:24)
    2. ACTION: etoews to comment on https://review.openstack.org/#/c/145579/ about current design analysis (etoews, 00:54:34)
    3. https://review.openstack.org/#/c/131736/ (sigmavirus24, 00:55:38)


Meeting ended at 01:01:24 UTC (full logs).

Action items

  1. etoews update the scope section of the wiki page and include api definition format
  2. elmiko to generate swagger doc for barbican and commit to github somewhere
  3. etoews start discussion about api def formats on ml
  4. sigmavirus24 reply to discussion with benefits moz saw from using an api def format
  5. sigmavirus24 will start a discussion on the ML about migrating to API WG standards
  6. etoews to comment on https://review.openstack.org/#/c/145579/ about current design analysis


Action items, by person

  1. elmiko
    1. elmiko to generate swagger doc for barbican and commit to github somewhere
  2. etoews
    1. etoews update the scope section of the wiki page and include api definition format
    2. etoews start discussion about api def formats on ml
    3. etoews to comment on https://review.openstack.org/#/c/145579/ about current design analysis
  3. openstack
    1. etoews to comment on https://review.openstack.org/#/c/145579/ about current design analysis
  4. sigmavirus24
    1. sigmavirus24 reply to discussion with benefits moz saw from using an api def format
    2. sigmavirus24 will start a discussion on the ML about migrating to API WG standards


People present (lines said)

  1. etoews (73)
  2. sigmavirus24 (47)
  3. miguelgrinberg (44)
  4. elmiko (38)
  5. dtroyer (15)
  6. openstack (3)


Generated by MeetBot 0.1.4.