#openstack-meeting-3: api wg

Meeting started by etoews at 16:00:20 UTC (full logs).

Meeting summary

  1. agenda (etoews, 16:02:34)
    1. https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (etoews, 16:02:41)
    2. https://review.openstack.org/#/c/145579/ (sigmavirus24, 16:16:01)
    3. https://review.openstack.org/#/c/145544 (sigmavirus24, 16:16:07)
    4. https://wiki.openstack.org/wiki/CrossProjectLiaisons#API_Working_Group (etoews, 16:18:19)
    5. ACTION: kaufer to update https://review.openstack.org/#/c/145579/ and add relevent cross-project liaisons as reviewers (etoews, 16:20:28)

  2. previous meeting action items (etoews, 16:20:48)
    1. http://eavesdrop.openstack.org/meetings/api_wg/2015/api_wg.2015-01-08-00.00.html (etoews, 16:20:55)
    2. http://lists.openstack.org/pipermail/openstack-dev/2015-January/054153.html (sigmavirus24, 16:21:27)
    3. http://lists.openstack.org/pipermail/openstack-dev/2015-January/054511.html (sigmavirus24, 16:21:43)
    4. https://github.com/elmiko/os-swagger-docs (elmiko, 16:22:14)
    5. https://github.com/elmiko/pecan-swagger (elmiko, 16:24:35)

  3. APIImpact (etoews, 16:33:13)
    1. https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z (etoews, 16:33:28)
    2. https://review.openstack.org/#/c/130715/ (sigmavirus24, 16:34:23)
    3. ACTION: miguelgrinberg to turn https://review.openstack.org/#/c/130715/ into a guideline (sigmavirus24, 16:37:18)
    4. http://specs.openstack.org/openstack/nova-specs/specs/kilo/approved/get-lock-status-of-instance.html (sigmavirus24, 16:39:49)
    5. ACTION: etoews to do some analysis on the status vs state current design (etoews, 16:44:20)
    6. https://review.openstack.org/#/c/138051/ (sigmavirus24, 16:45:36)

  4. guidelines (etoews, 16:49:53)
    1. https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z (etoews, 16:50:54)
    2. https://review.openstack.org/133660 (sigmavirus24, 16:52:29)
    3. https://review.openstack.org/#/c/137490/ (sigmavirus24, 16:53:13)


Meeting ended at 17:00:14 UTC (full logs).

Action items

  1. kaufer to update https://review.openstack.org/#/c/145579/ and add relevent cross-project liaisons as reviewers
  2. miguelgrinberg to turn https://review.openstack.org/#/c/130715/ into a guideline
  3. etoews to do some analysis on the status vs state current design


Action items, by person

  1. etoews
    1. etoews to do some analysis on the status vs state current design
  2. kaufer
    1. kaufer to update https://review.openstack.org/#/c/145579/ and add relevent cross-project liaisons as reviewers
  3. miguelgrinberg
    1. miguelgrinberg to turn https://review.openstack.org/#/c/130715/ into a guideline
  4. openstack
    1. kaufer to update https://review.openstack.org/#/c/145579/ and add relevent cross-project liaisons as reviewers
    2. miguelgrinberg to turn https://review.openstack.org/#/c/130715/ into a guideline


People present (lines said)

  1. sigmavirus24 (87)
  2. etoews (41)
  3. elmiko (40)
  4. miguelgrinberg (15)
  5. kaufer (14)
  6. dtroyer (5)
  7. edleafe (4)
  8. openstack (3)


Generated by MeetBot 0.1.4.