#openstack-meeting-3: api wg

Meeting started by etoews at 00:00:27 UTC (full logs).

Meeting summary

  1. agenda (etoews, 00:01:40)
    1. https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (etoews, 00:01:45)

  2. previous meeting action items (etoews, 00:02:05)
    1. http://eavesdrop.openstack.org/meetings/api_wg/2015/api_wg.2015-01-15-16.00.html (etoews, 00:02:13)
    2. ACTION: etoews to put api wg item on the cross-project meeting agenda and attend the next meeting (etoews, 00:14:57)
    3. https://wiki.openstack.org/w/index.php?title=API_Working_Group/Current_Design/State_vs_Status (etoews, 00:29:02)
    4. https://github.com/openstack/api-wg/blob/master/guidelines/naming.rst (miguelgrinberg, 00:38:31)

  3. APIImpact (etoews, 00:39:03)
    1. https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z (etoews, 00:39:17)
    2. https://review.openstack.org/#/c/134279/4/specs/kilo/approved/server-count-api.rst (miguelgrinberg, 00:41:03)
    3. ACTION: propose guideline on representing boolean values (etoews, 00:46:47)
    4. http://developer.openstack.org/api-ref-networking-v2.html (see GET /) (ycombinator_, 00:50:01)
    5. ACTION: ycombinator_ to kick of discussion on openstack-dev on how does a client discover all supported and current versions of a service (etoews, 00:56:29)
    6. https://wiki.openstack.org/wiki/API_Working_Group/Current_Design/Service_Catalog (etoews, 00:56:50)

  4. guidelines (etoews, 00:57:10)
    1. https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z (etoews, 00:57:16)


Meeting ended at 01:00:37 UTC (full logs).

Action items

  1. etoews to put api wg item on the cross-project meeting agenda and attend the next meeting
  2. propose guideline on representing boolean values
  3. ycombinator_ to kick of discussion on openstack-dev on how does a client discover all supported and current versions of a service


Action items, by person

  1. etoews
    1. etoews to put api wg item on the cross-project meeting agenda and attend the next meeting
  2. openstack
    1. ycombinator_ to kick of discussion on openstack-dev on how does a client discover all supported and current versions of a service
  3. ycombinator_
    1. ycombinator_ to kick of discussion on openstack-dev on how does a client discover all supported and current versions of a service


People present (lines said)

  1. etoews (74)
  2. sigmavirus24 (49)
  3. miguelgrinberg (32)
  4. ycombinator_ (21)
  5. elmiko (18)
  6. salv-orlando (9)
  7. openstack (3)


Generated by MeetBot 0.1.4.