#openstack-meeting-3: api wg

Meeting started by sigmavirus24 at 16:00:47 UTC (full logs).

Meeting summary

  1. agenda (sigmavirus24, 16:02:01)
    1. https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (sigmavirus24, 16:02:33)

  2. mission statement (sigmavirus24, 16:02:53)
    1. https://etherpad.openstack.org/p/api-wg-mission-statement (elmiko, 16:03:20)
    2. mailing list thread http://lists.openstack.org/pipermail/openstack-dev/2015-February/055763.html (sigmavirus24, 16:03:42)
    3. https://etherpad.openstack.org/p/api-wg-mission-statement (ryansb, 16:03:48)
    4. http://lists.openstack.org/pipermail/openstack-dev/2015-February/056441.html (sigmavirus24, 16:05:22)
    5. ACTION: etoews to wrap up conversation on the mailing list and disseminate our mission statement (sigmavirus24, 16:07:42)

  3. Glance and functional API (sigmavirus24, 16:07:49)
    1. https://etherpad.openstack.org/p/glance-adding-functional-operations-to-api (sigmavirus24, 16:08:22)
    2. https://review.openstack.org/#/c/135122 (sigmavirus24, 16:08:28)
    3. VOTE: Voted on "Is the API WG's recommendation to use POST with a query parameter, e.g., /images/{id}?action=deactivate, instead of a functional API, e.g., /images/{id}/action/deactivate?" Results are (sigmavirus24, 16:31:49)

  4. versioning (sigmavirus24, 16:44:00)
    1. https://review.openstack.org/#/c/148037/ (sigmavirus24, 16:44:13)
    2. http://specs.openstack.org/openstack/nova-specs/specs/kilo/approved/api-microversions.html (sigmavirus24, 16:44:25)
    3. ACTION: sigmavirus24 to carry this topic forward to next week (sigmavirus24, 16:45:54)

  5. previous meeting action items (sigmavirus24, 16:46:10)
    1. http://eavesdrop.openstack.org/meetings/api_wg/2015/api_wg.2015-02-05-00.00.html (sigmavirus24, 16:46:18)

  6. guidelines (sigmavirus24, 16:47:06)
    1. https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z (sigmavirus24, 16:47:11)
    2. https://review.openstack.org/#/c/132248/ (sigmavirus24, 16:47:52)
    3. ACTION: kaufer to get some more input from other project members on https://review.openstack.org/#/c/147684/ (sigmavirus24, 16:49:49)
    4. metadata guideline https://review.openstack.org/#/c/141229/ (sigmavirus24, 16:51:42)
    5. ACTION: miguelgrinberg to make a guideline for tagging (sigmavirus24, 16:53:02)

  7. APIImpact (sigmavirus24, 16:54:47)
    1. https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z (sigmavirus24, 16:54:58)


Meeting ended at 17:02:13 UTC (full logs).

Action items

  1. etoews to wrap up conversation on the mailing list and disseminate our mission statement
  2. sigmavirus24 to carry this topic forward to next week
  3. kaufer to get some more input from other project members on https://review.openstack.org/#/c/147684/
  4. miguelgrinberg to make a guideline for tagging


Action items, by person

  1. kaufer
    1. kaufer to get some more input from other project members on https://review.openstack.org/#/c/147684/
  2. miguelgrinberg
    1. miguelgrinberg to make a guideline for tagging
  3. openstack
    1. kaufer to get some more input from other project members on https://review.openstack.org/#/c/147684/
  4. sigmavirus24
    1. sigmavirus24 to carry this topic forward to next week


People present (lines said)

  1. sigmavirus24 (76)
  2. rosmaita (49)
  3. cdent (41)
  4. elmiko (25)
  5. ryansb (18)
  6. dtroyer (16)
  7. edleafe (14)
  8. miguelgrinberg (12)
  9. jaypipes (9)
  10. openstack (6)
  11. salv-orlando (4)
  12. kaufer (3)
  13. clu_ (1)


Generated by MeetBot 0.1.4.