#openstack-meeting-3: api wg

Meeting started by sigmavirus24 at 16:00:01 UTC (full logs).

Meeting summary

  1. agenda (sigmavirus24, 16:00:29)
    1. https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (sigmavirus24, 16:00:37)

  2. versioning (sigmavirus24, 16:01:41)
  3. previous meeting action items (sigmavirus24, 16:04:55)
    1. http://eavesdrop.openstack.org/meetings/api_wg/2015/api_wg.2015-02-12-16.00.log.html (sigmavirus24, 16:05:01)
    2. http://eavesdrop.openstack.org/meetings/api_wg/2015/api_wg.2015-02-19-00.00.html (sigmavirus24, 16:05:08)
    3. ACTION: kaufer to gather more API-WG consensus on https://review.openstack.org/#/c/147684/5 before bringing it to the ML (sigmavirus24, 16:09:24)

  4. guidelines (sigmavirus24, 16:09:58)
    1. https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z (sigmavirus24, 16:10:12)
    2. https://review.openstack.org/#/c/155911/ seems to have consensus (sigmavirus24, 16:10:44)
    3. https://review.openstack.org/#/c/141229/ needs more input because there's a serious discussion of how to accommodate Swift (sigmavirus24, 16:11:20)
    4. ACTION: miguelgrinberg to get ML feedback on https://review.openstack.org/#/c/141229/ (sigmavirus24, 16:18:16)
    5. ACTION: miguelgrinberg to bring tagging guideline to the ML https://review.openstack.org/#/c/155620/ (sigmavirus24, 16:22:12)
    6. https://review.openstack.org/#/c/157563/ (elmiko, 16:28:09)

  5. APIImpact (sigmavirus24, 16:28:42)
    1. https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z (sigmavirus24, 16:28:49)
    2. ACTION: e0ne and yuriy_n17 to write a guideline about datetime representation in APIs (sigmavirus24, 16:38:44)
    3. https://review.openstack.org/#/c/157563/ (elmiko, 16:39:46)
    4. https://review.openstack.org/#/c/159204/ (cdent, 16:54:45)


Meeting ended at 17:00:07 UTC (full logs).

Action items

  1. kaufer to gather more API-WG consensus on https://review.openstack.org/#/c/147684/5 before bringing it to the ML
  2. miguelgrinberg to get ML feedback on https://review.openstack.org/#/c/141229/
  3. miguelgrinberg to bring tagging guideline to the ML https://review.openstack.org/#/c/155620/
  4. e0ne and yuriy_n17 to write a guideline about datetime representation in APIs


Action items, by person

  1. e0ne
    1. e0ne and yuriy_n17 to write a guideline about datetime representation in APIs
  2. kaufer
    1. kaufer to gather more API-WG consensus on https://review.openstack.org/#/c/147684/5 before bringing it to the ML
  3. miguelgrinberg
    1. miguelgrinberg to get ML feedback on https://review.openstack.org/#/c/141229/
    2. miguelgrinberg to bring tagging guideline to the ML https://review.openstack.org/#/c/155620/
  4. openstack
    1. kaufer to gather more API-WG consensus on https://review.openstack.org/#/c/147684/5 before bringing it to the ML
    2. miguelgrinberg to get ML feedback on https://review.openstack.org/#/c/141229/
    3. miguelgrinberg to bring tagging guideline to the ML https://review.openstack.org/#/c/155620/


People present (lines said)

  1. sigmavirus24 (101)
  2. miguelgrinberg (48)
  3. elmiko (34)
  4. cdent (24)
  5. kaufer (19)
  6. e0ne (10)
  7. stevelle (7)
  8. gilliard_ (4)
  9. dtroyer (3)
  10. openstack (3)
  11. DuncanT (2)
  12. briancurtin (1)


Generated by MeetBot 0.1.4.