#openstack-meeting-3: api wg

Meeting started by sigmavirus24 at 00:00:44 UTC (full logs).

Meeting summary

  1. agenda (sigmavirus24, 00:01:25)
    1. https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (sigmavirus24, 00:01:32)

  2. versioning (sigmavirus24, 00:01:48)
    1. ACTION: sigmavirus24 to write versioning/migration guideline (sigmavirus24, 00:07:27)

  3. #openstack-api channel (sigmavirus24, 00:07:42)
    1. https://review.openstack.org/#/c/161330/ (sigmavirus24, 00:08:22)

  4. merge the mission? (sigmavirus24, 00:09:53)
    1. https://review.openstack.org/#/c/155911/ (sigmavirus24, 00:09:59)
    2. ACTION: update the wiki page with the mission statement (etoews, 00:12:35)

  5. previous meeting action items (sigmavirus24, 00:13:06)
    1. http://eavesdrop.openstack.org/meetings/api_wg/2015/api_wg.2015-02-26-16.00.html (sigmavirus24, 00:13:16)
    2. ACTION: kaufer to gather more API-WG consensus on https://review.openstack.org/#/c/147684/5 before bringing it to the ML (sigmavirus24, 00:14:27)
    3. ACTION: miguelgrinberg to get ML feedback on https://review.openstack.org/#/c/141229/ (sigmavirus24, 00:14:37)
    4. ACTION: miguelgrinberg to bring tagging guideline to the ML https://review.openstack.org/#/c/155620/ (sigmavirus24, 00:14:45)

  6. guidelines (sigmavirus24, 00:15:46)
    1. https://review.openstack.org/159892 (sigmavirus24, 00:16:04)
    2. https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z (sigmavirus24, 00:16:46)
    3. ACTION: cyeoh to look into how nova handled datetimes and comment on Yuriy's guideline (sigmavirus24, 00:20:01)
    4. I'd really like more people to read https://review.openstack.org/#/c/141229/ (sigmavirus24, 00:28:14)
    5. ACTION: miguelgrinberg to update the metadata guideline and advertise it on the ML (sigmavirus24, 00:31:02)
    6. https://review.openstack.org/147684 seems to be overall fairly positively received (sigmavirus24, 00:36:05)
    7. https://review.openstack.org/147684 (sigmavirus24, 00:36:24)
    8. https://review.openstack.org/155620 (sigmavirus24, 00:41:05)


Meeting ended at 01:00:00 UTC (full logs).

Action items

  1. sigmavirus24 to write versioning/migration guideline
  2. update the wiki page with the mission statement
  3. kaufer to gather more API-WG consensus on https://review.openstack.org/#/c/147684/5 before bringing it to the ML
  4. miguelgrinberg to get ML feedback on https://review.openstack.org/#/c/141229/
  5. miguelgrinberg to bring tagging guideline to the ML https://review.openstack.org/#/c/155620/
  6. cyeoh to look into how nova handled datetimes and comment on Yuriy's guideline
  7. miguelgrinberg to update the metadata guideline and advertise it on the ML


Action items, by person

  1. cyeoh
    1. cyeoh to look into how nova handled datetimes and comment on Yuriy's guideline
  2. miguelgrinberg
    1. miguelgrinberg to get ML feedback on https://review.openstack.org/#/c/141229/
    2. miguelgrinberg to bring tagging guideline to the ML https://review.openstack.org/#/c/155620/
    3. miguelgrinberg to update the metadata guideline and advertise it on the ML
  3. openstack
    1. kaufer to gather more API-WG consensus on https://review.openstack.org/#/c/147684/5 before bringing it to the ML
    2. miguelgrinberg to get ML feedback on https://review.openstack.org/#/c/141229/
    3. miguelgrinberg to bring tagging guideline to the ML https://review.openstack.org/#/c/155620/
  4. sigmavirus24
    1. sigmavirus24 to write versioning/migration guideline


People present (lines said)

  1. sigmavirus24 (108)
  2. elmiko (42)
  3. miguelgrinberg (37)
  4. cyeoh (19)
  5. etoews (18)
  6. openstack (3)
  7. notmyname (3)


Generated by MeetBot 0.1.4.