00:00:23 <etoews> #startmeeting api wg
00:00:25 <openstack> Meeting started Thu Apr 16 00:00:23 2015 UTC and is due to finish in 60 minutes.  The chair is etoews. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
00:00:28 <openstack> The meeting name has been set to 'api_wg'
00:00:40 <etoews> hi
00:00:48 <elmiko> hi
00:01:07 <sigmavirus24> hi
00:01:52 <etoews> i've got a feeling we're just a trifecta today
00:02:09 <sigmavirus24> trifectas for the trifecta tribunal
00:02:32 <etoews> trifecats
00:02:37 <elmiko> lol
00:02:55 <etoews> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
00:03:04 <etoews> not much out of the ordinary there
00:03:16 <etoews> #topic previous meeting action items
00:03:35 <etoews> lemme look at some of the previous meetings for action items
00:05:03 <etoews> looks like there's some stuff here #link http://eavesdrop.openstack.org/meetings/api_wg/2015/api_wg.2015-03-26-16.00.html
00:05:42 <elmiko> whelp, got my action item done =D
00:05:53 <etoews> yep. nice!
00:05:59 <sigmavirus24> poor etoews with all his action items
00:06:08 <sigmavirus24> woops wrong list
00:06:26 <etoews> :)
00:06:29 <elmiko> lol
00:08:33 <etoews> i haven't yet followed up on the meeting time thread on openstack-dev
00:11:02 <etoews> jaypipes suggested an afternoon time to work with folks in asia
00:11:34 <etoews> asia is a big place
00:11:59 <jaypipes> etoews: by "afternoon time", you are referring to PST afternoons?
00:12:16 <elmiko> was that the 2:00UTC time?
00:12:20 <etoews> JST
00:12:36 <etoews> sorry...JST afternoons
00:12:47 <jaypipes> etoews: well, I say that because 7pm EST is 10am Australia/Brisbane time
00:13:09 <jaypipes> etoews: and I wouldn't call 7pm an afternoon time ;)
00:13:47 <etoews> any suggestions for a workable time?
00:14:42 <etoews> this is what i'm using to compare times #link http://www.worldtimebuddy.com/
00:16:38 <elmiko> afternoon in Beijing makes the US times pretty late
00:17:17 <jaypipes> I'm specifically *not* suggesting anything that would be a workable time for the EST folks :) because only late in the evening (i.e. now) would be workable
00:17:43 <elmiko> fair
00:18:03 <elmiko> we could do like 6am EST but that would still be like 7pm Beijing
00:18:10 <elmiko> probably too late
00:18:50 <jaypipes> yeah... there's really no great solution. which is why the alternating week times were appropriate, IMO
00:18:58 <sigmavirus24> 6am EST would be 3AM PST
00:19:05 <jaypipes> right :)
00:19:09 <sigmavirus24> In other words, I approve =P
00:19:14 <sigmavirus24> /s
00:19:17 <elmiko> lol
00:21:45 <etoews> would 21:00 UTC be too early for asia?
00:22:11 <etoews> or 22:00?
00:23:02 <etoews> 22:00 == 7 am tokyo and 6 am beijing
00:24:10 <elmiko> sounds kinda early
00:25:59 <etoews> ya. i suppose we can leave it as is.
00:27:09 <etoews> not sure how often i'll be able to make it. i'll try to mention it on #openstack-api more.
00:27:14 <etoews> let's move on
00:27:42 <etoews> #topic guidelines
00:27:53 <etoews> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
00:28:12 <elmiko> might be worthwhile to kick the ml thread again
00:29:55 <etoews> on the meeting time?
00:29:59 <elmiko> yea
00:30:20 <etoews> to what end?
00:30:40 <elmiko> i was hoping maybe to draw more folks out into the discussion, but maybe it's already at a dead end
00:31:17 <etoews> okay. at the very least i'll mention that we discussed it. see if anyone has anymore input.
00:31:31 <etoews> #action etoews kick meeting time ml thread
00:31:52 <elmiko> it's frustrating, but would be nice to hear from more folks who are attending from asia. it just seems like we aren't hearing from too many in that camp
00:32:02 <etoews> ya
00:32:56 <etoews> i'm not aware of having anyone from asia attend our meetings. otoh if we didn't have a reasonable meeting time for them then that would guarantee never getting any attendees.
00:33:03 <etoews> anyhoo
00:33:11 <elmiko> isn't cdent in australia?
00:34:00 <elmiko> i dunno, one of the late meetings we had there were 3 of us and i think cdent said he was in australia
00:34:24 <elmiko> but yeah, nuff said
00:34:52 <etoews> that's good to know
00:35:10 <etoews> elmiko's template is looking mergable :) #link https://review.openstack.org/#/c/169415/
00:35:27 <elmiko> \o/
00:37:39 <sigmavirus24> elmiko: you're awesome
00:37:48 <elmiko> aww shucks...
00:38:01 <etoews> hmmmm...elmiko how were you envisioning pointing people at the template?
00:38:43 <elmiko> that's a good question, maybe we should add something to the root README?
00:39:35 <elmiko> i'll add one more patch to the review
00:39:59 <etoews> i think it should more high profile than that
00:40:13 <elmiko> what did you have in mind?
00:40:14 <etoews> maybe in the process doc? http://specs.openstack.org/openstack/api-wg/process.html
00:40:35 <elmiko> that works
00:40:57 <etoews> put the existing text into a section and add a new section briefly describing your template and pointing at it.
00:41:09 <elmiko> yea
00:41:15 <elmiko> and hey, our template ;)
00:41:24 <etoews> :)
00:41:28 <etoews> sorry that didn't occur to me before...
00:41:36 <elmiko> lol, no worries
00:41:46 <elmiko> it's a good idea
00:41:48 <etoews> i definitely want to be able to share that as a link though
00:41:52 <elmiko> k
00:43:32 <etoews> commented on the review for pedantry's sake
00:43:43 <elmiko> works for me
00:44:35 <etoews> this looks mergable #link https://review.openstack.org/#/c/131320/
00:46:03 <etoews> done
00:46:13 <sigmavirus24> I agree
00:46:28 <elmiko> yea
00:47:51 <etoews> i still have some work to do on #link https://review.openstack.org/#/c/167793/
00:48:03 <elmiko> what about https://review.openstack.org/#/c/155620/ ?
00:49:00 <etoews> oops. lemme look.
00:49:27 <elmiko> might need more consensus, not sure as that reviewer list i think has all the PTLs
00:52:08 <etoews> i think it has all of the CPLs
00:53:38 <etoews> we definitely run the risk of approving something that none of the PTLs/CPLs have really agreed to though
00:53:50 <etoews> i'm not sure what to do about that
00:54:34 <etoews> i'm starting to think we might need something like a standing agenda item in the cross project meeting about guidelines that are ready to merge
00:54:47 <elmiko> that's a nice idea
00:54:56 <elmiko> at least get folks attention more
00:56:00 <etoews> #action etoews to put mergable api-wg guidelines on the cross-project meeting agenda and attend c-p meetings
00:56:06 <etoews> yay. more meetings.
00:56:12 <elmiko> lol
00:57:10 <etoews> #topic other topics
00:57:32 <etoews> i got an email from lauren sell of the openstack foundation about time/space at the summit for working groups
00:58:18 <elmiko> cool, seemed like we had a nice turnout last time
00:58:48 <etoews> yep. and there's also the call for cross-project sessions too. https://docs.google.com/forms/d/1LJZxdxE8P2F0WoULZEsRCXeqZP_VgH5nWUdZlbcA68M/viewform?c=0&w=1
00:59:10 <elmiko> nice
01:00:37 <etoews> deadline is april 27 for c-p session proposal
01:00:43 <etoews> we can discuss later
01:00:46 <etoews> #endmeeting