#openstack-meeting-3: api wg

Meeting started by annegentle at 16:00:31 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda (annegentle, 16:00:57)
    2. http://eavesdrop.openstack.org/meetings/api_wg/2015/api_wg.2015-04-16-00.00.html (etoews, 16:02:13)
    3. ACTION: etoews freeze the 3 current guidelines up for final review (etoews, 16:15:08)
    4. https://wiki.openstack.org/wiki/APIChangeGuidelines (etoews, 16:15:41)
    5. http://lists.openstack.org/pipermail/openstack-dev/2015-April/062050.html (etoews, 16:20:44)
    6. ACTION: elmiko to investigate moving https://wiki.openstack.org/wiki/APIChangeGuidelines to the api wg repo (etoews, 16:32:06)
    7. https://docs.google.com/forms/d/1LJZxdxE8P2F0WoULZEsRCXeqZP_VgH5nWUdZlbcA68M/viewform?c=0&w=1 (etoews, 16:43:19)
    8. https://docs.google.com/spreadsheets/d/1vCTZBJKCMZ2xBhglnuK3ciKo3E8UMFo5S5lmIAYMCSE/edit#gid=827503418 (annegentle, 16:44:30)
    9. ACTION: propose a state of the api wg cp session (etoews, 16:47:21)

  1. Swift (annegentle, 16:55:52)
    1. https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z (annegentle, 16:58:59)
    2. https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z (annegentle, 16:59:43)


Meeting ended at 17:00:39 UTC (full logs).

Action items

  1. etoews freeze the 3 current guidelines up for final review
  2. elmiko to investigate moving https://wiki.openstack.org/wiki/APIChangeGuidelines to the api wg repo
  3. propose a state of the api wg cp session


Action items, by person

  1. elmiko
    1. elmiko to investigate moving https://wiki.openstack.org/wiki/APIChangeGuidelines to the api wg repo
  2. etoews
    1. etoews freeze the 3 current guidelines up for final review
  3. openstack
    1. elmiko to investigate moving https://wiki.openstack.org/wiki/APIChangeGuidelines to the api wg repo


People present (lines said)

  1. etoews (85)
  2. annegentle (81)
  3. elmiko (26)
  4. sigmavirus24_awa (12)
  5. dtroyer (12)
  6. edleafe (9)
  7. miguelgrinberg (6)
  8. notmyname (5)
  9. cdent (4)
  10. stevelle (4)
  11. sigmavirus24 (3)
  12. openstack (3)


Generated by MeetBot 0.1.4.