16:02:28 <elmiko> #startmeeting api wg
16:02:28 <openstack> Meeting started Thu Jul 16 16:02:28 2015 UTC and is due to finish in 60 minutes. The chair is elmiko. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:02:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:31 <openstack> The meeting name has been set to 'api_wg'
16:02:57 <elmiko> #topic agenda
16:03:18 <elmiko> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:03:30 <elmiko> anyone around?
16:04:05 <stevelle> o/
16:04:44 <elmiko> weeeeell, might be a short one today
16:04:54 <elmiko> #topic previous meeting action items
16:05:07 <elmiko> the only 2 action items were for me
16:05:21 <elmiko> #link http://eavesdrop.openstack.org/meetings/api_wg/2015/api_wg.2015-07-09-00.00.html
16:05:45 <elmiko> i have made a patch to etoews dashboard in the gerrit dashabords repo
16:06:04 <elmiko> and i think it will take a few more, we need to move away from using -2 as method for marking freezes
16:06:36 <elmiko> #topic guidelines
16:06:48 <elmiko> #link https://review.openstack.org/#/q/status:open+project:openstack/api-wg,n,z
16:06:57 <stevelle> elmiko: I seem to recall issues with gerrit supported options being limited which means that -2 is the defacto, but I agree we should find another way.
16:07:04 <stevelle> or a human process to resolve that
16:07:25 <elmiko> yea, human might be the best but then the dashboard doesn't work as well
16:07:50 <elmiko> i talked with the folks in -infra and they seemed to indicate that we could use -A instead of -2 because it can be overridden by a core
16:08:03 <stevelle> we should carry forward that question till we have more members to brainstorm ideas perhaps then bring those to the list
16:08:15 <elmiko> good idea
16:08:26 <stevelle> but I think that -A sounds like a good idea to bring up
16:09:03 <elmiko> #idea talk more about freeze methodologies when there are more bodies present
16:09:26 <elmiko> as for guidelines, i think there are 4 that we could freeze this week
16:09:35 <elmiko> #link https://review.openstack.org/196918
16:09:41 <elmiko> #link https://review.openstack.org/186526
16:09:46 <elmiko> #link https://review.openstack.org/184358
16:09:51 <elmiko> #link https://review.openstack.org/183698
16:10:21 <elmiko> i'm going to post these into freeze, and i guess i can just mark them as freezed in the comments
16:10:28 <elmiko> should i -A on them?
16:12:06 <stevelle> just before you send out the mail to the list, I suppose yes. but that last one already has a -2
16:12:26 <elmiko> yea, i know. gonna need to bug etoews again to remove it
16:12:59 <elmiko> any guidelines you wanted to discuss stevelle ?
16:13:02 <stevelle> I think https://review.openstack.org/#/c/196918/ might be a little premature though
16:13:30 <stevelle> not sure
16:13:48 <elmiko> hmm, my concern is that we aren't getting more reviews on it and it's been over a week now
16:14:04 <elmiko> if we toss it on the fire, so to say, we'll definitely get some opinions
16:14:10 <miguelgrinberg> sorry to be late guys
16:14:13 <stevelle> the last two are definitely mature enough.
16:14:17 <stevelle> welcome miguelgrinberg
16:14:18 <elmiko> no worries miguelgrinberg
16:14:47 <elmiko> stevelle, would you mind commenting on https://review.openstack.org/#/c/196918/
16:15:05 <stevelle> I will look at it carefully today
16:15:12 <elmiko> i don't have a problem holding it back, i just think we need more reviews on it
16:15:26 <stevelle> I am fine if you want to propose it for freeze.
16:15:41 <elmiko> ok, let's send it out and see what the community thinks then
16:16:05 <elmiko> #action elmiko to freeze 4 proposals
16:16:20 <elmiko> #topic guideline pipeline
16:16:35 <elmiko> so, etoews has been working on the dashboard and it has been merged
16:16:42 <elmiko> #link http://ghostcloud.net/openstack_gerrit_dashboards/dashboard_api-wg.html
16:16:55 <elmiko> i'm not sure if these get published elsewhere, but he wanted some sort of link in the agenda
16:17:00 <elmiko> any thoughts?
16:18:38 <elmiko> ok, i'll keep researching this then
16:19:00 <elmiko> #action elmiko followup on dashboard linking into agenda
16:19:41 <elmiko> #topic merge guidelines
16:19:58 <elmiko> so, i had wanted to talk about the whole -2 thing
16:20:07 <elmiko> but maybe we'll just push this till we have more folks
16:20:51 * salv-orlando is lurking, maybe others are too
16:20:55 <stevelle> I just need to look at the dashboard a little more to form an opinion
16:21:10 <elmiko> stevelle: awesome, any suggestions would be great
16:21:28 <elmiko> i guess my main issue at this point is the whole -2 thing
16:21:49 <elmiko> we are using it heavily in the dashboard to help build the freeze based categories
16:21:55 <stevelle> yeah, that does feel like the most pressing issue
16:22:08 <elmiko> which is cool, but it causes issues on the merge side
16:22:10 <stevelle> beyond the actual guidelines and reviews
16:22:23 <elmiko> yea
16:22:39 <miguelgrinberg> it's odd that the same review is in frozen by needs feedback, and again in ready to merge
16:22:50 <elmiko> miguelgrinberg: yea, i posted a fix for that already
16:22:55 <miguelgrinberg> ah ok, great
16:23:05 <elmiko> #link https://review.openstack.org/#/c/202633/
16:23:45 <elmiko> etoews original work got merged a little quicker than i had expected, but no worries, that's what new reviews are for =)
16:24:31 <elmiko> i guess on this topic too, it might be nice to address the idea of freezed proposals that get rejected
16:24:47 <elmiko> i'm concerned that they can languish after failing to gain acceptance in the wider community
16:25:01 <elmiko> not sure that we can do anything to speed that process up, but just an issue i suppose
16:25:55 <elmiko> for example, #link https://review.openstack.org/#/c/183599/
16:26:01 <elmiko> jaypipes ^^
16:26:33 <elmiko> i'm not sure where to go on this one, there are some good comments but i think it needs another spin
16:27:22 <jaypipes> elmiko: seems like folks are in disagreement about it fundamentally to me.
16:27:42 <elmiko> jaypipes: ah, ok. should we drop it or ..?
16:27:50 <jaypipes> elmiko: not sure :(*
16:28:01 <elmiko> ok, maybe something for the ML
16:28:42 <salv-orlando> is there any other point of contention beyond should vs must?
16:28:58 <elmiko> i dunno, that seemed like the major bone
16:30:44 <elmiko> so, maybe change to should not and add a little description on why?
16:31:04 <elmiko> does that sound reasonable
16:34:07 <elmiko> jaypipes: does that sound ok to you?
16:34:43 <jaypipes> elmiko: sure I could do that
16:34:48 <elmiko> awesome
16:35:58 <elmiko> #topic APIImpact
16:36:08 <elmiko> #link https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z
16:36:16 <elmiko> any reviews folks would like to discuss?
16:38:52 <elmiko> #topic open discussion
16:38:57 <elmiko> any other business?
16:39:06 <stevelle> nothing this week
16:39:24 <elmiko> if not, we'll take 20 minutes back from the meeting gods ;)
16:40:32 <elmiko> ok then, thanks everybody!
16:40:37 <elmiko> #endmeeting