16:00:05 <elmiko> #startmeeting api wg
16:00:10 <openstack> Meeting started Thu Sep 10 16:00:05 2015 UTC and is due to finish in 60 minutes.  The chair is elmiko. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:14 <openstack> The meeting name has been set to 'api_wg'
16:00:26 <elmiko> hi everyone =)
16:00:32 <cdent> o/
16:00:45 <elmiko> #topic agenda
16:00:53 <elmiko> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:01:12 <elmiko> let's give folks a few minutes
16:01:15 <Nikolay_St> hi
16:01:18 <ryansb> hey folks
16:01:24 <elmiko> hey
16:01:32 <edleafe> o/
16:02:00 <stevelle> o/
16:02:11 <miguelgrinberg> hello
16:02:32 <elmiko> cool, good crowd today =)
16:02:57 <elmiko> looks like we had no action items from last time
16:03:12 <elmiko> #topic Mitaka sessions
16:03:20 <elmiko> #link https://etherpad.openstack.org/p/mitaka-api-wg-session-plans
16:03:27 <elmiko> we have one big session for tokyo
16:04:09 <elmiko> so far there is an outline forming there, but i welcome any additions for topics that should be addressed
16:04:32 <elmiko> hopefully, we'll flesh that out more before summit
16:05:31 <elmiko> #topic guidelines
16:05:50 <elmiko> so, we have the dashboard up #link http://ghostcloud.net/openstack_gerrit_dashboards/dashboard_api-wg.html
16:06:10 <elmiko> are there any new guidelines that folks would like to highlight, or suggestions for freeze?
16:06:39 <ryansb> I'd like to remind folks of https://review.openstack.org/#/c/217764/
16:06:47 <ryansb> (which is ready for freeze, btw)
16:07:02 <elmiko> ok, cool. i will mark that as +2 and put it up for freeze
16:07:22 <ryansb> and also reminder to review https://review.openstack.org/#/c/214817
16:07:26 <elmiko> oh, actually that is process related so we don't need to freeze it
16:07:29 <ryansb> it's not (IMO) freeze-ready yet
16:07:37 <ryansb> but more reviews more better
16:07:40 <elmiko> +1
16:08:01 <elmiko> this one #link https://review.openstack.org/#/c/187112/ could also use some reviews
16:08:22 <elmiko> i don't think its ready yet, but it will be nice to have. we just need to clean the language up
16:09:42 <elmiko> any other guidelines to  mention?
16:10:31 <elmiko> actually, #link https://review.openstack.org/#/c/221163/
16:10:40 <elmiko> i think that is close to freeze, but needs a few more reviews
16:10:46 <ryansb> those are the only two I wanted to point out
16:11:06 <ryansb> oops, forgot to #link https://review.openstack.org/#/c/214817
16:11:52 <elmiko> ok, so more reviews then we have a couple ready for freeze
16:11:54 <ryansb> ooh, hadn't seen that one elmiko, thanks for the pointer
16:12:12 <elmiko> we probably won't have any new freezes to announce for next week
16:12:30 <elmiko> #topic APIImpact
16:12:41 <elmiko> #link https://review.openstack.org/#/q/status:open+AND+(message:ApiImpact+OR+message:APIImpact),n,z
16:12:57 <elmiko> any reviews that should be highlighted?
16:13:44 <cdent> I had a nice chat with flaper87 about this one: https://review.openstack.org/#/c/219649/
16:13:50 <cdent> was glad to see it happening
16:14:20 * flaper87 bows and thanks cdent for the feedback
16:14:22 <elmiko> interesting, hadn't seen that
16:14:49 <elmiko> cdent: is this something we could spin into a guideline, or are we already advising this?
16:15:14 <cdent> I don't know. Until it came up I hadn't realized anyone would do anything differently
16:15:34 <elmiko> yea, seems like you wouldn't want to do that
16:16:28 <elmiko> looks like we are getting lots of usage out of the APIImpact flag though, which is nice
16:16:36 <ryansb> +1
16:17:04 <edleafe> elmiko: +1
16:17:06 <elmiko> i wonder if there is something more formalized we should do to help add comments on these. i almost feel like there are so many to look at. any thoughts?
16:18:16 <ryansb> I think just asking members to cover whatever they can is the way to go
16:18:44 <elmiko> that's fair, i was just kinda thinking out loud =)
16:18:54 <ryansb> we're just a working group, so our capacity shouldn't be blocking other projects, but when possible we should try to provide all the feedback we can
16:19:04 <elmiko> agreed
16:19:33 <ryansb> I'm not sure any policy would be helpful, other than "there are lots to look at, cover what's possible"
16:20:15 <elmiko> yea, i was thinking something along the lines of like the "office hours" that are held by... governance?
16:20:49 <elmiko> like, could we make a 1hour slot during the week that folks might assemble in openstack-api for the purpose of reviewing some APIImpact stuff?
16:20:59 <elmiko> maybe that's too formalized though
16:21:27 <ryansb> yeah, I'd be mildly -1 on that
16:21:38 <elmiko> yea, i think it's too much
16:21:46 <elmiko> again, just spit-balling
16:21:59 <elmiko> ok, anyone else want to highlight a review?
16:22:16 <ryansb> Do the docs on the APIImpact flag also point to our IRC channel?
16:22:26 <elmiko> good question
16:22:43 <ryansb> if not, maybe that'd be the way to go for folks who have an api-impacting change that want to ask questions
16:22:51 <elmiko> +1
16:23:18 <elmiko> #action elmiko check APIImpact docs to make sure they also mention #openstack-api channel
16:23:39 <cdent> I think we need to do a bit of work to make it easier for those of us who are api-wg oriented to devote real time toit
16:23:52 <cdent> as it is, right now I always feel a bit like it is stolentime
16:24:13 <elmiko> agreed, not sure what we could do. reviewing them during out meetings seems like a nice middle ground though
16:25:05 <elmiko> maybe for meetings without a large agenda we should queue up a few to review as a group?
16:25:34 <elmiko> i dunno, something to think about i suppose
16:25:44 <ryansb> cdent: yeah, I have a calendar event set aside for api reviews weekly, and whenever there are replies to things I've reviewed already I see those when I do the rest of my reviews
16:25:58 <cdent> one of the topics at summit is "how to get (and be) more engaged and engaging"
16:26:01 <ryansb> but that's about the maximum structure possible with the existing setup
16:26:06 <elmiko> cdent: +1
16:26:26 <elmiko> i like that idea ryansb
16:26:44 <ryansb> (also, obligatory plug for gertty)
16:26:46 <cdent> given the number of apiimpact tagged things, and the relatively strong flow of guidelines, we probably have some useful metrics to wave around
16:26:56 <ryansb> it's like 10x more efficient for me to do reviews that way
16:27:30 <cdent> it is very cool but I ended up not sticking with it. not sure why
16:27:57 <elmiko> gonna have to check it out
16:29:12 <elmiko> #topic Open discussion
16:29:19 <elmiko> any other business?
16:30:24 <cdent> not from me
16:30:30 <edleafe> nope
16:30:35 <ryansb> not I
16:30:35 <elmiko> shall we all go review APIImpact stuff for the next 30 min. ;)
16:30:46 <edleafe> seconded!
16:30:57 <Nikolay_St> oh
16:30:59 <elmiko> ok, thanks everybody!
16:31:05 <elmiko> #endmeeting