16:00:38 <etoews> #startmeeting api wg
16:00:38 <openstack> Meeting started Thu Sep 24 16:00:38 2015 UTC and is due to finish in 60 minutes.  The chair is etoews. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:43 <openstack> The meeting name has been set to 'api_wg'
16:00:47 <ryansb> hello folks
16:00:52 <etoews> hello
16:00:59 <elmiko> hi
16:01:45 <etoews> small crowd...
16:01:53 <elmiko> yea, no one showed last week :/
16:02:10 <etoews> well that's never too surprising on the "late" meeting
16:02:15 <elmiko> true
16:02:50 <etoews> #topic agenda
16:02:59 <etoews> #link https://wiki.openstack.org/wiki/Meetings/API-WG#Agenda
16:03:13 <etoews> looks like it's pretty much just our standing agenda
16:03:26 <etoews> #topic previous meeting action items
16:03:47 <elmiko> i added a small note to the gerrit wiki page about APIImpact
16:04:01 <elmiko> mainly, just adding a sentence about contacting the api-wg in #openstack-api on freenode
16:04:11 * etoews looks for last meaningful meeting minutes
16:04:24 <elmiko> that link is actually the last attended meeting
16:05:07 <etoews> ah yes
16:05:10 <etoews> #link http://eavesdrop.openstack.org/meetings/api_wg/2015/api_wg.2015-09-10-16.00.html
16:07:00 <etoews> elmiko: is the gerrit wiki page still the canonical source for openstack contrib?
16:07:24 <elmiko> um, it looked like it
16:07:26 <etoews> i thought it had moved to some doc maintained in git
16:07:28 <elmiko> let me dig up the link
16:07:33 <elmiko> oh, that may be the case
16:07:54 <ryansb> as far as I know, it still is. I think project docs went to developer.openstack.org
16:08:16 <ryansb> but for stuff like the contributor guide, the wiki is still the place I think
16:08:46 <elmiko> maybe we should make a PR against http://docs.openstack.org/infra/manual/developers.html too?
16:09:07 <etoews> that's the one i was thinking of
16:09:13 <etoews> it mentions APIImpact too
16:09:22 <elmiko> i added it to this page https://wiki.openstack.org/wiki/GitCommitMessages
16:09:39 <elmiko> in this section, https://wiki.openstack.org/wiki/GitCommitMessages#Including_external_references
16:10:01 <etoews> that's reasonable.
16:10:14 <elmiko> basically, my addition was "Additionally, the API Working Group can be contacted directly on IRC in the #openstack-api channel of Freenode."
16:10:16 <ryansb> don't think I'd discovered that dev guide, neat
16:10:46 <elmiko> just one more nod to improve communication
16:11:17 <ryansb> +1
16:12:13 <etoews> elmiko: did you want to PR against  http://docs.openstack.org/infra/manual/developers.html too or wiki is good enough?
16:12:36 <elmiko> i can make a pr there as well, always better to have this info spread more widely
16:12:49 <elmiko> plus it seems like a low likehood that openstack-api is going away anytime soon
16:13:29 <etoews> ++
16:13:38 <elmiko> #action elmiko to make a PR against http://docs.openstack.org/infra/manual/developers.html to add info about the openstack-api irc channel
16:13:44 <etoews> thx
16:13:52 <elmiko> i mean, they may reject it but i don't mind making an effort =)
16:14:30 <etoews> #topic Mitaka sessions etherpad
16:14:41 <etoews> did you still want to discuss this elmiko ?
16:15:03 <elmiko> i mainly left it on there as an ongoing topic until the summit
16:15:10 <elmiko> #link https://etherpad.openstack.org/p/mitaka-api-wg-session-plans
16:15:21 <elmiko> we do need to flesh it out a little more though
16:15:40 <elmiko> and, i suppose, i'll need to make a more thorough agenda if i'm supposed to do some talking for more than like 5 minutes ;)
16:15:54 <ryansb> or bring lots of beer
16:16:03 <ryansb> then nobody will notice your presentation is short
16:16:39 <elmiko> mm, good point
16:16:44 <elmiko> maybe group karaoke?
16:17:21 <etoews> added 3.3
16:17:26 <elmiko> cool, ty
16:17:26 <ryansb> That would be very location-appropriate :)
16:17:39 <stevelle> wouldn't we all end up getting into debates about how to improve the interface on the karaoke machine?
16:17:40 <etoews> sake and karaoke!
16:17:50 <elmiko> stevelle: lol, i would hope so!
16:18:16 <elmiko> mmm sake...
16:18:29 <elmiko> never really tried karaoke
16:18:34 <etoews> #topic guidelines dashboard
16:18:47 <etoews> #link http://ghostcloud.net/openstack_gerrit_dashboards/dashboard_api-wg.html
16:19:08 <elmiko> would be cool if we could have the direct link to the dashboard somewhere
16:19:20 <elmiko> like, a task to compile the dashboard then make a shortened link
16:19:38 <elmiko> i feel like this should be a post-commit hook in the dashboard-generator stuff
16:19:44 <etoews> ya. better yet. a short link where you can just edit the link.
16:19:51 <elmiko> right
16:20:05 <ryansb> as in with bit.ly or something?
16:20:12 <etoews> so many public shorteners you can't edit the link after the fact
16:20:28 <etoews> can you edit bit.ly links after you've created them?
16:20:40 <ryansb> I don't know, I thought so
16:20:41 <etoews> i remember trying to do that ages ago
16:20:41 <elmiko> new openstack project idea?
16:20:50 <etoews> i'm the PTL!
16:20:55 <elmiko> sold!
16:21:08 <ryansb> hoy vey
16:21:13 <elmiko> haha
16:21:20 <etoews> openstack generates another PTL
16:22:16 <etoews> anne needs to respond to the comments on her guideline before we can consider a freeze there #link https://review.openstack.org/214817
16:23:09 <elmiko> yea
16:23:15 <etoews> as i said in #openstack-api, the transitive dependencies of Ken'ichi's guidelines is makin me nuts.
16:23:26 <elmiko> i know...
16:23:43 <elmiko> ryansb had a good one that should be up for freeze once it gets a little attention
16:23:47 <ryansb> yeah https://review.openstack.org/#/c/183599/2
16:24:28 <elmiko> spliiiiiit
16:24:33 <ryansb> hm?
16:24:58 <elmiko> sorry, just saw a bunch of drops. figured netsplit
16:25:15 <etoews> ugh. i see this regularly with rackspace's deployment of heat. it gives me feels.
16:25:22 <elmiko> lol
16:25:23 <ryansb> oh, I have drops hidden if they haven't talked in the last 15 mins
16:25:34 <elmiko> nice
16:25:47 <ryansb> by far my favorite weechat feature
16:25:54 <ryansb> etoews: :(
16:25:57 <ryansb> sorry...
16:26:10 <stevelle> given the merge conflict I just kept overlooking that on ryansb
16:26:23 <ryansb> yeah, no worries
16:28:37 * etoews commenting on review
16:34:32 <etoews> so is there anything ready for freeze this week?
16:34:56 <elmiko> i don't think much has been updated, so probably not
16:35:38 <ryansb> I don't think so - there's still controversy on the errors guideline
16:35:45 <ryansb> so that isn't freezeable
16:36:30 <etoews> ya. i wanted to discuss that next.
16:36:49 <etoews> #topic errors guideline
16:37:04 <etoews> #link https://review.openstack.org/#/c/167793/
16:37:45 <elmiko> i need to re-review this one
16:38:23 <etoews> does anyone know matthew booth or his irc nick?
16:39:00 <elmiko> sadly, no
16:39:08 <ryansb> nope
16:41:16 <etoews> i like rocky's suggestion at the very end. it's a good way to leave the door open but not creating a dependency on matthew's "...the list located at X."
16:41:49 <elmiko> agreed, we should not be defining the error code specs
16:41:56 <etoews> i'd like to get your thoughts on the review too
16:42:21 <elmiko> re-added to my queue ;)
16:43:08 <stevelle> agreed on rocky's segmentation of the problem
16:43:59 <etoews> ken makes a good point about link relations
16:44:16 <etoews> we definitely don't have a guideline for that
16:44:39 <elmiko> yea, that seems like good fodder for a new guideline
16:44:56 <elmiko> although, given the state of apis now it may be controversial
16:45:07 <etoews> i'm not crazy about json api's take on them http://jsonapi.org/format/#document-links
16:45:41 <etoews> i don't really care for https://github.com/blongden/vnd.error either
16:45:50 <elmiko> hehe
16:46:24 <ryansb> what don't you like, that they keep them in {"href": ...} ?
16:46:30 <elmiko> etoews: what don't you like about the jsonapi stuff?
16:47:05 <etoews> 1. that's there's 2 ways to express them
16:47:51 <etoews> 2. the meta thing (i get it, but i feel like they punted on doing something useful)
16:48:54 <elmiko> #1 makes sense to me, i kinda get why they would do #2. gotta leave the door open for the weird custom stuff, right?
16:48:59 <etoews> if i was to change the link relations in this guideline, i'd probably do it whatever way most other openstack apis already do it
16:49:36 <etoews> ya. i totally get why they did that for #2. maximum squishiness.
16:49:38 <elmiko> seems to me though, we would need to decide whether we recommend using "href" or "ref" or whatever, if only to help with consistency
16:50:02 <elmiko> haha, i like that. etoew's principle of maximal squishiness ;)
16:50:32 <etoews> it pains me to think that this could be held up by having to get people to agree on a link relation format.
16:50:40 <elmiko> you know it will
16:50:44 <etoews> (even though it's probably necessary)
16:51:17 <etoews> i really don't have the time right now to do the proper research and put together a guideline for link relations
16:51:17 <elmiko> well yea, i mean even if nobody changes the old stuff it would be cool to be able to crawl apis, or auto discover, based on a known link key
16:51:35 <etoews> and then have the ensuing argument of what the hell hypermedia means.
16:52:08 <elmiko> i'd like to dig into the apis, if only to discover some patterns, but i might need help presenting the argument to the larger community.
16:52:15 <etoews> sigh. i don't mean to sound so jaded. just pressed for time for the next month.
16:53:09 <etoews> elmiko: i've been putting my research into https://wiki.openstack.org/wiki/API_Working_Group/Current_Design
16:53:13 <elmiko> would you be willing to help if i could collate the data?
16:53:23 <elmiko> (or anyone else too)
16:53:27 <etoews> sure
16:53:44 <elmiko> ok, i'll try to get something going over the next few weeks
16:54:26 <etoews> cool. thx a ton elmiko!
16:55:13 <etoews> anything else in the last 5 min?
16:56:50 <ryansb> don't think so
16:56:55 <elmiko> nothing from me
16:57:08 <stevelle> nothing here
16:58:10 <etoews> here's something interesting to chew on :) https://github.com/jamiehannaford/swagger-magnum
16:58:25 <elmiko> wow, missed opportunity to call that swagnum...
16:58:51 <etoews> it's also a WIP
16:58:56 <elmiko> cool
17:00:38 <etoews> #endmeeting